besoin d aide formule

Le
mikefly62
Bonjour,

en colonne A j 'ai des dates et B des prenoms puis enfin C des chiffres

J'aimerais une formule dans une seule cellule (matricielle) qui me compte le
nombre de lignes ayant la meme date en colonne A, sur la meme ligne les
prenoms recherche "Pierre et Luc" en colonne B et sur la meme ligne un
chiffre en colonne C.

Dans mon exemple la formule aurait un resultat de 2 car sur la ligne 1 et 2
puis 8 et 9 elle touve la meme date pour Pierre et Luc en colonne A,Pierre
et Luc en colonne B,et un chiffre en face en colonne C de Pierre et Luc.


COLONNE A COLONNE B COLONNE C
01/01/2008 PIERRE 3
01/01/2008 LUC 4
01/01/2008 PAUL
02/01/2008 PAUL 7
02/01/2008 PIERRE
03/01/2008 PAUL 8
03/01/2008 PIERRE
05/01/2008 LUC 8
05/01/2008 PIERRE 1


Pour les colonne A et B j'ai 2 formule ci dessous il me manque a ajouté la
condition de la colonne C

=SOMME((FREQUENCE(SI((B1:B9="Pierre")+(B1:B9="LUC");A1:A9);A1:A9)>1)*1)

=SOMME((B$2:B$9=D$2)+(B$2:B$9=F$2))-SOMME((FREQUENCE(SI((B$2:B$9=D$2)+(B$2:B$9=F$2);EQUIV(A$2:A$9;A$2:A$9;0));LIGNE(B$1:B$9))>0)*1)

Merci de votre aide
Cordialement
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5445501
Bonjour.
J'ai honte de cette formule, mais elle semble fonctionner, en attendant
mieux :
=SI(MAX(FREQUENCE(SI(B1:B9="pierre";1;SI(B1:B9="luc";1))*(C1:C9 Formule matricielle.
Cordialement.
Daniel

"mikefly62" %
Bonjour,

en colonne A j 'ai des dates et B des prenoms puis enfin C des chiffres

J'aimerais une formule dans une seule cellule (matricielle) qui me compte
le nombre de lignes ayant la meme date en colonne A, sur la meme ligne les
prenoms recherche "Pierre et Luc" en colonne B et sur la meme ligne un
chiffre en colonne C.

Dans mon exemple la formule aurait un resultat de 2 car sur la ligne 1 et
2 puis 8 et 9 elle touve la meme date pour Pierre et Luc en colonne
A,Pierre et Luc en colonne B,et un chiffre en face en colonne C de Pierre
et Luc.


COLONNE A COLONNE B COLONNE C
01/01/2008 PIERRE 3
01/01/2008 LUC 4
01/01/2008 PAUL
02/01/2008 PAUL 7
02/01/2008 PIERRE
03/01/2008 PAUL 8
03/01/2008 PIERRE
05/01/2008 LUC 8
05/01/2008 PIERRE 1


Pour les colonne A et B j'ai 2 formule ci dessous il me manque a ajouté la
condition de la colonne C

=SOMME((FREQUENCE(SI((B1:B9="Pierre")+(B1:B9="LUC");A1:A9);A1:A9)>1)*1)

=SOMME((B$2:B$9=D$2)+(B$2:B$9=F$2))-SOMME((FREQUENCE(SI((B$2:B$9=D$2)+(B$2:B$9=F$2);EQUIV(A$2:A$9;A$2:A$9;0));LIGNE(B$1:B$9))>0)*1)

Merci de votre aide
Cordialement






ChrisV
Le #5443411
Bonjour mikefly62,

Avec les plages de données A1:A9 nommée ici "dtS", B1:B9 "prN" et C1:C9
"vaL"
(à saisir sans les { } et valider par Ctrl+Shift+Entrée)

{=ARRONDI(SOMME((NB.SI(dtS;dtS)>1)*((prNÒ)+(prNò))*(vaL<>""))/2;)}


ChrisV
[de passage...]


"mikefly62" %
Bonjour,

en colonne A j 'ai des dates et B des prenoms puis enfin C des chiffres

J'aimerais une formule dans une seule cellule (matricielle) qui me compte
le nombre de lignes ayant la meme date en colonne A, sur la meme ligne les
prenoms recherche "Pierre et Luc" en colonne B et sur la meme ligne un
chiffre en colonne C.

Dans mon exemple la formule aurait un resultat de 2 car sur la ligne 1 et
2 puis 8 et 9 elle touve la meme date pour Pierre et Luc en colonne
A,Pierre et Luc en colonne B,et un chiffre en face en colonne C de Pierre
et Luc.


COLONNE A COLONNE B COLONNE C
01/01/2008 PIERRE 3
01/01/2008 LUC 4
01/01/2008 PAUL
02/01/2008 PAUL 7
02/01/2008 PIERRE
03/01/2008 PAUL 8
03/01/2008 PIERRE
05/01/2008 LUC 8
05/01/2008 PIERRE 1


Pour les colonne A et B j'ai 2 formule ci dessous il me manque a ajouté la
condition de la colonne C

=SOMME((FREQUENCE(SI((B1:B9="Pierre")+(B1:B9="LUC");A1:A9);A1:A9)>1)*1)

=SOMME((B$2:B$9=D$2)+(B$2:B$9=F$2))-SOMME((FREQUENCE(SI((B$2:B$9=D$2)+(B$2:B$9=F$2);EQUIV(A$2:A$9;A$2:A$9;0));LIGNE(B$1:B$9))>0)*1)

Merci de votre aide
Cordialement






Modeste
Le #5443361
Hau pescaluna avec ferveur ;o))) vous nous disiez :

ChrisV
[de passage...]


Tóksha aké wanchinyankin kte

Daniel.C
Le #5443261
Bonjour.
Euh, je n'en suis pas tout à fait sûr, dans tous les cas.
Cordialement.
Daniel

"ChrisV"
Bonjour mikefly62,

Avec les plages de données A1:A9 nommée ici "dtS", B1:B9 "prN" et C1:C9
"vaL"
(à saisir sans les { } et valider par Ctrl+Shift+Entrée)

{=ARRONDI(SOMME((NB.SI(dtS;dtS)>1)*((prNÒ)+(prNò))*(vaL<>""))/2;)}


ChrisV
[de passage...]


"mikefly62" %
Bonjour,

en colonne A j 'ai des dates et B des prenoms puis enfin C des chiffres

J'aimerais une formule dans une seule cellule (matricielle) qui me compte
le nombre de lignes ayant la meme date en colonne A, sur la meme ligne
les prenoms recherche "Pierre et Luc" en colonne B et sur la meme ligne
un chiffre en colonne C.

Dans mon exemple la formule aurait un resultat de 2 car sur la ligne 1 et
2 puis 8 et 9 elle touve la meme date pour Pierre et Luc en colonne
A,Pierre et Luc en colonne B,et un chiffre en face en colonne C de Pierre
et Luc.


COLONNE A COLONNE B COLONNE C
01/01/2008 PIERRE 3
01/01/2008 LUC 4
01/01/2008 PAUL
02/01/2008 PAUL 7
02/01/2008 PIERRE
03/01/2008 PAUL 8
03/01/2008 PIERRE
05/01/2008 LUC 8
05/01/2008 PIERRE 1


Pour les colonne A et B j'ai 2 formule ci dessous il me manque a ajouté
la condition de la colonne C

=SOMME((FREQUENCE(SI((B1:B9="Pierre")+(B1:B9="LUC");A1:A9);A1:A9)>1)*1)

=SOMME((B$2:B$9=D$2)+(B$2:B$9=F$2))-SOMME((FREQUENCE(SI((B$2:B$9=D$2)+(B$2:B$9=F$2);EQUIV(A$2:A$9;A$2:A$9;0));LIGNE(B$1:B$9))>0)*1)

Merci de votre aide
Cordialement










ChrisV
Le #5443251
:-)


Pilámaya. Wakhan Thánka níci un.
Akhé ú wo.


ChrisV


"Modeste"
Hau pescaluna avec ferveur ;o))) vous nous disiez :

ChrisV
[de passage...]


Tóksha aké wanchinyankin kte




Publicité
Poster une réponse
Anonyme