Besoin d'aide pour Somme.si

Le
Christian
Bonjour à tous et toutes
Problème:
a12 2
a23 3
c12 4
c123 5
e235 1
Réponse souhaitée en colonne C: (A2) "a"=5
(A4) "c"=9
(A5) "e"=1
J'essaie avec =SOMME.SI($a$1:$a$5;(GAUCHE($A$2)<>GAUCHE($A$3));$B$1:$B$5)
Malheureusement, je reçois des 0 à chaque ligne.

--
Merci d'avance pour toute aide où début de solution.
Christian
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas B.
Le #5291091
Bonjour,

Comme ça ?
=SI(GAUCHE(A5)=GAUCHE(A6);"";SOMMEPROD((GAUCHE(A$1:A$5)=GAUCHE(A5))*B$1:B$5))

A+


Nicolas

Bonjour à tous et toutes
Problème:
a12 2
a23 3
c12 4
c123 5
e235 1
Réponse souhaitée en colonne C: (A2) "a"=5
(A4) "c"=9
(A5) "e"=1
J'essaie avec =SOMME.SI($a$1:$a$5;(GAUCHE($A$2)<>GAUCHE($A$3));$B$1:$B$5)
Malheureusement, je reçois des 0 à chaque ligne.



Christian
Le #5291081
Bonsoir Nicolas

Merci de m'avoir lu et proposé une solution.
Elle fonctionne très bien.
Cordialement
Christian



Bonjour,

Comme ça ?
=SI(GAUCHE(A5)=GAUCHE(A6);"";SOMMEPROD((GAUCHE(A$1:A$5)=GAUCHE(A5))*B$1:B$5))

A+


Nicolas

Bonjour à tous et toutes
Problème:
a12 2
a23 3
c12 4
c123 5
e235 1
Réponse souhaitée en colonne C: (A2) "a"=5
(A4) "c"=9
(A5) "e"=1
J'essaie avec =SOMME.SI($a$1:$a$5;(GAUCHE($A$2)<>GAUCHE($A$3));$B$1:$B$5)
Malheureusement, je reçois des 0 à chaque ligne.






didiersee
Le #5291071
Pas possible tu dois obligatoirement créer une colonne supplémentaire pcq il
y a conflit dans ta formule
et ça donnera ceci
A B C
a12 2 a
a23 3 a
c12 4 c
c123 5 c
e235 1 e

valeur a => 5 =SOMME.SI(C1:C5;"=a";B1:B5)
valeur c => 9 =SOMME.SI(C1:C5;"=c";B1:B5)
valeur e => 1 =SOMME.SI(C1:C5;"=e";B1:B5)

Bien à Toi


"Christian" news:
Bonjour à tous et toutes
Problème:
a12 2
a23 3
c12 4
c123 5
e235 1
Réponse souhaitée en colonne C: (A2) "a"=5
(A4) "c"=9
(A5) "e"=1
J'essaie avec =SOMME.SI($a$1:$a$5;(GAUCHE($A$2)<>GAUCHE($A$3));$B$1:$B$5)
Malheureusement, je reçois des 0 à chaque ligne.

--
Merci d'avance pour toute aide où début de solution.
Christian


Modeste
Le #5291051
Bonsour® Nicolas B. avec ferveur ;o))) vous nous disiez :

Comme ça ?
=SI(GAUCHE(A5)=GAUCHE(A6);"";SOMMEPROD((GAUCHE(A$1:A$5)=GAUCHE(A5))*B$1:B$5))


et pouquoi pas simplement comme ça ???:
=SOMMEPROD($B$1:$B$5*(GAUCHE($A$1:$A$5)="a"))
=SOMMEPROD($B$1:$B$5*(GAUCHE($A$1:$A$5)="c"))
=SOMMEPROD($B$1:$B$5*(GAUCHE($A$1:$A$5)="e"))



--
--
@+
;o)))

Christian
Le #5291021
Bonjour Modeste
Merci de m'avoir lu et répondu.
Bien que ta soluce fonctionne très bien; ne connaissant pas les lettres au
départ, je me dois d'utiliser la solution de Nicolas.
D'où ma formulation avec "Gauche".
--
Cordialement
Christian



Bonsour® Nicolas B. avec ferveur ;o))) vous nous disiez :

Comme ça ?
=SI(GAUCHE(A5)=GAUCHE(A6);"";SOMMEPROD((GAUCHE(A$1:A$5)=GAUCHE(A5))*B$1:B$5))


et pouquoi pas simplement comme ça ???:
=SOMMEPROD($B$1:$B$5*(GAUCHE($A$1:$A$5)="a"))
=SOMMEPROD($B$1:$B$5*(GAUCHE($A$1:$A$5)="c"))
=SOMMEPROD($B$1:$B$5*(GAUCHE($A$1:$A$5)="e"))



--
--
@+
;o)))






Christian
Le #5291011
Bonjour Didier
Merci de m'avoir lu et répondu.
--
Cordialement
Christian



Pas possible tu dois obligatoirement créer une colonne supplémentaire pcq il
y a conflit dans ta formule
et ça donnera ceci
A B C
a12 2 a
a23 3 a
c12 4 c
c123 5 c
e235 1 e

valeur a => 5 =SOMME.SI(C1:C5;"=a";B1:B5)
valeur c => 9 =SOMME.SI(C1:C5;"=c";B1:B5)
valeur e => 1 =SOMME.SI(C1:C5;"=e";B1:B5)

Bien à Toi


"Christian" news:
Bonjour à tous et toutes
Problème:
a12 2
a23 3
c12 4
c123 5
e235 1
Réponse souhaitée en colonne C: (A2) "a"=5
(A4) "c"=9
(A5) "e"=1
J'essaie avec =SOMME.SI($a$1:$a$5;(GAUCHE($A$2)<>GAUCHE($A$3));$B$1:$B$5)
Malheureusement, je reçois des 0 à chaque ligne.

--
Merci d'avance pour toute aide où début de solution.
Christian







Publicité
Poster une réponse
Anonyme