BIRT: Erreur prévisualisation

Le
Eric Guirbal
Bonjour,

J'utilise BIRT 2.1.2 + Eclipse 3.2 sur ma Debian Etch. Depuis l'upgrade à
partir d'une Sarge quand je veux prévisualiser un rapport j'ai
un "Internal Error: An SWT error has occured". Dans le .log j'ai

!SESSION 2007-05-15
05:23:18.007 --
eclipse.buildId=M20070212-1330
java.version=1.5.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=fr_FR
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.ui 4 4 2007-05-15 05:23:35.107
!MESSAGE Unhandled event loop exception

!ENTRY org.eclipse.ui 4 0 2007-05-15 05:23:35.107
!MESSAGE No more handles
(java.lang.UnsatisfiedLinkError: /home/eric/eclipse/configuration/org.eclipse.osgi/bundles/80/1/.cp/libswt-mozilla-gtk-3236.so:
Can't load IA 32-bit .so on a IA 32-bit platform)
!STACK 0
org.eclipse.swt.SWTError: No more handles
(java.lang.UnsatisfiedLinkError: /home/eric/eclipse/configuration/org.eclipse.osgi/bundles/80/1/.cp/libswt-mozilla-gtk-3236.so:
Can't load IA 32-bit .so on a IA 32-bit platform)
at org.eclipse.swt.SWT.error(SWT.java:3400)
at org.eclipse.swt.SWT.error(SWT.java:3297)
at org.eclipse.swt.browser.Browser.<init>(Browser.java:168)
at
org.eclipse.birt.report.designer.ui.preview.editors.ReportPreviewEditor.createPartControl(ReportPreviewEditor.java:155)
at
org.eclipse.birt.report.designer.ui.preview.editors.ReportPreviewFormPage.createPartControl(ReportPreviewFormPage.java:175)
at org.eclipse.ui.forms.editor.FormEditor.pageChange(FormEditor.java:462)
at
org.eclipse.birt.report.designer.ui.editors.MultiPageReportEditor.pageChange(MultiPageReportEditor.java:539)
at
org.eclipse.ui.part.MultiPageEditorPart$2.widgetSelected(MultiPageEditorPart.java:232)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:90)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1109)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1094)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:935)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:3171)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1953)
at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.java:288)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3180)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2856)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1930)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1894)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:422)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:95)
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)
Caused by:
java.lang.UnsatisfiedLinkError: /home/eric/eclipse/configuration/org.eclipse.osgi/bundles/80/1/.cp/libswt-mozilla-gtk-3236.so:
Can't load IA 32-bit .so on a IA 32-bit platform
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1660)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)
at java.lang.System.loadLibrary(System.java:993)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.browser.Browser.<init>(Browser.java:153)

Je précise que pour Eclipse et la jvm je n'utilise pas les paquets fournis
par Debian. En vous remerciant,

--
Eric


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #9556011
Eric Guirbal, mercredi 16 mai 2007, 23:53:06 CEST

Bonjour,



’soir,

J'utilise BIRT 2.1.2 + Eclipse 3.2 sur ma Debian Etch. Depuis l'upgrade à
partir d'une Sarge quand je veux prévisualiser un rapport j'ai
un "Internal Error: An SWT error has occured". Dans le .log j'ai
[...]
(java.lang.UnsatisfiedLinkError: /home/eric/eclipse/configuration/org.ecl ipse.osgi/bundles/80/1/.cp/libswt-mozilla-gtk-3236.so:
Can't load IA 32-bit .so on a IA 32-bit platform)



C’est pourtant clair : mauvais format de bibliothèque.

[...]
Je précise que pour Eclipse et la jvm je n'utilise pas les paquets f ournis
par Debian.



1. Pourquoi pas ?
2. Ce qui explique que le .so n’est plus compatible.

Tu as essayé les paquets ?
Tu as essayé une version plus récente ?

--
Sylvain Sauvage
Eric Guirbal
Le #9555831
Le jeudi 17 mai 2007 00:05, Sylvain Sauvage a écrit :
> Je précise que pour Eclipse et la jvm je n'utilise pas les paquets
> fournis par Debian.

1. Pourquoi pas ?
2. Ce qui explique que le .so n’est plus compatible.

Tu as essayé les paquets ?
Tu as essayé une version plus récente ?



Je viens d'essayer avec les paquets debian à l'exception de BIRT qui n'est
pas fourni. L'onglet "preview" a disparu et dans le menu "file" les
entrées me permettant de générer un rapport en pdf ou html ont disparues.
Et toujours le même problème

!ENTRY org.eclipse.ui.browser 2 0 2007-05-17 21:23:28.001
!MESSAGE Internal browser is not available: No more handles
(java.lang.UnsatisfiedLinkError: /home/eric/.eclipse/org.eclipse.platform_3.2.0/configuration/org.ec
lipse.osgi/bundles/5/1/.cp/libswt-mozilla-gtk-3235.so: Can't load IA
32-bit .so on a IA 32-bit platform)

Je précise que j'ai bien effacé mon .eclipse avant de tout réinstaller.

Merci,

--
Eric





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Davy Gigan
Le #9555791
--nextPart1282455.RrYACLjtea
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le jeudi 17 mai 2007 00:05, Sylvain Sauvage a écrit :
> Can't load IA 32-bit .so on a IA 32-bit platform)
C’est pourtant clair : mauvais format de bibliothèque.



Certes, le message est clair sur le principe. Mais si tu le regardes bien i l
est totalement con ce message : qu'est-ce qui peut se charger sur une
plateforme « IA 32-bit » si le « IA 32-bit » ne le peut ?

Pour faire avancer la chose, est-ce que tu as regardé les dépenda nces de link
de ton fichier .so non chargé :

ldd /home/eric/eclipse/configuration/org.eclipse.osgi/bundles/80/1/.cp/libs wt-mozilla-gtk-3236.so

Si tu as une seule librairie manquante, cela expliquera peut-être ton
problème. Mais si tu as bien installé un paquet debian via apt, ça
m'étonnerait qu'il manque quoi que ce soit.


--
Davy Gigan
System & Network Administration [Please no HTML, I'm not a browser]
University Of Caen (France) [Pas d'HTML, je ne suis pas un navigateur]

--nextPart1282455.RrYACLjtea
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBGTZ80kbS8+CLlzYgRAvvGAJ9AhHy7E170S3h3DX9uBA+vFbfH7wCdFusx
5hY1w0fz1ypDkvRquMdsn1A =Mnc1
-----END PGP SIGNATURE-----

--nextPart1282455.RrYACLjtea--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Eric Guirbal
Le #9555671
Le vendredi 18 mai 2007 14:42, Davy Gigan a écrit :
ldd
/home/eric/eclipse/configuration/org.eclipse.osgi/bundles/80/1/.cp/libs
wt-mozilla-gtk-3236.so

Si tu as une seule librairie manquante, cela expliquera peut-être ton
problème. Mais si tu as bien installé un paquet debian via apt, ça
m'étonnerait qu'il manque quoi que ce soit.



Merci, il me manquait le paquet libxuld0d.

--
Eric


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme