bizarerie avec NB.SI.ENS

Le
andre
Bonjour,
Comme il ecrit dans le titre j'ai un souci avec cette formule
ex dans un tableau B2:J40 j'ai des valeurs numeriques et alpha
numeriques ("A" "NC" etc..)
en fin de tableau il y a une recap
pour les valeurs alpha si je fais ex :
=NB.SI.ENS(B2:J40;"A";B2:J40;"NC") il me mets 0
alors que j'ai A et NC une fois
si je fais
=NB.SI.ENS($B$2:$J$40;"A")+NB.SI.ENS($B$2:$J$40;"NC") il me mets bien 2
il me semble pourtant que la formule 1 est la bonne
Quel est votre avis svp
merci

--
André
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
GL
Le #26348669
Le 11/04/2015 10:43, andre a écrit :
Bonjour,
Comme il ecrit dans le titre j'ai un souci avec cette formule
ex dans un tableau B2:J40 j'ai des valeurs numeriques et alpha
numeriques ("A" "NC" etc..)
en fin de tableau il y a une recap
pour les valeurs alpha si je fais ex :
=NB.SI.ENS(B2:J40;"A";B2:J40;"NC") il me mets 0
alors que j'ai A et NC une fois
si je fais
=NB.SI.ENS($B$2:$J$40;"A")+NB.SI.ENS($B$2:$J$40;"NC") il me mets bien 2
il me semble pourtant que la formule 1 est la bonne
Quel est votre avis svp
merci



Non NB.SI.ENS(plage1;critère1;plage2;critère2)
exécute une intersection, c'est :

plage1 répond à critère1 ET plage2 répond à critère2

Alors que si vous sommez, vous faites une réunion
(de listes, pas d'ensemble) :

plage1 répond à critère1 OU plage2 répond à critère2

Ce n'est pas une réunion d'ensemble car :

NB.SI.ENS(plage;"A*") + NB.SI.ENS(plage;"A")

va sommer les cardinaux de chaque ensemble, qui n'est pas
le cardinal de la réunion...

Cordialement,
Florent.
andre
Le #26348684
GL a exposé le 11/04/2015 :
Le 11/04/2015 10:43, andre a écrit :
Bonjour,
Comme il ecrit dans le titre j'ai un souci avec cette formule
ex dans un tableau B2:J40 j'ai des valeurs numeriques et alpha
numeriques ("A" "NC" etc..)
en fin de tableau il y a une recap
pour les valeurs alpha si je fais ex :
=NB.SI.ENS(B2:J40;"A";B2:J40;"NC") il me mets 0
alors que j'ai A et NC une fois
si je fais
=NB.SI.ENS($B$2:$J$40;"A")+NB.SI.ENS($B$2:$J$40;"NC") il me mets bien 2
il me semble pourtant que la formule 1 est la bonne
Quel est votre avis svp
merci



Non NB.SI.ENS(plage1;critère1;plage2;critère2)
exécute une intersection, c'est :

plage1 répond à critère1 ET plage2 répond à critère2

Alors que si vous sommez, vous faites une réunion
(de listes, pas d'ensemble) :

plage1 répond à critère1 OU plage2 répond à critère2

Ce n'est pas une réunion d'ensemble car :

NB.SI.ENS(plage;"A*") + NB.SI.ENS(plage;"A")

va sommer les cardinaux de chaque ensemble, qui n'est pas
le cardinal de la réunion...

Cordialement,
Florent.



Donc pour resumer si dans une colonne j'ai des "A","NC", "E"
je ne pourai pas utiliser NB SI ENS cela retourne valeur
cela fonction uniquement sur l'ensemble du tableau

--
André
Jacquouille
Le #26348690
Bonjour

Je suis sous Excel 2003, donc je ne connais pas ce NB.SI.ENS.

Par contre, dans le temps, nous avions un Dr Sommeprod, Président de la SPA
( SommeProd Académie). -)

Je suis persuadé à 99,99%que SP trouverait votre réponse souhaitée.
Peut-être un =Sommeprod((B2:J40="A")+(B2:J40="NC")*1) ? devrait vous
donner le nombre de "A" et de "NC" dans la plage A2:J40

Bonne journée
Jacques.



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"andre" a écrit dans le message de groupe de discussion :
5528f5bf$0$3047$

GL a exposé le 11/04/2015 :
Le 11/04/2015 10:43, andre a écrit :
Bonjour,
Comme il ecrit dans le titre j'ai un souci avec cette formule
ex dans un tableau B2:J40 j'ai des valeurs numeriques et alpha
numeriques ("A" "NC" etc..)
en fin de tableau il y a une recap
pour les valeurs alpha si je fais ex :
=NB.SI.ENS(B2:J40;"A";B2:J40;"NC") il me mets 0
alors que j'ai A et NC une fois
si je fais
=NB.SI.ENS($B$2:$J$40;"A")+NB.SI.ENS($B$2:$J$40;"NC") il me mets bien 2
il me semble pourtant que la formule 1 est la bonne
Quel est votre avis svp
merci



Non NB.SI.ENS(plage1;critère1;plage2;critère2)
exécute une intersection, c'est :

plage1 répond à critère1 ET plage2 répond à critère2

Alors que si vous sommez, vous faites une réunion
(de listes, pas d'ensemble) :

plage1 répond à critère1 OU plage2 répond à critère2

Ce n'est pas une réunion d'ensemble car :

NB.SI.ENS(plage;"A*") + NB.SI.ENS(plage;"A")

va sommer les cardinaux de chaque ensemble, qui n'est pas
le cardinal de la réunion...

Cordialement,
Florent.



Donc pour resumer si dans une colonne j'ai des "A","NC", "E"
je ne pourai pas utiliser NB SI ENS cela retourne valeur
cela fonction uniquement sur l'ensemble du tableau

--
André


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
GL
Le #26348696
Le 11/04/2015 12:21, andre a écrit :
GL a exposé le 11/04/2015 :
Le 11/04/2015 10:43, andre a écrit :





[Pour résumer]

Bonjour,
Comme il ecrit dans le titre j'ai un souci avec cette formule
ex dans un tableau B2:J40 j'ai des valeurs numeriques et alpha
numeriques ("A" "NC" etc..)
en fin de tableau il y a une recap
pour les valeurs alpha si je fais ex :
=NB.SI.ENS(B2:J40;"A";B2:J40;"NC") il me mets 0






Ca ça calcule:
Nombre de ( B2:J40 = "A" ET B2:J40 = "NC" )

donc c'est TOUJOURS 0, quel que soit le contenu de B2:J40.

alors que j'ai A et NC une fois
si je fais
=NB.SI.ENS($B$2:$J$40;"A")+NB.SI.ENS($B$2:$J$40;"NC") il me mets bien 2
il me semble pourtant que la formule 1 est la bonne







Non c'est la Formule 2 (on n'arrête pas le progrès, même si Jakouye
semble s'être arrêté à la Formule 1 -- private joke ;-) )

NB.SI.ENS ne fait JAMAIS "OU" sur les critères : il fait TOUJOURS "ET".

Cdt.
Jacquouille
Le #26348712
Zizi ze question!

Le Français parlé confond très souvent, voire toujours le "et" et le "ou".
Tandis que Sommeprod peut faire la différence entre des pommes qui sont
rouges et jaunes (bicolores) et les pommes qui sont soit rouges, soit jaunes
(2 pommes différentes).

Dans ce cas, pour connaitre le nombre de pommes qui sont rouges et jaunes
(bicolores), on aura : =sommeprod((plage="jaune")*(plage="rouge")*1).
Tandis que pour avoir la somme des rouges et des jaunes, on aura
=sommeprod((plage="rouge")+(plage="jaune")*1)

Bon app.

Jacquouille, légumier à 16 heures.

" Le vin est au repas ce que le parfum est à la femme."

"GL" a écrit dans le message de groupe de discussion :
55290c90$0$3353$

=NB.SI.ENS(B2:J40;"A";B2:J40;"NC") il me mets 0






Ca ça calcule:
Nombre de ( B2:J40 = "A" ET B2:J40 = "NC" )

donc c'est TOUJOURS 0, quel que soit le contenu de B2:J40.

alors que j'ai A et NC une fois
si je fais
=NB.SI.ENS($B$2:$J$40;"A")+NB.SI.ENS($B$2:$J$40;"NC") il me mets bien 2
il me semble pourtant que la formule 1 est la bonne







Non c'est la Formule 2 (on n'arrête pas le progrès, même si Jakouye
semble s'être arrêté à la Formule 1 -- private joke ;-) )

NB.SI.ENS ne fait JAMAIS "OU" sur les critères : il fait TOUJOURS "ET".

Cdt.


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Jacky
Le #26348713
Hello à vous...

Jacquouille, légumier à 16 heures.




Tout ca ne me dit pas si la fumée est blanche...;o))
va sommer les cardinaux de chaque ensemble, qui n'est pas
le cardinal de la réunion...



Ok! Ok....je sors
--
Salutations
JJ
Jacquouille
Le #26348715
Hello Jacky,

Assommer les cardinaux tous ensemble. En vlà une idée....
Pour la Réunion, on fera le point sur ce Cardinal-là.
PS: Si tu sors, mets quand même une petite laine. -)
Bon WE
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Jacky" a écrit dans le message de groupe de discussion :
mgb53o$gb$

Hello à vous...

Jacquouille, légumier à 16 heures.




Tout ca ne me dit pas si la fumée est blanche...;o))
va sommer les cardinaux de chaque ensemble, qui n'est pas
le cardinal de la réunion...



Ok! Ok....je sors
--
Salutations
JJ



---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
GL
Le #26348723
Le 11/04/2015 15:02, Jacquouille a écrit :
Hello Jacky,

Assommer les cardinaux tous ensemble. En vlà une idée....
Pour la Réunion, on fera le point sur ce Cardinal-là.



Oui il va falloir, car il s'agit du bien du Cardinal de la Réunion,
et non la Réunion des Cardinaux, qu'on clave jusqu'à 40 jours s'il le
faut...

Oui ça existe bien 'claver'
http://www.cnrtl.fr/definition/claver
Jacquouille
Le #26348737
Où l'on retrouve très facilement le mot "en...claver"
Brûlons donc toutes ces cottes violettes et laissons au Peuple la parole du
sage.....

Bien vu pour Mon Saigneur, mais, as-tu vu: faire le POINT sur le CARDINAL ?

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"GL" a écrit dans le message de groupe de discussion :
55292222$0$3354$

Le 11/04/2015 15:02, Jacquouille a écrit :
Hello Jacky,

Assommer les cardinaux tous ensemble. En vlà une idée....
Pour la Réunion, on fera le point sur ce Cardinal-là.



Oui il va falloir, car il s'agit du bien du Cardinal de la Réunion,
et non la Réunion des Cardinaux, qu'on clave jusqu'à 40 jours s'il le
faut...

Oui ça existe bien 'claver'
http://www.cnrtl.fr/definition/claver



---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Jacky
Le #26348742
Re..
Voila que André,(le pauvre) devra faire le tri entre:

-Valeurs numériques et alpha numériques ("A" "NC" etc..)
-Une courses de formule 1 en concurrence avec les formules 2
-L'académie des sommeprod()
-JAMAIS "OU" TOUJOURS "ET".
-Le Français qui confond toujours le "et" et le "ou".
-La fumée blanche qui assomment les cardinaux
-Ceux que l'on clavent jusqu'à 40 jours parce-qu'ils n'ont pas de petite laine.

:o))))
Allez, bon courage
-

--
Salutations
JJ


"GL"
Le 11/04/2015 15:02, Jacquouille a écrit :
Hello Jacky,

Assommer les cardinaux tous ensemble. En vlà une idée....
Pour la Réunion, on fera le point sur ce Cardinal-là.



Oui il va falloir, car il s'agit du bien du Cardinal de la Réunion,
et non la Réunion des Cardinaux, qu'on clave jusqu'à 40 jours s'il le
faut...

Oui ça existe bien 'claver'
http://www.cnrtl.fr/definition/claver



Publicité
Poster une réponse
Anonyme