bizarre

Le
News Free
bonjour (soir) à tous
je rencontre un pb bizarre autant qu'étrange
j'ai une macro assez longue qui retraite un fichier texte en transférant des
éléments de colonnes dans d'autres colonnes (après élimination des espaces,
transformation des "," en ".", concaténations, puis suppression de certaines
colonnes )
Cette macro fonctionne parfaitement avec mon ordi fixe (windows XP pro ,
excel XP 2003 pro) et sur mon portable équipé pareil (win xp pro, excel xp
pro).
Sur l'ordi portable d'un client (windows xp pro, excel xp pro) cette macro
se déroule sans plantage mais génère un bordel pas possible en décalant des
colonnes.
j'ai pensé aux bibliothèques (références dans VBE), aux macros
complémentaires, aux paramètres régionaux (symbole décimal notamment): tout
est correct
celà doit venir d'ailleurs mais j'ai plus d'idées
A priori, cela ne semble pas venir d'excel puisque le même code marche bien
sur 3 ordi (j'ai essayé aussi un autre portable équipé pareil et qui accepte
sans pb la macro)
et flanque le bordel sur le 4ème (celui du client, bien sûr ..)
si quelqu'un(e) a le début des prémisses du commencement d'une idée ou d'une
suggestion; cela me serait d'un grand secours
merci d'avance
claude
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #5392291
Bonsoir,
Déroule ta macro pas à pas avec F8 et regarde déjà à partir de quelle
ligne cela coince...
difficile de t'aider comme ça "dans le vide".
Bon courage
Misange

bonjour (soir) à tous
je rencontre un pb bizarre autant qu'étrange
j'ai une macro assez longue qui retraite un fichier texte en transférant des
éléments de colonnes dans d'autres colonnes (après élimination des espaces,
transformation des "," en ".", concaténations, puis suppression de certaines
colonnes ...)
Cette macro fonctionne parfaitement avec mon ordi fixe (windows XP pro ,
excel XP 2003 pro) et sur mon portable équipé pareil (win xp pro, excel xp
pro).
Sur l'ordi portable d'un client (windows xp pro, excel xp pro) cette macro
se déroule sans plantage mais génère un bordel pas possible en décalant des
colonnes.
j'ai pensé aux bibliothèques (références dans VBE), aux macros
complémentaires, aux paramètres régionaux (symbole décimal notamment): tout
est correct
celà doit venir d'ailleurs mais j'ai plus d'idées
A priori, cela ne semble pas venir d'excel puisque le même code marche bien
sur 3 ordi (j'ai essayé aussi un autre portable équipé pareil et qui accepte
sans pb la macro)
et flanque le bordel sur le 4ème (celui du client, bien sûr .....)
si quelqu'un(e) a le début des prémisses du commencement d'une idée ou d'une
suggestion; cela me serait d'un grand secours ...
merci d'avance
claude




News Free
Le #5392241
bonsoir
merci de ton aide
j'ai déroulé déjà la macro: je vois bien à partir de quoi çà décale :
il s'agit d'une concaténation de cellules (les références sont écrites en
"cells(RC)" )
apparemment, le code se trompe de colonne et ne concatène pas les bonnes
cellules
il faut que je vérifie le déroulement de la macro sur le poste qui coince
j'essaierai d'extraire les lignes qui sont mal interprêtées
de toute façon il n'y a pas d'erreurs à l'exécution de la macro, seulement
des résultats faux (ce qui est presque pire ...)
mais sur mon poste (et sur 2 autres sur lesquels j'ai testé le code) tout se
déroule parfaitement et donne des résultats corrects

le même code sur deux ordi équipés semblables peut-il être interprêté
différemment ?
j'avoue que je ne comprends pas

:-((
claude



"Misange"
Bonsoir,
Déroule ta macro pas à pas avec F8 et regarde déjà à partir de quelle
ligne cela coince...
difficile de t'aider comme ça "dans le vide".
Bon courage
Misange

bonjour (soir) à tous
je rencontre un pb bizarre autant qu'étrange
j'ai une macro assez longue qui retraite un fichier texte en transférant
des éléments de colonnes dans d'autres colonnes (après élimination des
espaces, transformation des "," en ".", concaténations, puis suppression
de certaines colonnes ...)
Cette macro fonctionne parfaitement avec mon ordi fixe (windows XP pro ,
excel XP 2003 pro) et sur mon portable équipé pareil (win xp pro, excel
xp pro).
Sur l'ordi portable d'un client (windows xp pro, excel xp pro) cette
macro se déroule sans plantage mais génère un bordel pas possible en
décalant des colonnes.
j'ai pensé aux bibliothèques (références dans VBE), aux macros
complémentaires, aux paramètres régionaux (symbole décimal notamment):
tout est correct
celà doit venir d'ailleurs mais j'ai plus d'idées
A priori, cela ne semble pas venir d'excel puisque le même code marche
bien sur 3 ordi (j'ai essayé aussi un autre portable équipé pareil et qui
accepte sans pb la macro)
et flanque le bordel sur le 4ème (celui du client, bien sûr .....)
si quelqu'un(e) a le début des prémisses du commencement d'une idée ou
d'une suggestion; cela me serait d'un grand secours ...
merci d'avance
claude




MichDenis
Le #5392231
À tout hasard,

Assure-toi que ce paramètre à partir de la barre des menus /
outils / options / Onglet Général : "Style de référence L1C1"
est identique sur tous les ordinateurs que tu testes !

Si tu utilises ce type de référence : Cells(5,4) , la case devrait être
décochée.



"News Free" 474b4324$0$27277$
bonsoir
merci de ton aide
j'ai déroulé déjà la macro: je vois bien à partir de quoi çà décale :
il s'agit d'une concaténation de cellules (les références sont écrites en
"cells(RC)" )
apparemment, le code se trompe de colonne et ne concatène pas les bonnes
cellules
il faut que je vérifie le déroulement de la macro sur le poste qui coince
j'essaierai d'extraire les lignes qui sont mal interprêtées
de toute façon il n'y a pas d'erreurs à l'exécution de la macro, seulement
des résultats faux (ce qui est presque pire ...)
mais sur mon poste (et sur 2 autres sur lesquels j'ai testé le code) tout se
déroule parfaitement et donne des résultats corrects

le même code sur deux ordi équipés semblables peut-il être interprêté
différemment ?
j'avoue que je ne comprends pas

:-((
claude



"Misange"
Bonsoir,
Déroule ta macro pas à pas avec F8 et regarde déjà à partir de quelle
ligne cela coince...
difficile de t'aider comme ça "dans le vide".
Bon courage
Misange

bonjour (soir) à tous
je rencontre un pb bizarre autant qu'étrange
j'ai une macro assez longue qui retraite un fichier texte en transférant
des éléments de colonnes dans d'autres colonnes (après élimination des
espaces, transformation des "," en ".", concaténations, puis suppression
de certaines colonnes ...)
Cette macro fonctionne parfaitement avec mon ordi fixe (windows XP pro ,
excel XP 2003 pro) et sur mon portable équipé pareil (win xp pro, excel
xp pro).
Sur l'ordi portable d'un client (windows xp pro, excel xp pro) cette
macro se déroule sans plantage mais génère un bordel pas possible en
décalant des colonnes.
j'ai pensé aux bibliothèques (références dans VBE), aux macros
complémentaires, aux paramètres régionaux (symbole décimal notamment):
tout est correct
celà doit venir d'ailleurs mais j'ai plus d'idées
A priori, cela ne semble pas venir d'excel puisque le même code marche
bien sur 3 ordi (j'ai essayé aussi un autre portable équipé pareil et qui
accepte sans pb la macro)
et flanque le bordel sur le 4ème (celui du client, bien sûr .....)
si quelqu'un(e) a le début des prémisses du commencement d'une idée ou
d'une suggestion; cela me serait d'un grand secours ...
merci d'avance
claude




claude
Le #5392151
bonjour Michel
je vais essayer: en tout cas merci,
j'avais point du tout pensé à çà ...
je vous tiens au courant
:-)
claude



"MichDenis"
À tout hasard,

Assure-toi que ce paramètre à partir de la barre des menus /
outils / options / Onglet Général : "Style de référence L1C1"
est identique sur tous les ordinateurs que tu testes !

Si tu utilises ce type de référence : Cells(5,4) , la case devrait être
décochée.



"News Free" 474b4324$0$27277$
bonsoir
merci de ton aide
j'ai déroulé déjà la macro: je vois bien à partir de quoi çà décale :
il s'agit d'une concaténation de cellules (les références sont écrites en
"cells(RC)" )
apparemment, le code se trompe de colonne et ne concatène pas les bonnes
cellules
il faut que je vérifie le déroulement de la macro sur le poste qui coince
j'essaierai d'extraire les lignes qui sont mal interprêtées
de toute façon il n'y a pas d'erreurs à l'exécution de la macro, seulement
des résultats faux (ce qui est presque pire ...)
mais sur mon poste (et sur 2 autres sur lesquels j'ai testé le code) tout
se
déroule parfaitement et donne des résultats corrects

le même code sur deux ordi équipés semblables peut-il être interprêté
différemment ?
j'avoue que je ne comprends pas

:-((
claude



"Misange"
Bonsoir,
Déroule ta macro pas à pas avec F8 et regarde déjà à partir de quelle
ligne cela coince...
difficile de t'aider comme ça "dans le vide".
Bon courage
Misange

bonjour (soir) à tous
je rencontre un pb bizarre autant qu'étrange
j'ai une macro assez longue qui retraite un fichier texte en transférant
des éléments de colonnes dans d'autres colonnes (après élimination des
espaces, transformation des "," en ".", concaténations, puis suppression
de certaines colonnes ...)
Cette macro fonctionne parfaitement avec mon ordi fixe (windows XP pro ,
excel XP 2003 pro) et sur mon portable équipé pareil (win xp pro, excel
xp pro).
Sur l'ordi portable d'un client (windows xp pro, excel xp pro) cette
macro se déroule sans plantage mais génère un bordel pas possible en
décalant des colonnes.
j'ai pensé aux bibliothèques (références dans VBE), aux macros
complémentaires, aux paramètres régionaux (symbole décimal notamment):
tout est correct
celà doit venir d'ailleurs mais j'ai plus d'idées
A priori, cela ne semble pas venir d'excel puisque le même code marche
bien sur 3 ordi (j'ai essayé aussi un autre portable équipé pareil et
qui
accepte sans pb la macro)
et flanque le bordel sur le 4ème (celui du client, bien sûr .....)
si quelqu'un(e) a le début des prémisses du commencement d'une idée ou
d'une suggestion; cela me serait d'un grand secours ...
merci d'avance
claude









Publicité
Poster une réponse
Anonyme