Bizarrerie dans les points de montage des disques durs

Le
Fenkys
Bonjour,


Fidèle utilisateur de LFS, je viens - suite à un décès d'ordi - d'opter
pour une distribution conviviale en l'occurrence une Debian Lenny. Et
j'ai plusieurs problème. Voici le premier.

Mon noyau démarre avec l'option root=/dev/sda1

Mais dans le fichier fstab j'ai :
/dev/sdb1 / ext3 errors=remount-ro

Pas très cohérent tout ça.

Après vérification, c'est bien l'option de démarrage qui est prise en
compte pour le répertoire de base, pas le contenu du fstab. Ma partition
racine est bien sur /dev/sda1. Ce qui est logique vu que /dev/sdb1 est
une partition fat32

Quelqu'un peut il m'expliquer ce qui se passe ici. Est ce que cela
risque de poser des problèmes. Dois modifier le fichier fstab pour
mettre en accord grub et fstab ?


Merci de votre aide.


Laurent
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
moi-meme
Le #19871661
Le Sun, 02 Aug 2009 15:41:43 +0200, Fenkys a écrit :

Bonjour,


Fidèle utilisateur de LFS, je viens - suite à un décès d'ordi - d'opter
pour une distribution conviviale en l'occurrence une Debian Lenny. Et
j'ai plusieurs problème. Voici le premier.

Mon noyau démarre avec l'option root=/dev/sda1

Mais dans le fichier fstab j'ai :
/dev/sdb1 / ext3 errors=remount-ro

Pas très cohérent tout ça.

Après vérification, c'est bien l'option de démarrage qui est prise en
compte pour le répertoire de base, pas le contenu du fstab. Ma partition
racine est bien sur /dev/sda1. Ce qui est logique vu que /dev/sdb1 est
une partition fat32

Quelqu'un peut il m'expliquer ce qui se passe ici. Est ce que cela
risque de poser des problèmes. Dois modifier le fichier fstab pour
mettre en accord grub et fstab ?





et qu'est-ce qu'il dit pour sda1 fstab ?
et tu arrives à accèder à sdb1 ?
pas d'alarme au boot ?

beaucoup de questions mes excuses mais si ça peut aider

CH (en standby)
Fenkys
Le #19871801
moi-meme a écrit :

et qu'est-ce qu'il dit pour sda1 fstab ?
et tu arrives à accèder à sdb1 ?
pas d'alarme au boot ?

beaucoup de questions mes excuses mais si ça peut aider



Dans fstab, il n'y a aucune référence à sda1, sda5 (le swap)

Je n'ai aucun problème à monter sbd1 si je le fait manuellement en ligne
de commande en omettant aucun paramètres, mais nautilus en est incapable
bien qu'il voir la partition et puisse donner ses caractéristiques :
Nom : Enfer
Taille : 1.5 Gio
Média : Hard Disk
Système de Fichier : vfat

Aucune alarme n'est signalée au boot. Il détecte bien sda et sdb et
donne la liste des partition des deux disques.

Il est interessant que pour le swap, j'ai une erreur :
Unable to find swap-space signature
Logique, le swap est en sda5, mais le fichier fstab le déclare en sdb5.
Ça, je peux le corriger sans problème, c'est plus le / qui me gène.


Les questions ne me posent aucun problème si elle permettent d'approcher
la solution.

LD
Nicolas George
Le #19871851
Fenkys wrote in message
Mais dans le fichier fstab j'ai :
/dev/sdb1 / ext3 errors=remount-ro

Pas très cohérent tout ça.



Eh bien corrige fstab.

C'est essentiellement esthétique : /etc/fstab est dans le filesystem racine,
donc on ne peut pas y accéder avant de savoir quel est le filesystem racine,
forcément. Donc ce n'est pas lui qui fait autorité.
Fenkys
Le #19871921
Nicolas George a écrit :
Fenkys wrote in message
Mais dans le fichier fstab j'ai :
/dev/sdb1 / ext3 errors=remount-ro

Pas très cohérent tout ça.



Eh bien corrige fstab.

C'est essentiellement esthétique : /etc/fstab est dans le filesystem racine,
donc on ne peut pas y accéder avant de savoir quel est le filesystem racine,
forcément. Donc ce n'est pas lui qui fait autorité.



OK, je corrige donc.

Merci pour ton aide


LD
Sergio
Le #19872231
Fenkys a écrit :

Fidèle utilisateur de LFS, je viens - suite à un décès d'ordi - d'opter
pour une distribution conviviale en l'occurrence une Debian Lenny. Et
j'ai plusieurs problème. Voici le premier.

Mon noyau démarre avec l'option root=/dev/sda1

Mais dans le fichier fstab j'ai :
/dev/sdb1 / ext3 errors=remount-ro

Pas très cohérent tout ça.

Après vérification, c'est bien l'option de démarrage qui est prise en
compte pour le répertoire de base, pas le contenu du fstab. Ma partition
racine est bien sur /dev/sda1. Ce qui est logique vu que /dev/sdb1 est
une partition fat32

Quelqu'un peut il m'expliquer ce qui se passe ici. Est ce que cela
risque de poser des problèmes. Dois modifier le fichier fstab pour
mettre en accord grub et fstab ?



AMHA, pour le fstab, mets des UUID plutôt que /dev/sdxy, celà évite des
complications quand tu rajoutes / enlèves des lecteurs (disques ou CD).
cf : http://doc.ubuntu-fr.org/uuid_et_label

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
moi-meme
Le #19874671
Le Sun, 02 Aug 2009 17:13:50 +0200, Fenkys a écrit :


Je n'ai aucun problème à monter sbd1 si je le fait manuellement en ligne
de commande en omettant aucun paramètres, mais nautilus en est incapable
bien qu'il voir la partition et puisse donner ses caractéristiques :



Je ne te prends pas pour un idiot mais quelquefois je le suis (et ça me
fait du bien quand on met le doigt dessus ) :

t'aurais pas changé le strap sur le DD après avoir chargé le système ?
ou un truc comme ça
Publicité
Poster une réponse
Anonyme