[bizarrerie] wget : "Fichier « 274.swf » est déjà là; pas de récupération."

Le
BULOT Grégory
bonjour,

j'ai un soucis de compréhension, le problème doit être évident, mai=
s j'arrive
pas à le voir :

$ wget -nc "http://monserver.com/274.swf" -O "/home/user/274.swf"
Fichier « 274.swf » est déjà là; pas de récupération.

user@debian:~$ rm /home/user/274.swf
user@debian:~$ rm /home/user/274.swf
rm: ne peut enlever `/home/user/274.swf': Aucun fichier ou répertoire de =
ce
type
user@debian:~$ wget -nc "http://monserver.com/274.swf" -O "/home/user/274.s=
wf"
Fichier « 274.swf » est déjà là; pas de récupération.

Au final /home/user/274.swf est de taille '0'


le truc rigolo (enfin .) sur mon serveur, je renome 274.swf en toto.swf,=
je
n'ais pas le "est déjà là; pas de récupération"

j'utilise l'option -nc car je veux écraser le fichier de destination mê=
me s'il
existe déjà.

ceci est un exemple hors contexte de mon développement, c'est un exemple=

minimaliste pour montrer mon problème

qui à la réponse magique ;-)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
on4hu
Le #9755361
probablement une question de droit
fais tu cette opération sous root
André

Le Wednesday 10 October 2007 12:07:04 BULOT Grégory, vous avez écrit :
bonjour,

j'ai un soucis de compréhension, le problème doit être évident, m ais
j'arrive pas à le voir :

$ wget -nc "http://monserver.com/274.swf" -O "/home/user/274.swf"
Fichier « 274.swf » est déjà là; pas de récupération.

:~$ rm /home/user/274.swf
:~$ rm /home/user/274.swf
rm: ne peut enlever `/home/user/274.swf': Aucun fichier ou répertoire d e ce
type
:~$ wget -nc "http://monserver.com/274.swf" -O
"/home/user/274.swf" Fichier « 274.swf » est déjà là; pas de r écupération.

Au final /home/user/274.swf est de taille '0'


le truc rigolo (enfin ....) sur mon serveur, je renome 274.swf en toto.sw f,
je n'ais pas le "est déjà là; pas de récupération"

j'utilise l'option -nc car je veux écraser le fichier de destination m ême
s'il existe déjà.

ceci est un exemple hors contexte de mon développement, c'est un exemple
minimaliste pour montrer mon problème

qui à la réponse magique ;-)





--
Quelle est la différence entre Windows et Linux ?
Réponse : Linux a un noyau, Windows a des pépins!
Bulot Grégory
Le #9755301
Le mercredi 10 octobre 2007 12:41, on4hu a écrit :
probablement une question de droit
fais tu cette opération sous root
André



ça marche en root, sauf si je suis dans le
répertoire /home/user/LeRepertoireDeTravail/ (même erreur que le sujet)

et en 'user' aussi, cela ne marche pas dans /home/user/LeRepertoireDeTravai l/,
par contre aucun soucis si je me place ailleurs !!

j'ai ~200 fichiers qui fonctionnent, sauf celui là, je vais pas modifier tous
mes scripts juste pour celui-là !

wget ne gère-t-il pas une blackliste de fichier par hasard (pas vu dans l e
man)
Bulot Grégory
Le #9755291
Le mercredi 10 octobre 2007 14:47, Bulot Grégory a écrit :

bon je crois avoir le fin mot de l'histoire (réponse demain surement)

en fait il manquait des informations (j'ai voulu être trop 'épuré)

Pendant son execution mon script se trouve (pwd)
là : /home/user/LeRepertoireDeTravail

le script lance un wget :

wget -nc "http://monserver.com/274.swf" -O "/home/user/FichierTempRecu/274. swf"

suite à un plantage le mois dernier, j'avais récupérer 'a la main"
dans /home/user/LeRepertoireDeTravail :
wget -nc "http://monserver.com/274.swf"
puis j'avais copié ce fichier dans FichierTempRecu/.


Visiblement ne veut pas charger un fichier MonFichier si dans son réperto ire
courant ce même fichier existe et ce si la destination (-O) est ailleurs !!

est-ce reproductible chez vous, dans ce cas ptet un bug a remonter, non ?

# wget -V | head -1 ; dpkg -l wget | grep ii
GNU Wget 1.10.2
ii wget 1.10.2-2 retrieves files from the web
Sylvain Sauvage
Le #9755281
Bulot Grégory, mercredi 10 octobre 2007, 14:47:21 CEST

Le mercredi 10 octobre 2007 12:41, on4hu a écrit :
> probablement une question de droit
> fais tu cette opération sous root
> André

ça marche en root, sauf si je suis dans le
répertoire /home/user/LeRepertoireDeTravail/ (même erreur que
le sujet)

et en 'user' aussi, cela ne marche pas
dans /home/user/LeRepertoireDeTravail/, par contre aucun
soucis si je me place ailleurs !! […]



Et une comparaison des droits/options de montages/… des
répertoires où cela fonctionne et des autres, ça pourrait être
intéressant, non ? Surtout pour nous : ça nous éviterait de
jouer aux devinettes.

--
Sylvain Sauvage
David Prévot
Le #9755251
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bulot Grégory a écrit :
Le mercredi 10 octobre 2007 14:47, Bulot Grégory a écrit :



[...]

Visiblement ne veut pas charger un fichier MonFichier si dans son répertoire
courant ce même fichier existe et ce si la destination (-O) est ailleurs !!

est-ce reproductible chez vous, dans ce cas ptet un bug a remonter, non ?



On dirait (je suis sous Sid) :

:/tmp$ mkdir wget
:/tmp$ wget -nc www.debian.org
- --09:44:25-- http://www.debian.org/
=> `index.html'
Résolution de www.debian.org... 194.109.137.218
Connexion vers www.debian.org|194.109.137.218|:80...connecté.
requête HTTP transmise, en attente de la réponse...200 OK
Longueur: 14 248 (14K) [text/html]

100%[========================================>] 14 248 26.56K/s

09:44:26 (26.51 KB/s) - « index.html » sauvegardé [14248/14248]

:/tmp$ wget -nc www.debian.org -O wget/index.html
Fichier « index.html » est déjà là; pas de récupération.

:/tmp$ rm index.html
:/tmp$ wget -nc www.debian.org -O wget/index.html
- --09:46:31-- http://www.debian.org/
=> `wget/index.html'
Résolution de www.debian.org... 194.109.137.218
Connexion vers www.debian.org|194.109.137.218|:80...connecté.
requête HTTP transmise, en attente de la réponse...200 OK
Longueur: 14 248 (14K) [text/html]

100%[========================================>] 14 248 30.47K/s

09:46:33 (30.38 KB/s) - « wget/index.html » sauvegardé [14248/14248]



Amicalement

David
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHDNgW18/WetbTC/oRAg0WAJ9UxehTc4m5uqvxkVIj+lhvkRHnrgCggw3g
dHSIDfW1ihNLhZXSN93ItgQ =RToM
-----END PGP SIGNATURE-----


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9755241
Le mercredi 10 octobre 2007 15:29, Sylvain Sauvage a écrit :
Bulot Grégory, mercredi 10 octobre 2007, 14:47:21 CEST

> Le mercredi 10 octobre 2007 12:41, on4hu a écrit :
> > probablement une question de droit
> > fais tu cette opération sous root
> > André
>
> ça marche en root, sauf si je suis dans le
> répertoire /home/user/LeRepertoireDeTravail/ (même erreur que
> le sujet)
>
> et en 'user' aussi, cela ne marche pas
> dans /home/user/LeRepertoireDeTravail/, par contre aucun
> soucis si je me place ailleurs !! […]

Et une comparaison des droits/options de montages/… des
répertoires où cela fonctionne et des autres, ça pourrait être
intéressant, non ? Surtout pour nous : ça nous éviterait de
jouer aux devinettes.



Je pense que ma réponse 1 minute avant la votre devrait répondre a quelques
questions (vous ne pouviez donc voir ces éclaircissements)

Que cela soit root ou user : /home/user/LeRepertoireDeTravail/ reste
littéralement /home/user/LeRepertoireDeTravail/

et les droits sont :
/home/user/* (il y a récursivité) (0755/drwxr-xr-x) Uid: ( 1001 / user)
Gid: ( user/ kiosk)

la commande est exécuté en tant que 'user' (uid 1001)
Sylvain Sauvage
Le #9755221
Bulot Grégory, mercredi 10 octobre 2007, 15:53:29 CEST
[…]
> Et une comparaison des droits/options de montages/… des
> répertoires où cela fonctionne et des autres, ça pourrait
> être intéressant, non ? Surtout pour nous : ça nous
> éviterait de jouer aux devinettes.

Je pense que ma réponse 1 minute avant la votre devrait
répondre a quelques questions (vous ne pouviez donc voir ces
éclaircissements) […]



Ce que je voulais dire c’est qu’à part « ç a marche pas », on
n’avait pas trop d’info. Puisque ça fonctionnait d⠀™un rép. et
pas d’un autre, le premier réflexe doit être de regarder leurs
différences. Ce que tu as fini par faire puisque tu as trouvé⠀¦
D’ailleurs, est-ce que l’option ‘-P’ ne s erait pas justement
faite pour ce que tu veux, vu que tu sembles conserver le nom
des fichiers et les télécharger un par un ?

--
Sylvain Sauvage
Bulot Grégory
Le #9755151
Le mercredi 10 octobre 2007 16:08, Sylvain Sauvage a écrit :
Bulot Grégory, mercredi 10 octobre 2007, 15:53:29 CEST




Ce que je voulais dire c’est qu’à part « à §a marche pas », on
n’avait pas trop d’info. Puisque ça fonctionnait d ’un rép. et
pas d’un autre, le premier réflexe doit être de regarde r leurs
différences. Ce que tu as fini par faire puisque tu as trouvé …



Je me suis visiblement mal exprimé, je suis pas partisans du "ça marche pas
point barre", cela m'a pris énormément de temps pour synthét iser mon problème
(visiblement pas assez, je suis désolé de vous avoir fait perdre du temps
pour me redemander d'autres explications)

D’ailleurs, est-ce que l’option ‘-P’ ne serait pas justement
faite pour ce que tu veux, vu que tu sembles conserver le nom
des fichiers et les télécharger un par un ?



-P : en regardant plus attentivement le man, cela pourrait être une pirouette
intéressante, je garde cette option que j'avais zappé lors d'une prochaine
révision de l'appli
Publicité
Poster une réponse
Anonyme