Blocage lecteurs CD

Le
Gérard Rigaud
bonjour,
j'ai une ancienne carte-mère MSI IDE avec 2 canaux Ultra ATA/100.
Tout récemment j'ai monté un DD de 250 Go Samsung Ultra ATA/166.
Tout marche bien, si ce n'est que je ne peux plus ouvrir mon lecteur et
graveur de CD !

Mon nouveau DD est responsable de cette situation, puisque si je le
déconnecte tout redevient OK.

Ma question est de savoir s'il s'agit d'un pb purement hard sans solution,
si ce n'est de connecter le DD sur une carte-mère avec IDE ATA/166,
ou bien un pb soft (pb de partitionnement par exemple).

Merci d'avance pour vos explications


--
Gérard Rigaud
pour me répondre personnellement cliquer sur le lien suivant :
http://viadresse.com?25101940
merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Zythum
Le #319621
bonjour,
j'ai une ancienne carte-mère MSI IDE avec 2 canaux Ultra ATA/100.
Tout récemment j'ai monté un DD de 250 Go Samsung Ultra ATA/166.
Tout marche bien,... si ce n'est que je ne peux plus ouvrir mon lecteur
et graveur de CD !

Mon nouveau DD est responsable de cette situation, puisque si je le
déconnecte tout redevient OK.

Ma question est de savoir s'il s'agit d'un pb purement hard sans
solution, si ce n'est de connecter le DD sur une carte-mère avec IDE
ATA/166,
ou bien un pb soft (pb de partitionnement par exemple).



Tu as réglé le cavalier maitre/esclave (master/slave) sur le nouveau DD ?


--
Zythum

Gérard Rigaud
Le #319620
Zythum wrote:
bonjour,
j'ai une ancienne carte-mère MSI IDE avec 2 canaux Ultra ATA/100.
Tout récemment j'ai monté un DD de 250 Go Samsung Ultra ATA/166.
Tout marche bien,... si ce n'est que je ne peux plus ouvrir mon
lecteur et graveur de CD !

Mon nouveau DD est responsable de cette situation, puisque si je le
déconnecte tout redevient OK.

Ma question est de savoir s'il s'agit d'un pb purement hard sans
solution, si ce n'est de connecter le DD sur une carte-mère avec IDE
ATA/166,
ou bien un pb soft (pb de partitionnement par exemple).



Tu as réglé le cavalier maitre/esclave (master/slave) sur le nouveau
DD ?


en fait câble select.
pas de pb niveau bios et xp reconnaît tout très bien.
la seule chose qui ne marche pas , c'est l'ouverture des tirroirs des CD !


--
Gérard Rigaud
pour me répondre personnellement cliquer sur le lien suivant :
http://viadresse.com?25101940
merci


Droger Jean-Paul
Le #319607
Le 16/08/2007, Gérard Rigaud a supposé :
Zythum wrote:
bonjour,
j'ai une ancienne carte-mère MSI IDE avec 2 canaux Ultra ATA/100.
Tout récemment j'ai monté un DD de 250 Go Samsung Ultra ATA/166.
Tout marche bien,... si ce n'est que je ne peux plus ouvrir mon
lecteur et graveur de CD !

Mon nouveau DD est responsable de cette situation, puisque si je le
déconnecte tout redevient OK.

Ma question est de savoir s'il s'agit d'un pb purement hard sans
solution, si ce n'est de connecter le DD sur une carte-mère avec IDE
ATA/166,
ou bien un pb soft (pb de partitionnement par exemple).



Tu as réglé le cavalier maitre/esclave (master/slave) sur le nouveau
DD ?


en fait câble select.
pas de pb niveau bios et xp reconnaît tout très bien.
la seule chose qui ne marche pas , c'est l'ouverture des tirroirs des CD !


si reconnut par bios et XP cela veut dire que alimenté alors peut être
un simple problème hard!! est ce que le tiroir fait mine de bouger en
appuyant dessus?

attention, y a des cas où cable select ne marche pas terrible, je ne
sais si c'est la CM ou Windows qui merdoie, aussi je préfère de loin
mettre le maitre en bout et l'esclave au milieu de la nappe, au moins
le système n'a pas à choisir!!!

Bonne recharche (à tout hasard tu débranche le conecteur puissance et
tu le rebranche, mais m'étonnerait qu'il ne soit pas alimenté!!!.

--
Pour m'envoyer un mail, remplacer anti par droger et manama par
wanadoo; to send me directly a mail replace anti with droger and manama
with wanadoo;




Zythum
Le #319606

attention, y a des cas où cable select ne marche pas terrible, je ne
sais si c'est la CM ou Windows qui merdoie, aussi je préfère de loin
mettre le maitre en bout et l'esclave au milieu de la nappe, au moins le
système n'a pas à choisir!!!


Le "cable select" impose d'utiliser une nappe spécifique (un des fils de
la nappe est coupé entre les deux derniers connecteurs).

Si tu utilises une nappe classique (ie celles généralement livrées avec
les cartes mères vendues au détails) le résultat ne peut qu'être aléatoire.

Vu que Gérard à une carte MSI et si c'est un PC d'assembleur, il y a de
bonne chance que sa nappe ne soit pas une nappe pour du "cable select.
Dans ce cas, il faut qu'il positionne le cavalier correctement sur son
DD avanr d'aller plus loin


--
Zythum

Pascal Hambourg
Le #319602
Salut,


attention, y a des cas où cable select ne marche pas terrible, je ne
sais si c'est la CM ou Windows qui merdoie,



Ni l'une ni l'autre. C'est soit la nappe soit le périphérique.

aussi je préfère de loin
mettre le maitre en bout et l'esclave au milieu de la nappe,



Ça tombe bien, c'est exactement ce que donne le réglage cable select
avec une nappe à 80 fils. ;-)

au moins le système n'a pas à choisir!!!



Le système ne choisit jamais. Ce sont les périphériques réglés en cable
select qui choisissent de se configurer en maître ou en esclave selon
l'état d'un signal particulier du bus ATA/IDE. Etat qui est différent
sur chacun des deux connecteurs destinés au branchement des
périphériques, bien sûr.

Le "cable select" impose d'utiliser une nappe spécifique (un des fils de
la nappe est coupé entre les deux derniers connecteurs).

Si tu utilises une nappe classique (ie celles généralement livrées avec
les cartes mères vendues au détails) le résultat ne peut qu'être aléatoire.


Vrai seulement pour les nappes à 40 fils. Dans les nappes à 80 fils,
aucun fil n'est coupé, ce sont les connecteurs eux-mêmes qui sont câblés
différemment en interne. Et normalement toutes les nappes à 80 fils
supportent le cable select, ce n'est plus une option. Un raison de ce
changement est notamment que le périphérique maître a été déplacé en
bout de nappe, afin d'améliorer la terminaison du bus aux hautes vitesses.


Gérard Rigaud
Le #319560
houba wrote:
Bonjour ° Bonsoir, le Thu, 16 Aug 2007 22:03:14 +0200, Gérard Rigaud

Zythum wrote:
bonjour,
j'ai une ancienne carte-mère MSI IDE avec 2 canaux Ultra ATA/100.
Tout récemment j'ai monté un DD de 250 Go Samsung Ultra ATA/166.
Tout marche bien,... si ce n'est que je ne peux plus ouvrir mon
lecteur et graveur de CD !



la seule chose qui ne marche pas , c'est l'ouverture des tirroirs
des CD !
L'ouverture du tiroir est électrique, pb d'alim.



merci à tous pour vos interventions.
en ce qui me concerne, il est clair que c'est le DD Ultra DMA 133 qui est la
cause de la non ouverture des lecteurs de CD, puisque si je déconnecte le
DD, les tiroirs s'ouvrent (et se ferment) sans probléme.
Quand tu dis que l'ouverture du tiroir est électrique et qu'il s'agit d'un
pb d'alim, ce n'est pas tout à fait vrai.
Le fait d'appuyer sur le bouton du lecteur de CD ne déclenche pas
nécessairement de façon instantanée l'ouverture du tiroir. Celle-ci ne se
fait qu'avec "l'accord" du système, de l'application en cours d'exécution,
etc. Il doit s'agir vraisemblablement d'un pb d'interruption.
J'ai souvent une fenêtre qui s'ouvre me disant que le système a reçu un
ordre d'éjection du CD et demande mon accord pour qu'il s'exécute.
Dans mon cas perso, je me demande si cette interruption n'est pas inhibée
par le fonctionnement d'un périphérique qui n'est pas dans les normes du
système (ma carte-mère n'accepte sur le papier que l'Ultra DMA 66 et100.
Tout ceci est assez curieux car a priori tout (le reste) marche
parfaitement.

A+ et encore merci


--
Gérard Rigaud
pour me répondre personnellement cliquer sur le lien suivant :
http://viadresse.com?25101940
merci




Pascal Hambourg
Le #319543
houba wrote:

Tout récemment j'ai monté un DD de 250 Go Samsung Ultra ATA/166.






ATA/166 ? C'est nouveau ? Jamais entendu parler.

en ce qui me concerne, il est clair que c'est le DD Ultra DMA 133 qui
est la cause de la non ouverture des lecteurs de CD, puisque si je
déconnecte le DD, les tiroirs s'ouvrent (et se ferment) sans probléme.


Alors, 133 ou 166 ?

Quand tu dis que l'ouverture du tiroir est électrique et qu'il s'agit
d'un pb d'alim, ce n'est pas tout à fait vrai.


En effet, cela fait intervenir l'électronique embarquée du lecteur.

Le fait d'appuyer sur le bouton du lecteur de CD ne déclenche pas
nécessairement de façon instantanée l'ouverture du tiroir. Celle-ci ne
se fait qu'avec "l'accord" du système, de l'application en cours
d'exécution, etc.


Oui et non. Un lecteur n'a pas besoin de l'autorisation explicite du
système hôte pour ouvrir le tiroir suite à l'appui sur le bouton
d'éjection, puisque ça marche même si la nappe n'est pas branchée. Par
contre le système hôte peut envoyer une commande pour bloquer l'action
du bouton.

L'ouverture est-elle possible avant le chargement du système
d'exploitation ? Que donne la commande d'ouverture logicielle depuis le
système d'exploitation, un logiciel de lecture de CD ? Un CD présent
dans le lecteur est-il reconnu et lisible ?

Il doit s'agir vraisemblablement d'un pb d'interruption.


Je ne vois pas pourquoi. En fait je ne vois pas en quoi la présence d'un
périphérique sur un canal pourrait perturber le fonctionnement d'un
autre périphérique sur un autre canal.

J'ai souvent une fenêtre qui s'ouvre me disant que le système a reçu un
ordre d'éjection du CD et demande mon accord pour qu'il s'exécute.


Jamais vu ça. Quel système ? Tu n'aurais pas un programme résident
particulier qui surveille les lecteurs optiques et qui serait perturbé
par la présence d'un disque supplémentaire ? Tu as essayé de brancher un
autre disque moins rapide pour voir s'il se passe la même chose qu'avec
le Samsung ?

Dans mon cas perso, je me demande si cette interruption n'est pas
inhibée par le fonctionnement d'un périphérique qui n'est pas dans les
normes du système (ma carte-mère n'accepte sur le papier que l'Ultra DMA
66 et 100.


Je n'ai jamais eu de problèmes à faire fonctionner des périphériques ATA
supportant des modes de transferts plus rapides que la carte mère. De
toute façon il y a compatibilité ascendante, un dispositif ATA 133
supporte les modes de transferts inférieurs. Ta carte mère fait
fonctionner le disque en mode ATA 100, voilà tout.





Zythum
Le #319509

Vrai seulement pour les nappes à 40 fils. Dans les nappes à 80 fils,
aucun fil n'est coupé, ce sont les connecteurs eux-mêmes qui sont câblés
différemment en interne. Et normalement toutes les nappes à 80 fils
supportent le cable select, ce n'est plus une option.


Merci pour la précision qui m'explique, après coup, certaines "anomalies".

Comme je suis curieux, j'ai sacrifié une nappe 80 fils pour voir.
Effectivement sur le connecteur central il manque une pine et donc la
nappe n'est pas perforée pour le fil correspondant (et on tombe sur le
fonctionnement normal du cable select, un périphérique reçoit le signal
et pas l'autre)

A l'issue du démontage, comme il se doit, je me suis aperçu que j'aurais
pu m'en dispenser.
En effet sur les connecteurs de cette nappe, il y a une petite encoche
au niveau de la pine concernée. L'encoche permet de vérifier si la pine
est présente ou pas.
Du coup j'ai vérifié sur mes 3 autres nappes non en service. Deux ont
ses petites encoches sur les connecteurs (et sont CS), une n'a aucune
encoche (ce n'est pas la plus vieille en plus).

--
Zythum

Pascal Hambourg
Le #319484

Comme je suis curieux, j'ai sacrifié une nappe 80 fils pour voir.
Effectivement sur le connecteur central il manque une pine et donc la
nappe n'est pas perforée pour le fil correspondant (et on tombe sur le
fonctionnement normal du cable select, un périphérique reçoit le signal
et pas l'autre)


Oui. Celui qui reçoit le signal devient maître, l'autre esclave. Or
comme sur les nappes à 80 fils le maître passe en bout de nappe et doit
recevoir le signal, plus question de couper un fil. Et puis ce serait
plus délicat tellement les fils sont serrés.

A l'issue du démontage, comme il se doit, je me suis aperçu que j'aurais
pu m'en dispenser.


C'est toujours comme ça. ;-) Comme quand on dévisse toutes les vis
extérieures d'un appareil pour en ouvrir le boîtier mais on se rend
compte après coup que certaines vis servent en fait à fixer les éléments
à l'interieur et non à maintenir le boîtier fermé.

En effet sur les connecteurs de cette nappe, il y a une petite encoche
au niveau de la pine concernée. L'encoche permet de vérifier si la pine
est présente ou pas.


Tu dois avoir de sacrés bons yeux ! J'ai une nappe dont les connecteurs
comportent ces encoches, mais impossible de voir une différence de
câblage entre les trois connecteurs à l'oeil nu.

Du coup j'ai vérifié sur mes 3 autres nappes non en service. Deux ont
ses petites encoches sur les connecteurs (et sont CS), une n'a aucune
encoche (ce n'est pas la plus vieille en plus).


Et elle supporte le cable select ou pas ? On peut aussi tester avec un
ohmmètre la continuité entre les broches de chacun des trois connecteurs.

Gérard Rigaud
Le #319408
houba wrote:
Bonjour ° Bonsoir, le Fri, 17 Aug 2007 22:42:15 +0200, Gérard Rigaud

houba wrote:
Bonjour ° Bonsoir, le Thu, 16 Aug 2007 22:03:14 +0200, Gérard Rigaud

Zythum wrote:
bonjour,
j'ai une ancienne carte-mère MSI IDE avec 2 canaux Ultra ATA/100.
Tout récemment j'ai monté un DD de 250 Go Samsung Ultra ATA/166.
Tout marche bien,... si ce n'est que je ne peux plus ouvrir mon
lecteur et graveur de CD !



la seule chose qui ne marche pas , c'est l'ouverture des tirroirs
des CD !
L'ouverture du tiroir est électrique, pb d'alim.



merci à tous pour vos interventions.
en ce qui me concerne, il est clair que c'est le DD Ultra DMA 133
qui est la cause de la non ouverture des lecteurs de CD, puisque si
je déconnecte le DD, les tiroirs s'ouvrent (et se ferment) sans
probléme.
Quand tu dis que l'ouverture du tiroir est électrique et qu'il
s'agit d'un pb d'alim, ce n'est pas tout à fait vrai.
Le fait d'appuyer sur le bouton du lecteur de CD ne déclenche pas
nécessairement de façon instantanée l'ouverture du tiroir.
Aurais je dis quelque part que cette ouverture devrait être

instantanée ?

Celle-ci ne se
fait qu'avec "l'accord" du système, de l'application en cours
d'exécution, etc. Il doit s'agir vraisemblablement d'un pb
d'interruption.
Non, fais l'essai suivant.

Déconnecte ton 250Go.
Dès le POST, appuie sur le bouton bien avant que le SE ne soit engagé.
Le tiroir devrait s'ouvrir sans la moindre difficulté.
C'est ce que je fais très fréquemment pour booter sur le CD.
1.changement de priorité du boot dans le Bios, sauvegarde
2.au POST, j'appuie sur éjection pour pouvoir mettre le CD du SE.
Le tiroir s'ouvre, je lui colle le CD et je le ferme. Et la procédure
de boot poursuit son cours.

Et quand je parlais d'alim, je pensais à l'insuffisance/défaillance ?
de ton alim (le boitier d'alim) à assurer l'alimentation et de ton
ancien ddur, et le nouveau 250Go + tes 2 lecteurs optiques.

Si le test ci-dessus passe, connecte ton 250Go et refais le même test
toujours au niveau du POST.
Si ca passe, tu pourrais écarter le pb d'alim de l'ensemble.

Après une fois dans le SE (XP ?), regarde du côté du gest de périph au
niveau des lecteurs de CD s'il y aurait anomalie quelconque...
J'ai encore une 440 bx/celeron 600/320Mo/GForce 256, alim sans marque
de 250w, 2 ddurs 40Go udma66 (nappe 80fils) + 2 ddurs 15Go udma33
(nappe 40fils) + 1 lecteur cd (nappe 40fils) en double boot w98se/w2k
qui fonctionne toujours.

L'interruption dont tu parles ne devrait poser aucun pb car le 1er ide
a l'irq 14 et le 2eme ide a l'irq 15. Et ca depuis un bon bout de
temps déjà (au moins depuis les dx2/33MHz des années 92).
Ce sont des irq réservés aux 2 ide et aucun autres périph ne peuvent
s'en accaparer.

D'ailleurs en parlant de ca, tu devrais vérifier si tes ide0/1 ou
ide1/2 dans le Bios sont sur 'enabled' ou 'auto' aussi bien pour le
maitre que l'esclave.


merci à Pascal Hambourg et à toi pour vos remarques et suggestions.
je vais examiner tout ça de plus près.

cordialement


--
Gérard Rigaud
pour me répondre personnellement cliquer sur le lien suivant :
http://viadresse.com?25101940
merci






Publicité
Poster une réponse
Anonyme