BONDING Problem

Le
admin
Bonjour
Voila, j'ai un gros probleme avec le module bonding du noyau et les
commutateurs Allied Telesyn modeles 8326gb, 9410gb et 950, tous
administrables et supportant normallement le 802.3ad.

Les conditions d'experimentations sont les suivantes

2 serverus avec 2interfaces e100 connectées a un commutateur AT port 1-2
, 3-4

*TESTA
1-interfaces debranchées configuration du commut en 2 trunks, un sur
port 1-2 et l'autre sur 3-4
2- changement du module
modprobe bonding mode=4 miimon0
3- montege de l'interface
ifconfig bond0 10.0.1.6 (et 7 pour l'autre serveur) netmask 255.255.255.0
4- assignation des interfaces
ifenslave bond0 eth1 eth2
5- montage des interfaces reseau
ifconfig eth1 0.0.0.0 up (et eth2)
6- je ping l'autre partie et . rien
arp -e n'indique
10.0.1.6 (incomplete) bond0

7- Si je debrance une interface d'un serveur
ifenslave -d bond0 eth1

ping 10.0.1.6 fonctionne

*TESTB
Si je fais la meme manip mais SANS creer de trunk sur le commut, la sa
fonctionne directement (sans retirer d'interface) MAIS

*PERFORMACES
Si je connect 1 seule interface des 2 serveur et que je fais un test
brut avec iperf
j'obtient 988Mb/s environ
Si je me place dans le TESTA avec une interface en moins ou dans le TESTB
j'obtient 58Mb/s environ

Je ne comprends pas.
IPERF est il incapable de me donner des resultats corrects avec un bonding??
Pourquoi cela ne fonctionne pas avec le commut en trunk???

De l'aide s'il vous plais sa URGE
MERCI
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien LE LEZ
Le #1901074
On Thu, 06 Sep 2007 13:28:00 +0200, admin
De l'aide s'il vous plais sa URGE


Ceci est un forum de discussion[*], pas une hotline.


[*] en langue française, du moins en théorie.

Emmanuel Florac
Le #1901064
Le Thu, 06 Sep 2007 13:28:00 +0200, admin a écrit :

IPERF est il incapable de me donner des resultats corrects avec un
bonding?? Pourquoi cela ne fonctionne pas avec le commut en trunk???


Tu ne spécifies pas que tu veux utiliser 802.3ad, par défaut le mode de
fonctionnement du bonding est balance-rr. La plupart des modes de bonding
ne fonctionnent que sur des ports sans trunking, voir le bonding howto
dans la doc du noyau.

--
Mais monsieur, voudriez-vous que je me l'écorchasse?
Barbey d'Aurevilly.

Publicité
Poster une réponse
Anonyme