Boot impossible : hal.dll manquant !

Le
®omain
Bonjour,

Suite à réparation d'une installation déjà présente sur DD, je ne peux
démarrer Windows.
Mais si je débranche mon 2nd disk c'est OK (la réciproque n'est pas vrai
car les fichiers systèmes sont sur 1er disk) mais j'aimerai bien
utiliser mes 2 disks (SATA).

Que faire ?

Mon boot.ini est classique :
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect

J'ai déjà essayé fixmbr ; fixboot c: ; bootcfg /rebuild

Merci par avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Azo4
Le #18851051
qu'y a-t-il sur ton deuxième disque? comment est-il branché? est-il en raid?

sinon , souvent, un simple chkdsk suffit pour hal.dll

--
Serge CENCI
MVP MS Windows
https://mvp.support.microsoft.com/profile/Serge.Cenci
http://www.communautes-numeriques.net/



"®omain" news:49b2e908$0$31315$
Bonjour,

Suite à réparation d'une installation déjà présente sur DD, je ne peux
démarrer Windows.
Mais si je débranche mon 2nd disk c'est OK (la réciproque n'est pas vrai
car les fichiers systèmes sont sur 1er disk) mais j'aimerai bien utiliser
mes 2 disks (SATA).

Que faire ?

Mon boot.ini est classique :
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect

J'ai déjà essayé fixmbr ; fixboot c: ; bootcfg /rebuild

Merci par avance


®omain
Le #18851141
Sur mon 2nd disk il y a 1 partition principal (e:) avec windows XP
installé une 2nde × et une partition étendue avec un lecteur logic
dedans (f:).

Ces disk Sata ne sont pas montés en RAID.

Losque le 2nd disk est branché je ne peux démarrer windows sur le 1er.

Que dois je utiliser comme paramètre avec chkdsk ?
Dois executer chkdsk à partit du cd windows ou partir de windows (en
mode sans échec) sur le DD ?

Le boot.ini est en C:
[boot loader]
timeout
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect


Azo4 a écrit :
qu'y a-t-il sur ton deuxième disque? comment est-il branché? est-il en
raid?

sinon , souvent, un simple chkdsk suffit pour hal.dll



Azo4
Le #18851911
en invite de commandes : chkdsk E: /F /R

mais ton boot.ini me parait bizarre: pourquoi ce dualboot sur deux xp?
est-ce que windows démarrer sur le deuxième disque seul branché?

--
Serge CENCI
MVP MS Windows
https://mvp.support.microsoft.com/profile/Serge.Cenci
http://www.communautes-numeriques.net/



"®omain" news:49b387b8$0$7897$
Sur mon 2nd disk il y a 1 partition principal (e:) avec windows XP
installé une 2nde × et une partition étendue avec un lecteur logic dedans
(f:).

Ces disk Sata ne sont pas montés en RAID.

Losque le 2nd disk est branché je ne peux démarrer windows sur le 1er.

Que dois je utiliser comme paramètre avec chkdsk ?
Dois executer chkdsk à partit du cd windows ou partir de windows (en mode
sans échec) sur le DD ?

Le boot.ini est en C:
[boot loader]
timeout
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect


Azo4 a écrit :
qu'y a-t-il sur ton deuxième disque? comment est-il branché? est-il en
raid?

sinon , souvent, un simple chkdsk suffit pour hal.dll





®omain
Le #18852171
j'ai ce dual boot car je souhaite utiliser 2 installations (l'une que je
pourrie en installant tout et n'importe quoi et en autre seine avec le
minimum).
Le 2nd windows ne démarre pas sans le 1er disk puisque c'est là qu'il y
a les fichiers systèmes (config.sys io.sys boot.ini etc.)

Donc maintenant que je n'ai plus que la 2nde install qui démarre je la
pourrie aussi.

Azo4 a écrit :
en invite de commandes : chkdsk E: /F /R

mais ton boot.ini me parait bizarre: pourquoi ce dualboot sur deux xp?
est-ce que windows démarrer sur le deuxième disque seul branché?



Michel__D
Le #18852321
Bonjour,

®omain a écrit :
Bonjour,

Suite à réparation d'une installation déjà présente sur DD, je ne peux
démarrer Windows.
Mais si je débranche mon 2nd disk c'est OK (la réciproque n'est pas vrai
car les fichiers systèmes sont sur 1er disk) mais j'aimerai bien
utiliser mes 2 disks (SATA).

Que faire ?

Mon boot.ini est classique :
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect

J'ai déjà essayé fixmbr ; fixboot c: ; bootcfg /rebuild

Merci par avance



Dans la mesure ou c'est ton 2ème disque qui est le disque de boot
(voir le paramêtrage de l'ordre de boot au niveau du BIOS) et avec
le contenu du boot.ini mentionné ci-dessus, il est évident que tu ne
peux démarrer que le système situé sur la 1ère partition primaire
active de ce 2ème disque, donc que veux-tu faire ?
®omain
Le #18852571
outre démarrer windows installé sur la 1ére partition (principale)
active du 2nd disk (e:) je souhaite démarrer celui installé sur 1er disk
(c:).

Mon 2nd disk (e:) n'est pas celui de boot car il est dépourvu de fichier
system à ça racine (io.sys config.sys) mais c'est celui sur lequel est
installé ma 2nde installation de windoze (qui reste la seule à fonctionner).

Ce qui est étrange est que lorsque je débranche le 2nd disk mon windoze
du 1er disk est OK.

Le boot.ini est en C:
[boot loader]
timeout
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect

Michel__D a écrit :
Bonjour,

®omain a écrit :
Bonjour,

Suite à réparation d'une installation déjà présente sur DD, je ne peux
démarrer Windows.
Mais si je débranche mon 2nd disk c'est OK (la réciproque n'est pas
vrai car les fichiers systèmes sont sur 1er disk) mais j'aimerai bien
utiliser mes 2 disks (SATA).

Que faire ?

Mon boot.ini est classique :
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect

J'ai déjà essayé fixmbr ; fixboot c: ; bootcfg /rebuild

Merci par avance



Dans la mesure ou c'est ton 2ème disque qui est le disque de boot
(voir le paramêtrage de l'ordre de boot au niveau du BIOS) et avec
le contenu du boot.ini mentionné ci-dessus, il est évident que tu ne
peux démarrer que le système situé sur la 1ère partition primaire
active de ce 2ème disque, donc que veux-tu faire ?


Michel__D
Le #18852921
Re,

®omain a écrit :
outre démarrer windows installé sur la 1ére partition (principale)
active du 2nd disk (e:) je souhaite démarrer celui installé sur 1er disk
(c:).

Mon 2nd disk (e:) n'est pas celui de boot car il est dépourvu de fichier
system à ça racine (io.sys config.sys) mais c'est celui sur lequel est
installé ma 2nde installation de windoze (qui reste la seule à
fonctionner).

Ce qui est étrange est que lorsque je débranche le 2nd disk mon windoze
du 1er disk est OK.

Le boot.ini est en C:
[boot loader]
timeout
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect



Ok, donc avec les 2 disques connectés (branchés), tu ne peux démarrer que
sur le windows situé sur le 2ème disque et en enlevant le 2ème disque
tu peux démarrer sur le 1er disque.

Si c'est bien le 1er disque qui est le disque de boot, c'est vrai que ce
n'est pas banal (point à vérifier).

PS1:Les fichiers de boot c'est ntldr, ntdetect.com, ...

PS2:Je suppose que c'est le système situé sur le 1er disque qui a été réparé ?
testeur
Le #18852961
1 - Il serait plus clair de changer le libéllé de chaque système dans le
boot.ini, par ex
[boot loader]
timeout
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="XP disque 2" /noexecute=optin
/fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="XP disque 1" /noexecute=optin
/fastdetect

2- Vous pouvez également copier les fichiers nécéssaires au boot sur le
second disque
NTLDR
NTDETECT.COM
BOOT.INI
et refaire sur ce disque un MBR pour être certain de pouvoir démarrer sur ce
disque seul, en cas de panne du 1er

Avez vous la possibilité de choisir le disque de boot dans le bios ?

Olivier
®omain
Le #18853251
J'ai déjà renommer de façon claire le boot.ini mais lors de
réinstallation, il fut changé.

Oui, j'ai la possibilité de choisir dans le BIOS mais ce n'est pas
facile de changer à chaque × et redémarrer après modif BIOS.

je vais essayé de copier les fichiers de boot d'un DD à l'autre.

testeur a écrit :
1 - Il serait plus clair de changer le libéllé de chaque système dans le
boot.ini, par ex
[boot loader]
timeout
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="XP disque 2" /noexecute=optin
/fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="XP disque 1" /noexecute=optin
/fastdetect

2- Vous pouvez également copier les fichiers nécéssaires au boot sur le
second disque
NTLDR
NTDETECT.COM
BOOT.INI
et refaire sur ce disque un MBR pour être certain de pouvoir démarrer sur ce
disque seul, en cas de panne du 1er

Avez vous la possibilité de choisir le disque de boot dans le bios ?

Olivier




®omain
Le #18853361
J'ai effectué des mises à niveaux des 2 installations à partir du CD de
Windoze XP avec SP3 intégré car celà me diminuait la taille du
répertoire Windows par rapport à l'utilisation du fichier SP3 seul.
Avant cette manip je pouvais démarrer sur une install ou l'autre.

Michel__D a écrit :
Re,

®omain a écrit :
outre démarrer windows installé sur la 1ére partition (principale)
active du 2nd disk (e:) je souhaite démarrer celui installé sur 1er
disk (c:).

Mon 2nd disk (e:) n'est pas celui de boot car il est dépourvu de
fichier system à ça racine (io.sys config.sys) mais c'est celui sur
lequel est installé ma 2nde installation de windoze (qui reste la
seule à fonctionner).

Ce qui est étrange est que lorsque je débranche le 2nd disk mon
windoze du 1er disk est OK.

Le boot.ini est en C:
[boot loader]
timeout
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP
Professionnel" /noexecute=optin /fastdetect



Ok, donc avec les 2 disques connectés (branchés), tu ne peux démarrer que
sur le windows situé sur le 2ème disque et en enlevant le 2ème disque
tu peux démarrer sur le 1er disque.

Si c'est bien le 1er disque qui est le disque de boot, c'est vrai que ce
n'est pas banal (point à vérifier).

PS1:Les fichiers de boot c'est ntldr, ntdetect.com, ...

PS2:Je suppose que c'est le système situé sur le 1er disque qui a été
réparé ?


Publicité
Poster une réponse
Anonyme