Bouton de commande

Le
André
Bonjour à tous,
Je viens de passer de 2003 à 2007. J'ai un formulaire qui me sert de menu
principal, donc avec des boutons de commandes et événements. En 2003 tout
fonctionne. Je récupère la BD en 2007 et les boutons ne fonctionnent plus.
Si vous avez des conseils, j'apprécierais beaucoup.
Merci à tous.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tisane
Le #6230231
Bonjour André,

Je viens de passer de 2003 à 2007. J'ai un formulaire qui me sert de menu
principal, donc avec des boutons de commandes et événements. En 2003 tout
fonctionne. Je récupère la BD en 2007 et les boutons ne fonctionnent
plus.


Vérifie déjà les références :
- dans la fenêtre VBE, menu Outils | Références
- décoche les références notées "manquantes".

--
Tisane

André
Le #6229521
Bonjour Tisane,

Je n'ai malheureusement aucune références manquantes dans la fenêtre VB.
Aurais-tu une autre piste?

Merci!


Bonjour André,

Je viens de passer de 2003 à 2007. J'ai un formulaire qui me sert de menu
principal, donc avec des boutons de commandes et événements. En 2003 tout
fonctionne. Je récupère la BD en 2007 et les boutons ne fonctionnent
plus.


Vérifie déjà les références :
- dans la fenêtre VBE, menu Outils | Références
- décoche les références notées "manquantes".

--
Tisane





Tisane
Le #6229491
Je n'ai malheureusement aucune références manquantes dans la fenêtre VB.
Aurais-tu une autre piste?


On peut toujours essayer ;-)
Regarde le niveau de sécurité des macros :
- bouton Office | bouton [Options Access]
- Centre de gestion de la confidentialité
- Paramètres du Centre de gestion de la confidentialité
- Paramètres des macros
- coche "Désactiver toutes les macros avec notification"
ou "Activer toutes les macros"

Enfin, as-tu compilé le code pour voir s'il y a des erreurs reconnues ?

--
Tisane

Bonjour André,

Je viens de passer de 2003 à 2007. J'ai un formulaire qui me sert de
menu
principal, donc avec des boutons de commandes et événements. En 2003
tout
fonctionne. Je récupère la BD en 2007 et les boutons ne fonctionnent
plus.


Vérifie déjà les références :
- dans la fenêtre VBE, menu Outils | Références
- décoche les références notées "manquantes".

--
Tisane





André
Le #6228821
Eureka! J'ai activé toutes les macros et pour être certain j'ai compilé de
nouveau. Merci encore de ta ténacité. Très apprécié.

A plus tard...


Je n'ai malheureusement aucune références manquantes dans la fenêtre VB.
Aurais-tu une autre piste?


On peut toujours essayer ;-)
Regarde le niveau de sécurité des macros :
- bouton Office | bouton [Options Access]
- Centre de gestion de la confidentialité
- Paramètres du Centre de gestion de la confidentialité
- Paramètres des macros
- coche "Désactiver toutes les macros avec notification"
ou "Activer toutes les macros"

Enfin, as-tu compilé le code pour voir s'il y a des erreurs reconnues ?

--
Tisane

Bonjour André,

Je viens de passer de 2003 à 2007. J'ai un formulaire qui me sert de
menu
principal, donc avec des boutons de commandes et événements. En 2003
tout
fonctionne. Je récupère la BD en 2007 et les boutons ne fonctionnent
plus.


Vérifie déjà les références :
- dans la fenêtre VBE, menu Outils | Références
- décoche les références notées "manquantes".

--
Tisane









Tisane
Le #6228781
Eureka! J'ai activé toutes les macros et pour être certain j'ai compilé
de
nouveau.


Merci André pour ce retour car je pense que la question sera de plus en plus
souvent posée avec le déploiement de la v2007.

--
Tisane


André"
Je n'ai malheureusement aucune références manquantes dans la fenêtre
VB.
Aurais-tu une autre piste?


On peut toujours essayer ;-)
Regarde le niveau de sécurité des macros :
- bouton Office | bouton [Options Access]
- Centre de gestion de la confidentialité
- Paramètres du Centre de gestion de la confidentialité
- Paramètres des macros
- coche "Désactiver toutes les macros avec notification"
ou "Activer toutes les macros"

Enfin, as-tu compilé le code pour voir s'il y a des erreurs reconnues ?

--
Tisane

Bonjour André,

Je viens de passer de 2003 à 2007. J'ai un formulaire qui me sert
de
menu
principal, donc avec des boutons de commandes et événements. En 2003
tout
fonctionne. Je récupère la BD en 2007 et les boutons ne
fonctionnent
plus.


Vérifie déjà les références :
- dans la fenêtre VBE, menu Outils | Références
- décoche les références notées "manquantes".
--
Tisane









Publicité
Poster une réponse
Anonyme