Bouze Grub 2, mode silencieux ?

Le
Sergio
J'ai installé une LMDE (Linux Mint Debian Edition) sur un vieux coucou. Ça marche à peu près bien. Petit problème :
C'est le seul OS installé sur la bécane, comment faire pour que grub2 (installé par défaut) ne présente pas son menu au démarrage ?

J'ai bien installé le start-up manager, mais les options sont spartiates (et y'a pas celle-là). J'ai bricolé les
"GRUB_HIDDEN_TIMEOUT" mais rien n'y fait

Je ne peux pas réinstaller le bon vieux grub legacy, vu que j'ai fait l'erreur de formater les partitions en ext4.

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Doug713705
Le #23114121
Le 11/2/2011 16:35 dans fr.comp.os.linux.configuration Sergio nous
expliquait:

J'ai installé une LMDE (Linux Mint Debian Edition) sur un vieux coucou.
Ça marche à peu près bien. Petit problème :
C'est le seul OS installé sur la bécane, comment faire pour que grub2
(installé par défaut) ne présente pas son menu au démarrage ?



http://grub.enbug.org/OptionsDeGrub

GRUB_TIMEOUT=X - Délai d'attente, en secondes, avant d'exécuter
l'entrée de menu sélectionnée automatiquement :

Paramétrer cette option à 0 charge immédiatement l'entrée
automatiquement sélectionnée. Setting this value to -1 will cause the
menu to display until the user makes a selection.

GRUB_HIDDEN_MENU_QUIET={true|false} -

Si le menu de chargement est caché, afficher un délai ou non avant
l'affichage du menu :
true : aucun chronomètre n'est affiché. L'écran reste vide
--
@+
Doug - Linux user #307925 - Slackware64 roulaize ;-)
http://usenet-fr.dougwise.org
http://news.dougwise.org
Hugues
Le #23114111
Ce cher Sergio

Je ne peux pas réinstaller le bon vieux grub legacy, vu que j'ai fait
l'erreur de formater les partitions en ext4.



Sauf grossière erreur de ma part, elles sont parfaitement lisibles avec
les drivers ext2fs et ext3fs ..

--
Hugues Hiegel [http://www.hiegel.fr/~hugues/]
jp willm
Le #23114241
Hello,

Le 11/02/2011 16:35, Sergio a écrit :
J'ai installé une LMDE (Linux Mint Debian Edition) sur un vieux coucou.
Ça marche à peu près bien.


Pareil pour moi, ça fonctionne bien.


Petit problème :
C'est le seul OS installé sur la bécane, comment faire pour que grub2
(installé par défaut) ne présente pas son menu au démarrage ?

J'ai bien installé le start-up manager, mais les options sont spartiates
(et y'a pas celle-là). J'ai bricolé les "GRUB_HIDDEN_TIMEOUT" mais rien
n'y fait...



Tu n'as pas oublié de faire update-grub après la modif ?


Je ne peux pas réinstaller le bon vieux grub legacy, vu que j'ai fait
l'erreur de formater les partitions en ext4.



Est-ce vraiment une erreur ?

J'ai ext4 depuis sa sortie et sur plusieurs postes. Rien à déplorer, au
contraire, c'est plus fluide et le fsck est envoyé en 10 secondes.


--
jp willm
http://perso.orange.fr/willms/index.html
Sergio
Le #23114361
Le 11/02/2011 17:02, Hugues a écrit :

Ce cher Sergio

Je ne peux pas réinstaller le bon vieux grub legacy, vu que j'ai fait
l'erreur de formater les partitions en ext4.



Sauf grossière erreur de ma part, elles sont parfaitement lisibles avec
les drivers ext2fs et ext3fs ..



Lisible certes, mais pas par grub legacy...

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
François
Le #23115821
Le 11/02/2011 16:35, Sergio a écrit :
J'ai installé une LMDE (Linux Mint Debian Edition) sur un vieux coucou.
Ça marche à peu près bien. Petit problème :
C'est le seul OS installé sur la bécane, comment faire pour que grub2
(installé par défaut) ne présente pas son menu au démarrage ?



Je ne pense pas que ce soit une bonne idée. Tu te prives du mode de
récupération, ce qui peut être embêtant en cas de problème avec le
serveur graphique.
De plus, si tu dois tester tes barrettes, memtest86 ou memtest86+ (selon
le matériel) se lancent à partir de Grub.

--
François
Sergio
Le #23116661
Le 11/02/2011 21:59, François a écrit :

J'ai installé une LMDE (Linux Mint Debian Edition) sur un vieux coucou.
Ça marche à peu près bien. Petit problème :
C'est le seul OS installé sur la bécane, comment faire pour que grub2
(installé par défaut) ne présente pas son menu au démarrage ?



Je ne pense pas que ce soit une bonne idée. Tu te prives du mode de récupération, ce qui peut être embêtant en cas de problème avec
le serveur graphique.
De plus, si tu dois tester tes barrettes, memtest86 ou memtest86+ (selon le matériel) se lancent à partir de Grub.



Si, si :
Ce que je veux, c'est un simple "Press Esc for menu" qui permet d'avoir le menu au cas où je veuille démarrer en mode récupération
(comme le fait le grub classique, d'ailleurs). Bon je vais tenir compte des explications et m'y lancer (la bécane est au fond de
l'appart).

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Sergio
Le #23116651
Le 11/02/2011 17:29, jp willm a écrit :


Petit problème :
> C'est le seul OS installé sur la bécane, comment faire pour que grub2
> (installé par défaut) ne présente pas son menu au démarrage ?
>
> J'ai bien installé le start-up manager, mais les options sont spartiates
> (et y'a pas celle-là). J'ai bricolé les "GRUB_HIDDEN_TIMEOUT" mais rien
> n'y fait...

Tu n'as pas oublié de faire update-grub après la modif ?



Si, si. C'est un "progrès" n'est-ce pas d'avoir à faire un update-grub après modification du menu !

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
jp willm
Le #23116941
Le 12/02/2011 08:29, Sergio a écrit :

Si, si. C'est un "progrès" n'est-ce pas d'avoir à faire un update-grub
après modification du menu !



J'avoue que j'oublie une fois sur deux :o

--
http://perso.orange.fr/willms/index.html
jp willm
Le #23116931
Le 11/02/2011 16:35, Sergio a écrit :
J'ai installé une LMDE (Linux Mint Debian Edition) sur un vieux coucou.
Ça marche à peu près bien. Petit problème :
C'est le seul OS installé sur la bécane, comment faire pour que grub2
(installé par défaut) ne présente pas son menu au démarrage ?



Perso, je mets

GRUB_TIMEOUT=0

Et ensuite update-grub


C'est pas top, mais bon...

--
http://perso.orange.fr/willms/index.html
Hugues
Le #23124721
Ce cher Sergio
Le 11/02/2011 17:02, Hugues a écrit :

Ce cher Sergio

Je ne peux pas réinstaller le bon vieux grub legacy, vu que j'ai fait
l'erreur de formater les partitions en ext4.



Sauf grossière erreur de ma part, elles sont parfaitement lisibles avec
les drivers ext2fs et ext3fs ..



Lisible certes, mais pas par grub legacy...



Mhm, ok, merci pour l'info.
Il me semble pourtant avoir eu une partition /boot lisible par un
grub-legacy, en ext4fs.. Ma mémoire doit certainement me jouer des
tours.

--
Hugues Hiegel [http://www.hiegel.fr/~hugues/]
Publicité
Poster une réponse
Anonyme