Bug d'apt-get/aptitude ?

Le
Jean-Louis Mas
* On bascule des paquet en hold

aptitude hold samba samba-common samba-common-bin samba-dsdb-modules
samba-libs samba-vfs-modules

* On vérifie ce qui est 'hold'

aptitude search ~ahold
ih samba - SMB/CIFS file, print, and login server for
ihA samba-common - fichiers communs utilisés par le serveur e
ihA samba-common-bin - Fichiers communs de Samba utilisés par le
ih samba-dsdb-modules - Samba Directory Services Database
ihA samba-libs - Bibliothèques principales de Samba
ih samba-vfs-modules - Samba Virtual FileSystem plugins

* On met à jour (après un aptitude update). Le -s est pour simulate

** Avec aptitude

aptitude -s upgrade
Résolution des dépendances…
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 11 non
mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o
seront utilisés.
Charger/installer/enlever des paquets.

** Avec apt-get

apt-get -s upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Calcul de la mise à jour Fait
Les paquets suivants seront mis à jour :
libsmbclient libwbclient0 python-samba samba samba-common
samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules
smbclient winbind
11 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst samba-dsdb-modules [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) []
Inst libwbclient0 [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) [winbind:amd64 ]
Inst winbind [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) []
Inst python-samba [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) []
Inst samba-vfs-modules [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) []
Inst smbclient [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) []
Inst libsmbclient [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) []
Inst samba-libs [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) [samba:amd64 samba-common-bin:amd64 ]
Inst samba [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) [samba-common-bin:amd64 ]
Inst samba-common-bin [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [amd64]) []
Inst samba-common [2:4.2.10+dfsg-0+deb8u1] (2:4.2.10+dfsg-0+deb8u2
Debian-Security:8/stable [all])
Conf libwbclient0 (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf samba-libs (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf samba-dsdb-modules (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable
[amd64])
Conf python-samba (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf samba-common (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [all])
Conf samba-common-bin (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable
[amd64])
Conf samba (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf winbind (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf samba-vfs-modules (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable
[amd64])
Conf libsmbclient (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])
Conf smbclient (2:4.2.10+dfsg-0+deb8u2 Debian-Security:8/stable [amd64])

apt-get ne prend pas en compte le 'hold' posé avec aptitude.

- C'est normal et j'ai raté un truc dans apt-get/aptitude? Dans ce cas
comment faire un hold avec la commande apt-get ?

- C'est pas normal, je vais ouvrir un bug repport ?

Cordialement

--
Jean Louis Mas
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacques
Le #26395408
Bonjour,

Il y a eu un bug dans une mise à jour de sécurité de samba hier, elle
est corrigée depuis, il n'est donc plus nécessaire de faire des hold
(juste un apt(itude|-get) update.

-------------------------------------------------------------------------


Debian Security Advisory DSA-3548-2
https://www.debian.org/security/ Salvatore Bonaccorso
April 14, 2016 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : samba
Debian Bug : 820947

The upgrade to Samba 4.2 issued as DSA-3548-1 introduced a packaging
regression causing an additional dependency on the samba binary package
for the samba-libs, samba-common-bin, python-samba and samba-vfs-modules
binary packages. Updated packages are now available to address this
problem.


Pour répondre à question sur le hold, avec apt-get pour marquer un
paquet en hold il faut utiliser les commandes:
apt-mark hold paquet
apt-mark unhold paquet

Cordialement
Jean-Louis Mas
Le #26395411
Le 15/04/2016 10:29, Jacques a écrit :

Il y a eu un bug dans une mise à jour de sécurité de samba hier,
elle est corrigée depuis, il n'est donc plus nécessaire de faire des
hold (juste un apt(itude|-get) update.



Merci pour l'info, car effectivement on avait pas mal de soucis avec les
mises à jour samba4, ces derniers jours.

Le 'hold' est assez vieux, car on a démarré samba4 avec la version 4.0.0
qui comportait pas mal de bugs.
Donc une fois une version fonctionnelle, on préférait bloquer les mises
à jour de samba.

Pour répondre à question sur le hold, avec apt-get pour marquer un
paquet en hold il faut utiliser les commandes: apt-mark hold paquet
apt-mark unhold paquet



Effectivement, voila pourquoi je ne trouvais pas l'info dans le man
d'apt-get.

apt-mark hold samba samba-common samba-common-bin samba-dsdb-modules
samba-libs samba-vfs-modules
samba passé en figé (« hold »).
samba-common passé en figé (« hold »).
samba-common-bin passé en figé (« hold »).
samba-dsdb-modules passé en figé (« hold »).
samba-libs passé en figé (« hold »).
samba-vfs-modules passé en figé (« hold »).

aptitude -s upgrade
Résolution des dépendances…
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 11 non
mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o
seront utilisés.
Charger/installer/enlever des paquets.

apt-get -s upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
libsmbclient libwbclient0 python-samba samba samba-common
samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules
smbclient winbind
0 mis à jour, 0 nouvellement installés, 0 à enlever et 11 non mis à jour.

En utilisant apt-mark hold, les paquets sont 'hold' quelque soit la
commande utilisée.
Je vais ouvrir un bug sur 'aptitude hold' alors.

Merci beaucoup.

--
Jean Louis Mas
François LE GAD
Le #26395440
Le 15/04/2016 10:06, Jean-Louis Mas a écrit :
* On bascule des paquet en hold


En présence d'un paquet bogué, je préfère un aptitude forbid-version
[paquet], qui gèle seulement la version proposée, et pas les versions
suivantes.

À noter qu'Apt-get ignore les paquets ainsi marqués par Aptitude.

--
François
http://flegad.infini.fr
Jean-Louis Mas
Le #26395670
Le 15/04/2016 11:26, Jean-Louis Mas a écrit :

apt-mark hold samba samba-common samba-common-bin samba-dsdb-modules
samba-libs samba-vfs-modules
samba passé en figé (« hold »).
samba-common passé en figé (« hold »).
samba-common-bin passé en figé (« hold »).
samba-dsdb-modules passé en figé (« hold »).
samba-libs passé en figé (« hold »).
samba-vfs-modules passé en figé (« hold »).

aptitude -s upgrade
Résolution des dépendances…
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 11 non
mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o
seront utilisés.
Charger/installer/enlever des paquets.

apt-get -s upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
libsmbclient libwbclient0 python-samba samba samba-common
samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules
smbclient winbind
0 mis à jour, 0 nouvellement installés, 0 à enlever et 11 non mis à jour.

En utilisant apt-mark hold, les paquets sont 'hold' quelque soit la
commande utilisée.
Je vais ouvrir un bug sur 'aptitude hold' alors.



Le bug existe déjà

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug7771

Ouvert en... 2002 et résolu sur la version 0.7.2-1 d'aptitude en
septembre 2015 !

aptitude 0.6.11-1 (version de jessie) est toujours sujette au bug. Il va
falloir attendre la sortie de stretch et prendre garde d'utiliser en
toutes circonstances 'apt-mark hold' comme Jacques me l'a suggéré.

Cordialement

--
Jean Louis Mas
Belaïd
Le #26395690
--001a113d526cf5d6320530d766b9
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Tu peux aussi jouer avec les priorités pour maintenir une version
spécifique d'un paquet malgré la présence d'une mise à jour, par exemple
dans le fichier /etc/apt/preferences, tu peux mettre une priorité de 1 001
au paquet samba version 4, du genre:

Package: samba
Pin: version 4.0*
Pin-Priority: 1001

Le 15/04/2016 10:29, Jacques a écrit :

Il y a eu un bug dans une mise à jour de sécurité de samba hier,
elle est corrigée depuis, il n'est donc plus nécessaire de fair e des
hold (juste un apt(itude|-get) update.



Merci pour l'info, car effectivement on avait pas mal de soucis avec les
mises à jour samba4, ces derniers jours.

Le 'hold' est assez vieux, car on a démarré samba4 avec la versio n 4.0.0
qui comportait pas mal de bugs.
Donc une fois une version fonctionnelle, on préférait bloquer les mises
à jour de samba.

Pour répondre à question sur le hold, avec apt-get pour marquer un
paquet en hold il faut utiliser les commandes: apt-mark hold paquet
apt-mark unhold paquet



Effectivement, voila pourquoi je ne trouvais pas l'info dans le man
d'apt-get.

apt-mark hold samba samba-common samba-common-bin samba-dsdb-modules
samba-libs samba-vfs-modules
samba passé en figé (« hold »).
samba-common passé en figé (« hold »).
samba-common-bin passé en figé (« hold »).
samba-dsdb-modules passé en figé (« hold »).
samba-libs passé en figé (« hold »).
samba-vfs-modules passé en figé (« hold »).

aptitude -s upgrade
Résolution des dépendances…
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 11 non
mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o
seront utilisés.
Charger/installer/enlever des paquets.

apt-get -s upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
libsmbclient libwbclient0 python-samba samba samba-common
samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules
smbclient winbind
0 mis à jour, 0 nouvellement installés, 0 à enlever et 11 no n mis à jour.

En utilisant apt-mark hold, les paquets sont 'hold' quelque soit la
commande utilisée.
Je vais ouvrir un bug sur 'aptitude hold' alors.

Merci beaucoup.

--
Jean Louis Mas

--001a113d526cf5d6320530d766b9
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<p dir="ltr">Bonjour,</p>
<p dir="ltr">Tu peux aussi jouer avec les priorités pour maintenir u ne version spécifique d&#39;un paquet malgré la présence d&# 39;une mise à jour, par exemple dans le fichier /etc/apt/preferences, tu peux mettre une priorité de 1001 au paquet samba version 4, du genr e:</p>
<p dir="ltr">Package: samba<br>
Pin: version 4.0*<br>
Pin-Priority: 1001</p>
<p dir="ltr">Le 15/04/2016 10:29, Jacques a écrit :</p>
<p dir="ltr">&gt; Il y a eu un bug dans une mise à jour de sécu rité de samba hier,<br>
&gt; elle est corrigée depuis, il n&#39;est donc plus nécessaire de faire des<br>
&gt; hold (juste un apt(itude|-get) update.</p>
<p dir="ltr">Merci pour l&#39;info, car effectivement on avait pas mal de soucis avec les<br>
mises à jour samba4, ces derniers jours.</p>
qui comportait pas mal de bugs.<br>
Donc une fois une version fonctionnelle, on préférait bloquer les mises<br>
à jour de samba.</p>
<p dir="ltr">&gt; Pour répondre à question sur le hold, avec ap t-get pour marquer un<br>
&gt; paquet en hold il faut utiliser les commandes: apt-mark hold paquet<br >
&gt; apt-mark unhold paquet</p>
<p dir="ltr">Effectivement, voila pourquoi je ne trouvais pas l&#39;info dans le man<br>
d&#39;apt-get.</p>
<p dir="ltr">  apt-mark hold samba samba-common samba-common-bin sam ba-dsdb-modules<br>
samba-libs samba-vfs-modules<br>
samba passé en figé (« hold »).<br>
samba-common passé en figé (« hold »).<br>
samba-common-bin passé en figé (« hold »).<br>
samba-dsdb-modules passé en figé (« hold »).<br>
samba-libs passé en figé (« hold »).<br>
samba-vfs-modules passé en figé (« hold »).</p>
<p dir="ltr">  aptitude -s upgrade<br>
Résolution des dépendances…<br>
Aucun paquet ne va être installé, mis à jour ou enlevé. <br>
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 11 non<br>
mis à jour.<br>
Il est nécessaire de télécharger 0 o d&#39;archives. Aprà ¨s dépaquetage, 0 o<br>
seront utilisés.<br>
Charger/installer/enlever des paquets.</p>
<p dir="ltr">  apt-get -s upgrade<br>
Lecture des listes de paquets... Fait<br>
Construction de l&#39;arbre des dépendances<br>
Lecture des informations d&#39;état... Fait<br>
Calcul de la mise à jour... Fait<br>
Les paquets suivants ont été conservés :<br>
  libsmbclient libwbclient0 python-samba samba samba-common<br>
samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules<br>
smbclient winbind<br>
0 mis à jour, 0 nouvellement installés, 0 à enlever et 11 no n mis à jour.</p>
<p dir="ltr">En utilisant  apt-mark hold, les paquets sont &#39;hold &#39; quelque soit la<br>
commande utilisée.<br>
Je vais ouvrir un bug sur &#39;aptitude hold&#39; alors.</p>
<p dir="ltr">--<br>
Jean Louis Mas</p>

--001a113d526cf5d6320530d766b9--
Publicité
Poster une réponse
Anonyme