Bug de la calculette en mode RPN

Le
Herve
Bonjour,

J'utilise la calculette intégrée à MacOS X en mode RPN.
Je tape :
10,9 > valeur bien affichée dans le registre x, au bas de la pile
Entrée > cette valeur reste bien dans le registre x

Mais la valeur affichée dans le registre y n'est pas "10,9", mais "10"
soit seulement la partie entière.
Cependant le registre y contient bien la bonne valeur "10,9" comme en
atteste le résultat de l'opération "-" qui me donne bien zéro et non
"0,9".
Les registres supérieurs de la pile n'affichent manifestement que des
valeurs entières, ce qui limite nettement l'intérêt de leur affichage=
.

Hervé
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick Stadelmann
Le #18712301
In article
Herve
Bonjour,

J'utilise la calculette intégrée à MacOS X en mode RPN.
Je tape :
10,9 ---> valeur bien affichée dans le registre x, au bas de la pile
Entrée ---> cette valeur reste bien dans le registre x

Mais la valeur affichée dans le registre y n'est pas "10,9", mais "10"
soit seulement la partie entière.
Cependant le registre y contient bien la bonne valeur "10,9" comme en
atteste le résultat de l'opération "-" qui me donne bien zéro et non
"0,9".
Les registres supérieurs de la pile n'affichent manifestement que des
valeurs entières, ce qui limite nettement l'intérêt de leur affichage.



Ici j'ai bien 10.9 dans toute la pile.

Patrick
--
Patrick Stadelmann
Paul Gaborit
Le #18712501
À (at) Thu, 19 Feb 2009 18:24:41 +0100,
Patrick Stadelmann
In article
Herve
Bonjour,

J'utilise la calculette intégrée à MacOS X en mode RPN.
Je tape :
10,9 ---> valeur bien affichée dans le registre x, au bas de la pile
Entrée ---> cette valeur reste bien dans le registre x

Mais la valeur affichée dans le registre y n'est pas "10,9", mais "10"
soit seulement la partie entière.
Cependant le registre y contient bien la bonne valeur "10,9" comme en
atteste le résultat de l'opération "-" qui me donne bien zéro et non
"0,9".
Les registres supérieurs de la pile n'affichent manifestement que des
valeurs entières, ce qui limite nettement l'intérêt de leur affichage.



Ici j'ai bien 10.9 dans toute la pile.



N'y a-t-il pas une petite différence entre "10.9" et 10,9" ?
;-)

--
Paul Gaborit -
alain
Le #18712491
Herve
Bonjour,

J'utilise la calculette intégrée à MacOS X en mode RPN.
Je tape :
10,9 ---> valeur bien affichée dans le registre x, au bas de la pile
Entrée ---> cette valeur reste bien dans le registre x

Mais la valeur affichée dans le registre y n'est pas "10,9", mais "10"
soit seulement la partie entière.
Cependant le registre y contient bien la bonne valeur "10,9" comme en
atteste le résultat de l'opération "-" qui me donne bien zéro et non
"0,9".
Les registres supérieurs de la pile n'affichent manifestement que des
valeurs entières, ce qui limite nettement l'intérêt de leur affichage.



Pareil chez moi.

Il existe d'autres calculettes dans le même genre, voire :
ou ce défaut n'est pas présent.

Alain
Patrick Stadelmann
Le #18713181
In article Paul Gaborit
N'y a-t-il pas une petite différence entre "10.9" et 10,9" ?
;-)



C'est 109/10 dans les deux cas :-) Bon, ça semble donc être un bug lié
au format de nombre (ça serait pas le premier !).

Patrick
--
Patrick Stadelmann
alain
Le #18713281
Paul Gaborit
À (at) Thu, 19 Feb 2009 18:24:41 +0100,
Patrick Stadelmann > In article
> > Herve >
>> Bonjour,
>>
>> J'utilise la calculette intégrée à MacOS X en mode RPN.
>> Je tape :
>> 10,9 ---> valeur bien affichée dans le registre x, au bas de la pile
>> Entrée ---> cette valeur reste bien dans le registre x
>>
>> Mais la valeur affichée dans le registre y n'est pas "10,9", mais "10"
>> soit seulement la partie entière.
>> Cependant le registre y contient bien la bonne valeur "10,9" comme en
>> atteste le résultat de l'opération "-" qui me donne bien zéro et non
>> "0,9".
>> Les registres supérieurs de la pile n'affichent manifestement que des
>> valeurs entières, ce qui limite nettement l'intérêt de leur affichage.
>
> Ici j'ai bien 10.9 dans toute la pile.

N'y a-t-il pas une petite différence entre "10.9" et 10,9" ?
;-)



Ici je peux avoir 10,9 mais pas 10.9, le point n'est pas reconnu, cela
entre 109.

Ce n'est pas une question d'enregistrement ?

Alain
OdarR
Le #18713691
On 19 fév, 13:58, Herve
Bonjour,

J'utilise la calculette intégrée à MacOS X en mode RPN.
Je tape :
10,9 ---> valeur bien affichée dans le registre x, au bas de la pile
Entrée ---> cette valeur reste bien dans le registre x

Mais la valeur affichée dans le registre y n'est pas "10,9", mais "10"
soit seulement la partie entière.
Cependant le registre y contient bien la bonne valeur "10,9" comme en
atteste le résultat de l'opération "-" qui me donne bien zéro et no n
"0,9".
Les registres supérieurs de la pile n'affichent manifestement que des
valeurs entières, ce qui limite nettement l'intérêt de leur afficha ge.

Hervé



Effectivement, ça craint !!

une si jolie Calculatrice... :-(

Olivier, en 10.5.6
Olivier
Frédéric Testuz
Le #18739891
Herve avait soumis l'idée :
Bonjour,

J'utilise la calculette intégrée à MacOS X en mode RPN.
Je tape :
10,9 ---> valeur bien affichée dans le registre x, au bas de la pile
Entrée ---> cette valeur reste bien dans le registre x

Mais la valeur affichée dans le registre y n'est pas "10,9", mais "10"
soit seulement la partie entière.
Cependant le registre y contient bien la bonne valeur "10,9" comme en
atteste le résultat de l'opération "-" qui me donne bien zéro et non
"0,9".
Les registres supérieurs de la pile n'affichent manifestement que des
valeurs entières, ce qui limite nettement l'intérêt de leur affichage.



Aucun problème de mon coté. J'ai réglé la précision sur 15 et si je
mets à 0, l'arrondi se fait correctement (vers le haut pour 10.9).

Mais, je suis dans un pays qui utilise le . comme séparateur décimal.

Frédéric
Publicité
Poster une réponse
Anonyme