Ca ne va pas avec SOMMPROD

Le
Apitos
Bonjour à tous,

Dans la colonne A, j'ai des dates avec du texte.

Dans la colonne E, j'ai des chiffres.

En appliquant cette formule :

=SOMMEPROD(($A:$A="01/11/2008")*(E:E))

J'ai une erreur #NOMBRE!

Comment la corriger ?

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sam
Le #17789581
Bonjour,
je crois avoir vu que c'est un pb de dernière ligne (à confirmer par les
pros)

=SOMMEPROD((A1:A999="01/11/2008")*(E1:E999))
devrait fonctionner

Cordialement
Michel dit "Sam"

"Apitos"
Bonjour à tous,

Dans la colonne A, j'ai des dates avec du texte.

Dans la colonne E, j'ai des chiffres.

En appliquant cette formule :

=SOMMEPROD(($A:$A="01/11/2008")*(E:E))

J'ai une erreur #NOMBRE!

Comment la corriger ?

Merci.
Misange
Le #17789571
Bonjour

Sommeprod ne PEUT pas travailler avec des colonnes entières
=SOMMEPROD(($A100:$A100="01/11/2008")*(E100:E100))
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Apitos a écrit :
Bonjour à tous,

Dans la colonne A, j'ai des dates avec du texte.

Dans la colonne E, j'ai des chiffres.

En appliquant cette formule :

=SOMMEPROD(($A:$A="01/11/2008")*(E:E))

J'ai une erreur #NOMBRE!

Comment la corriger ?

Merci.


Misange
Le #17789551
oups !!
=SOMMEPROD(($A1:$A100="01/11/2008")*(E1:E100))
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Misange a écrit :
Bonjour

Sommeprod ne PEUT pas travailler avec des colonnes entières
=SOMMEPROD(($A100:$A100="01/11/2008")*(E100:E100))
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Apitos a écrit :
Bonjour à tous,

Dans la colonne A, j'ai des dates avec du texte.

Dans la colonne E, j'ai des chiffres.

En appliquant cette formule :

=SOMMEPROD(($A:$A="01/11/2008")*(E:E))

J'ai une erreur #NOMBRE!

Comment la corriger ?

Merci.




LSteph
Le #17789741
Bonjour,

faut préciser exactement une plage(colonnes et lignes), exemple:

=SOMMEPROD(($A$2:$A$5231="01/11/2008")*($E$2:$E$5231))

Cordialement.

--
lSteph

Apitos a écrit :
Bonjour à tous,

Dans la colonne A, j'ai des dates avec du texte.

Dans la colonne E, j'ai des chiffres.

En appliquant cette formule :

=SOMMEPROD(($A:$A="01/11/2008")*(E:E))

J'ai une erreur #NOMBRE!

Comment la corriger ?

Merci.


Apitos
Le #17789721
Bonjour Sam, Misange,

j'ai essayé avec cette formule :

=SOMMEPROD(($A1:$A50="01/11/2008")*($E1:$E50))

Mais ça donne une erreur : #VALEUR!
Apitos
Le #17789701
Bonjour LSteph,

Avec cette formule :

=SOMMEPROD(($A$1:$A$50="01/11/2008")*($E$1:$E$50))

Ca donne aussi une erreur : #VALEUR!
Misange
Le #17789831
Aurais tu des valeurs d'erreur dans ta colonne ?
Je te conseille vivement de lire les quelques pages consacrées à
sommeprod qui sont ici
http://xlwiki.free.fr/wiki/wakka.php?wiki=SommeProd
pour voir les quelques précautions à prendre pour utiloiser cette
fonction magique.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Apitos a écrit :
Bonjour Sam, Misange,

j'ai essayé avec cette formule :

=SOMMEPROD(($A1:$A50="01/11/2008")*($E1:$E50))

Mais ça donne une erreur : #VALEUR!


Jacquouille
Le #17790301
Bonjour Apitos

Dans ton message initial, j'ai lu que tu avais des dates avec du texte
("Dans la colonne A, j'ai des dates avec du texte.")

Essaie d'insérer une col quelque part, dans laquelle tu écris en première
colonne A1=estnum. Tu tires vers le bas et tu regardes si toutes tes cel
de la col A sont bien de la même sorte. Soit des chiffres(num), soit des
lettres (texte).

Ensuite, regardes aussi le format de tes cel. le 1/11/2008 (format date)
correspond à 39753, au format nombre.

Comme les autres contributeurs te l'ont signalé, la fonction SP n'accepte
pas les col entières du style A:A. De plus, tu perds du temps à analyser
des milliers de cases qui sont vides....

Ensuite, pour les conditions, les noms exigents d'être mis entre "" .
=Sommeprod((A1:A100="bidule")*(B1:B100P)*prix)
où prix est le nom de la plage C1:C100.

Ensuite, dans ta formule, essaie de remplacer le "01/11/2008", que SP va
comprendre comme du texte, par 9753 qui est la vraie valeur Excellienne du
01/11/2008, soit le 39.753 zième jour après le 01/01/1900.

Bonne chance et si prob, tu reviens.
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Apitos"
Bonjour LSteph,

Avec cette formule :

=SOMMEPROD(($A$1:$A$50="01/11/2008")*($E$1:$E$50))

Ca donne aussi une erreur : #VALEUR!



Jacquouille
Le #17790681
http://cjoint.com/?ljnbnKQgx1
Voilà, tu supprimes tes 36 titres de mini colonnes de manière à avoir un
tableau bien compact, prêt à emballer.
Tu modiifes ta formule de A1 en A4 et c'est parti.
Bonne chance

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Apitos"
Voila un fichier exemple joint :

http://www.cijoint.fr/cjlink.php?file=cj200811/cijh0ExPDi.xls


Publicité
Poster une réponse
Anonyme