calcul avec valeur n/a qui apparait

Le
Marc
voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les la colonne
a est vide il me fait une belle erreur "#n/a" et alors mon calcule ne
fonctionne pas
=SOMME(D17:D24)
comment faire
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal
Le #4565271
Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc"
voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon calcule ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com

Marc
Le #4565141
j'ai essayé les deux exemple que tu m'as donné et ca ne fonctionne pas
malheureusement



Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc"
voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon calcule ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







Pascal
Le #4564591
Envoi ton fichier sur Ci Joint
"Marc"
j'ai essayé les deux exemple que tu m'as donné et ca ne fonctionne pas
malheureusement



Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc"
voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon calcule ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:37:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:38:58
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com



Marc
Le #4564141
ou est ci-joint


Envoi ton fichier sur Ci Joint
"Marc"
j'ai essayé les deux exemple que tu m'as donné et ca ne fonctionne pas
malheureusement



Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc"
voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon calcule ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:37:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:38:58
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com









Pascal
Le #4564101
Ici
http://www.cijoint.fr/index.php



"Marc"
ou est ci-joint


Envoi ton fichier sur Ci Joint
"Marc"
j'ai essayé les deux exemple que tu m'as donné et ca ne fonctionne pas
malheureusement



Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc" news:

voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon calcule
ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:37:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:38:58
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:03
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:46
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com





Marc
Le #4564061
voici l'adresse du fichier
http://www.cijoint.fr/cij51354227815232.xls

désolé je ne connaissais pas ce site

Marc




Ici
http://www.cijoint.fr/index.php



"Marc"
ou est ci-joint


Envoi ton fichier sur Ci Joint
"Marc"
j'ai essayé les deux exemple que tu m'as donné et ca ne fonctionne pas
malheureusement



Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc" news:

voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon calcule
ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:37:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:38:58
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:03
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:46
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com











Francois L
Le #4564021
voici l'adresse du fichier
http://www.cijoint.fr/cij51354227815232.xls

désolé je ne connaissais pas ce site



Bonsoir,

Ne pas écrire :
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))

mais
=SI(A20="";0;(INDEX(Montant;EQUIV(A20;Metier;0))))

--
François L

Pascal
Le #4563761
Je te renvoie ton fichier après quelques Modifs.
Une modif de formule en A17
=SI(A17<>"";INDEX(Montant;EQUIV(A17;Metier;0));"")
Une Modif en D17 =SI(ET(B17<>"";A17<>"");C17*B17;"") car à partir du moment
ou tu as extrais le taux correspondant à la main d'oeuvre, il ne s'agit plus
que d'une multiplication. Donc ta recherche en E est inutiel( A moins que je
n'ai pas compris la manip.
Par contre en B, il y avait plus simple que Index/Equiv.
Perso j'utilise toujours RECHERCHEV ou RECHERCHH avec un tableau nommé je
recherche la valeur en A17 et je décale du nombre de col voulues pour
arriver à la donnée recherchée. Idem pour ta col F a partir du moment ou tu
as la main d'oeuvre tu décales de 2 col pour retrouver
PI98-1 / PICK-UP CHEVROLET

http://www.cijoint.fr/cij63029850115307.xls
Pascal



"Marc"
voici l'adresse du fichier
http://www.cijoint.fr/cij51354227815232.xls

désolé je ne connaissais pas ce site

Marc




Ici
http://www.cijoint.fr/index.php



"Marc"
ou est ci-joint


Envoi ton fichier sur Ci Joint
"Marc" news:

j'ai essayé les deux exemple que tu m'as donné et ca ne fonctionne
pas
malheureusement



Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc" news:

voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les
la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon
calcule
ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:37:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:38:58
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:03
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:46
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 03/06/2007 07:58:46
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 03/06/2007 08:17:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







Marc
Le #4563501
un gros merci Pascal t'es mon sauveur


Je te renvoie ton fichier après quelques Modifs.
Une modif de formule en A17
=SI(A17<>"";INDEX(Montant;EQUIV(A17;Metier;0));"")
Une Modif en D17 =SI(ET(B17<>"";A17<>"");C17*B17;"") car à partir du moment
ou tu as extrais le taux correspondant à la main d'oeuvre, il ne s'agit plus
que d'une multiplication. Donc ta recherche en E est inutiel( A moins que je
n'ai pas compris la manip.
Par contre en B, il y avait plus simple que Index/Equiv.
Perso j'utilise toujours RECHERCHEV ou RECHERCHH avec un tableau nommé je
recherche la valeur en A17 et je décale du nombre de col voulues pour
arriver à la donnée recherchée. Idem pour ta col F a partir du moment ou tu
as la main d'oeuvre tu décales de 2 col pour retrouver
PI98-1 / PICK-UP CHEVROLET

http://www.cijoint.fr/cij63029850115307.xls
Pascal



"Marc"
voici l'adresse du fichier
http://www.cijoint.fr/cij51354227815232.xls

désolé je ne connaissais pas ce site

Marc




Ici
http://www.cijoint.fr/index.php



"Marc"
ou est ci-joint


Envoi ton fichier sur Ci Joint
"Marc" news:

j'ai essayé les deux exemple que tu m'as donné et ca ne fonctionne
pas
malheureusement



Bonjour
Essayes de remplacer ton SI(B21=#N/A;"" par
=SI(ESTERREUR(B21);"";(INDEX(Montant;EQUIV(A21;Metier;0))))
Pour la deuxième vois du côté =SI(ET(A20="";B20="";
(INDEX(Montant;EQUIV(A20;Metier;0))))

Pascal


"Marc" news:

voici la ligne que j'ai écrit
=SI(B21=#N/A;"";(INDEX(Montant;EQUIV(A21;Metier;0)))) ou
=SI(A20="";B20=0;(INDEX(Montant;EQUIV(A20;Metier;0))))
mais mon calcul du total des lignes ne ce calcule pas lorsque les
la
colonne
a est vide il me fait une belle erreur "#n/a" et alors mon
calcule
ne
fonctionne pas
=SOMME(D17:D24)
comment faire


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 15:42:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 01/06/2007 16:35:34
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:37:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 07:38:58
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:03
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 02/06/2007 16:54:46
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com







---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 03/06/2007 07:58:46
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000746-2, 01/06/2007
Analyse le : 03/06/2007 08:17:59
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com













Publicité
Poster une réponse
Anonyme