Calcul cellule vide

Le
michel.villaume
Bonjour,

J'ai un tableau avec en ligne 1 une succession de valeur "X"


A B C D E F G H I J K L M N O P
X X X X X

Je voudrais obtenir les écarts entre les x, calculer le nombre de
cellule vide entre les X

Dans cet exemple, je souhaite obtenir comme résultat

2 3 3 2

Merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #4912701
Bonjour,

Du mal à trouver une solution simple. Pour l'instant tu peux le faire avec 2
lignes de calculs :
Ligne 1 : =SI(A1="x";COLONNE();"")
Ligne 2 colonne B : =SI(B2<>"";B2-MAX($A2:A2)-1;"")

Camille

"" wrote:

Bonjour,

J'ai un tableau avec en ligne 1 une succession de valeur "X"


A B C D E F G H I J K L M N O P
X X X X X

Je voudrais obtenir les écarts entre les x, calculer le nombre de
cellule vide entre les X

Dans cet exemple, je souhaite obtenir comme résultat

2 3 3 2

Merci de votre aide




AV
Le #4912681
Avec les "x" ou vides en A1:zzzzzz1 (ligne 1)

En B2 et recopie >>> zzzzzz2
Matricielle à valider par ctrl +maj+entrée :

=SI(((PETITE.VALEUR(SI(1:1="x";COLONNE(1:1);9^9);COLONNE())-PETITE.VALEUR(SI(1:1="x";COLONNE(1:1);9^9);COLONNE()-1)-1)
Exemple là :
http://cjoint.com/?gukve1gOyW

AV
JB
Le #4912651
Bonjour,

-Sélectionner A3:K3
=SI(ESTNUM(PETITE.VALEUR(SI(DECALER(ch;0;1)="x";COLONNE(DECALER(ch;
0;1)));COLONNE(ch)));
PETITE.VALEUR(SI(DECALER(ch;0;1)="x";COLONNE(DECALER(ch;
0;1)));COLONNE(ch))-
PETITE.VALEUR(SI(ch="x";COLONNE(ch));COLONNE(ch));"")
Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?gulNgw624K

JB

On 20 juin, 09:01, wrote:
Bonjour,

J'ai un tableau avec en ligne 1 une succession de valeur "X"

A B C D E F G H I J K L M N O P
X X X X X

Je voudrais obtenir les écarts entre les x, calculer le nombre de
cellule vide entre les X

Dans cet exemple, je souhaite obtenir comme résultat

2 3 3 2

Merci de votre aide


Publicité
Poster une réponse
Anonyme