Calcul échéance

Le
Paul Laurnic
Bonjour à toutes et à tous.
j'ai 4 dates d'échéances de paiements le 31 janvier, le 30 avril, le 31
juillet et le 31 octobre. dans la cellule A1, j'ai une date de facture
quelconque et je cherche à savoir à quelles échéances elle appartient. je
souhaite donc avoir en B1 la réponse : janvier, avril, juillet ou octobre.
Merci par avance pour votre aide
Paul
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #19349501
Bonjour Paul,

Il y a ceci : En supposant

=SI(MOIS(A1)<=1;("31-01-"&ANNEE(A1))*1;SI(MOIS(A1)<=4;("30-04-"&ANNEE(A1))*1;SI(MOIS(A1)<=8;("31-08-"&ANNEE(A1))*1;SI(MOIS(A1)<;("31-12-"&ANNEE(A1))*1))))





"Paul Laurnic" de discussion :
Bonjour à toutes et à tous.
j'ai 4 dates d'échéances de paiements le 31 janvier, le 30 avril, le 31
juillet et le 31 octobre. dans la cellule A1, j'ai une date de facture
quelconque et je cherche à savoir à quelles échéances elle appartient. je
souhaite donc avoir en B1 la réponse : janvier, avril, juillet ou octobre.
Merci par avance pour votre aide
Paul
isabelle
Le #19349491
bonjour Paul,

=SI(ESTERREUR(EQUIV(MOIS(A1);{1;4;7;10};0));INDEX({"janvier";"avril";"juillet";"octobre"};1+EQUIV(MOIS(A1);{1;4;7;10}));INDEX({"janvier";"avril";"juillet";"octobre"};EQUIV(MOIS(A1);{1;4;7;10})))

isabelle

Paul Laurnic a écrit :
Bonjour à toutes et à tous.
j'ai 4 dates d'échéances de paiements le 31 janvier, le 30 avril, le 31
juillet et le 31 octobre. dans la cellule A1, j'ai une date de facture
quelconque et je cherche à savoir à quelles échéances elle appartient. je
souhaite donc avoir en B1 la réponse : janvier, avril, juillet ou octobre.
Merci par avance pour votre aide
Paul



MichDenis
Le #19349481
La cellule contenant la formule doit être au format "Date".
Modeste
Le #19349541
Bonsour® Paul Laurnic avec ferveur ;o))) vous nous disiez :

j'ai 4 dates d'échéances de paiements le 31 janvier, le 30 avril, le
31 juillet et le 31 octobre. dans la cellule A1, j'ai une date de
facture quelconque et je cherche à savoir à quelles échéances elle
appartient. je souhaite donc avoir en B1 la réponse : janvier, avril,
juillet ou octobre. Merci par avance pour votre aide




en B1
ÚTE(ANNEE(A1);(3*ENT((1+MOIS(A1))/3))+2;0)

format date complet ou "mmmm"
@+
isabelle
Le #19349631
ben oui, pourquoi faire compliqué quand un peut faire simple ;-)

isabelle

Modeste a écrit :
Bonsour® Paul Laurnic avec ferveur ;o))) vous nous disiez :


j'ai 4 dates d'échéances de paiements le 31 janvier, le 30 avril, le
31 juillet et le 31 octobre. dans la cellule A1, j'ai une date de
facture quelconque et je cherche à savoir à quelles échéances elle
appartient. je souhaite donc avoir en B1 la réponse : janvier, avril,
juillet ou octobre. Merci par avance pour votre aide





en B1
ÚTE(ANNEE(A1);(3*ENT((1+MOIS(A1))/3))+2;0)

format date complet ou "mmmm"
@+





Modeste
Le #19349711
Bonsour® isabelle avec ferveur ;o))) vous nous disiez :

ben oui, pourquoi faire compliqué quand un peut faire simple ;-)



;o)))
si l'on veut compliquer on pourrait introduire le fait que :
une facture émise un jour proche de l'échéance devrait voir son échéance reportée de 3 mois :
alors avec une variable nommée report (de 1 à 7 jours par exemple)
en B1
ÚTE(ANNEE(A1+report);(3*ENT((1+MOIS(A1+report))/3))+2;0)
format date complet ou "mmmm"

et puis pourquoi ne pas introduire la notion de jours ouvrés pendant qu'on y est ????
;o)))
A toujours imaginer le pire, on est rarement déçu..


@+
Paul Laurnic
Le #19352751
Merci à toutes et à tous
vous êtes des chefs

"Modeste" a écrit :

Bonsour® Paul Laurnic avec ferveur ;o))) vous nous disiez :

> j'ai 4 dates d'échéances de paiements le 31 janvier, le 30 avril, le
> 31 juillet et le 31 octobre. dans la cellule A1, j'ai une date de
> facture quelconque et je cherche à savoir à quelles échéances elle
> appartient. je souhaite donc avoir en B1 la réponse : janvier, avril,
> juillet ou octobre. Merci par avance pour votre aide


en B1
ÚTE(ANNEE(A1);(3*ENT((1+MOIS(A1))/3))+2;0)

format date complet ou "mmmm"
@+





Publicité
Poster une réponse
Anonyme