calcul de moyenne scolaire avec coefficient

Le
gerard
Bonsoir,
J'ai une liste d'élèves en colonne 2 de mon fichier Excel 2007,
en colonne 3, pour chaque élève la note de la matière A
en colonne 4, pour chaque élève la note de la matière B
en colonne 5, pour chaque élève, je donne la moyenne des 2 notes.
Çà fonctionne très bien avec la fonction "MOY"

Là où çà se corse, c'est que pour chaque note de chaque matière, =
je dois intégrer un coefficient noté en B2 pour la matière A et en C2=
pour la matière B

Au plus simple, pour le 1er élève (ligne 3 de mon fichier) qui a 15 en =
matière A (coef 2) et 12 en matière B (coef 3), je peux rédiger la fo=
rmule ainsi :
=SOMME((B3*B2)+(C3*C2))/5

C'est un peu fastidieux ; n'y aurait-il pas un moyen plus simple utilisant =
la formule "MOY" ?

Merci pour votre aide

Cordialement,

Gérard
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
GL
Le #26120402
Le 08/05/2014 19:14, gerard a écrit :
Bonsoir,
J'ai une liste d'élèves en colonne 2 de mon fichier Excel 2007,
en colonne 3, pour chaque élève la note de la matière A
en colonne 4, pour chaque élève la note de la matière B
en colonne 5, pour chaque élève, je donne la moyenne des 2 notes.
Çà fonctionne très bien avec la fonction "MOY"

Là où çà se corse, c'est que pour chaque note de chaque matière, je dois intégrer un coefficient noté en B2 pour la matière A et en C2 pour la matière B

Au plus simple, pour le 1er élève (ligne 3 de mon fichier) qui a 15 en matière A (coef 2) et 12 en matière B (coef 3), je peux rédiger la formule ainsi :
=SOMME((B3*B2)+(C3*C2))/5

C'est un peu fastidieux ; n'y aurait-il pas un moyen plus simple utilisant la formule "MOY" ?



Ce sera surtout fastidieux si vous multipliez les colonnes.
En principe, c'est une moyenne pondérée que vous voulez :

=SOMMEPROD(<vecteur notes>;<vecteur pondérations>)/SOMME(<pondérations>)

Donc par exemple :
=SOMMEPROD(B3:C3;$B$2:$C$2)/SOMME($B$2:$C$2)

Vous pouvez faire en sorte d'inscrire la SOMME directement dans une
cellule pour simplifier encore la formule (la somme des coefs est
une information qu'on a souvent intérêt à afficher clairement...).


Merci pour votre aide



Derien.
Publicité
Poster une réponse
Anonyme