Calcul nombre d'occurence avec filtre

Le
acrobapt Hors ligne
Bonjour,

J'ai besoin d'aide pour une formule sur excel :
j'ai une colonne sur laquelle j'applique un certain nombre de filtres et je voudrais un calcul automatique qui me donne le nombre d'occurences différentes de 0. Le pb est que j'arrive bien à intégrer une formule qui calcul ce nombre (=SOMMEPROD(NB.SI(N4:N523;"<>0");1), mais cela ne prends pas en compte lorsque j'applique les filtres.
Qqn aurait-il une idée?
Merci,

Baptiste
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #24673671
Bonsoir
La fonction SOUS.TOTAL est ce qu'il y a de mieux pour calculer des trucs
issus d'un filtre .....



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"acrobapt" a écrit dans le message de groupe de discussion :


Bonjour,

J'ai besoin d'aide pour une formule sur excel :
j'ai une colonne sur laquelle j'applique un certain nombre de filtres et je
voudrais un calcul automatique qui me donne le nombre d'occurences
différentes
de 0. Le pb est que j'arrive bien à intégrer une formule qui calcul ce
nombre
(=SOMMEPROD(NB.SI(N4:N523;"<>0");1), mais cela ne prends pas en compte
lorsque
j'applique les filtres.
Qqn aurait-il une idée?
Merci,

Baptiste
MichD
Le #24673711
Bonjour,

Suppose que tu appliques un filtre automatique sur la colonne A2:AX (plage nommée "MichD")
et que tu veuilles calculer le nombre d'entrées où chaque donnée est différente de 0

La plage nommées "MichD" ne doit pas comprendre l'étiquette de colonne.


=SOMMEPROD((SOUS.TOTAL(3;DECALER(MichD;LIGNE(MichD)-MIN(LIGNE(MichD));;1)))*(MichD<>0))



MichD
---------------------------------------------------------------
acrobapt Hors ligne
Le #24674631
Le mercredi 01 Août 2012 à 14:32 par acrobapt :
Bonjour,

J'ai besoin d'aide pour une formule sur excel :
j'ai une colonne sur laquelle j'applique un certain nombre de filtres et je
voudrais un calcul automatique qui me donne le nombre d'occurences
différentes de 0. Le pb est que j'arrive bien à intégrer
une formule qui calcul ce nombre
(=SOMMEPROD(NB.SI(N4:N523;"<>0");1), mais cela ne prends pas en
compte lorsque j'applique les filtres.
Qqn aurait-il une idée?
Merci,

Baptiste


Merci pour votre réponse et votre réactivité! Cela fonctionne parfaitement!
Publicité
Poster une réponse
Anonyme