Calcul particulierdans Excel

Le
alenico78
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc positionné en A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures indiquées.

C'est probablement simple mais .

Merci à tous pour l'aide que vous vudrez bien m'apporter
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4802251
Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc... positionné en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter




alenico78
Le #4802201
Merci beaucoup pour la réponse, j'essaie dès que possible
Cordialement
alenico


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc... positionné en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter









alenico78
Le #4802191
Dans ce cas, lorsque j'indique =si(ESTNUM(A1), cela mindique "faux" et donc
le résultat de la formule indique donc en A3 l'heure portée en A1 au lieu de
calculer le nombre d'heure résultant de A2-A1


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc... positionné en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter









Daniel
Le #4802091
Si ESTNUM(A1) indique faux, c'est que tu n'as pas d'heure en A1, mais plutôt
un libellé alphabétique.
Daniel
"alenico78"
Dans ce cas, lorsque j'indique =si(ESTNUM(A1), cela mindique "faux" et
donc
le résultat de la formule indique donc en A3 l'heure portée en A1 au lieu
de
calculer le nombre d'heure résultant de A2-A1


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une
autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc... positionné
en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures
indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter











alenico78
Le #4801871
Bonjour,
Merci bcppour la réponse, mais après contrôle du format en A1 (comme en A2
d'ailleurs), le format est bien en heure hh:mm.
Je ne comprends donc pas et ne sais donc toujours pas résoudre mon problème.

Merci encore pour toute l'aide que chacun voudra bien m'apporter
Cordialement


Si ESTNUM(A1) indique faux, c'est que tu n'as pas d'heure en A1, mais plutôt
un libellé alphabétique.
Daniel
"alenico78"
Dans ce cas, lorsque j'indique =si(ESTNUM(A1), cela mindique "faux" et
donc
le résultat de la formule indique donc en A3 l'heure portée en A1 au lieu
de
calculer le nombre d'heure résultant de A2-A1


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une
autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc... positionné
en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures
indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter
















Daniel
Le #4801821
Bonjour.
Regarde le classeur à l'adresse :
http://cjoint.com/?ivjwXFkBug
Daniel
"alenico78"
Bonjour,
Merci bcppour la réponse, mais après contrôle du format en A1 (comme en A2
d'ailleurs), le format est bien en heure hh:mm.
Je ne comprends donc pas et ne sais donc toujours pas résoudre mon
problème.

Merci encore pour toute l'aide que chacun voudra bien m'apporter
Cordialement


Si ESTNUM(A1) indique faux, c'est que tu n'as pas d'heure en A1, mais
plutôt
un libellé alphabétique.
Daniel
"alenico78"
Dans ce cas, lorsque j'indique =si(ESTNUM(A1), cela mindique "faux" et
donc
le résultat de la formule indique donc en A3 l'heure portée en A1 au
lieu
de
calculer le nombre d'heure résultant de A2-A1


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une
autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc...
positionné
en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures
indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter


















alenico78
Le #4801711
J'ai regardé le classeur et ceci correspond parfaitement à ce que j'avais
fait suite au renseignement fourni. Malheureusement sur mon tableau, cela ne
me donne pas le résultat escompté.
Peut être ai-je oublié une précision ou alors je me suis mal exprimé, je
repose donc le problème:
En A1 j'ai 7:00
En A2 j'ai 15:00
En A3 A2 - A1 = 8:00 no problem

Puis en B1 j'ai R
Obtenir R en B3 n'est pas non plus compliqué,

mais avec une seule formule, comment obtenir dans le cas de la colonne A
"8:00 " en A3 et dans le cas de la colonne B "R" en B3.

Effectivement, la solution devrait être la bonne, sauf qu'avec la formule
SI(ESTNUM(A1);A2-A1;A1), j'obtiens en A3 "7:00".

Qu'aurai-je oublié de faire ou que fais-je mal?

Merci bcp par avance
Alenico


Bonjour.
Regarde le classeur à l'adresse :
http://cjoint.com/?ivjwXFkBug
Daniel
"alenico78"
Bonjour,
Merci bcppour la réponse, mais après contrôle du format en A1 (comme en A2
d'ailleurs), le format est bien en heure hh:mm.
Je ne comprends donc pas et ne sais donc toujours pas résoudre mon
problème.

Merci encore pour toute l'aide que chacun voudra bien m'apporter
Cordialement


Si ESTNUM(A1) indique faux, c'est que tu n'as pas d'heure en A1, mais
plutôt
un libellé alphabétique.
Daniel
"alenico78"
Dans ce cas, lorsque j'indique =si(ESTNUM(A1), cela mindique "faux" et
donc
le résultat de la formule indique donc en A3 l'heure portée en A1 au
lieu
de
calculer le nombre d'heure résultant de A2-A1


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai une
autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc...
positionné
en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures
indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter























Daniel
Le #4801681
En A3, tu mets la formule :
=SI(ESTNUM(A1);A2-A1;A1)
Tu la copies et tu la colles en B3.
Daniel
"alenico78"
J'ai regardé le classeur et ceci correspond parfaitement à ce que j'avais
fait suite au renseignement fourni. Malheureusement sur mon tableau, cela
ne
me donne pas le résultat escompté.
Peut être ai-je oublié une précision ou alors je me suis mal exprimé, je
repose donc le problème:
En A1 j'ai 7:00
En A2 j'ai 15:00
En A3 A2 - A1 = 8:00 no problem

Puis en B1 j'ai R
Obtenir R en B3 n'est pas non plus compliqué,

mais avec une seule formule, comment obtenir dans le cas de la colonne A
"8:00 " en A3 et dans le cas de la colonne B "R" en B3.

Effectivement, la solution devrait être la bonne, sauf qu'avec la formule
SI(ESTNUM(A1);A2-A1;A1), j'obtiens en A3 "7:00".

Qu'aurai-je oublié de faire ou que fais-je mal?

Merci bcp par avance
Alenico


Bonjour.
Regarde le classeur à l'adresse :
http://cjoint.com/?ivjwXFkBug
Daniel
"alenico78"
Bonjour,
Merci bcppour la réponse, mais après contrôle du format en A1 (comme en
A2
d'ailleurs), le format est bien en heure hh:mm.
Je ne comprends donc pas et ne sais donc toujours pas résoudre mon
problème.

Merci encore pour toute l'aide que chacun voudra bien m'apporter
Cordialement


Si ESTNUM(A1) indique faux, c'est que tu n'as pas d'heure en A1, mais
plutôt
un libellé alphabétique.
Daniel
"alenico78"
Dans ce cas, lorsque j'indique =si(ESTNUM(A1), cela mindique "faux"
et
donc
le résultat de la formule indique donc en A3 l'heure portée en A1 au
lieu
de
calculer le nombre d'heure résultant de A2-A1


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai
une
autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc...
positionné
en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou
en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures
indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter

























alenico78
Le #4801651
C'est exactement ce que j'ai fait sauf qu'avec la formule
SI(ESTNUM(A1);A2-A1;A1), j'obtiens en A3 "7:00" au lieu de la différence entre A1 et A3
Alenico




En A3, tu mets la formule :
=SI(ESTNUM(A1);A2-A1;A1)
Tu la copies et tu la colles en B3.
Daniel
"alenico78"
J'ai regardé le classeur et ceci correspond parfaitement à ce que j'avais
fait suite au renseignement fourni. Malheureusement sur mon tableau, cela
ne
me donne pas le résultat escompté.
Peut être ai-je oublié une précision ou alors je me suis mal exprimé, je
repose donc le problème:
En A1 j'ai 7:00
En A2 j'ai 15:00
En A3 A2 - A1 = 8:00 no problem

Puis en B1 j'ai R
Obtenir R en B3 n'est pas non plus compliqué,

mais avec une seule formule, comment obtenir dans le cas de la colonne A
"8:00 " en A3 et dans le cas de la colonne B "R" en B3.

Effectivement, la solution devrait être la bonne, sauf qu'avec la formule
SI(ESTNUM(A1);A2-A1;A1), j'obtiens en A3 "7:00".

Qu'aurai-je oublié de faire ou que fais-je mal?

Merci bcp par avance
Alenico


Bonjour.
Regarde le classeur à l'adresse :
http://cjoint.com/?ivjwXFkBug
Daniel
"alenico78"
Bonjour,
Merci bcppour la réponse, mais après contrôle du format en A1 (comme en
A2
d'ailleurs), le format est bien en heure hh:mm.
Je ne comprends donc pas et ne sais donc toujours pas résoudre mon
problème.

Merci encore pour toute l'aide que chacun voudra bien m'apporter
Cordialement


Si ESTNUM(A1) indique faux, c'est que tu n'as pas d'heure en A1, mais
plutôt
un libellé alphabétique.
Daniel
"alenico78"
Dans ce cas, lorsque j'indique =si(ESTNUM(A1), cela mindique "faux"
et
donc
le résultat de la formule indique donc en A3 l'heure portée en A1 au
lieu
de
calculer le nombre d'heure résultant de A2-A1


Bonsoir.
=SI(ESTNUM(A1);A2-A1;A1)
Cordialement.
Daniel
"alenico78"
Bonsoir,
J'ai vainement tenté de résoudre le problème suivant:
Dans un planning en A1 j'ai une heure format hh:mm et en A2 j'ai
une
autre
heure même format.
Mais je peux aussi avoir un code par ex R ou M ou CP etc...
positionné
en
A1.

Comment avoir en A3 le nombre d'heures (cela s'avère facile) ou
en
priorité
le libellé porté en A1 (R ou M ou CP) s'il n'y a pas d'heures
indiquées.

C'est probablement simple mais ....

Merci à tous pour l'aide que vous vudrez bien m'apporter






























Daniel
Le #4801581
"alenico78"
C'est exactement ce que j'ai fait sauf qu'avec la formule
SI(ESTNUM(A1);A2-A1;A1), j'obtiens en A3 "7:00" au lieu de la
différence entre A1 et A3




Tu ne peux pas obtenir en A3 la différence entre A1 et A3.
Daniel



Publicité
Poster une réponse
Anonyme