Calcul prenom

Le
verdo.v4
Bonjour,
de "A1" a "AX1" j'ai des prénoms d’écrit, et en "AZ1" je voudrait que=
cela me dise le nombre de fois que j'ai écrit "jean" entre "A1" a "AX1"
Est ce possible ?
merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
verdo.v4
Le #24376741
Oups, j'ai trouvé sur le net ^^
=NB.SI(C11:BG11;"Jean")
alors, une autre question, est il possible, dans la même formule de calcu l, de multiplier le résultat par "7:00"
Merci d'avance
MichD
Le #24376901
Bonjour,

Oui c'est possible. Ta formule deviendrait : =NB.SI(A1:A7;"Toto")*"7:00"
et tu donnes à la cellule affichant le résultat, un format personnalisé comme ceci : [hh]:mm


MichD
------------------------------------------
verdo.v4
Le #24377401
J'ai fait ca, est-ce correct ?
=SOMMEPROD((C11:BG11="Jean")*("7:00"))

Et une autre chose,
en BJ11, en BL11 et en BN11 j'ai des heures, quand je fais la somme de ces 3 cellules et que cette dite somme est inférieur ou égal a 151:00, ma f ormule fonctionne, la cellule me renvoie -00:00 ou -1:00 selon le résulta t. Mais, si la somme de ces 3 cellules est supérieur a 151:00, c'est #VAL EUR que me renvoie la cellule, alors que je veux que cela me renvoie le r ésultat soit +2:00 ou 2:00, quelqu'un serait me dire pourquoi ?
Merci d'avance
=(SI((BJ11+BL11+BN11)>"151:00";(BJ11+BL11+BN11)-"151:00";"-"&TEXTE("151:0 0"-(BJ11+BL11+BN11);"hh:mm")))
MichD
Le #24378421
Bonjour,

Quelle est la question?

| J'ai fait ca, est-ce correct ?
| =SOMMEPROD((C11:BG11="Jean")*("7:00"))


Dans cette formule :
=(SI((BJ11+BL11+BN11)>"151:00";(BJ11+BL11+BN11)-"151:00";"-"&TEXTE("151:00"-(BJ11+BL11+BN11);"hh:mm")))

Si tu obtiens "#VALEUR", il y a une des 3 cellules qui est considérée comme du "Texte" ou qui retourne une valeur d'erreur.
Si tu veux afficher des heures dans un format négatif, pourquoi ne pas utiliser le calendrier 1904 disponible dans les
options d'Excel
au lieu de la fonction texte()? Par exemple, tu pourrais avoir dans une cellule : ¡-B1 et obtenir un résultat
négatif: -15:50

Attention, si tu optes pour un calendrier 1904, et que tu as déjà saisi des dates, il ne faut pas te surprendre si ces dates
font un bon de 4 ans.

Avec le format approprié, Il n'y a aucune raison pour qu'Excel s'arrête de calculer le nombre d'heures après 151.

MichD
------------------------------------------
a écrit dans le message de groupe de discussion :

J'ai fait ca, est-ce correct ?
=SOMMEPROD((C11:BG11="Jean")*("7:00"))

Et une autre chose,
en BJ11, en BL11 et en BN11 j'ai des heures, quand je fais la somme de ces 3 cellules et que cette dite somme est inférieur
ou égal a 151:00, ma formule fonctionne, la cellule me renvoie -00:00 ou -1:00 selon le résultat. Mais, si la somme de ces 3
cellules est supérieur a 151:00, c'est #VALEUR que me renvoie la cellule, alors que je veux que cela me renvoie le résultat
soit +2:00 ou 2:00, quelqu'un serait me dire pourquoi ?
Merci d'avance
=(SI((BJ11+BL11+BN11)>"151:00";(BJ11+BL11+BN11)-"151:00";"-"&TEXTE("151:00"-(BJ11+BL11+BN11);"hh:mm")))
Publicité
Poster une réponse
Anonyme