Carte wifi IPv6

Le
PP
Bonjour à tous,

je me permet de poster car, je ne trouve rien sur les moteur de recherche.

En effet, je recherche une carte wifi N interne, supportant l'IPv6 et
étant compatible avec Linux.

Par exemple, la TP-LINK TL-WN851ND me parait bien, mais voilà aucune
information sur sa compatibilité IPv6

merci de vos renseignements
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Benoit Izac
Le #25578272
Bonjour,

le 02/08/2013 à 22:39, PP a écrit dans le message

En effet, je recherche une carte wifi N interne, supportant l'IPv6 et
étant compatible avec Linux.

Par exemple, la TP-LINK TL-WN851ND me parait bien, mais voilà aucune
information sur sa compatibilité IPv6 ...



Si ta distribution Linux supporte IPv6 (l'inverse doit être rare de nos
jours), tu n'auras aucun problème pour faire de l'IPv6.

En revanche, après avoir jeté un coup d'oeil rapide sur google, je ne
suis pas certain que tu puisses la faire fonctionner en 801.11n ; les
messages datent de 2012, c'est peut-être implémenté depuis, à creuser...

--
Benoit Izac
PP
Le #25578262
Le 02/08/2013 23:03, Benoit Izac a écrit :
Bonjour,

le 02/08/2013 à 22:39, PP a écrit dans le message

En effet, je recherche une carte wifi N interne, supportant l'IPv6 et
étant compatible avec Linux.

Par exemple, la TP-LINK TL-WN851ND me parait bien, mais voilà aucune
information sur sa compatibilité IPv6 ...



Si ta distribution Linux supporte IPv6 (l'inverse doit être rare de nos
jours), tu n'auras aucun problème pour faire de l'IPv6.

En revanche, après avoir jeté un coup d'oeil rapide sur google, je ne
suis pas certain que tu puisses la faire fonctionner en 801.11n ; les
messages datent de 2012, c'est peut-être implémenté depuis, à creuser...



Mais c'est due à quoi le NON support de l'IPv6 ?
Hardware ou bien software ?
Cyprien Nicolas
Le #25578312
Salut,

Le 02/08/2013 23:13, PP écrivit :
Mais c'est due à quoi le NON support de l'IPv6 ? Hardware ou bien
software ?



Ça dépend du besoin. Une carte Wifi travaille dans les couches 1/2 du
modèle OSI (comme l’Ethernet filaire). IP (4 ou 6, ou même 112, si on
parle du champ "version" de l'en-tête du paquet IP) est au niveau 3,
donc au-dessus. Dans le cas d'une carte Wifi, c'est l'OS qui s'occupe
de faire de l'IP au-dessus de la couche liaison fournie par la carte.
Donc software ici.

Si tu est dans un cœur de réseau, les routeurs bossent au niveau 3, et
une partie du routage IP est fait en hardware par des composants
spécialisés, et là faut changer le matériel s'il supporte pas v6.

--
« Ceci n'est pas une signature. » — René Magritte (Apocryphe)
Benoit Izac
Le #25578302
Bonjour,

le 02/08/2013 à 23:13, PP a écrit dans le message

En effet, je recherche une carte wifi N interne, supportant l'IPv6 et
étant compatible avec Linux.

Par exemple, la TP-LINK TL-WN851ND me parait bien, mais voilà aucune
information sur sa compatibilité IPv6 ...



Si ta distribution Linux supporte IPv6 (l'inverse doit être rare de nos
jours), tu n'auras aucun problème pour faire de l'IPv6.

En revanche, après avoir jeté un coup d'oeil rapide sur google, je ne
suis pas certain que tu puisses la faire fonctionner en 801.11n ; les
messages datent de 2012, c'est peut-être implémenté depuis, à creuser...



Mais c'est due à quoi le NON support de l'IPv6 ?
Hardware ou bien software ?



Logiciel (option dans le noyau Linux).

--
Benoit Izac
PP
Le #25578452
Le 02/08/2013 23:32, Benoit Izac a écrit :
Bonjour,

le 02/08/2013 à 23:13, PP a écrit dans le message

En effet, je recherche une carte wifi N interne, supportant l'IPv6 et
étant compatible avec Linux.

Par exemple, la TP-LINK TL-WN851ND me parait bien, mais voilà aucune
information sur sa compatibilité IPv6 ...



Si ta distribution Linux supporte IPv6 (l'inverse doit être rare de nos
jours), tu n'auras aucun problème pour faire de l'IPv6.

En revanche, après avoir jeté un coup d'oeil rapide sur google, je ne
suis pas certain que tu puisses la faire fonctionner en 801.11n ; les
messages datent de 2012, c'est peut-être implémenté depuis, à creuser...



Mais c'est due à quoi le NON support de l'IPv6 ?
Hardware ou bien software ?



Logiciel (option dans le noyau Linux).



OK merci

J'ai du mal à comprendre, parce que j'ai un laptop, qui est sous Vista,
qui ne me met pas l'ipv6 (connectivité réduite), et je fais des essais
de cdlive Linux pour voir si ça marche avec Linux.
PP
Le #25578562
Le 03/08/2013 00:24, PP a écrit :
Le 02/08/2013 23:32, Benoit Izac a écrit :
Bonjour,

le 02/08/2013 à 23:13, PP a écrit dans le message

En effet, je recherche une carte wifi N interne, supportant l'IPv6 et
étant compatible avec Linux.

Par exemple, la TP-LINK TL-WN851ND me parait bien, mais voilà aucune
information sur sa compatibilité IPv6 ...



Si ta distribution Linux supporte IPv6 (l'inverse doit être rare de nos
jours), tu n'auras aucun problème pour faire de l'IPv6.

En revanche, après avoir jeté un coup d'oeil rapide sur google, je ne
suis pas certain que tu puisses la faire fonctionner en 801.11n ; les
messages datent de 2012, c'est peut-être implémenté depuis, à
creuser...



Mais c'est due à quoi le NON support de l'IPv6 ?
Hardware ou bien software ?



Logiciel (option dans le noyau Linux).



OK merci

J'ai du mal à comprendre, parce que j'ai un laptop, qui est sous Vista,
qui ne me met pas l'ipv6 (connectivité réduite), et je fais des essais
de cdlive Linux pour voir si ça marche avec Linux.



bon avec une bonne soirée de recherche en tout sens, voilà mon constat :

sur mon laptop, j'ai ma "carte" wifi qui est une realtek USB utilisant
le driver rtl8187b, et ce que je découvre finalement, c'est que
l'autoconfiguration en ipv6 ne fonctionne pas tant sous Linux que sous
Windows Vista. Sous Linux, en mettant en manuel l'adresse ipv6, et la
route, j'ai réussi à établir la connexion en ipv6. POURQUOI !!!???

ma freebox v6 fonctionne très bien, puisque mon desktop sous Linux et
sous Windows Vista sont en ipv6 sans problème, tout comme mon Raspberry
Pi en ethernet en direct sur la freebox server.

sur internet je ne trouve rien à propos d'un éventuel problème
d'autoconfig et de sa résolution.
Cyprien Nicolas
Le #25578802
Bon matin Usenet !

Foutou sur fcr.ip

Le 03/08/2013 03:48, PP écrivit :
Le 03/08/2013 00:24, PP a écrit :
J'ai du mal à comprendre, parce que j'ai un laptop, qui est sous
Vista, qui ne me met pas l'ipv6 (connectivité réduite), et je fais
des essais de cdlive Linux pour voir si ça marche avec Linux.



bon avec une bonne soirée de recherche en tout sens, voilà mon
constat :

sur mon laptop, j'ai ma "carte" wifi qui est une realtek USB
utilisant le driver rtl8187b, et ce que je découvre finalement, c'est
que l'autoconfiguration en ipv6 ne fonctionne pas tant sous Linux que
sous Windows Vista. Sous Linux, en mettant en manuel l'adresse ipv6,
et la route, j'ai réussi à établir la connexion en ipv6. POURQUOI
!!!???



Inutile de crier et de répéter des signes de ponctuations, ça te fait
passer pour un capricieux.

Il serait plus facile pour que nous t'aidions de décrire calmement ta
configuration, ton réseau, freebox v5 ou v6, accès adsl ou fibre, etc.
Quelques secondes sur google "freebox ipv6 wifi" donnent quelques
résultats :

Est-ce que le mode « routeur » de la freebox est activé ?
http://www.commentcamarche.net/forum/affich-3036769-freebox-acces-wifi-limite-ss-vista

ma freebox v6 fonctionne très bien, puisque mon desktop sous Linux
et sous Windows Vista sont en ipv6 sans problème, tout comme mon
Raspberry Pi en ethernet en direct sur la freebox server.



A priori, il semblerait donc que les RA ne sont pas envoyés sur le
réseau wifi, Je ne vois rien d'autres que d'essayer de dumper le
traffic avec des outils comme wireshark pour observer ce qui merdoit.
(je suis pas expert sur la chose).

sur internet je ne trouve rien à propos d'un éventuel problème
d'autoconfig et de sa résolution.



Et auprès du service client Free ?

--
« Ceci n'est pas une signature. » — René Magritte (Apocryphe)
Pascal Hambourg
Le #25578952
Salut,

Cyprien Nicolas a écrit :

sur mon laptop, j'ai ma "carte" wifi qui est une realtek USB
utilisant le driver rtl8187b, et ce que je découvre finalement, c'est
que l'autoconfiguration en ipv6 ne fonctionne pas tant sous Linux que
sous Windows Vista. Sous Linux, en mettant en manuel l'adresse ipv6,
et la route, j'ai réussi à établir la connexion en ipv6. POURQUOI
!!!???




[...]
ma freebox v6 fonctionne très bien, puisque mon desktop sous Linux
et sous Windows Vista sont en ipv6 sans problème, tout comme mon
Raspberry Pi en ethernet en direct sur la freebox server.



A priori, il semblerait donc que les RA ne sont pas envoyés sur le
réseau wifi,



Ou bien l'interface wifi ne les traite pas correctement. Ce ne serait
pas la première interface réseau qui merdoie joyeusement avec la
réception du multicast.

Je ne vois rien d'autres que d'essayer de dumper le
trafic avec des outils comme wireshark pour observer ce qui merdoie.



Pareil.
PP
Le #25580872
Le 03/08/2013 10:51, Cyprien Nicolas a écrit :
Bon matin Usenet !

Foutou sur fcr.ip

Le 03/08/2013 03:48, PP écrivit :
Le 03/08/2013 00:24, PP a écrit :
J'ai du mal à comprendre, parce que j'ai un laptop, qui est sous
Vista, qui ne me met pas l'ipv6 (connectivité réduite), et je
fais des essais de cdlive Linux pour voir si ça marche avec
Linux.



bon avec une bonne soirée de recherche en tout sens, voilà mon
constat :

sur mon laptop, j'ai ma "carte" wifi qui est une realtek USB
utilisant le driver rtl8187b, et ce que je découvre finalement,
c'est que l'autoconfiguration en ipv6 ne fonctionne pas tant sous
Linux que sous Windows Vista. Sous Linux, en mettant en manuel
l'adresse ipv6, et la route, j'ai réussi à établir la connexion en
ipv6. POURQUOI !!!???



Inutile de crier et de répéter des signes de ponctuations, ça te
fait passer pour un capricieux.



:)
je faisais une petite pointe d'humour, je ne suis point énervé par cette
histoire ... pour une fois.

Il serait plus facile pour que nous t'aidions de décrire calmement
ta configuration, ton réseau, freebox v5 ou v6, accès adsl ou fibre,
etc.



je pensais pourtant avoir tout dit.
J'ai une freebox server, donc une V6.
ma connexion est en ADSL.


Quelques secondes sur google "freebox ipv6 wifi" donnent quelques
résultats :

Est-ce que le mode « routeur » de la freebox est activé ?



http://www.commentcamarche.net/forum/affich-3036769-freebox-acces-wifi-limite-ss-vista

désolé rien à voir

ma freebox v6 fonctionne très bien, puisque mon desktop sous Linux
et sous Windows Vista sont en ipv6 sans problème, tout comme mon
Raspberry Pi en ethernet en direct sur la freebox server.



A priori, il semblerait donc que les RA ne sont pas envoyés sur le
réseau wifi, Je ne vois rien d'autres que d'essayer de dumper le
traffic avec des outils comme wireshark pour observer ce qui
merdoit. (je suis pas expert sur la chose).



RA ?


sur internet je ne trouve rien à propos d'un éventuel problème
d'autoconfig et de sa résolution.



Et auprès du service client Free ?



ça ne vient pas de free.
Pourquoi ?
parce que mon ordinateur fixe, sous Vista et sous Ubuntu avec une carte
Wifi fonctionne très bien en Wifi, même si curieusement avec ma nouvelle
carte Wifi N 300 acheté hier il a fallu que je rajoute un DNS openDNS
sous windows (DNS IPv6 en rade ?). Par contre sur ma ubuntu de mon
desktop tout est nickel, sans rien faire (http://test-ipv6.com) 10/10.

par contre avec le laptop ...

j'ai essayé de mettre en "dur" une IP, une route, et les DNS, mais après
reboote sous Windows Vista, c'est comme si Windows/carteWifi ne
voulait/pouvait garder que les DNS, les informations IP, et route, étant
perdu au reboot ...


PS : tu es sur FDN ! respect :) Je suis en train de visionner tous les
vidéos des conférences de benj, c'est vraiment très intéressant, mais
aussi un peu déprimant parfois ;)
Cyprien Nicolas
Le #25580992
Le 04/08/2013 20:26, PP écrivit :
Le 03/08/2013 10:51, Cyprien Nicolas a écrit :
je pensais pourtant avoir tout dit.
J'ai une freebox server, donc une V6.
ma connexion est en ADSL.



Merci !

ma freebox v6 fonctionne très bien, puisque mon desktop sous Linux
et sous Windows Vista sont en ipv6 sans problème, tout comme mon
Raspberry Pi en ethernet en direct sur la freebox server.



A priori, il semblerait donc que les RA ne sont pas envoyés sur le
réseau wifi, Je ne vois rien d'autres que d'essayer de dumper le
traffic avec des outils comme wireshark pour observer ce qui
merdoit. (je suis pas expert sur la chose).



RA ?



Router Advertisement, c'est à la base de l'autoconf en v6. Un serveur
annonce périodiquement en multicast le préfixe du sous réseau local avec
la gateway à utiliser, et éventuellement les serveurs DNS. Ça se
configure assez bien à la main avec un linux qui sert de routeur :-).
Les hôtes non configurés choisissent une adresse IP dérivée de leur MAC
address et du préfixe annoncé.
C'est tout de l'icmpv6, si tu veux essayer de dumper le traffic pour
voir. J'ignore ton niveau de connaissances sur IPv6, il y a une
introduction sur le site de Wireshark ici:

http://sharkfest.wireshark.org/sharkfest.10/B-6_Leutert%20Discovering%20IPv6%20with%20Wireshark.pdf

sur internet je ne trouve rien à propos d'un éventuel problème
d'autoconfig et de sa résolution.



Et auprès du service client Free ?



ça ne vient pas de free.
Pourquoi ?
parce que mon ordinateur fixe, sous Vista et sous Ubuntu avec une carte
Wifi fonctionne très bien en Wifi, même si curieusement avec ma nouvelle
carte Wifi N 300 acheté hier il a fallu que je rajoute un DNS openDNS
sous windows (DNS IPv6 en rade ?). Par contre sur ma ubuntu de mon
desktop tout est nickel, sans rien faire (http://test-ipv6.com) 10/10.



Okay, je n'avais pas saisi cette information. J'avais compris de tes
messages précédent que ça marchait en filaire et pas en sans fil. Du
coup je pensais à un souci de la box (ça serait pas le premier).
Maintenant c'est plus clair, merci des précisions.

Pour le coup du DNS, c'est très fréquent avec les box oranges qui
fontionnent mal, mais je me souviens pas avoir entendu de problème DNS
avec les freebox. Celà dit, si tu préfères d'autres résolveurs DNS que
ceux d'OpenDNS, il y a ceux de FDN : 80.67.169.12 et 2001:910:800::12.

par contre avec le laptop ...

j'ai essayé de mettre en "dur" une IP, une route, et les DNS, mais après
reboote sous Windows Vista, c'est comme si Windows/carteWifi ne
voulait/pouvait garder que les DNS, les informations IP, et route, étant
perdu au reboot ...



Je maîtrise assez mal ubuntu, bien que ce soit assez similaire à Debian
sur certains points. Aucune idée pour Windows, ça fait des années que
j'en ai plus utilisé, je laisse les connaisseurs donner leur avis.

Pour Linux, tu peux essayer de vérifier les options du système:

$ sysctl net.ipv6.conf.default.{accept_ra,autoconf,forwarding}
net.ipv6.conf.default.accept_ra = 1
net.ipv6.conf.default.autoconf = 1
net.ipv6.conf.default.forwarding = 0

Activer le forwarding désactive l'acceptation des ra sur certains
noyaux, j'ai plus le souci en tête, mais j'avais vu passer quelque chose
dans le genre sur IRC. C'est ptet une fausse piste. Et ça explique pas
pourquoi Windows suit pas…

Une autre option est d'essayer dhcpv6, si c'est supporté par la box?

En tout cas le symptôme est très étrange.

<hors sujet>
PS : tu es sur FDN ! respect :) Je suis en train de visionner tous les
vidéos des conférences de benj, c'est vraiment très intéressant, mais
aussi un peu déprimant parfois ;)



C'est cool si tu trouves ça intéressant ;-)
L'ADSL par FDN marche assez bien si on a pas besoin de la télé/voip.
Mais il y a obligation de gérer son réseau soi-même, du coup on apprend
des trucs. :-)
</hors sujet>

--
« Ceci n'est pas une signature. » — René Magritte (Apocryphe)
Publicité
Poster une réponse
Anonyme