cellule exacte

Le
Marc
Bonjour à vous tous
j'ai deux colonnes, A et B. Je veux comparer si une donnée qui est dans la
colonne A existe dans la colonne B. Voici la formule que quelqu'un, m'avait
donné ici même sur ce forum.

=SI(SOMMEPROD(N(A2=$B$2:$B$5001))>=1;"Existe dans la colonne B";"N'existe
pas dans la colonne B").

J'aimerais à partir de cette formule, si cela est possible, que la formule
m'indique dans quel cellule il trouve la donnée. Exemple. Si dans A2 j'ai le
mot Toto et que le mot Toto est écrit en B200, ma formule m'indique que Toto
existe dans la colonne B, par contre, si je veux savoir dans quel cellule il
est, je m'organise en utilisant les filtres automatique. Est-ce que quelqu'un
à une autre idée?

merci de votre aide

Marc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4356321
Bonsoir,

=SI(ESTNA(EQUIV(A2;champ;0));"inconnu";ADRESSE(EQUIV(A2;champ;
0)+LIGNE(champ)-1;2))

JB

On 6 mar, 21:12, Marc
Bonjour à vous tous
j'ai deux colonnes, A et B. Je veux comparer si une donnée qui est dans la
colonne A existe dans la colonne B. Voici la formule que quelqu'un, m'ava it
donné ici même sur ce forum.

=SI(SOMMEPROD(N(A2=$B$2:$B$5001))>=1;"Existe dans la colonne B";"N' existe
pas dans la colonne B").

J'aimerais à partir de cette formule, si cela est possible, que la form ule
m'indique dans quel cellule il trouve la donnée. Exemple. Si dans A2 j' ai le
mot Toto et que le mot Toto est écrit en B200, ma formule m'indique que Toto
existe dans la colonne B, par contre, si je veux savoir dans quel cellule il
est, je m'organise en utilisant les filtres automatique. Est-ce que quelq u'un
à une autre idée?

merci de votre aide

Marc


Marc
Le #4356291
Bonjour JB
est-ce que je dois modifier quelque chose dans ta formule? exemple, champ=??
parce que j'ai fait un copier coller dans mon fichier et j'ai le message
d'erreur #NOM?

merci


Bonsoir,

=SI(ESTNA(EQUIV(A2;champ;0));"inconnu";ADRESSE(EQUIV(A2;champ;
0)+LIGNE(champ)-1;2))

JB

On 6 mar, 21:12, Marc
Bonjour à vous tous
j'ai deux colonnes, A et B. Je veux comparer si une donnée qui est dans la
colonne A existe dans la colonne B. Voici la formule que quelqu'un, m'avait
donné ici même sur ce forum.

=SI(SOMMEPROD(N(A2=$B$2:$B$5001))>=1;"Existe dans la colonne B";"N'existe
pas dans la colonne B").

J'aimerais à partir de cette formule, si cela est possible, que la formule
m'indique dans quel cellule il trouve la donnée. Exemple. Si dans A2 j'ai le
mot Toto et que le mot Toto est écrit en B200, ma formule m'indique que Toto
existe dans la colonne B, par contre, si je veux savoir dans quel cellule il
est, je m'organise en utilisant les filtres automatique. Est-ce que quelqu'un
à une autre idée?

merci de votre aide

Marc







JB
Le #4356271
'Champ' est le nom de champ de B2:B5000

http://cjoint.com/?dgv7oSTmf6

JB

On 6 mar, 21:42, Marc
Bonjour JB
est-ce que je dois modifier quelque chose dans ta formule? exemple, champ =??
parce que j'ai fait un copier coller dans mon fichier et j'ai le message
d'erreur #NOM?

merci




Bonsoir,

=SI(ESTNA(EQUIV(A2;champ;0));"inconnu";ADRESSE(EQUIV(A2;champ;
0)+LIGNE(champ)-1;2))

JB

On 6 mar, 21:12, Marc
Bonjour à vous tous
j'ai deux colonnes, A et B. Je veux comparer si une donnée qui est dans la
colonne A existe dans la colonne B. Voici la formule que quelqu'un, m 'avait
donné ici même sur ce forum.

=SI(SOMMEPROD(N(A2=$B$2:$B$5001))>=1;"Existe dans la colonne B" ;"N'existe
pas dans la colonne B").

J'aimerais à partir de cette formule, si cela est possible, que la formule
m'indique dans quel cellule il trouve la donnée. Exemple. Si dans A 2 j'ai le
mot Toto et que le mot Toto est écrit en B200, ma formule m'indique que Toto
existe dans la colonne B, par contre, si je veux savoir dans quel cel lule il
est, je m'organise en utilisant les filtres automatique. Est-ce que q uelqu'un
à une autre idée?

merci de votre aide

Marc- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




Marc
Le #4356261
Un très gros merci JB
cela fonctionne parfaitement


'Champ' est le nom de champ de B2:B5000

http://cjoint.com/?dgv7oSTmf6

JB

On 6 mar, 21:42, Marc
Bonjour JB
est-ce que je dois modifier quelque chose dans ta formule? exemple, champ=??
parce que j'ai fait un copier coller dans mon fichier et j'ai le message
d'erreur #NOM?

merci




Bonsoir,

=SI(ESTNA(EQUIV(A2;champ;0));"inconnu";ADRESSE(EQUIV(A2;champ;
0)+LIGNE(champ)-1;2))

JB

On 6 mar, 21:12, Marc
Bonjour à vous tous
j'ai deux colonnes, A et B. Je veux comparer si une donnée qui est dans la
colonne A existe dans la colonne B. Voici la formule que quelqu'un, m'avait
donné ici même sur ce forum.

=SI(SOMMEPROD(N(A2=$B$2:$B$5001))>=1;"Existe dans la colonne B";"N'existe
pas dans la colonne B").

J'aimerais à partir de cette formule, si cela est possible, que la formule
m'indique dans quel cellule il trouve la donnée. Exemple. Si dans A2 j'ai le
mot Toto et que le mot Toto est écrit en B200, ma formule m'indique que Toto
existe dans la colonne B, par contre, si je veux savoir dans quel cellule il
est, je m'organise en utilisant les filtres automatique. Est-ce que quelqu'un
à une autre idée?

merci de votre aide

Marc- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -









Publicité
Poster une réponse
Anonyme