Cellule non vide...

Le
Noégor
Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #18934661
Bonjour,

En X1
=SI(ESTERREUR(PETITE.VALEUR(SI($A$1:$J$1
En Y1
=SI(ESTERREUR(PETITE.VALEUR(SI($A$1:$J$1
En Z1
=SI(ESTERREUR(PETITE.VALEUR(SI($A$1:$J$1
Le tout en validation matricielle (Maj+Ctrl+Entrée)

--
Salutations
JJ


"Noégor"
Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu
de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor




JB
Le #18934291
Bonjour,

Champ: A1:J1

En X1:
=SI(COLONNES($A:A)<=NBVAL(champ);INDEX(champ;PETITE.VALEUR(SI
(champ<>"";COLONNE(champ));COLONNES($A:A)));"")
Valider avec maj+ctrl+entrée

JB
http://boisgontierjacques.free.fr

On 19 mar, 11:24, "Noégor"
Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le conte nu de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor


isabelle
Le #18934421
bonjour Noégor,

si la plage contient uniquement des nombres
mettre en cellule X1 la formule suivante et recopier à droite

=PETITE.VALEUR($A$1:$J$1;COLONNE()-23)
matriciel à valider par Ctrl+Shift+Enter

isabelle

Noégor a écrit :
Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor





Jacky
Le #18934641
...o)) oupsss!
C'est pas beau ça...de répondre un jour avant que la question soit posée,
hein !
;o))

--
Salutations
JJ


"Jacky" %
Bonjour,

En X1
=SI(ESTERREUR(PETITE.VALEUR(SI($A$1:$J$1
En Y1
=SI(ESTERREUR(PETITE.VALEUR(SI($A$1:$J$1
En Z1
=SI(ESTERREUR(PETITE.VALEUR(SI($A$1:$J$1
Le tout en validation matricielle (Maj+Ctrl+Entrée)

--
Salutations
JJ


"Noégor" news:
Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu
de
la première cellule non vide, puis en Y1 celui de la seconde cellule et
Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor








garnote
Le #18934911
Ave,

Essaie ceci :
Sélectionne X1:Z1, colle cette formule dans la barre de formule :
=INDEX(A1:J1;PETITE.VALEUR(SI(A1:J1<>"";COLONNE(A1:J1);11);{1.2.3}))
et valide par Ctrl+Maj+Entrée.

Serge


"Noégor"
Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor




Modeste
Le #18934901
Bonsour® Jacky avec ferveur ;o))) vous nous disiez :

...o)) oupsss!
C'est pas beau ça...de répondre un jour avant que la question soit
posée, hein !
;o))



l'avait des doutes sur la logique ????
l'a mer...é sur la pratique !!!
;o)))
Arghhhh...réfléchissement Jacky !!!!
garnote
Le #18934891
Bonjour Isabelle,

Ouais mais ne faudrait-il pas que les nombres soient
ordonnés en ordre croissant dans la plage A1:J1 ?

Serge


"isabelle" a écrit dans le message de news:
bonjour Noégor,

si la plage contient uniquement des nombres
mettre en cellule X1 la formule suivante et recopier à droite

=PETITE.VALEUR($A$1:$J$1;COLONNE()-23)
matriciel à valider par Ctrl+Shift+Enter

isabelle

Noégor a écrit :
Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor







isabelle
Le #18934991
salut Serge,

heu... non
http://cjoint.com/?dvoPR8DYUm

??

isabelle

garnote a écrit :
Bonjour Isabelle,

Ouais mais ne faudrait-il pas que les nombres soient
ordonnés en ordre croissant dans la plage A1:J1 ?

Serge


"isabelle" a écrit dans le message de news:

bonjour Noégor,

si la plage contient uniquement des nombres
mettre en cellule X1 la formule suivante et recopier à droite

=PETITE.VALEUR($A$1:$J$1;COLONNE()-23)
matriciel à valider par Ctrl+Shift+Enter

isabelle

Noégor a écrit :

Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor













Jacky
Le #18935071
l'avait des doutes sur la logique ????
Non Modeste pas de doute.....mais "maintenant" des 1/4 de test oui,
quoi que la logique était là, mais pas la remise de la date à son origine,
oui "l'a mer...é" JJ
;o))

--
Salutations
JJ


"Modeste"
Bonsour® Jacky avec ferveur ;o))) vous nous disiez :

...o)) oupsss!
C'est pas beau ça...de répondre un jour avant que la question soit
posée, hein !
;o))



l'avait des doutes sur la logique ????
l'a mer...é sur la pratique !!!
;o)))
Arghhhh...réfléchissement Jacky !!!!
isabelle
Le #18935061
ok, je viens de comprendre, il ne faut pas que le résultat soit trier en
ordre croissant,
j'va aller m'verser un bon café.. :-(
isabelle

garnote a écrit :
Bonjour Isabelle,

Ouais mais ne faudrait-il pas que les nombres soient
ordonnés en ordre croissant dans la plage A1:J1 ?

Serge


"isabelle" a écrit dans le message de news:

bonjour Noégor,

si la plage contient uniquement des nombres
mettre en cellule X1 la formule suivante et recopier à droite

=PETITE.VALEUR($A$1:$J$1;COLONNE()-23)
matriciel à valider par Ctrl+Shift+Enter

isabelle

Noégor a écrit :

Bonjour,
Sur une plage allant de A1 à J1, je souhaiterais stocker en X1 le contenu de
la première cellule non vide, puis en Y1 celui de la seconde cellule et Z1
celui de la troisième.
Comment faire sans utliser le VBA,
Merci.

Noégor













Publicité
Poster une réponse
Anonyme