Certificats de sécurité : IE7 XP SP2 et IE7 Vista sont-ils différents ?

Le
Korrigan
Bonjour,
Pourquoi les certificats de sécurité (en l'espèce : ceux de Impots.gouv) ne
fonctionnent pas avec IE7 sous Vista ?

- Sous XP SP2 avec IE7 : pas de problème.

- Je les "exporte" (via une clé USB) vers une autre machine sous XP SP2
(également IE7) : aucun problème d'accès.

- Je fais la même chose sur un portable sous Vista, avec IE7 bien sûr : ça
mouline, une fenêtre finit par apparaitre avec le certificat et me demande
de le valider; cette fenêtre se ferme, ça mouline encore (petit cercle sur
l'onglet de la page) puis la fenêtre de IE qui dit : "Internet Explorer ne
peut pas afficher cette page Web" .

Dans tous ces process j'agis comme administrateur.

J'ai vu que certains avaient eu des Pblms au passage de IE6 vers IE7, pas
moi.
Chez moi il semble que ce soit Vista qui soit en cause, sans doute des
droits ou une case à cocher/décocher, mais laquelle ?

Merci de vos commentaires et idées pour débloquer le schmilblick !
Kor
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Alias Martin
Le #187981
Bonjour.
C'est vista et IE7 qui posent problème.
J'ai passé un mail sur le site des impôts et il connaisse bien le problème.
D'après ce qu'ils m'ont dit, ils vont modifier leur site pour qu'il soit
compatible avec Vista+IE7. Tout devrait être prêt pour la prochaine
déclaration en mai. En attendant, le site marche très bien avec Firefox 2
(en important bien sur,sur firefox, le certificat.)

"Korrigan" news:
Bonjour,
Pourquoi les certificats de sécurité (en l'espèce : ceux de Impots.gouv)
ne
fonctionnent pas avec IE7 sous Vista ?

- Sous XP SP2 avec IE7 : pas de problème.

- Je les "exporte" (via une clé USB) vers une autre machine sous XP SP2
(également IE7) : aucun problème d'accès.

- Je fais la même chose sur un portable sous Vista, avec IE7 bien sûr : ça
mouline, une fenêtre finit par apparaitre avec le certificat et me demande
de le valider; cette fenêtre se ferme, ça mouline encore (petit cercle sur
l'onglet de la page) puis la fenêtre de IE qui dit : "Internet Explorer
ne
peut pas afficher cette page Web" .

Dans tous ces process j'agis comme administrateur.

J'ai vu que certains avaient eu des Pblms au passage de IE6 vers IE7, pas
moi.
Chez moi il semble que ce soit Vista qui soit en cause, sans doute des
droits ou une case à cocher/décocher, mais laquelle ?

Merci de vos commentaires et idées pour débloquer le schmilblick !
Kor



J. K.
Le #187980
Bonsoir,


"> Merci de vos commentaires et idées pour débloquer le
schmilblick !
Kor


As-tu coché dans les propriétés avancées de Ie SSL 2 et 3 ? C'est
un tuyau que j'avais eu ici. J'ai Vista.

--
Cordialement.
Jacques

J. K.
Le #187979
Bonjour, soir,

[couic]



C'est vista et IE7 qui posent problème.
J'ai passé un mail sur le site des impôts et il connaisse bien
le problème. D'après ce qu'ils m'ont dit, ils vont modifier
leur site pour qu'il soit compatible avec Vista+IE7.


Ben non, je viens d'y aller pour vérifier, ça marche IE 7 +
Vista.
http://www.cijoint.fr/cij4079053185922.jpg

--
Cordialement.
Jacques

Korrigan
Le #187928
"J. K." news:
As-tu coché dans les propriétés avancées de Ie SSL 2 et 3 ? C'est un tuyau
que j'avais eu ici. J'ai Vista.

SSL 2 n'était pas coché, mais le faire ne résoud pas le Pblm.

J'ai importé 2 certif. Ils sont bien présents puisqu'on les voit dans le
"gestionnaire de certificats"
Quand, sur impots.gouv, je demande à acceder à mon espace perso, une petite
fenêtre s'ouvre et montre un seul des 2 certif.
....et quand je valide j'ai : "IE ne peut pas afficher cette page web".

J. K.
Le #187925
Re,

SSL 2 n'était pas coché, mais le faire ne résoud pas le Pblm.
J'ai importé 2 certif. Ils sont bien présents puisqu'on les
voit dans le "gestionnaire de certificats"
Quand, sur impots.gouv, je demande à acceder à mon espace
perso, une petite fenêtre s'ouvre et montre un seul des 2
certif.
....et quand je valide j'ai : "IE ne peut pas afficher cette
page web".


As-tu un pare-feu, un routeur avec des règles contraignantes ?
Cela peut bloquer l'accès aux sites sécurisés. Consultes-tu ton
compte bancaire sur le web ?
J'ai une Livebox, j'utilise le pare-feu de Vista. Il faut
regarder les paramètres de sécurité, mettre par défaut. Peut-être
aussi un anti pop-up !
Ou alors un certificat qui n'est plus valide. Le mien : 29.08.09.
Je n'en sais pas plus.

--
Cordialement.
Jacques

Korrigan
Le #187874
;
"J. K." news:OdEZw$

As-tu un pare-feu, un routeur avec des règles contraignantes ? Cela peut
bloquer l'accès aux sites sécurisés. Consultes-tu ton compte bancaire sur
le web ?
J'ai une Livebox, j'utilise le pare-feu de Vista. Il faut regarder les
paramètres de sécurité, mettre par défaut. Peut-être aussi un anti pop-up
!
Ou alors un certificat qui n'est plus valide. Le mien : 29.08.09.
Je n'en sais pas plus.


- J'ai aussi une box et son fire wall intégré est actif : mais il n'empêche
pas les 2 autres machines de se connecter sans Pblm au site sécurisé.
- Derrière il y a le parefeu de Vista : Quand je le désactive l'accès ne se
fait pas non plus.
- J'ai autorisé les pop-ups sur le site des impots
- Enfin les certificats ont une date de fin de validité encore bien
lointaine

C'est sympa de m'avoir tendu des perches pour trouver des solutions
possibles...même si ça ne donne rien.

Pour finir, j'essaierai d'avoir de nouveaux certif en me loggant avec le
portable sur le site, certif que j'exporterai vers la machine sous XP.

Merci encore et bonne soirée
Korrigan

J. K.
Le #187873
Re,

C'est sympa de m'avoir tendu des perches pour trouver des
solutions possibles...même si ça ne donne rien.

Pour finir, j'essaierai d'avoir de nouveaux certif en me
loggant avec le portable sur le site, certif que j'exporterai
vers la machine sous XP.

Merci encore et bonne soirée
Korrigan


Désolé de ne pas pouvoir t'aider plus. Bon courage et bonne
soirée à toi aussi.

--
Cordialement.
Jacques

Jean-Claude BELLAMY
Le #187871
Dans le message :,
Korrigan
Bonjour,
Pourquoi les certificats de sécurité (en l'espèce : ceux de
Impots.gouv) ne fonctionnent pas avec IE7 sous Vista ?

- Sous XP SP2 avec IE7 : pas de problème.

- Je les "exporte" (via une clé USB) vers une autre machine sous XP
SP2 (également IE7) : aucun problème d'accès.

- Je fais la même chose sur un portable sous Vista, avec IE7 bien sûr
: ça mouline, une fenêtre finit par apparaitre avec le certificat et
me demande de le valider; cette fenêtre se ferme, ça mouline encore
(petit cercle sur l'onglet de la page) puis la fenêtre de IE qui dit
: "Internet Explorer ne peut pas afficher cette page Web" .



Je viens de faire la manip suivante :

- je me connecte au site des impôts sous XP : no problem
- j'exporte mon certificat (avec la clef privée, donc en .PFX)
dans un dossier partagé
- depuis une machine sous VISTA, j'importe ce certificat
- j'essaye de me connecter au site des impôts : blocage
- je sélectionne dans IE7 le menu Outils/Options Internet
onglet "Avancés", zone "Sécurité"
- je coche la case "SSL 2.0"
- je me connecte au site des impôts sous XP : mon certificat
apparait bien dans une boite de dialogue, je le sélectionne,
la page me conecernant s'affiche immédiatement, no problem !!!!

http://cjoint.com/?dcabtvK7A6

Donc le pb n'est du qu'à une différence de niveau de protocole SSL, qui est
par défaut 3.0 sous IE7/VISTA, alors que le serveur des impôts doit encore
utiliser le 2.0.


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr

korrigan
Le #187745
"Jean-Claude BELLAMY" message de news:

|
| Donc le pb n'est du qu'à une différence de niveau de protocole SSL, qui
est
| par défaut 3.0 sous IE7/VISTA, alors que le serveur des impôts doit encore
| utiliser le 2.0.

Merci de partager votre expérimentation en la matière, mais pour moi le Pblm
est tjrs là.
L'image qui suit vient de la connexion sous XP
http://cjoint.com/?dcjrryeWMB
où l'on voit que seul SSL 3.0 est coché (et pas le 2.0), ce qui contredit
votre dernière phrase.
Bien à vous
Korrigan
Jean-Claude BELLAMY
Le #187323
"korrigan" news:

"Jean-Claude BELLAMY" message de news:
| Donc le pb n'est du qu'à une différence de niveau de protocole SSL, qui
est
| par défaut 3.0 sous IE7/VISTA, alors que le serveur des impôts doit
encore
| utiliser le 2.0.

Merci de partager votre expérimentation en la matière, mais pour moi le
Pblm
est tjrs là.


Sous VISTA ?????

L'image qui suit vient de la connexion sous XP
http://cjoint.com/?dcjrryeWMB
où l'on voit que seul SSL 3.0 est coché (et pas le 2.0), ce qui contredit
votre dernière phrase.


Cela le contredirait en ce qui concerne XP, mais pas VISTA !

Ta capture d'écran provient d'une connexion sous XP,
Or la mienne provient d'une connexion sous VISTA !

Parce que chez moi, c'est vraiment biunivoque :
SSL 2 non coché -> pas de connexion possible
SSL 2 coché -> connexion immédiate
La corrélation est quand même forte, n'est-ce pas ?
Je précise bien que je parle de VISTA, qui a un comportement différent de XP
à ce niveau.

Quand tu as exporté/importé ton certificat de XP vers VISTA, as-tu bien
exporté la clef privée ?
(avec saisie de password)
Est-ce bien un certificat .PFX que tu as exporté, et non pas un .CER (qui
n'a pas de clef privée)?


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr

Publicité
Poster une réponse
Anonyme