Cette somme m'assomme

Le
garnote
Bonsoir,

Cette formule validée matriciellement sur trois
lignes adjacentes me renvoie trois valeurs numériques :
=RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0)
Mais la formule :
=SOMME(RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0))
validée matriciellement se contente de me retourner la
première valeur de la matrice. Pourquoi SOMME ne
fait-elle pas la somme, hein ?

Marci

Sarge
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4395471
salut serge,

pour la formule =RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0) si tu la valide en sélectionnent une seule cellule le résultat sera
également la première valeur de la matrice.

=SOMMEPROD((A1:A20Ò&E2)*(B1:B20))+SOMMEPROD((A1:A20Ó&E3)*(B1:B20))+SOMMEPROD((A1:A20Ô&E4)*(B1:B20))

isabelle

Bonsoir,

Cette formule validée matriciellement sur trois
lignes adjacentes me renvoie trois valeurs numériques :
=RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0)
Mais la formule :
=SOMME(RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0))
validée matriciellement se contente de me retourner la
première valeur de la matrice. Pourquoi SOMME ne
fait-elle pas la somme, hein ?

Marci

Sarge




dre
Le #4395421
Bonjour,

Je n'ai pas testé cette formule, mais ne fonctionnerait-elle pas :

=SOMMEPROD(((A1:A20Ò&E2)+(A1:A20Ó&E3)+(A1:A20Ô&E4))*(B1:B20))

Â+




salut serge,

pour la formule =RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0) si tu la valide en sélectionnent une seule cellule le résultat sera
également la première valeur de la matrice.

=SOMMEPROD((A1:A20Ò&E2)*(B1:B20))+SOMMEPROD((A1:A20Ó&E3)*(B1:B20))+SOMMEPROD((A1:A20Ô&E4)*(B1:B20))

isabelle

Bonsoir,

Cette formule validée matriciellement sur trois
lignes adjacentes me renvoie trois valeurs numériques :
=RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0)
Mais la formule :
=SOMME(RECHERCHEV(E2:E4&D2:D4;A2:B28;2;0))
validée matriciellement se contente de me retourner la
première valeur de la matrice. Pourquoi SOMME ne
fait-elle pas la somme, hein ?

Marci

Sarge







Publicité
Poster une réponse
Anonyme