Champs calculés

Le
TITUS
Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je voulais
faire un champs calculé avec

NOM PRENOM-INITIALE/INITIALE

Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]

et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur

Comment dois-je procéder ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Willi2004
Le #6230271
Salut TITUS.
Où ton champ calculé se trouve-t-il?
Dans une requête, un formulaire, un état?


"TITUS"
Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je voulais
faire un champs calculé avec

NOM PRENOM-INITIALE/INITIALE

Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]

et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur

Comment dois-je procéder ?



Tisane
Le #6230201
Bonjour à toi aussi "TITUS",

Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je voulais
faire un champs calculé avec
NOM PRENOM-INITIALE/INITIALE
Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]
et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur


Entre temps, il y a eu de nouvelles versions d'Access qui supportent mal que
l'on utilise des mots réservés.
Le mot "Nom" en fait partie.
Soit tu changes le nom du champ (NomFamille par exemple), soit tu ajoutes le
! devant, si ton champ est dans un état : ![Nom] etc.
soit tu indiques carrément le nom de la table [La_Table!Nom]

Cela dit, comme le demande Willi2004, il serait utile de préciser où est ton
champ calculé.
Si c'est dans une requête, tu devrais avoir quelque chose comme :
Expr1:[La_Table!Nom] etc.
Si c'est dans un contrôle de formulaire ou d'état, ta formule doit commencer
par
PS : je suppose que d'avoir 2 fois le même champ Initiale est voulu...

--
Tisane

TITUS
Le #6230151
Dans un état


Salut TITUS.
Où ton champ calculé se trouve-t-il?
Dans une requête, un formulaire, un état?


"TITUS"
Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je voulais
faire un champs calculé avec

NOM PRENOM-INITIALE/INITIALE

Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]

et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur

Comment dois-je procéder ?








TITUS
Le #6230131
C'est dans un état et oui le fait de mettre 2 fois INITIALE est voulu


Bonjour à toi aussi "TITUS",

Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je voulais
faire un champs calculé avec
NOM PRENOM-INITIALE/INITIALE
Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]
et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur


Entre temps, il y a eu de nouvelles versions d'Access qui supportent mal que
l'on utilise des mots réservés.
Le mot "Nom" en fait partie.
Soit tu changes le nom du champ (NomFamille par exemple), soit tu ajoutes le
! devant, si ton champ est dans un état : ![Nom] etc.
soit tu indiques carrément le nom de la table [La_Table!Nom]

Cela dit, comme le demande Willi2004, il serait utile de préciser où est ton
champ calculé.
Si c'est dans une requête, tu devrais avoir quelque chose comme :
Expr1:[La_Table!Nom] etc.
Si c'est dans un contrôle de formulaire ou d'état, ta formule doit commencer
par >
PS : je suppose que d'avoir 2 fois le même champ Initiale est voulu...

--
Tisane





Tisane
Le #6230121
C'est dans un état et oui le fait de mettre 2 fois INITIALE est voulu


As-tu essayé ce que je t'ai suggéré ?

--
Tisane

Bonjour à toi aussi "TITUS",

Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je
voulais
faire un champs calculé avec
NOM PRENOM-INITIALE/INITIALE
Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]
et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur


Entre temps, il y a eu de nouvelles versions d'Access qui supportent mal
que
l'on utilise des mots réservés.
Le mot "Nom" en fait partie.
Soit tu changes le nom du champ (NomFamille par exemple), soit tu ajoutes
le
! devant, si ton champ est dans un état : ![Nom] etc.
soit tu indiques carrément le nom de la table [La_Table!Nom]

Cela dit, comme le demande Willi2004, il serait utile de préciser où est
ton
champ calculé.
Si c'est dans une requête, tu devrais avoir quelque chose comme :
Expr1:[La_Table!Nom] etc.
Si c'est dans un contrôle de formulaire ou d'état, ta formule doit
commencer
par >>
PS : je suppose que d'avoir 2 fois le même champ Initiale est voulu...

--
Tisane





TITUS
Le #6230111
Non je n'ai pas encore eu le temps.
Dès que je l'ai fait je te dis


C'est dans un état et oui le fait de mettre 2 fois INITIALE est voulu


As-tu essayé ce que je t'ai suggéré ?

--
Tisane

Bonjour à toi aussi "TITUS",

Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je
voulais
faire un champs calculé avec
NOM PRENOM-INITIALE/INITIALE
Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]
et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur


Entre temps, il y a eu de nouvelles versions d'Access qui supportent mal
que
l'on utilise des mots réservés.
Le mot "Nom" en fait partie.
Soit tu changes le nom du champ (NomFamille par exemple), soit tu ajoutes
le
! devant, si ton champ est dans un état : ![Nom] etc.
soit tu indiques carrément le nom de la table [La_Table!Nom]

Cela dit, comme le demande Willi2004, il serait utile de préciser où est
ton
champ calculé.
Si c'est dans une requête, tu devrais avoir quelque chose comme :
Expr1:[La_Table!Nom] etc.
Si c'est dans un contrôle de formulaire ou d'état, ta formule doit
commencer
par > >>
PS : je suppose que d'avoir 2 fois le même champ Initiale est voulu...

--
Tisane









TITUS
Le #6230071
Dans mon état j'ai fait un autre champs calculé qui est le suivant (l'autre,
j'ai laissé tombé) :
=![N° Complet] & "/" & ![Rédacteur] & "/" & ![Frappé par]

Quant je veux visualiser l'état la base plante et demande d'envoyer un
rapport à Microsoft.
Quant je reviens sur la modifcation de l'état après réouverture de la base
la formule à changée comme suit /
=![N° Complet] & "/" & !Rédacteur & "/" & ![Frappé par]

Rédacteur n'est plus entre crochet.

Que dois-je faire !



C'est dans un état et oui le fait de mettre 2 fois INITIALE est voulu


As-tu essayé ce que je t'ai suggéré ?

--
Tisane

Bonjour à toi aussi "TITUS",

Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je
voulais
faire un champs calculé avec
NOM PRENOM-INITIALE/INITIALE
Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]
et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur


Entre temps, il y a eu de nouvelles versions d'Access qui supportent mal
que
l'on utilise des mots réservés.
Le mot "Nom" en fait partie.
Soit tu changes le nom du champ (NomFamille par exemple), soit tu ajoutes
le
! devant, si ton champ est dans un état : ![Nom] etc.
soit tu indiques carrément le nom de la table [La_Table!Nom]

Cela dit, comme le demande Willi2004, il serait utile de préciser où est
ton
champ calculé.
Si c'est dans une requête, tu devrais avoir quelque chose comme :
Expr1:[La_Table!Nom] etc.
Si c'est dans un contrôle de formulaire ou d'état, ta formule doit
commencer
par > >>
PS : je suppose que d'avoir 2 fois le même champ Initiale est voulu...

--
Tisane









Tisane
Le #6230041
Dans mon état j'ai fait un autre champs calculé qui est le suivant
(l'autre,
j'ai laissé tombé) :
=![N° Complet] & "/" & ![Rédacteur] & "/" & ![Frappé par]
Quant je veux visualiser l'état la base plante et demande d'envoyer un
rapport à Microsoft.
Quant je reviens sur la modifcation de l'état après réouverture de la base
la formule à changée comme suit /
=![N° Complet] & "/" & !Rédacteur & "/" & ![Frappé par]
Rédacteur n'est plus entre crochet.


Que les crochets disparaissent n'est pas grave : le nom du champ n'a pas
d'espace.
Le "!" n'est pas obligatoire. Il ne vaut que si tu utilises un mot réservé
(comme "Nom" donc).
Chez toi, manifestement le problème est ailleurs.

Essayons les 2 manipulations suivantes :
- menu Outils | Utilitaires de bases de données | Compacter
Si cela ne suffit pas :
- dans la fenêtre de l'éditeur VB (<Alt><F11>),
- menu Outils | Références,
- désactive celle qui est notée "Manquante".

--
Tisane


Bonjour à toi aussi "TITUS",

Il y a plus de 4 ans que je n'ai pas fais ça, mais avant quand je
voulais
faire un champs calculé avec
NOM PRENOM-INITIALE/INITIALE
Je tapais [NOM]&" "&[PRENOM]&"-"&[INITIALE]&"/"&[INITIALE]
et j'avais bien ce que je voulais.
Aujourd'hui j'obtiens #Erreur


Entre temps, il y a eu de nouvelles versions d'Access qui supportent
mal
que
l'on utilise des mots réservés.
Le mot "Nom" en fait partie.
Soit tu changes le nom du champ (NomFamille par exemple), soit tu
ajoutes
le
! devant, si ton champ est dans un état : ![Nom] etc.
soit tu indiques carrément le nom de la table [La_Table!Nom]

Cela dit, comme le demande Willi2004, il serait utile de préciser où
est
ton
champ calculé.
Si c'est dans une requête, tu devrais avoir quelque chose comme :
Expr1:[La_Table!Nom] etc.
Si c'est dans un contrôle de formulaire ou d'état, ta formule doit
commencer
par >> >>
PS : je suppose que d'avoir 2 fois le même champ Initiale est voulu...

--
Tisane









Publicité
Poster une réponse
Anonyme