charge machine > 1

Le
Hugolino
[x-post : fcolc + fcsp ; fu2 : fcolc ]

Yo !!

Un portable (MSI-1681E) tout nouveau tout beau avec 4GB de ram et un proc
i5-460M sur lequel je viens d'installer une arch linux 2010.05 sous KDE
4.6.1.

(Arch est une distro 'rolling release' et elle est à jour avec par
exemple un noyau 2.6.37 du 25/03/2011)

La charge machine ne descend jamais en dessous de 100%, exemple:
$ top -bn 1 | head -n 15
8<--8<8<-8<-8<-8<-8<
top - 14:55:30 up 12:12, 2 users, load average: 1.03, 1.06, 1.11
Tasks: 165 total, 1 running, 164 sleeping, 0 stopped, 0 zombie
Cpu(s): 9.1%us, 2.2%sy, 0.3%ni, 87.2%id, 1.1%wa, 0.0%hi, 0.1%si,0.0%st
Mem: 3841052k total, 3745220k used, 95832k free, 227992k buffers
Swap: 4883724k total, 0k used, 4883724k free, 2543824k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
2994 root 20 0 291m 51m 10m S 10 1.4 11:32.62 Xorg
3299 hugo 20 0 873m 67m 32m S 8 1.8 8:02.40 plasma-desktop
3420 hugo 20 0 855m 226m 35m S 8 6.1 2:16.19 konqueror
3289 hugo 20 0 576m 47m 32m S 6 1.3 5:21.79 kwin
3306 hugo 20 0 8972 1076 740 S 4 0.0 1:03.57 ksysguardd
3344 hugo 20 0 210m 12m 9928 S 2 0.3 0:47.71 gkrellm
6565 hugo 20 0 10784 1164 840 R 2 0.0 0:00.01 top
1 root 20 0 3916 632 540 S 0 0.0 0:01.33 init
8<--8<8<-8<-8<-8<-8<

Par comparaison, la même commande sur une debian/lenny installé sur un
PC à base de Celeron@2700MHz datant de 2005 raconte:
8<--8<8<-8<-8<-8<-8<
top - 14:56:37 up 18 days, 10:17, 3 users, load average: 0.12, 0.30, 0.37
Tasks: 179 total, 2 running, 177 sleeping, 0 stopped, 0 zombie
Cpu(s): 16.5%us, 3.5%sy, 2.2%ni, 75.7%id, 1.7%wa, 0.2%hi, 0.2%si, 0.0%st
Mem: 775936k total, 727712k used, 48224k free, 14712k buffers
Swap: 1052216k total, 182304k used, 869912k free, 139892k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
26709 hans 20 0 413m 280m 19m R 13.5 37.0 78:48.11 firefox-bin
1658 hugo 20 0 2420 1100 800 R 3.9 0.1 0:00.02 top
23060 www-data 20 0 25468 6176 2488 S 3.9 0.8 0:01.04 apache2
1 root 20 0 2016 576 552 S 0.0 0.1 0:18.24 init
2 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/0
4 root 15 -5 0 0 0 S 0.0 0.0 2:31.92 ksoftirqd/0
5 root RT -5 0 0 0 S 0.0 0.0 0:05.36 watchdog/0
8<--8<8<-8<-8<-8<-8<

J'ai soupçonné la carte wifi (une Ralink 3090 que je galère à faire
fonctionner) de mettre le bronx dans le bus, mais même quand je la
désactive avec une combinaison de touches (via le BIOS donc) ou avec
rfkill, la charge ne descend jamais en dessous de 100%.

Quelles commandes/quels fichiers de log faut-il exécuter/examimer pour
déterminer ce qui charge la machine comme ça ?

Ça ne rend pas ce PC inutilisable puisque le calcul de la charge est
fait en prenant en compte les quatre (pseudos) processeurs, mais je me
dis que ça relève soit d'un problème hard, soit d'une mauvaise
configuration d'un daemon.


Merci de votre aide.


--
> je voudrais pirater la fac ou je suis qui est sur réseau sur linux!
echo "rpub "w'nv yr cnffjbeq ebbg!"|znvy ebbg" |tr a-mn-z n-za-m|/bin/sh
Hugo (né il y a 1 480 772 665 secondes)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Damien Wyart
Le #23239861
* Hugolino
La charge machine ne descend jamais en dessous de 100%, exemple:
$ top -bn 1 | head -n 15
8<-----------8<---------8<----------8<----------8<----------8<----------8<
top - 14:55:30 up 12:12, 2 users, load average: 1.03, 1.06, 1.11



Ca me fait penser à un bug corrigé par ce patch :
https://lkml.org/lkml/2010/12/8/330

mais normalement c'est inclus dans 2.6.37.

Peux-tu tester avec d'autres noyaux (plus récents ou plus anciens) pour
voir si ça vient de là ? Peux-tu booter avec nohz=off pour voir si le
problème persiste ?

--
DW
Hugolino
Le #23240071
Le 28-03-2011, Damien Wyart
* Hugolino > La charge machine ne descend jamais en dessous de 100%, exemple:
> $ top -bn 1 | head -n 15
> 8<-----------8<---------8<----------8<----------8<----------8<----------8<
> top - 14:55:30 up 12:12, 2 users, load average: 1.03, 1.06, 1.11

Ca me fait penser à un bug corrigé par ce patch :
https://lkml.org/lkml/2010/12/8/330

mais normalement c'est inclus dans 2.6.37.

Peux-tu tester avec d'autres noyaux (plus récents ou plus anciens) pour
voir si ça vient de là ?



Ouh là...
Je préfère attendre d'avoir pris en main correctement cette distrib'
avant de me lancer dans le bizarre...

Peux-tu booter avec nohz=off pour voir si le problème persiste ?



Fait. Ça ne change rien au niveau de la charge qui reste toujours
supérieure à 1, j'ai même eu l'impression qu'elle était plus élevée
(jusqu'à 5.3) au moment du démarrage...

Mais je persiste à croire que cela vient de ma carte wifi et son driver
moisi. C'est pour ça que je cherchais des outils d'investigation...

Je vais voir comment augmenter la verbosité de syslog.


--
This god is a geek who wears socks with his sandals. His name
is Linus Torvalds. (From 'Time')
Hugo (né il y a 1 480 772 988 secondes)
Benoit Izac
Le #23240671
Bonjour,

le 28/03/2011 à 15:10, Hugolino message
Un portable (MSI-1681E) tout nouveau tout beau avec 4GB de ram et un proc
i5-460M sur lequel je viens d'installer une arch linux 2010.05 sous KDE
4.6.1.

(Arch est une distro 'rolling release' et elle est à jour avec par
exemple un noyau 2.6.37 du 25/03/2011)

La charge machine ne descend jamais en dessous de 100%, exemple:
$ top -bn 1 | head -n 15
8<-----------8<---------8<----------8<----------8<----------8<----------8<
top - 14:55:30 up 12:12, 2 users, load average: 1.03, 1.06, 1.11

J'ai soupçonné la carte wifi (une Ralink 3090 que je galère à faire
fonctionner) de mettre le bronx dans le bus, mais même quand je la
désactive avec une combinaison de touches (via le BIOS donc) ou avec
rfkill, la charge ne descend jamais en dessous de 100%.

Quelles commandes/quels fichiers de log faut-il exécuter/examimer pour
déterminer ce qui charge la machine comme ça ?

Ça ne rend pas ce PC inutilisable puisque le calcul de la charge est
fait en prenant en compte les quatre (pseudos) processeurs, mais je me
dis que ça relève soit d'un problème hard, soit d'une mauvaise
configuration d'un daemon.



J'ai aussi le cas sur le portable du boulot lorsque je boot dessus avec
mon disque dur USB qui contient ArchLinux. Je ne sais pas si c'est du
à la machine ou au fait que je sois en USB mais j'ai la même chose :
% uptime
19:51:16 up 25 min, 0 users, load average: 1.00, 1.06, 1.09

Après, ça ne change pas grand chose : ni la mémoire ni le cpu ne sont
affectés, et aucune différence avec une charge à 0. Faudrait que je
mette mon disque sur mon portable qui a archlinux sur le disque interne
pour voir si ça vient de la machine (pas possible avant ce week-end).

--
Benoit Izac
Éric Jacoboni
Le #23240821
Le 28/03/2011 15:10, Hugolino a écrit :

J'ai soupçonné la carte wifi (une Ralink 3090 que je galère à faire
fonctionner)



Paraitrait que le module rt2860sta des noyaux récents la gère.

Avec Arch Linux, certains suggèrent de blacklister aussi les modules
rt2800pci, rt2x00pci, rt2800lib, rt2x00usb, rt2x00lib.

Après, un coup de wicd et roulez jeunesse.

Bon, après, j'ai pas testé car ma carte wifi est une Intel...
Hugolino
Le #23241571
Le 28-03-2011, Éric Jacoboni
Le 28/03/2011 15:10, Hugolino a écrit :

> J'ai soupçonné la carte wifi (une Ralink 3090 que je galère à faire
> fonctionner)

Paraitrait que le module rt2860sta des noyaux récents la gère.



Oui... il paraît.

Avec Arch Linux, certains suggèrent de blacklister aussi les modules
rt2800pci, rt2x00pci, rt2800lib, rt2x00usb, rt2x00lib.



C'est ce que j'ai fait.

Après, un coup de wicd et roulez jeunesse.



J'arrive à me connecter à mon AP (une Freebox v5) mais quand je lance le
téléchargement d'un fichier de 10 Mo à travers mon LAN, le transfert
débute à 800 ko/s puis chute quasi-instantanément à 100 ko/s puis se
termine (en plus de 10 minutes) à 20 ko/s.

De plus /proc/net/dev/ raconte que la carte reçoit en permanence de 10 à
30 ko/s même quand je ne télécharge rien.

Et même sous Windows® Seven®, j'ai parfois des déconnexions.

J'ai essayé de recompiler à partir des sources téléchargées depuis
ralinktech.com: j'ai une erreur qu'il faut que j'investigue.

Bon, après, j'ai pas testé car ma carte wifi est une Intel...



Et ta moto est une Harley... Heureux homme ;-))

--
Tout le monde croit que le café empêche de dormir... c'est l'inverse !!
Hugo (né il y a 1 480 795 851 secondes)
Doug713705
Le #23244011
Le 29-03-2011, Hugolino nous expliquait dans
fr.comp.os.linux.configuration :

De plus /proc/net/dev/ raconte que la carte reçoit en permanence de 10 à
30 ko/s même quand je ne télécharge rien.

Et même sous Windows® Seven®, j'ai parfois des déconnexions.

J'ai essayé de recompiler à partir des sources téléchargées depuis
ralinktech.com: j'ai une erreur qu'il faut que j'investigue.



Je n'ai jamais réussi à obtenir une connexion stable (quand j'arrivais à
me connecter !) avec les drivers ralink pour Linux, y compris avec les
dernières verisons à jours (ma dernière tentative doit dater de 6 mois
avec un eeepc équipé d'une puce rt2860).

Par expérience, je peux dire que ndisrapper fait _beaucoup_ mieux.
C'est moche, mais c'est efficace.

--
@+ Doug - Linux user #307925 - Slackware64 roulaize ;-)
http://usenet-fr.dougwise.org
http://newsportal.dougwise.org/
http://news.dougwise.org
Hugolino
Le #23246991
Le 29-03-2011, Doug713705
Le 29-03-2011, Hugolino nous expliquait dans
fr.comp.os.linux.configuration :

> De plus /proc/net/dev/ raconte que la carte reçoit en permanence de 10 à
> 30 ko/s même quand je ne télécharge rien.
>
> Et même sous Windows® Seven®, j'ai parfois des déconnexions.
>
> J'ai essayé de recompiler à partir des sources téléchargées depuis
> ralinktech.com: j'ai une erreur qu'il faut que j'investigue.

Je n'ai jamais réussi à obtenir une connexion stable (quand j'arrivais à
me connecter !) avec les drivers ralink pour Linux, y compris avec les
dernières verisons à jours (ma dernière tentative doit dater de 6 mois
avec un eeepc équipé d'une puce rt2860).



J'arrive à avoir une connection, mais le ping vers mon routeur peut
monter à 5 secondes (oui, 5000 ms !!).
Il faudrait sans doute que j'arrive à recompiler le driver pour x64,
mais j'ai une erreur que je ne comprends pas...

Par expérience, je peux dire que ndisrapper fait _beaucoup_ mieux.
C'est moche, mais c'est efficace.



Kernel panic - not syncing : Fatal exception in interrupt...

Je vais continuer à bidouiller et si ça va pas, j'irais voir mon
revendeur s'il peut monter une autre carte dans ce portable...


--
la plupart des automobilistes n'ont aucune idée de comment fonctionne
une moto


Si : trop vite, et en faisant trop de bruit.
Hugo (né il y a 1 480 975 638 secondes)
Doug713705
Le #23247091
Le 30-03-2011, Hugolino nous expliquait dans
fr.comp.os.linux.configuration :


Par expérience, je peux dire que ndisrapper fait _beaucoup_ mieux.
C'est moche, mais c'est efficace.



Kernel panic - not syncing : Fatal exception in interrupt...



Pour être honnête, je n'ai jamais réussi à fire fonctionner ndsiswrapper
en 64 bits.

Je vais continuer à bidouiller et si ça va pas, j'irais voir mon
revendeur s'il peut monter une autre carte dans ce portable...



Fuir raLink me semble être une bonne idée.

--
@+ Doug - Linux user #307925 - Slackware64 roulaize ;-)
http://usenet-fr.dougwise.org
http://newsportal.dougwise.org/
http://news.dougwise.org
Hugolino
Le #23247121
Le 30-03-2011, Doug713705
Le 30-03-2011, Hugolino nous expliquait dans

>> Par expérience, je peux dire que ndisrapper fait _beaucoup_ mieux.
>> C'est moche, mais c'est efficace.
>
> Kernel panic - not syncing : Fatal exception in interrupt...

Pour être honnête, je n'ai jamais réussi à fire fonctionner ndsiswrapper
en 64 bits.



Je vais voir si en recompilant ndiswrapper...

> Je vais continuer à bidouiller et si ça va pas, j'irais voir mon
> revendeur s'il peut monter une autre carte dans ce portable...

Fuir raLink me semble être une bonne idée.



Oui. J'ai acheté ce portable en urgence, sans prendre le temps de
vérifier ce point de détail.


--
Quant à Linux [..] trés bon système d'exploitation, mais difficile
à implanter en entreprise, pour des raisons non techniques.


Dont celle-ci : Le singe préfère la voiture rouge.
Hugo (né il y a 1 480 977 113 secondes)
Fabien LE LEZ
Le #23247181
On Thu, 31 Mar 2011 01:57:31 +0200, Hugolino
J'ai acheté ce portable en urgence



Tu peux toujours rajouter une carte wifi qui fonctionne :
http://www.clubic.com/comparer-prix/carte-wifi/pc-card-pcmcia,1368-111736/
Publicité
Poster une réponse
Anonyme