Chargement de module au démarrage

Le
Alexandre
Bonjour,

j'ai la carte:

#lspci | grep -i wireless
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG
Network Connection (rev 02)

et pour qu'elle fonctionne à merveille, je dois lancer en root:
# rmmod iwl3945; modprobe iwl3945 disable_hw_scan=1 ; ifconfig wlan0 up

je me demande comment automatiser cela au démarrage de la manière la
propre (orthodoxe) possible.

On m'a conseillé un script initrd (si oui, vous auriez un exemple? pour
que j'évite de mettre un peu trop de désordre?)

Qu'en pensez-vous?

Je vous remercie de vos conseils.
--
()()()-()()()-()()()--)()()(-)()()(-)()()(
-()-()--()-()--()-()--)(-)(--)(-)(--)(-)(-
()-()-()()()-()()()-)()()(-)()()(-)(-)(

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #11194641
Alexandre a écrit :
Bonjour,

j'ai la carte:

#lspci | grep -i wireless
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG
Network Connection (rev 02)

et pour qu'elle fonctionne à merveille, je dois lancer en root:
# rmmod iwl3945; modprobe iwl3945 disable_hw_scan=1 ; ifconfig wlan0 up

je me demande comment automatiser cela au démarrage de la manière la
propre (orthodoxe) possible.

On m'a conseillé un script initrd (si oui, vous auriez un exemple? pour
que j'évite de mettre un peu trop de désordre?)



c'est une rustine, mais ça aide (même PB avec une carte TV HVR-1300)

donc, dans /usr/local/sbin/WIFI, tu peux mettre:
#!/bin/sh
/sbin/rmmod iwl3945
/sbin/modprobe iwl3945 disable_hw_scan=1
/sbin/ifconfig wlan0 up

puis ajouter, dans /etc/rc.local la ligne suivante:
/usr/local/sbin/WIFI

en rendant, bien sur WIFI exécutable (chmod +x /usr/local/sbin/WIFI)

JY
--
Girls who throw themselves at men, are actually taking very careful aim.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Nicolas Salles
Le #11194991
--=-ZP3bh55Wli+a88MEqNsB
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable

Le samedi 05 juillet 2008 à 13:40 +0200, Alexandre a écrit :
et pour qu'elle fonctionne à merveille, je dois lancer en root:
# rmmod iwl3945; modprobe iwl3945 disable_hw_scan=1 ; ifconfig wlan0 up

je me demande comment automatiser cela au démarrage de la maniè re la
propre (orthodoxe) possible.



Tu ajoutes une ligne dans /etc/modules de la sorte :
iwl3945 disable_hw_scan=1

Lors du premier chargement du module celui-ci sera normalement chargé
avec l'option qui t'est nécessaire.
--
Nicolas

--=-ZP3bh55Wli+a88MEqNsB
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBIb2VJW8l1zlkz8uURAstnAJ0eBi1RnEHb2WlgcomZcs2i1EgGdwCePWfz
M+cfmAX1DXZqPaEZsZFdNMM =OsEO
-----END PGP SIGNATURE-----

--=-ZP3bh55Wli+a88MEqNsB--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Alexandre
Le #11198271
Bonjour,

je vous remercie de vos réponses mais aucune des deux ne fonctionne et
cela me questionne... voici plus de précisions:

Je reprécise mon problème qui n'est pas lié à un pb de configuration
wifi mais à un chargement de module avec la bonne option.

Après chaque boot, j'ai:

e# lsmod | grep iwl
iwl3945 84712 0
firmware_class 9312 2 pcmcia,iwl3945
mac80211 114380 1 iwl3945


mais je n'arrive pas à me connecter à ma borne wifi malgré un fichier /etc/network/interfaces
qui me permet de me connecter via ethernet habituellement avec mon
ancien ordi.

Ensuite, je lance la commande suivante
# rmmod iwl3945; modprobe iwl3945 disable_hw_scan=1 ; ifconfig wlan0 up

je lance /etc/init.d/networking restart
et j'arrive à me connecter. Donc je souhaite automatiser la commande du
chargement du module à chaque boot.

deux propositions, voici mes précisions:

Le samedi 05 juillet de l'année 2008, vers 14 heures et 02 minutes, Jean-Yves F. Barbier écrivait:
Alexandre a écrit :
> [...]

c'est une rustine, mais ça aide (même PB avec une carte TV HVR-1300)

donc, dans /usr/local/sbin/WIFI, tu peux mettre:
#!/bin/sh
/sbin/rmmod iwl3945
/sbin/modprobe iwl3945 disable_hw_scan=1
/sbin/ifconfig wlan0 up

puis ajouter, dans /etc/rc.local la ligne suivante:
/usr/local/sbin/WIFI

en rendant, bien sur WIFI exécutable (chmod +x /usr/local/sbin/WIFI)





J'ai essayé mais le script part après la tentative de connexion.

un iwconfig donne une carte présente mais sans configuration de mon
réseau dans /etc/network/interfaces

Ensuite, si je lance la commande:
# rmmod iwl3945; modprobe iwl3945 disable_hw_scan=1 ; ifconfig wlan0 up

wlan0 reste "down".

Donc obligé de rebooter (il doit y avoir une autre commande plus
propre) pour retenter l'expérience.

Le samedi 05 juillet de l'année 2008, vers 14 heures et 12 minutes, Nicolas Salles écrivait:
Le samedi 05 juillet 2008 à 13:40 +0200, Alexandre a écrit :
> et pour qu'elle fonctionne à merveille, je dois lancer en root:
> # rmmod iwl3945; modprobe iwl3945 disable_hw_scan=1 ; ifconfig wlan0 up
>
> je me demande comment automatiser cela au démarrage de la manière la
> propre (orthodoxe) possible.

Tu ajoutes une ligne dans /etc/modules de la sorte :
iwl3945 disable_hw_scan=1

Lors du premier chargement du module celui-ci sera normalement chargé
avec l'option qui t'est nécessaire.



Je n'arrive pas à me connecter, même si les paramètres de
/etc/network/interfaces sont bien pris en compte.

Si je lance la commande:

# rmmod iwl3945; modprobe iwl3945 disable_hw_scan=1 ; ifconfig wlan0 up

un iwlist scan donne:
wlan0 Interface doesn't support scanning : Network is down


Pourtant lors des deux solution précédentes, après plusieurs passage de
la commande, je lance
# /etc/init.d/networking restart
Reconfiguring network interfaces...SIOCDELRT: No such process
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:1f:3c:1c:77:18
Sending on LPF/wlan0/00:1f:3c:1c:77:18
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.0.254 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:1f:3c:1c:77:18
Sending on LPF/wlan0/00:1f:3c:1c:77:18
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
^[ DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
done.

ensuite, un iwconfig montre que les paramètre /etc/network/interfaces
sont bien pris en compte.

Donc pour résumer, la première solution charge les modules trop tard, la
seconde ne semble pas prendre en compte un rmmod iwl3945. Si sans rien
faire, je trouve les modules dans lsmod, par quel intermédiaire sont-il
chargés? Est-il possible de désactiver le chargement automatique du
module? un blacklist?

donc j'ai blacklisté le module pour le charger grâce à /etc/modules
echo "blacklist iwl3945" >> /etc/modprobe.d/blacklist

je reboote pour voir (je précise que mon fichier /etc/network/interfaces
et bien configuré)

et wlan0 n'est pas up, un lsmod | grep iwl3945 ne donne rien...

je refais l'étape du début: rmmod iwl...

et j'arrive à me connecter...

Je vous avoue ne pas vraiment comprendre ce qu'il se passe vraiment sous
mes doigts... (c'est un portable).

Merci de votre aide.
--
---()()()----()()()----()()()--)()()(----)()()(----)()()(---
-()----()--()-()-----()----()--)(----)(-----)(-)(--)(----)(-
()----()----()()()----()()()----)()()(----)()()(----)(----)(

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Alexandre
Le #11198261
Une précision:

Le dimanche 06 juillet de l'année 2008, vers 02 heures et 33 minutes, Alexandre Delanoë écrivait:
mais je n'arrive pas à me connecter à ma borne wifi malgré un fichier /etc/network/interfaces
qui me permet de me connecter via ethernet habituellement avec mon
ancien ordi.



fichier interfaces qui permet de se connecter via ethernet _et_ wifi (je
précise bien que le pb me semble bien être celui du module car j'arrive
à me connecter)

--
---()()()----()()()----()()()--)()()(----)()()(----)()()(---
-()----()--()-()-----()----()--)(----)(-----)(-)(--)(----)(-
()----()----()()()----()()()----)()()(----)()()(----)(----)(

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Alexandre
Le #11207701
Si je fais en root:

# echo -e 'alias wlan0 iwl3945 noptions iwl3945 disable_hw_scan=1' > /etc/modprobe.d/iwl3945

je reboote, un iwconfig montre que les paramètres de
/etc/network/interfaces ont été pris en compte et un iwlist scan
fonctionne.

Cependant, la connexion dhcp ne fonctionne pas;
pour que cela fonctionne à nouveau, un
/etc/init.d/networking restart ne suffit pas.

il faut un
/etc/init.d/networking stop
puis:
/sbin/rmmod iwl3945
/sbin/modprobe iwl3945 disable_hw_scan=1
/sbin/ifconfig wlan0 up

puis /etc/init.d/networking start
et cela fonctionne.

Donc ce n'est plus vraiment un pb de chargement de module ?

merci de vos lumières.

--
---()()()----()()()----()()()--)()()(----)()()(----)()()(---
-()----()--()-()-----()----()--)(----)(-----)(-)(--)(----)(-
()----()----()()()----()()()----)()()(----)()()(----)(----)(

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Leopold BAILLY
Le #11387881
Alexandre
Si je fais en root:

# echo -e 'alias wlan0 iwl3945 noptions iwl3945 disable_hw_scan=1' > /etc/modprobe.d/iwl3945



Oui, c'est bonne façon de faire pour passer des paramètres aux
modules.

je reboote, un iwconfig montre que les paramètres de
/etc/network/interfaces ont été pris en compte et un iwlist scan
fonctionne.

Cependant, la connexion dhcp ne fonctionne pas;
pour que cela fonctionne à nouveau, un
/etc/init.d/networking restart ne suffit pas.

il faut un
/etc/init.d/networking stop
puis:
/sbin/rmmod iwl3945
/sbin/modprobe iwl3945 disable_hw_scan=1



Ici, tu n'as plus besoin de préciser l'option puisqu'elle est dans
modprobe.d.

/sbin/ifconfig wlan0 up

puis /etc/init.d/networking start
et cela fonctionne.

Donc ce n'est plus vraiment un pb de chargement de module ?



Je dirais que c'est un problème d'ordre de chargement. Il semble que
ton module nécessite d'être chargé après un autre, qu'il va falloir
découvrir (le pilote de ta carte éthernet ?).

Pour imposer que mod1 se charge avant mod2, la seule méthode que je
connaisse est de rajouter une autre directive dans modprobe.d :

install mod2 /sbin/modprobe mod1 && /sbin/modprobe --ignore-install mod2

--
Léo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme