Chercher avec le jocker "*"

Le
Apitos
Bonsoir à tous,

J'ai cette formule :

=SOMMEPROD((A1:A27="*Ch*")*E2:E28)

Je dis à Excel de chercher tous les cellules qui contiennent la sous-
chaine "Ch" et faire le calcul correspondant des valeurs dans la
colonne E.

Mais ca ne marche pas !!!!

Pourquoi ?

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #16548011
Bonsoir.
Formule matricielle (valider avec CTRL+Maj+Entrée) :
=SOMME(SI(ESTERR((CHERCHE("Ch";A1:A27)>0));0;1)*E2:E28)
Formule insensible à la casse (C = c).
Cordialement.
Daniel
"Apitos"
Bonsoir à tous,

J'ai cette formule :

=SOMMEPROD((A1:A27="*Ch*")*E2:E28)

Je dis à Excel de chercher tous les cellules qui contiennent la sous-
chaine "Ch" et faire le calcul correspondant des valeurs dans la
colonne E.

Mais ca ne marche pas !!!!

Pourquoi ?

Merci.
Apitos
Le #16552221
Bonjour Daniel,

Ca marche ta formule.


Egalement ça marche avec cette formule, que j'ai modifié, de Pierre
Fauconnier :


SOMMEPROD((NON(ESTERR(CHERCHE("*Ch*";A1:A50)))*E2:E51))

Merci :)
Publicité
Poster une réponse
Anonyme