Chercher info sur autre feuille

Le
Denys
Bonjour à tous,

Sur une feuille de travail 2, je dois, en colonne A aller chercher de
l'information sur la feuille 1 se trouvant dans les colonne A et B.
Comment faire pour que toute l'info ne se retrouve que sur la colonne
A de la seconde feuille, l'une à la suite de l'autre ?

Voici:
Colonne A Colonne B de la feuille 1
56544098 9326267
52217840 43674972
54789595 65475001
54314907 26561204
55694383 43784557
56611676
55965842

Colonne A de la feuille 2

56544098
52217840
54789595
54314907
55694383
56611676
55965842
9326267
43674972
65475001
26561204
43784557

La quantité d'information est variable. J'aimerais d'abord avoir
l'info de la colonne A de la feuille 1 et ensuite continuer avec
l'info de la colonne B immédiatement après celle de la colonne A..

Z'auriez une idée ?

Merci pour votre temps

Denys
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #20426921
Bonjour.
En A1 de la feuille 2, mets :
=SI(SI(Feuil1!A1<>"";Feuil1!A1;DECALER(Feuil1!B1;-7;0))=0;"";SI(Feuil1!A1<>"";Feuil1!A1;DECALER(Feuil1!B1;-7;0)))
et recopie vers le bas.
Cordialement.
Daniel

Bonjour à tous,

Sur une feuille de travail 2, je dois, en colonne A aller chercher de
l'information sur la feuille 1 se trouvant dans les colonne A et B.
Comment faire pour que toute l'info ne se retrouve que sur la colonne
A de la seconde feuille, l'une à la suite de l'autre ?

Voici:
Colonne A Colonne B de la feuille 1
56544098 9326267
52217840 43674972
54789595 65475001
54314907 26561204
55694383 43784557
56611676
55965842

Colonne A de la feuille 2

56544098
52217840
54789595
54314907
55694383
56611676
55965842
9326267
43674972
65475001
26561204
43784557

La quantité d'information est variable. J'aimerais d'abord avoir
l'info de la colonne A de la feuille 1 et ensuite continuer avec
l'info de la colonne B immédiatement après celle de la colonne A..

Z'auriez une idée ?

Merci pour votre temps

Denys


PolareBear
Le #20426911
Bonjour,

Il y a peut-être plus simple, mais la formuler suivante en A1 de ta
feuille 2, et recopiée vers le bas fonctionne :

=SI(LIGNE(A1)<=EQUIV("";Feuil1!A:A;-1);Feuil1!A1;DECALER(Feuil1!A1;-EQUIV("";Feuil1!A:A;-1);1))

Ca te convient ?

Bonne journée

Raimond


Denys a écrit :
Bonjour à tous,

Sur une feuille de travail 2, je dois, en colonne A aller chercher de
l'information sur la feuille 1 se trouvant dans les colonne A et B.
Comment faire pour que toute l'info ne se retrouve que sur la colonne
A de la seconde feuille, l'une à la suite de l'autre ?

Voici:
Colonne A Colonne B de la feuille 1
56544098 9326267
52217840 43674972
54789595 65475001
54314907 26561204
55694383 43784557
56611676
55965842

Colonne A de la feuille 2

56544098
52217840
54789595
54314907
55694383
56611676
55965842
9326267
43674972
65475001
26561204
43784557

La quantité d'information est variable. J'aimerais d'abord avoir
l'info de la colonne A de la feuille 1 et ensuite continuer avec
l'info de la colonne B immédiatement après celle de la colonne A..

Z'auriez une idée ?

Merci pour votre temps

Denys


Denys
Le #20427201
Bonjour Daniel et Raimond,

merci infiniment...

je vous reviens dans quelques minutes après lesa voir essayées...

Bonne journée

Denys
Denys
Le #20427441
re-bonjour,

Malheureusement, ça ne va pas chercher toute l'info....

565440989 525932711
543674972 566149019
565475001 884851387
526561204 45786373
543784557 563089150
565777182 547046607
884256413 56627761
884171950 566406096
565744588 526835350
527515480 566587564
527512867 551481252
540777240 559071261
49326267 540487352
522178409 885008672
547895953 48427033
543149074 558170429
556943835 553362880
566116760 880170584
559658422 563295427
551145857
551145931
607038817
557305695
526902614
305039042
566616082
306858606
527947824
803268895
555859156

Avec la formule, Excel ne me rapporte pas toutes données....seulement
37

565440989
543674972
565475001
526561204
543784557
565777182
884256413
884171950
565744588
527515480
527512867
540777240
49326267
522178409
547895953
543149074
556943835
566116760
559658422
540487352
885008672
48427033
558170429
553362880
880170584
563295427
551145857
551145931
607038817
557305695
526902614
305039042
566616082
306858606
527947824
803268895
555859156

Il y a un p'tit quelque chose qui manque....

Merci

Denys
Daniel.C
Le #20427591
Au temps pour moi :
=SI(SI(Feuil1!A1<>"";Feuil1!A1;DECALER(Feuil1!B1;-NBVAL(Feuil1!A:A);0))=0;"";SI(Feuil1!A1<>"";Feuil1!A1;DECALER(Feuil1!B1;-NBVAL(Feuil1!A:A);0)))
Daniel

re-bonjour,

Malheureusement, ça ne va pas chercher toute l'info....

565440989 525932711
543674972 566149019
565475001 884851387
526561204 45786373
543784557 563089150
565777182 547046607
884256413 56627761
884171950 566406096
565744588 526835350
527515480 566587564
527512867 551481252
540777240 559071261
49326267 540487352
522178409 885008672
547895953 48427033
543149074 558170429
556943835 553362880
566116760 880170584
559658422 563295427
551145857
551145931
607038817
557305695
526902614
305039042
566616082
306858606
527947824
803268895
555859156

Avec la formule, Excel ne me rapporte pas toutes données....seulement
37

565440989
543674972
565475001
526561204
543784557
565777182
884256413
884171950
565744588
527515480
527512867
540777240
49326267
522178409
547895953
543149074
556943835
566116760
559658422
540487352
885008672
48427033
558170429
553362880
880170584
563295427
551145857
551145931
607038817
557305695
526902614
305039042
566616082
306858606
527947824
803268895
555859156

Il y a un p'tit quelque chose qui manque....

Merci

Denys


Denys
Le #20427981
Salut Daniel,

C'est absolument parfait !!!!

merci infiniment...

Bonne journée

Denys


On 26 oct, 10:14, Daniel.C
Au temps pour moi :
=SI(SI(Feuil1!A1<>"";Feuil1!A1;DECALER(Feuil1!B1;-NBVAL(Feuil1!A:A);0)) =0;"­";SI(Feuil1!A1<>"";Feuil1!A1;DECALER(Feuil1!B1;-NBVAL(Feuil1!A:A); 0)))
Daniel


Publicité
Poster une réponse
Anonyme