Chercher et trouver

Le
Didier NOVARIN
Bonsoir,
J'ai dans un tableau Excel 2 colonnes K3:K et L3.:L
Je souhaite avoir une procédure qui "passe en revue" les valeurs des
cellules se trouvant de K3:K
et vérifie si elles ne se trouvent pas en L3:L si elle s'y trouve mettre
OK dans la cellule à droite.
Exemple : dans la cellule K4 = "alpha" si en L254="alpha" alors un OK ira en
M254 et ainsi de suite
Merci beaucoup
Didier
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Brunos
Le #5285531
J'ai dans un tableau Excel 2 colonnes K3:K... et L3.:L...
Je souhaite avoir une procédure qui "passe en revue" les valeurs des
cellules se trouvant de K3:K...
et vérifie si elles ne se trouvent pas en L3:L... si elle s'y trouve
mettre OK dans la cellule à droite.
Exemple : dans la cellule K4 = "alpha" si en L254="alpha" alors un OK
ira en M254 et ainsi de suite...


Bonsoir Didier,
Pour "passer en revue" RECHERCHEV doit fonctionner.
un truc comme ça (pas testé) :
=SI(ESTERREUR(RECHERCHEV(L254;K3:K2000;1;FAUX));"";"OK")
--
Brunos

JB
Le #5285521
Bonsoir,

En M3:
=SI(ESTNA(EQUIV(L3;$K$3:$K$23;0));"";"ok")

JB

On 30 jan, 19:33, "Didier NOVARIN" wrote:
Bonsoir,
J'ai dans un tableau Excel 2 colonnes K3:K... et  L3.:L...
Je souhaite avoir une procédure qui "passe en revue" les valeurs des
cellules se trouvant de K3:K...
et vérifie si elles ne se trouvent pas en L3:L... si elle s'y trouve met tre
OK dans la cellule à droite.
Exemple : dans la cellule K4 = "alpha" si en L254="alpha" alors un OK ira en
M254 et ainsi de suite...
Merci beaucoup
Didier


Jacky
Le #5285491
Bonsoir

Pas vraiment besoin de procedure.
En M3
=SI(NB.SI($K$3:$K$500;L3)=0;"";"OK")

ou avec une plage nommée
=SI(NB.SI(plage;L3)=0;"";"OK")

Et tirer vers le bas

--
Salutations
JJ


"Didier NOVARIN" de news:
Bonsoir,
J'ai dans un tableau Excel 2 colonnes K3:K... et L3.:L...
Je souhaite avoir une procédure qui "passe en revue" les valeurs des
cellules se trouvant de K3:K...
et vérifie si elles ne se trouvent pas en L3:L... si elle s'y trouve
mettre OK dans la cellule à droite.
Exemple : dans la cellule K4 = "alpha" si en L254="alpha" alors un OK ira
en M254 et ainsi de suite...
Merci beaucoup
Didier



ChrisV
Le #5285451
Bonjour Didier,

Avec la plage K3:Kxx nommée ici Zn
(à saisir en M3 sans les { } et valider par Ctrl+shift+Entrée)

{=SI(OU(L3=Zn);"Ok";"")}


ChrisV


"Didier NOVARIN" de news:
Bonsoir,
J'ai dans un tableau Excel 2 colonnes K3:K... et L3.:L...
Je souhaite avoir une procédure qui "passe en revue" les valeurs des
cellules se trouvant de K3:K...
et vérifie si elles ne se trouvent pas en L3:L... si elle s'y trouve
mettre OK dans la cellule à droite.
Exemple : dans la cellule K4 = "alpha" si en L254="alpha" alors un OK ira
en M254 et ainsi de suite...
Merci beaucoup
Didier



Jacky
Le #5285441
Un peu plus court.....

=SI(NB.SI($K$3:$K$500;L3);"OK";"")

--
Salutations
JJ


"Jacky"
Bonsoir

Pas vraiment besoin de procedure.
En M3
=SI(NB.SI($K$3:$K$500;L3)=0;"";"OK")

ou avec une plage nommée
=SI(NB.SI(plage;L3)=0;"";"OK")

Et tirer vers le bas

--
Salutations
JJ


"Didier NOVARIN" de news:
Bonsoir,
J'ai dans un tableau Excel 2 colonnes K3:K... et L3.:L...
Je souhaite avoir une procédure qui "passe en revue" les valeurs des
cellules se trouvant de K3:K...
et vérifie si elles ne se trouvent pas en L3:L... si elle s'y trouve
mettre OK dans la cellule à droite.
Exemple : dans la cellule K4 = "alpha" si en L254="alpha" alors un OK ira
en M254 et ainsi de suite...
Merci beaucoup
Didier







Didier NOVARIN
Le #5285391
Merci beaucoup à tous !
C'est exactement cela !
Bonne soirée
Didier

"ChrisV"
Bonjour Didier,

Avec la plage K3:Kxx nommée ici Zn
(à saisir en M3 sans les { } et valider par Ctrl+shift+Entrée)

{=SI(OU(L3=Zn);"Ok";"")}


ChrisV


"Didier NOVARIN" de news:
Bonsoir,
J'ai dans un tableau Excel 2 colonnes K3:K... et L3.:L...
Je souhaite avoir une procédure qui "passe en revue" les valeurs des
cellules se trouvant de K3:K...
et vérifie si elles ne se trouvent pas en L3:L... si elle s'y trouve
mettre OK dans la cellule à droite.
Exemple : dans la cellule K4 = "alpha" si en L254="alpha" alors un OK ira
en M254 et ainsi de suite...
Merci beaucoup
Didier







Publicité
Poster une réponse
Anonyme