choix d'un IDE

Le
fabrice
Bonsoir à tous

Je suis en train de réinstaller ma machine et je pose la question quel
est le meilleur IDE pour moi :-)
POur le moment je suis assez rustique. J'utilise une vieille application +
le SDK 1.1 pour la compilation.
Je maintiens une application sous le framework 1.1 et réalise une autre sous
le 2.0.

Puis je utiliser la dernière version de Visual studio express à savoir 2008
et developpez sous les deux versions sans "flinguer" mes projets.
Peux t il gérer les deux versions pour deux projets différents ?

Et concernant le SDK ? la version 2.0 permet de compiler pour le 1.1 ?

OU peut etre avez vous connaissance d'un autre IDE bien mieux ;-)

merci de votre aide
fabrice.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
PhilTheGap
Le #12156671
Salut Fabrice,
"fabrice" news:
Bonsoir à tous

Je suis en train de réinstaller ma machine... et je pose la question quel
est le meilleur IDE pour moi :-)
POur le moment je suis assez rustique. J'utilise une vieille application +
le SDK 1.1 pour la compilation.
Je maintiens une application sous le framework 1.1 et réalise une autre
sous le 2.0.

Puis je utiliser la dernière version de Visual studio express à savoir
2008 et developpez sous les deux versions sans "flinguer" mes projets.


Oui
Peux t il gérer les deux versions pour deux projets différents ?


Oui

Et concernant le SDK ? la version 2.0 permet de compiler pour le 1.1 ?



???
OU peut etre avez vous connaissance d'un autre IDE bien mieux ;-)


Non...
merci de votre aide
fabrice.


De rien...



Gilles TOURREAU [MVP]
Le #12156661
"fabrice" news:
Bonsoir à tous

Je suis en train de réinstaller ma machine... et je pose la question quel
est le meilleur IDE pour moi :-)
POur le moment je suis assez rustique. J'utilise une vieille application +
le SDK 1.1 pour la compilation.
Je maintiens une application sous le framework 1.1 et réalise une autre
sous le 2.0.

Puis je utiliser la dernière version de Visual studio express à savoir
2008 et developpez sous les deux versions sans "flinguer" mes projets.
Peux t il gérer les deux versions pour deux projets différents ?

Et concernant le SDK ? la version 2.0 permet de compiler pour le 1.1 ?

OU peut etre avez vous connaissance d'un autre IDE bien mieux ;-)

merci de votre aide
fabrice.





Bonjour,

Utiliser la version 2008, elle permet de générer des applications qui
utilisent le .NET 2.0, 3.0 et 3.5...
Migrer votre application 1.1 en 2.0 (il n'y a normalement rien à modifier).

Cordialement

--
Gilles TOURREAU - MVP C#


S.A.R.L. P.O.S
Le spécialiste en motoculture depuis + de 30 ans !
http://www.pos.fr
DEVUYST_Benjamin
Le #12156441
Gilles TOURREAU [MVP] a écrit :
"fabrice" news:
Bonsoir à tous

Je suis en train de réinstaller ma machine... et je pose la question
quel est le meilleur IDE pour moi :-)
POur le moment je suis assez rustique. J'utilise une vieille
application + le SDK 1.1 pour la compilation.
Je maintiens une application sous le framework 1.1 et réalise une
autre sous le 2.0.

Puis je utiliser la dernière version de Visual studio express à savoir
2008 et developpez sous les deux versions sans "flinguer" mes projets.
Peux t il gérer les deux versions pour deux projets différents ?

Et concernant le SDK ? la version 2.0 permet de compiler pour le 1.1 ?

OU peut etre avez vous connaissance d'un autre IDE bien mieux ;-)

merci de votre aide
fabrice.





Bonjour,

Utiliser la version 2008, elle permet de générer des applications qui
utilisent le .NET 2.0, 3.0 et 3.5...
Migrer votre application 1.1 en 2.0 (il n'y a normalement rien à modifier).




Cordialement




Attention Migrer une application Web du 1.1 au 2.0 peut poser de gros
problèmes (vécu) !!! par contre pour les application Windows et Dll no
soucy !

mais effectivement VS.NET est assez génial comme IDE !!!
Publicité
Poster une réponse
Anonyme