Des choses bizarres en lecture de JPG

Le
YouDontNeedToKnowButItsNoëlle
Une amie m'a passée un disque usb pour que je lui mette des photos en
jpg dessus, ce que j'ai fait depuis ma machine (Snow Leopard) juste
comme sur une clé. Dans plusieurs répertoires.
Une fois chez elle, branché sur sa machine à elle (Vista) on voit les
répertoires, on voit les photos jpg, mais sauf 4 elles refusent de
s'afficher avec les imagettes et encore moins en grand.
Son photoshop (plus récent que le mien) refuse d'ouvrir.
Je me confonds en excuses, persuadée d'avoir fait la copie de travers,
je remporte le disque chez moi, les images (rien que du jpg) sont là,
parfaitement visibles et ouvrablesJe jette un œil dans un autre
répertoire qui contient d'autres photos, en provenance de son disque à
elle, ça s'ouvre aussi. Elimination de l'hypothèse de formatage
spécifique du disque usb.
MAIS : quand je les rouvre (avec le photoshop qui les a engendrées grace
à un script), j'ai le message "ce fichier contient des informations
illisibles et a été ignoré".
C'est fort étrange car il s'ouvre dans photoshop quand même malgré cet
avertissement et est d'aspect parfaitement normal.
Qu'est ce qui peut bien faire qu'un fichier jpg produit par PS soit
ainsi moitié bancal et illisible dans une autre machine et un autre
système ? Et pis, fasse rouspéter le Ps qui l'a produit ?
J'ai utilisé la commande "enregistrer pour le web" qui attribue d'office
un profil sRVB dans le script donc je pense que ce n'est pas un souci de
profil.
Aperçu ne rechigne pas et me fait un diaporama parfaitement normal.
Capture NX ne se plaint de rien non plus. Acrobat affiche sans râler.
Firefox et Safari affichent sans erreur, comme à peu près tout ce que je
peux essayer capable d'afficher une image jpg.

Mais ça apparait comme cassé sous Vista.
La copie sur le disque usb n'est pas en cause, les originaux se
comportent pareil.

Je nage en plein brouillard.
Et il y a une grosse tripotée de ces photos, et je n'ai pas du tout le
goût de repartir de 0 dessus et mon amie en a besoin pour un dossier à
remettre très bientôt.

Merci de toute piste

Noëlle Adam
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Alf92
Le #25001482
"YouDontNeedToKnowButItsNoëlle"
(...)
Je nage en plein brouillard.
Et il y a une grosse tripotée de ces photos, et je n'ai pas du tout le goût de
repartir de 0 dessus et mon amie en a besoin pour un dossier à remettre très
bientôt.



pas d'explication mais une solution : tout réenregistrer avec un taux de
compression très légèrement inférieur (afin d'éviter la casse) avec un soft
comme XNView (pour mac biensur :-)
http://www.clubic.com/telecharger-fiche195132-xnview.html
René
Le #25001822
"YouDontNeedToKnowButItsNoëlle" a écrit dans le message de groupe de
discussion : k9609f$gei$

Une amie m'a passée un disque usb pour que je lui mette des photos en jpg
dessus, ce que j'ai fait depuis ma machine (Snow Leopard) juste comme sur
une clé. Dans plusieurs répertoires.



Un CD "universel" ne se fait pas en copiant les fichiers "comme sur une clef
USB", les formatages ne sont pas les mêmes. Il faut utiliser un logiciel
d'écriture approprié maintenant normalement inclus dans tout bon système
d'exploitation. Sinon en trouver un gratuit sur le Web.

René
markorki
Le #25001892
YouDontNeedToKnowButItsNoëlle a écrit :

Une amie m'a passée un disque usb pour que je lui mette des photos en
jpg dessus, ce que j'ai fait depuis ma machine (Snow Leopard) juste
comme sur une clé. Dans plusieurs répertoires.
Une fois chez elle, branché sur sa machine à elle (Vista) on voit les
répertoires, on voit les photos jpg, mais sauf 4 elles refusent de
s'afficher avec les imagettes et encore moins en grand.
Son photoshop (plus récent que le mien) refuse d'ouvrir.
Je me confonds en excuses, persuadée d'avoir fait la copie de travers,
je remporte le disque chez moi, les images (rien que du jpg) sont là,
parfaitement visibles et ouvrables...Je jette un œil dans un autre
répertoire qui contient d'autres photos, en provenance de son disque à
elle, ça s'ouvre aussi. Elimination de l'hypothèse de formatage
spécifique du disque usb.
MAIS : quand je les rouvre (avec le photoshop qui les a engendrées grace
à un script), j'ai le message "ce fichier contient des informations
illisibles et a été ignoré".
C'est fort étrange car il s'ouvre dans photoshop quand même malgré cet
avertissement et est d'aspect parfaitement normal.
Qu'est ce qui peut bien faire qu'un fichier jpg produit par PS soit
ainsi moitié bancal et illisible dans une autre machine et un autre
système ? Et pis, fasse rouspéter le Ps qui l'a produit ?
J'ai utilisé la commande "enregistrer pour le web" qui attribue d'office
un profil sRVB dans le script donc je pense que ce n'est pas un souci de
profil.
Aperçu ne rechigne pas et me fait un diaporama parfaitement normal.
Capture NX ne se plaint de rien non plus. Acrobat affiche sans râler.
Firefox et Safari affichent sans erreur, comme à peu près tout ce que je
peux essayer capable d'afficher une image jpg.

Mais ça apparait comme cassé sous Vista.
La copie sur le disque usb n'est pas en cause, les originaux se
comportent pareil.

Je nage en plein brouillard.
Et il y a une grosse tripotée de ces photos, et je n'ai pas du tout le
goût de repartir de 0 dessus et mon amie en a besoin pour un dossier à
remettre très bientôt.



Un idée en l'air comme-ça : l'ancienne version n'aurait-elle pas ajouté
des meta-données dont certaines specs ont évolué (IPTC ou XMP) ??

Il se peut qu'une balise mal comprise empèche de trouver le début des
données ?
Ou même que le simple fait d'afficher en galerie windows depuis le mode
vignette dans l'explorateur casse des métadonnées (par exemple, je sais
qu'on avait interdit dans mon assoc de tourner les images depuis la
visionneuse windows, mais je ne jurerais pas que ce soit sous VIsta,
bien que côté date, ça corresponde pas mal.

Tu te souviens si tu les avais déjà ouvertes avec *ton* photoshop avant
de lui confier le DD ?
Jacques DASSIÉ
Le #25002342
YouDontNeedToKnowButItsNoëlle a formulé la demande :

Je nage en plein brouillard.
Et il y a une grosse tripotée de ces photos, et je n'ai pas du tout le goût
de repartir de 0 dessus et mon amie en a besoin pour un dossier à remettre
très bientôt.



Tout en PC et Windows 7/8, j'ai déjà rencontré ce problème avec PS,
sans réussir à trouver une explication rationnelle.

La seule solution pratique chez moi consiste à ouvrir et réenregistrer
avec XnView. Plus aucun problème ensuite !

--
Jacques DASSIÉ
http://archaero.com/
Jean-Pierre Roche
Le #25002332
Le 29/11/2012 08:20, Jacques DASSIÉ a écrit :


Je nage en plein brouillard.
Et il y a une grosse tripotée de ces photos, et je n'ai
pas du tout le goût de repartir de 0 dessus et mon amie en
a besoin pour un dossier à remettre très bientôt.



Tout en PC et Windows 7/8, j'ai déjà rencontré ce problème
avec PS, sans réussir à trouver une explication rationnelle.

La seule solution pratique chez moi consiste à ouvrir et
réenregistrer avec XnView. Plus aucun problème ensuite !




J'ai connu ce genre de problème sur quelques photos. Il
semble que le problème vienne des métadonnées (exif, iptc,
etc.). Comme Jacques, ouvrir puis réenregistrer avec un
logiciel différent...

--
Jean-Pierre Roche

enlever sanspub pour m'écrire...
YouDontNeedToKnowButItsNoëlle
Le #25002672
Le 28/11/12 23:54, markorki a écrit :

Un idée en l'air comme-ça : l'ancienne version n'aurait-elle pas ajouté
des meta-données dont certaines specs ont évolué (IPTC ou XMP) ??


PS ajoute des méta-données ? Dans du jpg préparé pour le web donc à
priori, dénudé de ses informations annexes ? Je ne comprends pas.

Il se peut qu'une balise mal comprise empèche de trouver le début des
données ?


D'ou vient-elle ? Comment le voir et comment y remédier ? Un outil pour
voir et réparer ?

Ou même que le simple fait d'afficher en galerie windows depuis le mode
vignette dans l'explorateur casse des métadonnées (par exemple, je sais
qu'on avait interdit dans mon assoc de tourner les images depuis la
visionneuse windows, mais je ne jurerais pas que ce soit sous VIsta,
bien que côté date, ça corresponde pas mal.



Je vais pas embrayer, mais pour moi Vista c'est le mal...Cependant mes
fichiers jpg (ceux sur mon disque à moi) n'ont pas fricoté avec Vista.

Tu te souviens si tu les avais déjà ouvertes avec *ton* photoshop avant
de lui confier le DD ?


Ben oui relis mon message (trop long j'admet).
J'ai créé ces photos avec mon photoshop, par avec un petit script qui me
permet de générer 3 tailles : 1 jpg plein pot haute qualité (impression
photo), un jpg moyen (web pleine page ou impression pour un dossier) un
petit qualité 60 (web ou envoi par mail).

Quand je les rouvre avec n'importe quoi pas de loup.
Quand je les rouvre avec Photoshop qui les a créés donc, j'ai le message
d'erreur : ce fichier comprend des informations illisibles et a été
ignoré. Le plus fort c'est que je clique ok et le fichier s'ouvre quand
même comme si de rien n'était.

Noëlle Adam
YouDontNeedToKnowButItsNoëlle
Le #25002712
Le 29/11/12 08:32, Jean-Pierre Roche a écrit :

La seule solution pratique chez moi consiste à ouvrir et
réenregistrer avec XnView. Plus aucun problème ensuite !




J'ai connu ce genre de problème sur quelques photos. Il semble que le
problème vienne des métadonnées (exif, iptc, etc.). Comme Jacques,
ouvrir puis réenregistrer avec un logiciel différent...



L'enregistrement pour le web vire les exifs, non ?
Le plus curieux c'est que les photos faites avec un script peu différent
sous le même photoshop ne posent pas le problème.

bon, je vis essayer de faire tourner capture NX sur ces répertoires.
Qu'est-ce que je pourrais bien faire sous NX pour qu'il soit forcé de
réenregistrer sans avoir pour autant fait de modif
visible...Hum...Ajouter un point de contrôle qui ne fait rien du tout ?
En tous cas merci. J'aimerais bien comprendre mais à défaut si ça
remédie, ça ira.

Noëlle Adam
YouDontNeedToKnowButItsNoëlle
Le #25002812
Le 28/11/12 23:41, René a écrit :


"YouDontNeedToKnowButItsNoëlle" a écrit dans le message de groupe de
discussion : k9609f$gei$

Une amie m'a passée un disque usb pour que je lui mette des photos en
jpg dessus, ce que j'ai fait depuis ma machine (Snow Leopard) juste
comme sur une clé. Dans plusieurs répertoires.



Un CD "universel" ne se fait pas en copiant les fichiers "comme sur une
clef USB", les formatages ne sont pas les mêmes. Il faut utiliser un
logiciel d'écriture approprié maintenant normalement inclus dans tout
bon système d'exploitation. Sinon en trouver un gratuit sur le Web.

René


Je n'ai pas parlé de CD, j'ai parlé de disque USB.
Pas de différence avec une clé USB, à part la taille.
Et d'ailleurs, les CD et DVD que je grave sur mac sont parfaitement
lisibles ailleurs.
Merci

Noëlle Adam
YouDontNeedToKnowButItsNoëlle
Le #25002802
Le 28/11/12 23:54, markorki a écrit :

Un idée en l'air comme-ça : l'ancienne version n'aurait-elle pas ajouté
des meta-données dont certaines specs ont évolué (IPTC ou XMP) ??


Dans le jpg pour le web qui est à priori dépouillé de ces informations là ?

Il se peut qu'une balise mal comprise empèche de trouver le début des
données ?


Comment le voir et y remedier ?

Ou même que le simple fait d'afficher en galerie windows depuis le mode
vignette dans l'explorateur casse des métadonnées (par exemple, je sais
qu'on avait interdit dans mon assoc de tourner les images depuis la
visionneuse windows, mais je ne jurerais pas que ce soit sous VIsta,
bien que côté date, ça corresponde pas mal.


Grrr---Vista est une indicible horreur lovecraftienne, selon moi.


Tu te souviens si tu les avais déjà ouvertes avec *ton* photoshop avant
de lui confier le DD ?


Evidemment puisque ces photos je les aie générées par script photoshop ...
Si je les ouvre de nouveau avec ce photoshop, le mien donc, j'ai un
message d'erreur -ce fichier contient des informations illisibles et a
été ignoré- . Je fais OK et hop, le fichier s'affiche tout beau comme si
de rien n'était. Incompréhensible.

Noëlle Adam
Jacques DASSIÉ
Le #25002892
Après mûre réflexion, YouDontNeedToKnowButItsNoëlle a écrit :
Le 29/11/12 08:32, Jean-Pierre Roche a écrit :

La seule solution pratique chez moi consiste à ouvrir et
réenregistrer avec XnView. Plus aucun problème ensuite !




J'ai connu ce genre de problème sur quelques photos. Il semble que le
problème vienne des métadonnées (exif, iptc, etc.). Comme Jacques,
ouvrir puis réenregistrer avec un logiciel différent...



L'enregistrement pour le web vire les exifs, non ?



Oui, c'est pour cela que je me contente souvent d'une réduction de
taille qui donne un fichier un peu plus gros. Mais bof, tant que ça
reste sous les 2 Mo de Ci-Joint...

bon, je vis essayer de faire tourner capture NX sur ces répertoires.



C'est une bien grosse bête... Alf92 te suggérait l'essai de WnView.
Ce serait une excellente occasion de découvrir ce manipulateur de
fichiers !

--
Jacques DASSIÉ
http://archaero.com/
Publicité
Poster une réponse
Anonyme