clamav et mise à jour

Le
fra-duf-no-spam
Salut.

Dites-moi si je me gourre mais lors d'une proposition de màj, apt-get
dist-upgrade me propose de virer clamav et autres paquets associés sur
mon serveur Etch.

En y regardant de plus près, je vois que:

clamav/stable <- libclamav2/stable <- libcurl3/testing

En gros, un paquet de stable dépends d'un paquet de testing Ça=
me
semble pas très normal hein?

Est-ce une erreur de ma part (Ma Etch a des morceaux de Lenny dedans)
ou bien un vrai bug ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
fra-duf-no-spam
Le #9543611
Le 13629ième jour après Epoch,
écrivait:

chez moi clamav dépend d'un dépot volatile ; celui-là :

http://www.debian.org/devel/debian-volatile/volatile-mirrors

ensuite j'ai ces paquets là : clamAV, ClamAV base, et
clamav-freshclam



Méa culpa... En fait, ma machine étant un savant (hum) mélan ge de Etch
et Lenny, il se trouve que le patch de sécurité était bien d ans
stable, mais que ma version est plutôt "Lenny" ... D'où un petit
souci.

A moi de mieux réflêchir, des fois :)
fra-duf-no-spam
Le #9543601
Le 13630ième jour après Epoch,
François TOURDE écrivait:

Le 13629ième jour après Epoch,
écrivait:

chez moi clamav dépend d'un dépot volatile ; celui-là :

http://www.debian.org/devel/debian-volatile/volatile-mirrors

ensuite j'ai ces paquets là : clamAV, ClamAV base, et
clamav-freshclam



Méa culpa... En fait, ma machine étant un savant (hum) mél ange de Etch
et Lenny, il se trouve que le patch de sécurité était bien dans
stable, mais que ma version est plutôt "Lenny" ... D'où un petit
souci.

A moi de mieux réflêchir, des fois :)



Bon, en fait j'arrive pas à bien penser sur ce coup-là. J'ai beso in
d'un coup de main:

un "apt-get dist-upgrade" me propose d'enlever certains paquets (ex:
php4-mysql). Quand je regarde chez moi, j'ai:

cantor:~# apt-get install php4-mysql
[...]
Les paquets suivants contiennent des dépendances non satisfaites :
php4-mysql: Dépend: libmysqlclient15off (>= 5.0.27-1) mais ne sera pas installé

et:

cantor:~# apt-cache policy libmysqlclient15off
libmysqlclient15off:
Installé : (aucun)
Candidat : 5.0.38-1
Table de version :
5.0.38-3 0
70 http://http.us.debian.org unstable/main Packages
5.0.38-1 0
700 http://http.us.debian.org testing/main Packages

Or il se trouve que:

http://packages.debian.org/stable/libs/libmysqlclient15off

Donc je pense que mon source.list n'est pas bon, mais je ne vois pas
pourquoi. Le voici:

-----8<-------8<-------8<-------8<-------8<-------8<--
deb http://http.us.debian.org/debian stable main contrib non-free
deb http://http.us.debian.org/debian testing main contrib non-free
deb http://http.us.debian.org/debian unstable main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free

deb http://www.debian-multimedia.org stable main
deb-src http://www.debian-multimedia.org stable main
deb http://www.debian-multimedia.org testing main
deb-src http://www.debian-multimedia.org testing main
deb-src http://www.debian-multimedia.org sid main

deb-src http://http.us.debian.org/debian stable main contrib non-free
-----8<-------8<-------8<-------8<-------8<-------8<--


Si une bonne âme pouvait éclairer ma lanterne...
fra-duf-no-spam
Le #9543561
Le 13630ième jour après Epoch,
François TOURDE écrivait:

un "apt-get dist-upgrade" me propose d'enlever certains paquets (ex:
php4-mysql). Quand je regarde chez moi, j'ai:



[...]

Si une bonne âme pouvait éclairer ma lanterne...



Bon, après examen, il se trouve que la récupération des list es de
paquets n'avait pas été correcte, pour une raison que j'ignore.

Après un nettoyage de /var/lib/apt/lists et un update, le dist-upgrade
se passe très bien.

Ma machine étant en RAID5 et n'ayant pas eu de coupures grave ou de
plantage depuis ... bien longtemps... j'avoue que je ne comprends pas
et que ça me fait un peu peur.

Mais bon... A suivre.
Publicité
Poster une réponse
Anonyme