Class 'XSLTProcessor' not found

Le
christophe
Bonjour,
Je suis sous ubuntu et lorsque je me connecte sur localhost j'obtiens ce
message d'erreur :
Fatal error: Class 'XSLTProcessor' not found in
/media/www-dev/XXX/test.php5 on line 7.
Or la librairie libxslt 1.1 est bien installée.
Quelqu'un peut-il m'expliquer que faire?
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Poncet
Le #23762771
Le 15/09/2011 10:56, christophe a écrit :
Bonjour,



Bonjour,

Je suis sous ubuntu ...



De même, bienvenu au club !

... et lorsque je me connecte sur localhost j'obtiens ce
message d'erreur :
Fatal error: Class 'XSLTProcessor' not found in
/media/www-dev/XXX/test.php5 on line 7.



Intéressant, je n'ai pas encore eu l'occasion de tester XSLT avec PHP.

J'ai donc essayé avec un fichier "test.php" contenant :
<?php $xslt = new Xsltprocessor; ?>

Je me retrouve effectivement avec la même erreur que toi.
Cela prouverait que le support de XSL n'est pas activé par défaut sous
PHP 5+.

Or la librairie libxslt 1.1 est bien installée.



Tu as vu ça avec phpinfo() ?
Parce que moi, je n'avais pas d'info pour cette extension, justement.

Quelqu'un peut-il m'expliquer que faire?



Si tu es dans le même cas que moi, voici ce que je viens de faire pour
régler l'affaire :

- Installation de "php5-xsl" (par la logithèque) ;
- Redémarrage d'Apache.

Merci



De rien, en espérant que ça marche aussi bien avec ta config.


--
Cordialement,
Pascal
christophe
Le #23765551
Le 15/09/2011 14:59, Pascal Poncet a écrit :
Le 15/09/2011 10:56, christophe a écrit :
Bonjour,



Bonjour,

Je suis sous ubuntu ...



De même, bienvenu au club !


Bon c'est tout nouveau pour moi

... et lorsque je me connecte sur localhost j'obtiens ce
message d'erreur :
Fatal error: Class 'XSLTProcessor' not found in
/media/www-dev/XXX/test.php5 on line 7.



Intéressant, je n'ai pas encore eu l'occasion de tester XSLT avec PHP.

J'ai donc essayé avec un fichier "test.php" contenant :
<?php $xslt = new Xsltprocessor; ?>

Je me retrouve effectivement avec la même erreur que toi.
Cela prouverait que le support de XSL n'est pas activé par défaut sous
PHP 5+.

Or la librairie libxslt 1.1 est bien installée.



Tu as vu ça avec phpinfo() ?
Parce que moi, je n'avais pas d'info pour cette extension, justement.


Eh non, j'avais vérifié avec la logithèque

Quelqu'un peut-il m'expliquer que faire?



Si tu es dans le même cas que moi, voici ce que je viens de faire pour
régler l'affaire :

- Installation de "php5-xsl" (par la logithèque) ;
- Redémarrage d'Apache.

Merci



De rien, en espérant que ça marche aussi bien avec ta config.


Ça marche aussi, par contre le peux pas renvoyé le
$proc->transformToXML($xmlDoc); par un echo $proc, mais c'est un autre
problème et je vais m'y penché.
Merci pour cette réponse


Une Bevue
Le #23766211
On 16/09/2011 11:41, christophe wrote:
Le 15/09/2011 14:59, Pascal Poncet a écrit :
Le 15/09/2011 10:56, christophe a écrit :
Bonjour,



Bonjour,

Je suis sous ubuntu ...



De même, bienvenu au club !


Bon c'est tout nouveau pour moi

... et lorsque je me connecte sur localhost j'obtiens ce
message d'erreur :
Fatal error: Class 'XSLTProcessor' not found in
/media/www-dev/XXX/test.php5 on line 7.



Intéressant, je n'ai pas encore eu l'occasion de tester XSLT avec PHP.

J'ai donc essayé avec un fichier "test.php" contenant :
<?php $xslt = new Xsltprocessor; ?>

Je me retrouve effectivement avec la même erreur que toi.
Cela prouverait que le support de XSL n'est pas activé par défaut sous
PHP 5+.

Or la librairie libxslt 1.1 est bien installée.



Tu as vu ça avec phpinfo() ?
Parce que moi, je n'avais pas d'info pour cette extension, justement.


Eh non, j'avais vérifié avec la logithèque

Quelqu'un peut-il m'expliquer que faire?



Si tu es dans le même cas que moi, voici ce que je viens de faire pour
régler l'affaire :

- Installation de "php5-xsl" (par la logithèque) ;
- Redémarrage d'Apache.

Merci



De rien, en espérant que ça marche aussi bien avec ta config.


Ça marche aussi, par contre le peux pas renvoyé le
$proc->transformToXML($xmlDoc); par un echo $proc, mais c'est un autre
problème et je vais m'y penché.
Merci pour cette réponse







auriez-vous une URL avec un exemple, pour test, j'ai aussi installé
php-xsl sur Ubuntu 11.04...
christophe
Le #23766411
Le 16/09/2011 14:24, Une Bevue a écrit :
On 16/09/2011 11:41, christophe wrote:
Le 15/09/2011 14:59, Pascal Poncet a écrit :
Le 15/09/2011 10:56, christophe a écrit :
Bonjour,



Bonjour,

Je suis sous ubuntu ...



De même, bienvenu au club !


Bon c'est tout nouveau pour moi

... et lorsque je me connecte sur localhost j'obtiens ce
message d'erreur :
Fatal error: Class 'XSLTProcessor' not found in
/media/www-dev/XXX/test.php5 on line 7.



Intéressant, je n'ai pas encore eu l'occasion de tester XSLT avec PHP.

J'ai donc essayé avec un fichier "test.php" contenant :
<?php $xslt = new Xsltprocessor; ?>

Je me retrouve effectivement avec la même erreur que toi.
Cela prouverait que le support de XSL n'est pas activé par défaut sous
PHP 5+.

Or la librairie libxslt 1.1 est bien installée.



Tu as vu ça avec phpinfo() ?
Parce que moi, je n'avais pas d'info pour cette extension, justement.


Eh non, j'avais vérifié avec la logithèque

Quelqu'un peut-il m'expliquer que faire?



Si tu es dans le même cas que moi, voici ce que je viens de faire pour
régler l'affaire :

- Installation de "php5-xsl" (par la logithèque) ;
- Redémarrage d'Apache.

Merci



De rien, en espérant que ça marche aussi bien avec ta config.


Ça marche aussi, par contre le peux pas renvoyé le
$proc->transformToXML($xmlDoc); par un echo $proc, mais c'est un autre
problème et je vais m'y penché.
Merci pour cette réponse







auriez-vous une URL avec un exemple, pour test, j'ai aussi installé
php-xsl sur Ubuntu 11.04...


Pour le moment, je le faiS tourner en local uniquement dsl
nemo83140
Le #24011571
Et si on est pas sous Ubuntu mais sous Windows ( Oui, je sais, c'est le mal, mais on fait avec ... ) ?
Olivier Miakinen
Le #24012701
Le 28/11/2011 19:12, a écrit :
Et si on est pas sous Ubuntu mais sous Windows ( Oui, je sais, c'est le mal, mais on fait avec ... ) ?



Euh... le mal, ce n'est pas tant d'être sous Windows que de passer par
Google groupes, avec des lignes super longues, et en répondant à un
article vieux de plus d'un mois sans résumer de quoi il était question.

;-)


Bon, sans avoir accès à l'article précédent, je dirais que si la
question concernait PHP et pas Ubuntu, il y a peut-être une chance
que la réponse soit la même sous Windows, non ? C'est vrai que ce
n'est pas absolument certain dans le cas où il s'agirait d'une
bibliothèque installée (peut-être par défaut) sur Ubuntu et pas
forcément sur Windows. Mais bon, tu aurais probablement intérêt
à reformuler la question, surtout si elle datait de plusieurs
années.

Cordialement,
--
Olivier Miakinen
Publicité
Poster une réponse
Anonyme