Clef wifi USB reconnue ne détecte pas de réseau

Le
Seb
Bonjour !


J'ai une clef USB wifi (TP-Link TL-WN727N) qui utilise un chipset Ralink:

~>lsusb | grep -i wireless
Bus 001 Device 016: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070
Wireless Adapter

Elle est reconnue par le système dès que je la branche:

~>ifconfig -a
[snip]
wlan0 Link encap:Ethernet HWaddr 54:e6:fc:92:72:00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

~>iw wlan0 info
Interface wlan0
ifindex 13
type managed

~>lsmod | grep rt2
rt2870sta 326811 0
rt2800usb 24919 0
rt2x00usb 5713 1 rt2800usb
rt2x00lib 19101 2 rt2800usb,rt2x00usb
led_class 1757 1 rt2x00lib
mac80211 123570 2 rt2x00usb,rt2x00lib
cfg80211 87657 2 rt2x00lib,mac80211
crc_ccitt 1039 2 rt2870sta,rt2800usb
usbcore 98733 7 rt2870sta,rt2800usb,rt2x00usb,usbhid,ohci_hcd,ehci_hcd

Problème: je ne parviens pas à détecter de signal wifi. *Aucun* signal
wifi, ce n'est pas seulement celui de ma Freebox qui n'apparaît pas: ceux
des voisins n'apparaissent pas non plus.

~#iwlist wlan0 scan
wlan0 No scan results

~>nmcli dev wifi
SSID BSSID MODE
FREQ RATE SIGNAL SECURITY ACTIVE
~>

~#wicd-client -n
-> fenêtre et la mention "No wireless networks found."

Quand j'ai testé cette clef sous Windows, je n'avais pas ce problème: une
dizaine de signaux wifi étaient captés, dont celui de ma Freebox. Donc la
clef fonctionne.

Précisions importantes:

* Je suis en Debian stable.

* Je connais assez bien Linux, mais je n'ai /jamais/ utilisé de wifi
auparavant; il est donc très possible que j'aie raté un truc évident et
essentiel à ce sujet.

* Je n'utilise pas Gnome/KDE/etc., mais fvwm2, et je n'ai pas de clic-clic
bien enrobé pour lancer network-manager (quand je lance nm-applet en
ligne de commande, il ne se passe rien, sauf que le prompt est
mobilisé).

* Pour faire comme dit dans la doc de network-manager, j'ai commenté
toutes les lignes concernant wlan0 dans /etc/network/interfaces.

* Quand je mets les lignes suivantes dans /etc/network/interfaces:
auto wlan0
iface wlan0 inet dhcp
wpa-ssid <snip:nom-du-réseau>
wpa-psk <snip:mot-de-passe>
et que je lance /etc/init.d/networking restart, l'établissement d'une
connexion échoue:
Listening on LPF/wlan0/54:e6:fc:92:72:00
Sending on LPF/wlan0/54:e6:fc:92:72:00
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
[etc.]

* En suivant des tutos en ligne, j'ai fait pas mal de manips type enlever
tel driver par rmmod, le blacklist, etc. Rien n'a marché. J'ai tout
remis en l'état de départ. Mais après avoir débranché et rebranché la
clef, c'est tombé en marche: "iwlist wlan0 scan" me donnait une dizaine
de réseaux. J'étais hélas incapable de savoir ce qui avait produit cet
effet (qui ne s'est manifesté qu'après avoir débranché/rebranché la
clef). J'ai rebooté et patatras: mêmes symptômes que ci-dessus, plus de
réseau détecté, que je boote avec la clef branchée ou non. Je ne sais
vraiment pas ce qui a fait temporairement la différence et je n'ai pas
réussi à retomber dessus par hasard. Moralité quand même: ça *peut*
marcher, ça *a* marché, c'est juste un problème de config qui me
dépasse.

* Enfin, un ami qui a la même clef me dit que sur son Ubuntu 11.04, le
clic-clic de Gnome fait marcher la clef tandis que "iwlist wlan0 scan"
ne renvoie rien en ligne de commande. À l'évidence son clic-clic fait un
truc supplémentaire, mais quoi


J'aimerais beaucoup réussir à faire enfin marcher cette clef, vous avez
sans doute compris que j'y ai déjà passé pas mal de temps Tout conseil
sera le bienvenu, merci d'avance !


Seb.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/Pine.LNX.4.58.1105062001180.24267@ybpnyubfg.ybpnyqbznva
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Christophe Maquaire
Le #23340741
On Fri, 6 May 2011 20:26:33 +0200 (CEST)
Seb

Bonjour !



Bonjour


J'ai une clef USB wifi (TP-Link TL-WN727N) qui utilise un chipset Ralink:

~>lsusb | grep -i wireless
Bus 001 Device 016: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070
Wireless Adapter


J'aimerais beaucoup réussir à faire enfin marcher cette clef, vous av ez
sans doute compris que j'y ai déjà passé pas mal de temps... Tout c onseil
sera le bienvenu, merci d'avance !




Ajouter la section non-free au sources.list et aptitude install
firmware-ralink pourrait t'aider.

Seb.



Chistophe
--
Christophe Maquaire
Happy Debian User

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Seb
Le #23340731
Bonjour Christophe,


| Ajouter la section non-free au sources.list et aptitude install
| firmware-ralink pourrait t'aider.

Bonne idée mais:

~>dpkg -l firmware-ralink
||/ Name Version Description
+++-==============-==============-=========================================== ii firmware-ralin 0.28 Binary firmware for Ralink wireless cards


Seb.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Sébastien Kroll-Rabotin
Le #23341001
--Sig_/hCp4qZspQlyFcjzDftdk/kN
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Salut,

Ma réponse est probablement trop simple, mais comme tu dis que utilises
le wifi pour la première fois…

~#iwlist wlan0 scan
wlan0 No scan results
* Enfin, un ami qui a la même clef me dit que sur son Ubuntu 11.04, le
clic-clic de Gnome fait marcher la clef tandis que "iwlist wlan0
scan" ne renvoie rien en ligne de commande. À l'évidence s on
clic-clic fait un truc supplémentaire, mais quoi...



Pour que iwlist te renvoie quelque-chose il faut bien le précéder d'un
« ifconfig wlan0 up », que je te conseille même de précéder d'un
« ifconfig wlan0 down » pour être sûr que la carte n'a pas des réglages
incompatibles avec la détection (par exemple airodump-ng change son
mode de réception).

En parlant de cet exemple, tu peux utiliser airodump-ng du paquet
aircrack-ng pour faire ta détection. Bien sûr ces paquets servent aussi
à bien d'autres choses, mais ils sont vraiment efficaces pour
s'affranchir des problèmes de conf. Tu fais un « ifconfig wl an0 down »
et airodump-ng se charge de passer en mode “promiscuous” et entame sa
détection des réseaux environnants.

J'espère que ça pourra t'aider.

Bonne chance.

--
(o< -!
// Happy debian user !
V_/_ http://www.debian.org/

--Sig_/hCp4qZspQlyFcjzDftdk/kN
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk3EYCIACgkQ3qwCc2aFrOYR/QCeKboe4X7Ec4rVk7sHSI0fBG5E
Rn8AoI9BOeCQJzIQQ689bdjI8t1aXfo9
¼TX
-----END PGP SIGNATURE-----

--Sig_/hCp4qZspQlyFcjzDftdk/kN--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
corbie
Le #23341141
J'ai la même clé :

$ ps aux | grep rt
rt73usb

$ lsusb
Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter

# cat /etc/modprobe.d/ralink
alias wlan* rt73

# /etc/network/interfaces
allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wireless-essid <SSID>
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

$ ifconfig -a
wlan0 Link encap:Ethernet HWaddr 00:27:19:b7:69:06
inet adr:192.168.1.9 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::227:19ff:feb7:6906/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1143 errors:0 dropped:0 overruns:0 frame:0
TX packets:647 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:410829 (401.2 KiB) TX bytes:104862 (102.4 KiB)

Je suis sous KDE et j'utilise network-manager.

Cette clé USB marche très bien, juste un peu capricieuse et parfois
lente pour accrocher le n° IP depuis le serveur DHCP.

Si ça peut aider ...


Le vendredi 6 mai 2011, Seb a écrit :

J'ai une clef USB wifi (TP-Link TL-WN727N) qui utilise un chipset Ralink:
~>lsusb | grep -i wireless
Bus 001 Device 016: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070
Wireless Adapter
Elle est reconnue par le système dès que je la branche:
~>ifconfig -a
[snip]
wlan0 Link encap:Ethernet HWaddr 54:e6:fc:92:72:00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

~>iw wlan0 info
Interface wlan0
ifindex 13
type managed

~>lsmod | grep rt2
rt2870sta 326811 0
rt2800usb 24919 0
rt2x00usb 5713 1 rt2800usb
rt2x00lib 19101 2 rt2800usb,rt2x00usb
led_class 1757 1 rt2x00lib
mac80211 123570 2 rt2x00usb,rt2x00lib
cfg80211 87657 2 rt2x00lib,mac80211
crc_ccitt 1039 2 rt2870sta,rt2800usb
usbcore 98733 7 rt2870sta,rt2800usb,rt2x00usb,usbhid,ohc i_hcd,ehci_hcd

Problème: je ne parviens pas à détecter de signal wifi. *Aucun* sig nal
wifi, ce n'est pas seulement celui de ma Freebox qui n'apparaît pas: ce ux
des voisins n'apparaissent pas non plus.

~#iwlist wlan0 scan
wlan0 No scan results

~>nmcli dev wifi
SSID BSSID MODE
FREQ RATE SIGNAL SECURITY ACTIVE
~>

~#wicd-client -n
-> fenêtre et la mention "No wireless networks found."

Quand j'ai testé cette clef sous Windows, je n'avais pas ce problème: une
dizaine de signaux wifi étaient captés, dont celui de ma Freebox. Don c la
clef fonctionne.

Précisions importantes:

* Je suis en Debian stable.

* Je connais assez bien Linux, mais je n'ai /jamais/ utilisé de wifi
auparavant; il est donc très possible que j'aie raté un truc évid ent et
essentiel à ce sujet.

* Je n'utilise pas Gnome/KDE/etc., mais fvwm2, et je n'ai pas de clic-clic
bien enrobé pour lancer network-manager (quand je lance nm-applet en
ligne de commande, il ne se passe rien, sauf que le prompt est
mobilisé).

* Pour faire comme dit dans la doc de network-manager, j'ai commenté
toutes les lignes concernant wlan0 dans /etc/network/interfaces.

* Quand je mets les lignes suivantes dans /etc/network/interfaces:
auto wlan0
iface wlan0 inet dhcp
wpa-ssid <snip:nom-du-réseau>
wpa-psk <snip:mot-de-passe>
et que je lance /etc/init.d/networking restart, l'établissement d'une
connexion échoue:
Listening on LPF/wlan0/54:e6:fc:92:72:00
Sending on LPF/wlan0/54:e6:fc:92:72:00
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
[etc.]

* En suivant des tutos en ligne, j'ai fait pas mal de manips type enlever
tel driver par rmmod, le blacklist, etc. Rien n'a marché. J'ai tout
remis en l'état de départ. Mais après avoir débranché et reb ranché la
clef, c'est tombé en marche: "iwlist wlan0 scan" me donnait une dizai ne
de réseaux. J'étais hélas incapable de savoir ce qui avait produi t cet
effet (qui ne s'est manifesté qu'après avoir débranché/rebranch é la
clef). J'ai rebooté et patatras: mêmes symptômes que ci-dessus, p lus de
réseau détecté, que je boote avec la clef branchée ou non. Je n e sais
vraiment pas ce qui a fait temporairement la différence et je n'ai pas
réussi à retomber dessus par hasard. Moralité quand même: ça *peut*
marcher, ça *a* marché, c'est juste un problème de config qui me
dépasse.

* Enfin, un ami qui a la même clef me dit que sur son Ubuntu 11.04, le
clic-clic de Gnome fait marcher la clef tandis que "iwlist wlan0 scan"
ne renvoie rien en ligne de commande. À l'évidence son clic-clic fait un
truc supplémentaire, mais quoi...


J'aimerais beaucoup réussir à faire enfin marcher cette clef, vous av ez
sans doute compris que j'y ai déjà passé pas mal de temps... Tout c onseil
sera le bienvenu, merci d'avance !


Seb.





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Seb
Le #23341131
Bonsoir Jean-Sébastien,


| Ma réponse est probablement trop simple, mais comme tu dis que utilises
| le wifi pour la première fois…

Je recherche justement des idées basiques, merci !

| Pour que iwlist te renvoie quelque-chose il faut bien le précéder d'un
| « ifconfig wlan0 up », que je te conseille même de précéder d'un
| « ifconfig wlan0 down » pour être sûr que la carte n'a pas des
| réglages incompatibles avec la détection (par exemple airodump-ng
| change son mode de réception).

Je viens d'essayer et hélas cela n'a pas changé la donne:

~# ifconfig wlan0 down && ifconfig wlan0 up && iwlist wlan0 scan
wlan0 No scan results

et ceci que je commente ou non les lignes concernant wlan0 dans
/etc/network/interfaces.

| En parlant de cet exemple, tu peux utiliser airodump-ng du paquet
| aircrack-ng pour faire ta détection. Bien sûr ces paquets servent
| aussi à bien d'autres choses, mais ils sont vraiment efficaces pour
| s'affranchir des problèmes de conf. Tu fais un « ifconfig wlan0
| down » et airodump-ng se charge de passer en mode “promiscuousâ€
Seb
Le #23341121
Bonsoir,


| J'ai la même clé :
| $ lsusb
| Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter

Presque mais pas tout à fait:
D-Link System AirPlus G DWL-G122 Wireless Adapter(rev.E) [Ralink RT2870]

| $ ps aux | grep rt
| rt73usb

Les chipsets des clefs USB Ralink un peu plus anciennes chargent
effectivement rt73usb, ce qui n'est pas le cas de la mienne hélas.
En l'occurrence, je n'ai rien via 'ps':

~>ps aux | grep rt | grep usb
~>

C'est peut-être un symptôme intéressant, mais je ne sais pas quoi en
faire...

| # cat /etc/modprobe.d/ralink
| alias wlan* rt73

~>cat /etc/modprobe.d/ralink
cat: /etc/modprobe.d/ralink: No such file or directory

puis:

~# echo "alias wlan* rt73" >> /etc/modprobe.d/ralink

ensuite je débranche/rebranche la clef, mais:

~# ifconfig wlan0 down && ifconfig wlan0 up && iwlist wlan0 scan
wlan0 No scan results

donc:

~# rm /etc/modprobe.d/ralink

| # /etc/network/interfaces
| allow-hotplug wlan0
| auto wlan0
| iface wlan0 inet dhcp
| wireless-essid <SSID>
| wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Je n'ai pas encore configuré wpa_supplicant, je me dis que cela vient en
aval de la détection de réseaux.

| Cette clé USB marche très bien, juste un peu capricieuse et parfois
| lente pour accrocher le n° IP depuis le serveur DHCP.

Lente comment ? Pourrais-tu copier-coller un exemple de transaction qui
s'affiche par "/etc/init.d/networking restart" ?


Merci pour ton aide et pour ces pistes !

Seb.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23341341
Le Fri, 6 May 2011 21:22:50 +0200 (CEST),
Seb

Bonjour Christophe,


| Ajouter la section non-free au sources.list et aptitude install
| firmware-ralink pourrait t'aider.

Bonne idée mais:

~>dpkg -l firmware-ralink
||/ Name Version Description
+++-==============-======== ======-================== ========================= =
ii firmware-ralin 0.28 Binary firmware for Ralink wireless
cards


Seb.




bonjour,

en premier et pour l'ensemble des lecteurs, serait il possible
de donner :

-a) la version du noyau installé
uname -ar |awk '{print $1 " "$3 " "$5}'
-b) la liste des paquets usb installés :
dpkg -l |grep usb |awk '{print $2" "$3}'

pour mémoire :

gestionnaire de bureau : fvwm
dpkg -l firmware-ralink|awk '{print $2" "$3}'

listes des paquets "conseillés"
hostapd - user space IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP

python-wicd
wicd
wicd-cli
wicd-curses
wicd-daemon
wicd-gtk

apt-cache show networkconf

Description:

Network/Wifi configuration tool Simple tool for quickly
configuring eth and wlan devices for Debian-based
distributions using /etc/network/interfaces.

Initially for the Morphix project, this tool also provides
WEP options for wireless network cards.

je n'ai pas de solution directe à donner, mais simplement pour
aporter une piste de réflexion ....

slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Seb
Le #23341981
Bonjour Bernard,


Merci pour les idées et pour les commandes à copier-coller !

(Prélude: j'ai lancé une Ubuntu en mode Live CD. Quand j'atterris dans
Gnome, je clique sur l'icône des arcs de cercle concentriques. L'interface
me propose tout de suite une liste de réseaux disponibles; je choisis le
mien, j'entre le mot de passe; ça marche du premier coup. Donc la clef
fonctionne sous Linux. Il manque juste de comprendre quelle magie opère
dans les coulisses de l'icône du wifi sous Gnome.)

| en premier et pour l'ensemble des lecteurs, serait il possible de
| donner :
| -a) la version du noyau installé
| uname -ar |awk '{print $1 " "$3 " "$5}'

~> uname -ar |awk '{print $1 " "$3 " "$5}'
Linux 2.6.32-5-686 SMP

| -b) la liste des paquets usb installés :
| dpkg -l |grep usb |awk '{print $2" "$3}'

~> dpkg -l |grep usb |awk '{print $2" "$3}'
libusb-0.1-4 2:0.1.12-17
libusb-1.0-0 2:1.0.8-2
libusbmuxd1 1.0.4-1
multisystem 1.0059
usb-modeswitch 1.1.4-2
usb-modeswitch-data 20100826-1+squeeze0
usbmount 0.0.21
usbmuxd 1.0.4-1
usbutils 0.87-5
xserver-xorg-video-sisusb 1:0.9.3-2

| pour mémoire :
| gestionnaire de bureau : fvwm
| dpkg -l firmware-ralink|awk '{print $2" "$3}'

~>dpkg -l firmware-ralink|awk '{print $2" "$3}'

Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
Err?=(none)/Reinst-required (Status,Err:
Name Version

firmware-ralink 0.28

| listes des paquets "conseillés"
| hostapd - user space IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP
| python-wicd
| wicd
| wicd-cli
| wicd-curses
| wicd-daemon
| wicd-gtk

Certains packages n'étaient pas encore installés. Je les ai ajoutés par:
apt-get install hostapd wicd-cli wicd-curses

Quand je branche la clef usb wifi, elle apparaît maintenant comme wlan1
dans ifconfig.

| apt-cache show networkconf

~# apt-cache show networkconf
N: Unable to locate package networkconf
E: No packages found

~# apt-cache search networkconf
knetworkconf - network configuration tool

~# apt-cache search network | grep network | grep conf | grep ^net | cut -d ' ' -f 1
netenv
netscript-2.4-upstart
netscript-2.4
network-config

Aucun (y compris knetworkconf) ne correspond à la description suivante:

| Network/Wifi configuration tool Simple tool for quickly
| configuring eth and wlan devices for Debian-based
| distributions using /etc/network/interfaces.
| Initially for the Morphix project, this tool also provides
| WEP options for wireless network cards.
| je n'ai pas de solution directe à donner, mais simplement pour
| aporter une piste de réflexion ....

C'est déjà utile, merci.

Nouvel essai, après avoir décommenté les lignes concernant wlan1 dans
/etc/network/interfaces (où j'ai également changé wlan0 en wlan1):

~# ifdown wlan1 && ifup wlan1
ifdown: interface wlan1 not configured
Internet Systems Consortium DHCP Client 4.1.1-P1
Copyright 2004-2010 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan1/34:08:04:94:0f:a9
Sending on LPF/wlan1/34:08:04:94:0f:a9
Sending on Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 9
^C

~# iwlist wlan1 scan
wlan1 No scan results

Bouh.


Je manque d'idée pour faire le pas suivant... Merci d'avance pour votre
aide !


Seb.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
corbie
Le #23342291
Le vendredi 6 mai 2011, Seb a écrit :
| Cette clé USB marche très bien, juste un peu capricieuse et parfois
| lente pour accrocher le n° IP depuis le serveur DHCP.

Lente comment ? Pourrais-tu copier-coller un exemple de transaction qui
s'affiche par "/etc/init.d/networking restart" ?

Merci pour ton aide et pour ces pistes !
Seb.



Avec plaisir ... !

Il n'y a pas de message d'erreur, le PC, via la clé USB,
tente 5 à 6 fois d'accrocher le n° IP, puis abandonne.

Il suffit de relancer :
# ifdown wlan0
# ifup wlan0
et la seconde fois, ça accroche.

Parfois, je dois retirer la clé puis la remettre.

Sous Windows XP et Seven, ça accroche tout de suite ...

En espérant que ta connexion va marcher pour toi.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
giggzounet
Le #23345901
Salut,

Le 06/05/2011 23:40, Seb a écrit :

Bonsoir,




[snip]

as tu regardé si ta clé a un "rfkill" ?
install le paquet du même nom. lire le man...

mais je ne pense pas que ça vienne de là. car si ton rfkill était à on,
tu n'aurais pas d'interface wlan0 visible.

| # /etc/network/interfaces
| allow-hotplug wlan0
| auto wlan0
| iface wlan0 inet dhcp
| wireless-essid <SSID>
| wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Je n'ai pas encore configuré wpa_supplicant, je me dis que cela vient en
aval de la détection de réseaux.




Ce que tu peux faire pour tester:
tu vires ces lignes du fichier interface:
wpa-ssid
wpa-psk

et tu fais un fichier de conf wpa_supplicant. Ensuite tu lances en mode
debug wpa_supplicant dessus. je sais c'est po très clair :D mais je suis
au boulot et j'ai pas trop de doc sous la main :D

pour les exemples de fichiers de conf:
/usr/share/doc/wpasupplicant/example

(attention dans certaines versions de wpa_supplicant, le monsieur est
capricieux: parfois il faut mettre des guillements autour des
password/passphrase, parfois non...lire le man et tester...)

pour lancer wpa_supplicant:
sudo wpa_supplicant -iMoninterfaceWifi -c Monfichierdeconf -d -K

Je n'ai jamais réussi à faire marcher du wifi direct en dur dans
/etc/network/interfaces. J'utilise le roaming de wpa_supplicant. lire la
doc de wpa_supplicant c'est bien expliqué et ça marche!

en espérant t'avoir donné des pistes.
GiGGz

[snip]

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/iq83cd$kqi$
Publicité
Poster une réponse
Anonyme