client citrix sous debian testing

Le
Kohler Gerard
bonjour,

dans mon parcours pour passer entièrement sous Debian, je me heurte à la
difficulté suivante :

je n'arrive pas à installer simplement un client Citrix (ICAClient) sur
ma Debian. J'en ai besoin sur mon portable, car l'établissement où je
travaille virtualise son système sous Citrix.

j'ai testé une bonne demi-douzaine de technique trouvées sur Google,
mais rien ne marche, il manque toujours une lib, ou il y a
incompatibilité de lib,
j'avais réussi à installer ce programme sur mon Ubuntu 10.10, mais là je
sèche.

Merci pour vos conseils

Gérard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/52A8CFB9.8060601@oceanetpro.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bzzz
Le #25862682
On Wed, 11 Dec 2013 21:48:57 +0100
Kohler Gerard
j'avais réussi à installer ce programme sur mon Ubuntu 10.10, m ais
là je sèche.



C'est assez peu étonnant, vu que trudububu utilise des libs
non-testées (et pouvant donc provoquer de graves problèmes).

Prends la version antérieure.

--
<Flint> Tu te rappelles l'autre jour quand tu t'es coincé les doigts
dans la porte ?
<Flint> Ils étaient tout enflés après. C'était marrant =D
<Xenu> tra gfueukle

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Gilles Mocellin
Le #25864952
Le 11/12/2013 21:48, Kohler Gerard a écrit :
bonjour,

dans mon parcours pour passer entièrement sous Debian, je me heurte à
la difficulté suivante :

je n'arrive pas à installer simplement un client Citrix (ICAClient)
sur ma Debian. J'en ai besoin sur mon portable, car l'établissement où
je travaille virtualise son système sous Citrix.

j'ai testé une bonne demi-douzaine de technique trouvées sur Google,
mais rien ne marche, il manque toujours une lib, ou il y a
incompatibilité de lib,
j'avais réussi à installer ce programme sur mon Ubuntu 10.10, mais là
je sèche.

Merci pour vos conseils

Gérard



J'essaye, en 64bits sous Debian SID :

$ sudo dpkg -i dev/pkg/icaclient_13.0.0.256735_amd64.deb
Sélection du paquet icaclient précédemment désélectionné.
(Lecture de la base de données... 238510 fichiers et répertoires déjà
installés.)
Preparing to unpack .../icaclient_13.0.0.256735_amd64.deb ...
Unpacking icaclient (13.0.0.256735) ...
dpkg: des problèmes de dépendances empêchent la configuration de icaclient :
icaclient dépend de ia32-libs ; cependant :
Le paquet ia32-libs n'est pas installé.
icaclient dépend de lib32asound2 ; cependant :
Le paquet lib32asound2 n'est pas installé.
icaclient dépend de nspluginwrapper ; cependant :
Le paquet nspluginwrapper n'est pas installé.

En effet, ce paquet n'est pas fait pour une Debian avec le support
muiltiarch, il veut les anciens paquet ia32-libs et lib32asound2 de
compatibilité 32bits sur un système 64bits.
Je vois que ce paquet dépend aussi de nspluginwrapper, qui n'existe plus.
Ceci servait à utiliser des plugins 32bits pour les navigateurs.

Je sais pas si c'est ton cas, d'être en 64bits ?

Autre point, Ubuntu 10.10, ça doit être assez vieux pour avoir encore le
paquet ia32-libs, c'est pour celà que ça devait fonctionner.

De mémoire, mais c'était une versions plus ancienne du client Citrix, il
ya avait aussi une dépendance sur une lib X qui n'existait pas en
version demandé sous Debian. Problème de licence je crois.

Je suppose que comme souvent, leur paquet 64bits n'est en fait qu'un
paquet 32bits avec des dépendances sur les paquets de compatibilité 32bits.

Il faut mieux installer le paquet 32bits avec les libraziries 32bits
nécessaires :

$ sudo dpkg -i dev/pkg/icaclient_13.0.0.256735_i386.deb
(Lecture de la base de données... 239024 fichiers et répertoires déjà
installés.)
Preparing to unpack .../icaclient_13.0.0.256735_i386.deb ...
Unpacking icaclient (13.0.0.256735) over (13.0.0.256735) ...
dpkg: des problèmes de dépendances empêchent la configuration de icaclient :
icaclient dépend de libgtk2.0-0 (>= 2.12.0) ; cependant :
Le paquet libgtk2.0-0 n'est pas installé.
icaclient dépend de libxmu6 ; cependant :
icaclient dépend de libxerces-c3.1 ; cependant :
icaclient dépend de libcurl3 (>= 7.19.1) ; cependant :
icaclient dépend de libwebkit-1.0-2 | libwebkitgtk-1.0-0 ; cependant :

dpkg: error processing package icaclient (--install):
problèmes de dépendances - laissé non configuré
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
Processing triggers for menu (2.1.46) ...
Des erreurs ont été rencontrées pendant l'exécution :
icaclient

$ sudo apt-get install libgtk2.0-0:i386 libxmu6:i386 libxerces-c3.1:i386
libcurl3:i386 libwebkitgtk-1.0-0:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
libcurl3:i386 : Dépend: libgssapi-krb5-2:i386 (>= 1.10+dfsg~) mais ne
sera pas installé
Dépend: libidn11:i386 (>= 1.13) mais ne sera pas installé
Dépend: libk5crypto3:i386 (>= 1.6.dfsg.2) mais ne sera
pas installé
Dépend: libkrb5-3:i386 (>= 1.6.dfsg.2) mais ne sera
pas installé
Dépend: librtmp0:i386 (>= 2.3) mais ne sera pas installé
Dépend: libssh2-1:i386 (>= 1.2.6) mais ne sera pas
installé
Dépend: libssl1.0.0:i386 (>= 1.0.1) mais ne sera pas
installé
libgtk2.0-0:i386 : Dépend: libatk1.0-0:i386 (>= 1.32.0) mais ne sera
pas installé
Dépend: libcairo2:i386 (>= 1.6.4-6.1) mais ne sera
pas installé
Dépend: libcups2:i386 (>= 1.6.0) mais ne sera pas
installé
...
...


Oulà,
Ça se complique.

Je ne veux pas pourrir mon système, alors j’arrête là.
Mais tu as raison, c'est la galère.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
honeyshell
Le #25865042
--047d7bea36d266b4da04ed584c70
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Si tu as un peu de temps, un test d'installation sous Testing et avec
aptitude serait plus facile?
Aptitude te proposera des solutions pour la compatibilité des libs.

Et au préalable faire :
# apt-get update && apt-get upgrade && apt-get dist-upgrade
tu seras alors sur que ton système est bien à jour et qu'il ne lu i manque
rien.

#apt-get -s install XXXXXX
pour simuler si tu as peur de casser quelque chose.

--047d7bea36d266b4da04ed584c70
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable


--047d7bea36d266b4da04ed584c70--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/CAJeHwDbdifAXofQws_kG+-FH2wepBL17DvOh2+
Gilles Mocellin
Le #25866132
Le 12/12/2013 16:50, honeyshell a écrit :
Si tu as un peu de temps, un test d'installation sous Testing et avec
aptitude serait plus facile?
Aptitude te proposera des solutions pour la compatibilité des libs.

Et au préalable faire :
# apt-get update && apt-get upgrade && apt-get dist-upgrade
tu seras alors sur que ton système est bien à jour et qu'il ne lui
manque rien.

#apt-get -s install XXXXXX
pour simuler si tu as peur de casser quelque chose.



J'ai essayé avec aptitude, c'était pire, et il ne trouvait pas de
solution convenable.
Il y a peut-être bien des dépendances manquantes pour ce paquet.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Kohler Gerard
Le #25878882
Le 12/12/2013 19:42, Gilles Mocellin a écrit :

J'ai essayé avec aptitude, c'était pire, et il ne trouvait pas de
solution convenable.
Il y a peut-être bien des dépendances manquantes pour ce paquet.



j'ai essayé toutes le combines trouvées sur le net, rien ne marche
(d'ailleurs vu le nombre de manips différentes trouvées cela ne m'étonne
pas)
je n'ai plus que la solution de recompiler toutes les librairies sous
Wheezy, mais là je cale, pas assez doué, pas assez de temps.

Cela me pose un réel problème, car toute l'informatique de notre groupe
tourne sous linux depuis plus de 10 ans, et nous sommes obligés de nous
connecté sous citrix à la maison mère .

les clients citrix pour linux sont des vielles daubes, tournant sous
32bits, jamais retravaillées, juste le packaging qui est remis à jour !
je pense que cela doit être la même chose sous win....

je reste dans la galère !

Gerard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme