Clignotement cellule + onglet feuille

Le
Apitos
Bonsoir,

Dans la feuille rendez-vous RDV j'ai :

Cellule A1 : date1
Cellule A2 : date2
Cellule B2 : la formule = DATEDIF(A1;A2;"d")

- J'aimerais avoir dans la colonne C2 un commentaire me signalant
qu'il me reste tant de jour avant la date limite en A2

- Avant trois jour de la date2 la cellule C2 clignote en jaune et
blanc ainsi que l'onglet de la feuille RDV.

- Le jour J, C3 ainsi que l'onglet RDV clignotent en rouge.

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4750431
Bonsoir,

Pour la différence entre A2 et A1, il suffit d'écrire ¢-A1

Le clignotement de plusieurs cellules va être lourd à gérer. Une
simple MFC doit suffire.

http://boisgontierjacques.free.fr/pages_site/mfc.htm#AlerteDate

Pour modifier la couleur d'un onglet:

Sheets("Feuil1").Tab.ColorIndex = 4

JB

On 10 sep, 22:58, Apitos
Bonsoir,

Dans la feuille rendez-vous RDV j'ai :

Cellule A1 : date1
Cellule A2 : date2
Cellule B2 : la formule = DATEDIF(A1;A2;"d")

- J'aimerais avoir dans la colonne C2 un commentaire me signalant
qu'il me reste tant de jour avant la date limite en A2

- Avant trois jour de la date2 la cellule C2 clignote en jaune et
blanc ainsi que l'onglet de la feuille RDV.

- Le jour J, C3 ainsi que l'onglet RDV clignotent en rouge.

Merci.


Apitos
Le #4750351
J'ai pas bien saisi ton exemple.

Je voulais l'adapter a mon cas mais ...

et pour la couleur de l'onglet :

il faut le mettre dans evenement woksheet_change ?
Apitos
Le #4750071
Un petit exemple sera le bienvenu.
JB
Le #4749801
Bonjour,

http://cjoint.com/?jlopz2BKl0

JB


On 11 sep, 10:39, Apitos
Un petit exemple sera le bienvenu.


Apitos
Le #4749191
Merci JB.

Peut-on accompagnié du texte avec du MFC ?

Par exemple :

- pour la premiere couleur : Attention il vous reste 3 jours

- pour la deuxieme couleur : Attention votre rendez-vous est demain

Merci.
JB
Le #4749131
Bonjour,

Il faut une forule dans une cellule:

=SI(A2-AUJOURDHUI()<=3;"Il reste "&A2-AUJOURDHUI() & "jour(s)";"")

JB

On 12 sep, 01:19, Apitos
Merci JB.

Peut-on accompagnié du texte avec du MFC ?

Par exemple :

- pour la premiere couleur : Attention il vous reste 3 jours

- pour la deuxieme couleur : Attention votre rendez-vous est demain

Merci.


Apitos
Le #4747771
Voila j'ai fait cet exemple, mais les cellules sont tout le temps en
jaune ...

http://cjoint.com/?jnaXyut6BF
JB
Le #4747721
Bonjour,

http://cjoint.com/?jnhhYIBZcZ

JB

On 13 sep, 01:21, Apitos
Voila j'ai fait cet exemple, mais les cellules sont tout le temps en
jaune ...

http://cjoint.com/?jnaXyut6BF


Apitos
Le #4698441
Merci JB.

Je voulais que le test soit fait sur la date inferieur la plus proche
à la date d'aujourd'hui, dans toute la Col A des date, et non pas
seuleument sur A3 ...

Sub auto_open()

al = Sheets(1).[A3] - Date
If al = 1 Or al = 0 Then
MsgBox "Alerte à " & al
Sheets(1).Tab.ColorIndex = 3
ElseIf al > 1 And al <= 3 Then
MsgBox "Alerte à " & al
Sheets(1).Tab.ColorIndex = 4
Else
MsgBox "Alerte à " & al
Sheets(1).Tab.ColorIndex = xlNone
End If
End Sub

Merci.
Apitos
Le #4692221
Un réponse, si c'est possible !
Publicité
Poster une réponse
Anonyme