Clonage partition (un peu long, desole)

Le
Michel MARTIN
Bonjour,
je viens chercher un peu d'aide, car depuis quelques jours, je galère
pas mal.
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
est partitionné exactement de la même manière, hormis la grandeur de
chaque partition (pratiquement le double pour chacune d'elle).
Je tente désespérément de copier la partition XP vers le nouveau DD. A
savoir, même partition (la 2e), et même lettre (E:, la D étant réservée
à un éventuel 2e disque dur avec partition active, comme au bon vieux
temps). Bref, tout pareil, pour ne pas trop mélanger les pinceaux.
Le problème est que je n'arrive pas à cloner correctement ce XP, que ce
soit avec Ghost de Norton, Partition suite et Cloneur Expert de
MicroApplication (en réalité, Acronis). Et pour certains, tentatives
sous Windows et sous Dos.
Hors, si la partition semble correctement clonée, Windows XP démarre,
puis s'arrête au moment où il devrait me présenter le choix des
utilisateurs, et me demander le mot de passe (soit après la "2e
ouverture" de fenêtre).
Impossible d'aller plus loin. Même en mode sans échec, l'arrêt a lieu au
même endroit.
D'après quelques recherches sur Internet, il semblerait que ce soit dû à
une question de propriété. Et que le logiciel NewSID devrait en venir à
bout. Est-ce bien là le problème?
Mais comme je maitrise mal la langue anglaise (même si je sais la lire,
il y a beaucoup de choses techniques auxquelles il faudrait faire très
attention), je n'ose m'aventurer à modifier les propriétés, de peur de
modifier en même temps celles de W2K qui fonctionne très bien (W2k a été
entièrement *réinstallé*, ainsi que tous les logiciels que j'utilise, à
cause de problèmes survenus lors de la découverte d'un rootkit, qui
même supprimé correctement, me laissait "pas trop tranquille").
Ma question est: si aucune solution ne peut être trouvée, à quoi servent
donc tous ces logiciels sencés cloner ou copier une partition. Mais je
pense que lors du clonage, il doit *peut-être* y avoir quelque chose que
j'oublie?
Je précise que les clonages ont été tentés avec 1 ou 2 DD installés, et
inversions des 2 DD installés lorsque la 1e solution ne donnait pas
satisfaction. De façon à bien prendre en compte un OS dans sa partition
et avec sa lettre, si éventuellement il pouvait y avoir une différence.
Comment faire pour ne pas à avoir à réinstaller XP, qui sera la dernière
solution si aucune autre ne donne satisfaction (mon PB est que je
dispose de beaucoup de périphériques, de beaucoup de logiciels divers,
et que je voudrais éviter toutes ces installations, si c'était
possible).
Merci d'avance pour tous les conseils que vous pourrez me donner.
Amicalement, Michel
--
http://martin.michel47.free.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
willpot
Le #1028459
j' ai utilisé Drive2Drive avec Win98
mais avec XP il existe Casper du même constructeur
http://www.fssdev.com/products/casper/
la version d'essai: http://www.fssdev.com/products/casper/trial/
et son guide:
http://download4.fssdev.com/download/userguide/fss_casper_te_40_userguide.pdf


"Michel MARTIN" 1hguerwbzk2rt.l0bzdjhr1kl3$
Bonjour,
je viens chercher un peu d'aide, car depuis quelques jours, je galère
pas mal.
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
est partitionné exactement de la même manière, hormis la grandeur de
chaque partition (pratiquement le double pour chacune d'elle).
Je tente désespérément de copier la partition XP vers le nouveau DD. A
savoir, même partition (la 2e), et même lettre (E:, la D étant réservée
à un éventuel 2e disque dur avec partition active, comme au bon vieux
temps). Bref, tout pareil, pour ne pas trop mélanger les pinceaux.
Le problème est que je n'arrive pas à cloner correctement ce XP, que ce
soit avec Ghost de Norton, Partition suite et Cloneur Expert de
MicroApplication (en réalité, Acronis). Et pour certains, tentatives
sous Windows et sous Dos.
Hors, si la partition semble correctement clonée, Windows XP démarre,
puis s'arrête au moment où il devrait me présenter le choix des
utilisateurs, et me demander le mot de passe (soit après la "2e
ouverture" de fenêtre).
Impossible d'aller plus loin. Même en mode sans échec, l'arrêt a lieu au
même endroit.
D'après quelques recherches sur Internet, il semblerait que ce soit dû à
une question de propriété. Et que le logiciel NewSID devrait en venir à
bout. Est-ce bien là le problème?
Mais comme je maitrise mal la langue anglaise (même si je sais la lire,
il y a beaucoup de choses techniques auxquelles il faudrait faire très
attention), je n'ose m'aventurer à modifier les propriétés, de peur de
modifier en même temps celles de W2K qui fonctionne très bien (W2k a été
entièrement *réinstallé*, ainsi que tous les logiciels que j'utilise, à
cause de problèmes survenus lors de la découverte d'un rootkit, qui
même supprimé correctement, me laissait "pas trop tranquille").
Ma question est: si aucune solution ne peut être trouvée, à quoi servent
donc tous ces logiciels sencés cloner ou copier une partition. Mais je
pense que lors du clonage, il doit *peut-être* y avoir quelque chose que
j'oublie?
Je précise que les clonages ont été tentés avec 1 ou 2 DD installés, et
inversions des 2 DD installés lorsque la 1e solution ne donnait pas
satisfaction. De façon à bien prendre en compte un OS dans sa partition
et avec sa lettre, si éventuellement il pouvait y avoir une différence.
Comment faire pour ne pas à avoir à réinstaller XP, qui sera la dernière
solution si aucune autre ne donne satisfaction (mon PB est que je
dispose de beaucoup de périphériques, de beaucoup de logiciels divers,
et que je voudrais éviter toutes ces installations, si c'était
possible).
Merci d'avance pour tous les conseils que vous pourrez me donner.
Amicalement, Michel
--
http://martin.michel47.free.fr/


Norbert
Le #1028458

Bonjour,
je viens chercher un peu d'aide, car depuis quelques jours, je galère
pas mal.
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque
DD est partitionné exactement de la même manière, hormis la grandeur
de chaque partition (pratiquement le double pour chacune d'elle).
Je tente désespérément de copier la partition XP vers le nouveau DD. A
savoir, même partition (la 2e), et même lettre (E:, la D étant
réservée à un éventuel 2e disque dur avec partition active, comme au
bon vieux temps). Bref, tout pareil, pour ne pas trop mélanger les
pinceaux.
Le problème est que je n'arrive pas à cloner correctement ce XP, que
ce soit avec Ghost de Norton, Partition suite et Cloneur Expert de
MicroApplication (en réalité, Acronis). Et pour certains, tentatives
sous Windows et sous Dos.


On dirait que ton système s'emmèle les pinceaux entre l'ancien et le nouveau
XP.
Je te propose le mode opératoire suivant :
- dans le PC, seulement l'ancien disque.
- arrêter le PC, monter le 2ème disque, cloner sous DOS (ou directement avec
Acronis)
- démonter le 1er disque
- redémarrer le PC.

Ca devrait éviter une cohabitation délicate entre deux OS identiques.

--
à bientôt (enlever les X pour me répondre)
================================= les secrets de l'univers http://nrumiano.free.fr
un atlas de l'univers http://atunivers.free.fr
images du ciel http://images.ciel.free.fr
==================================

Michel MARTIN
Le #1028457
Le Fri, 11 Jan 2008 19:04:09 +0100, willpot a écrit dans

j' ai utilisé Drive2Drive avec Win98
mais avec XP il existe Casper du même constructeur
http://www.fssdev.com/products/casper/
la version d'essai: http://www.fssdev.com/products/casper/trial/
et son guide:
http://download4.fssdev.com/download/userguide/fss_casper_te_40_userguide.pdf

"Michel MARTIN" 1hguerwbzk2rt.l0bzdjhr1kl3$
Bonjour,
je viens chercher un peu d'aide, car depuis quelques jours, je galère
pas mal.
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
....


Amicalement, Michel
--
http://martin.michel47.free.fr/




Bonsoir,
merci, je vais essayer tout de suite.
Amicalement, Michel
--
http://martin.michel47.free.fr/


Michel MARTIN
Le #1028456
Le Fri, 11 Jan 2008 20:04:19 +0100, Michel MARTIN a écrit dans

Le Fri, 11 Jan 2008 19:04:09 +0100, willpot a écrit dans

j' ai utilisé Drive2Drive avec Win98
mais avec XP il existe Casper du même constructeur
http://www.fssdev.com/products/casper/
la version d'essai: http://www.fssdev.com/products/casper/trial/
et son guide:
http://download4.fssdev.com/download/userguide/fss_casper_te_40_userguide.pdf

"Michel MARTIN" 1hguerwbzk2rt.l0bzdjhr1kl3$
Bonjour,
je viens chercher un peu d'aide, car depuis quelques jours, je galère
pas mal.
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
....


Amicalement, Michel



Bonsoir,
merci, je vais essayer tout de suite.
Amicalement, Michel



Re-Bonsoir,
toujours pareil.
Il s'arrête au même endroit.
Merci quand même.
Amicalement, Michel
--
http://martin.michel47.free.fr/



Michel_D
Le #1028455
Bonjour,
je viens chercher un peu d'aide, car depuis quelques jours, je galère
pas mal.
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
est partitionné exactement de la même manière, hormis la grandeur de
chaque partition (pratiquement le double pour chacune d'elle).
Je tente désespérément de copier la partition XP vers le nouveau DD. A
savoir, même partition (la 2e), et même lettre (E:, la D étant réservée
à un éventuel 2e disque dur avec partition active, comme au bon vieux
temps). Bref, tout pareil, pour ne pas trop mélanger les pinceaux.
Le problème est que je n'arrive pas à cloner correctement ce XP, que ce
soit avec Ghost de Norton, Partition suite et Cloneur Expert de
MicroApplication (en réalité, Acronis). Et pour certains, tentatives
sous Windows et sous Dos.
Hors, si la partition semble correctement clonée, Windows XP démarre,
puis s'arrête au moment où il devrait me présenter le choix des
utilisateurs, et me demander le mot de passe (soit après la "2e
ouverture" de fenêtre).
Impossible d'aller plus loin. Même en mode sans échec, l'arrêt a lieu au
même endroit.
D'après quelques recherches sur Internet, il semblerait que ce soit dû à
une question de propriété. Et que le logiciel NewSID devrait en venir à
bout. Est-ce bien là le problème?
Mais comme je maitrise mal la langue anglaise (même si je sais la lire,
il y a beaucoup de choses techniques auxquelles il faudrait faire très
attention), je n'ose m'aventurer à modifier les propriétés, de peur de
modifier en même temps celles de W2K qui fonctionne très bien (W2k a été
entièrement *réinstallé*, ainsi que tous les logiciels que j'utilise, à
cause de problèmes survenus lors de la découverte d'un rootkit, qui
même supprimé correctement, me laissait "pas trop tranquille").
Ma question est: si aucune solution ne peut être trouvée, à quoi servent
donc tous ces logiciels sencés cloner ou copier une partition. Mais je
pense que lors du clonage, il doit *peut-être* y avoir quelque chose que
j'oublie?
Je précise que les clonages ont été tentés avec 1 ou 2 DD installés, et
inversions des 2 DD installés lorsque la 1e solution ne donnait pas
satisfaction. De façon à bien prendre en compte un OS dans sa partition
et avec sa lettre, si éventuellement il pouvait y avoir une différence.
Comment faire pour ne pas à avoir à réinstaller XP, qui sera la dernière
solution si aucune autre ne donne satisfaction (mon PB est que je
dispose de beaucoup de périphériques, de beaucoup de logiciels divers,
et que je voudrais éviter toutes ces installations, si c'était
possible).
Merci d'avance pour tous les conseils que vous pourrez me donner.
Amicalement, Michel


Bon essaye la technique suivante avec les deux disques connectés, ce qui
sous-entend que ton nouveau disque est bien reconnu sous XP, d'ailleurs
je te recommande de refaire le partionnement s'il n'a pas été fait sous
XP, ensuite le clonage classique sur une partition que tu auras créé
(repérer la lettre du volume/partition ou tu auras efectuer ton clonage)
puis tu rajoute une ligne dans le boot.ini pour pouvoir atteindre ton
clone et c'est ici qu'il vérifier que ton clone posséde bien la lettre
du systéme originel et si ce n'est pas le cas tu échange la lettre au
niveau de la bdr à l'emplacement suivant :
[HKEY_LOCAL_MACHINESYSTEMMountedDevices]

Exemple avec un système originel en C: cloné sur une partition E:
Avant la manip :
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINESYSTEMMountedDevices]
"\DosDevices\C:"=hex:7a,00,80,ba,00,c2,39,7f,03,00,00,00
"\DosDevices\E:"=hex:f4,4c,b4,70,00,96,a7,3f,01,00,00,00

Aprés la manip :
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINESYSTEMMountedDevices]
"\DosDevices\E:"=hex:7a,00,80,ba,00,c2,39,7f,03,00,00,00
"\DosDevices\C:"=hex:f4,4c,b4,70,00,96,a7,3f,01,00,00,00

Ensuite il faut redémarrer et théoriquement ton clone posséde la lettre
du système originel.

Jean-Claude BELLAMY
Le #1028283
"Michel MARTIN" news:1hguerwbzk2rt.l0bzdjhr1kl3$
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
est partitionné exactement de la même manière, hormis la grandeur de
chaque partition (pratiquement le double pour chacune d'elle).
Je tente désespérément de copier la partition XP vers le nouveau DD. A
savoir, même partition (la 2e), et même lettre (E:, la D étant réservée
à un éventuel 2e disque dur avec partition active, comme au bon vieux
temps). Bref, tout pareil, pour ne pas trop mélanger les pinceaux.
Le problème est que je n'arrive pas à cloner correctement ce XP, que ce
soit avec Ghost de Norton, Partition suite et Cloneur Expert de
MicroApplication (en réalité, Acronis). [...]


Bizarre, bizarre, car j'ai fait cela il y a un peu plus d'un an avec "True
Image" (ex "Cloneur Expert) et la manip s'est déroulée "nasodigitalement"
...
Tu as du faire une conceté quelque part ;-)

Voici comment j'ai procédé :
Sur un des mes portables (un HP Pavilion zx 5270EA, datant d'octobre 2004,
donc une antiquité !), j'avais un DD de 80 Go seulement, vu tout ce qu'il y
a d'installé dessus.
Mon DD de 80 Go (en réalité 74 Go) était partagé en 5 partitions :
- 1 primaire NTFS de 10 Go pour Windows
- 1 logique NTFS de 16 Go pour les applis
- 1 logique NTFS de 10 Go pour les documents
- 1 logique NTFS de 36 Go pour les OS virtuels
- 1 logique FAT32 de 2 Go pour le swap

J'ai donc décidé de changer de DD, après avoir constaté avec plaisir que le
DD sur ce portable HP était directement accessible par une simple trappe
sous le PC.
J'ai pris un 120 Go (en réalité 112 Go) Hitachi (je n'ai pas trouvé plus
gros à l'époque)

Pour effectuer les transferts, j'ai inséré le 2ème DD (celui de 112 Go) dans
un boitier USB prévu pour disques de 2"1/2 (marque Vanguard, 25 euros) que
j'ai branché sur un port USB du portable.

Ensuite, j'ai installé "True Image" (à l'époque la version 9, maintenant
j'ai la V10) de chez Acronis, diffusé par Micro Application (auparavant, ce
logicel s'appelait "Cloneur Expert", dont j'ai toujours dit le plus grand
bien d'ailleurs). Il m'a coûté 50 euros dans un hypermarché proche de chez
moi.
http://www.microapp.com/logiciel_acronis_true_image_10_7945.html
(pour info, le prix actuel de la version 10 est tombé à 35 euros)

Mon intention était de conserver la proportion d'espace disque pour chaque
partition. Je voulais aussi conserver les mêmes lettres (pour des raisons
"historiques", chez moi toutes les partions applis s'appellent "I:", toutes
les partitions documents s'appellent "M:", ...)

Et bien je n'ai rien eu à faire d'autre que de cliquer successivement sur :
"Cloner un disque"
"Automatique"
"Suivant"
"Démarrer"
(authentique, je n'ai RIEN eu à définir sur les types, noms, lettres,
tailles, ... des partitons)

Mon PC a alors redémarré, les copies de partition se sont faites (dans la
phase où Windows est en mode VGA, avant démarrage du shell) bien gentiment
(pour 80 Go, cela a pris environ 3 heures), puis le PC s'est arrêté.
J'ai alors permuté PHYSIQUEMENT les 2 disques (c'est la phase la plus
pénible ! :-) )
J'ai rebooté le PC une 1ère fois, True Image a alors fait un mini traitement
dans la phase VGA (je suppose au niveau MBR).

Puis reboot final , sans broncher, XP s'est ouvert du 1er coup, tous les
services ont démarré (Apache, MySQL, ...) accès réseau, WIFI , ..., VMWare
(mes serveurs NT4 et W2K3), .... toutes mes partitions (agrandies de 50%)
ont bien conservé leurs lettres ...
Et XP ne m'a pas demandé de réactivation (ce qui est normal en fait, vu que
seul le DD a été modifié).


As-tu procédé de la même façon ?

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org

Michel_D
Le #1028282
"Michel MARTIN" news:1hguerwbzk2rt.l0bzdjhr1kl3$
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
est partitionné exactement de la même manière, hormis la grandeur de
chaque partition (pratiquement le double pour chacune d'elle).
Je tente désespérément de copier la partition XP vers le nouveau DD. A
savoir, même partition (la 2e), et même lettre (E:, la D étant réservée
à un éventuel 2e disque dur avec partition active, comme au bon vieux
temps). Bref, tout pareil, pour ne pas trop mélanger les pinceaux.
Le problème est que je n'arrive pas à cloner correctement ce XP, que ce
soit avec Ghost de Norton, Partition suite et Cloneur Expert de
MicroApplication (en réalité, Acronis). [...]


Bizarre, bizarre, car j'ai fait cela il y a un peu plus d'un an avec
"True Image" (ex "Cloneur Expert) et la manip s'est déroulée
"nasodigitalement" ....
Tu as du faire une conceté quelque part ;-)

Voici comment j'ai procédé :
Sur un des mes portables (un HP Pavilion zx 5270EA, datant d'octobre
2004, donc une antiquité !), j'avais un DD de 80 Go seulement, vu tout
ce qu'il y a d'installé dessus.
Mon DD de 80 Go (en réalité 74 Go) était partagé en 5 partitions :
- 1 primaire NTFS de 10 Go pour Windows
- 1 logique NTFS de 16 Go pour les applis
- 1 logique NTFS de 10 Go pour les documents
- 1 logique NTFS de 36 Go pour les OS virtuels
- 1 logique FAT32 de 2 Go pour le swap

J'ai donc décidé de changer de DD, après avoir constaté avec plaisir que
le DD sur ce portable HP était directement accessible par une simple
trappe sous le PC.
J'ai pris un 120 Go (en réalité 112 Go) Hitachi (je n'ai pas trouvé plus
gros à l'époque)

Pour effectuer les transferts, j'ai inséré le 2ème DD (celui de 112 Go)
dans un boitier USB prévu pour disques de 2"1/2 (marque Vanguard, 25
euros) que j'ai branché sur un port USB du portable.

Ensuite, j'ai installé "True Image" (à l'époque la version 9,
maintenant j'ai la V10) de chez Acronis, diffusé par Micro Application
(auparavant, ce logicel s'appelait "Cloneur Expert", dont j'ai toujours
dit le plus grand bien d'ailleurs). Il m'a coûté 50 euros dans un
hypermarché proche de chez moi.
http://www.microapp.com/logiciel_acronis_true_image_10_7945.html
(pour info, le prix actuel de la version 10 est tombé à 35 euros)

Mon intention était de conserver la proportion d'espace disque pour
chaque partition. Je voulais aussi conserver les mêmes lettres (pour
des raisons "historiques", chez moi toutes les partions applis
s'appellent "I:", toutes les partitions documents s'appellent "M:", ...)

Et bien je n'ai rien eu à faire d'autre que de cliquer successivement sur :
"Cloner un disque"
"Automatique"
"Suivant"
"Démarrer"
(authentique, je n'ai RIEN eu à définir sur les types, noms, lettres,
tailles, ... des partitons)

Mon PC a alors redémarré, les copies de partition se sont faites (dans
la phase où Windows est en mode VGA, avant démarrage du shell) bien
gentiment (pour 80 Go, cela a pris environ 3 heures), puis le PC s'est
arrêté.
J'ai alors permuté PHYSIQUEMENT les 2 disques (c'est la phase la plus
pénible ! :-) )
J'ai rebooté le PC une 1ère fois, True Image a alors fait un mini
traitement dans la phase VGA (je suppose au niveau MBR).

Puis reboot final , sans broncher, XP s'est ouvert du 1er coup, tous les
services ont démarré (Apache, MySQL, ...) accès réseau, WIFI , ...,
VMWare (mes serveurs NT4 et W2K3), .... toutes mes partitions (agrandies
de 50%) ont bien conservé leurs lettres ...
Et XP ne m'a pas demandé de réactivation (ce qui est normal en fait, vu
que seul le DD a été modifié).


As-tu procédé de la même façon ?



Son problème vient du fait qu'il a 2 OS (on remarque qu'il n'y a aucun
problème pour W2K qui équivaut à ta configuration) le problème vient
de la lettre qui est réattribuée à la parttion XP qui n'est plus située
au même endroit et donc avec un système originel en E: ,aprés le clonage
celui-ci doit surement se voir réattribuer la lettre D: si elle est
disponible et donc problème.

Une solution (avec celle que j'ai déja proposé) consisterai à attribuer
avant le clonage la lettre D: à un périphérique comme un lecteur CD/DVD
pour faire en sorte que la 1ère lettre libre disponible soit la lettre
E: correspondant à la lettre du système originel.


Michel MARTIN
Le #1028281
Le Sat, 12 Jan 2008 13:46:52 +0100, Michel_D a écrit dans

"Michel MARTIN" news:1hguerwbzk2rt.l0bzdjhr1kl3$
Je change de disque dur, pour un plus gros (250 vers 500 Go).
J'utilise 2 OS, W2k et XP. Chacun sur sa propre partition. Et chaque DD
est partitionné exactement de la même manière, hormis la grandeur de
chaque partition (pratiquement le double pour chacune d'elle).
Je tente désespérément de copier la partition XP vers le nouveau DD. A
savoir, même partition (la 2e), et même lettre (E:, la D étant réservée
à un éventuel 2e disque dur avec partition active, comme au bon vieux
temps). Bref, tout pareil, pour ne pas trop mélanger les pinceaux.
Le problème est que je n'arrive pas à cloner correctement ce XP, que ce
soit avec Ghost de Norton, Partition suite et Cloneur Expert de
MicroApplication (en réalité, Acronis). [...]


Bizarre, bizarre, car j'ai fait cela il y a un peu plus d'un an avec
"True Image" (ex "Cloneur Expert) et la manip s'est déroulée
"nasodigitalement" ....
Tu as du faire une conceté quelque part ;-)

Voici comment j'ai procédé :
Sur un des mes portables (un HP Pavilion zx 5270EA, datant d'octobre
2004, donc une antiquité !), j'avais un DD de 80 Go seulement, vu tout
ce qu'il y a d'installé dessus.
Mon DD de 80 Go (en réalité 74 Go) était partagé en 5 partitions :
- 1 primaire NTFS de 10 Go pour Windows
- 1 logique NTFS de 16 Go pour les applis
- 1 logique NTFS de 10 Go pour les documents
- 1 logique NTFS de 36 Go pour les OS virtuels
- 1 logique FAT32 de 2 Go pour le swap

J'ai donc décidé de changer de DD, après avoir constaté avec plaisir que
le DD sur ce portable HP était directement accessible par une simple
trappe sous le PC.
J'ai pris un 120 Go (en réalité 112 Go) Hitachi (je n'ai pas trouvé plus
gros à l'époque)

Pour effectuer les transferts, j'ai inséré le 2ème DD (celui de 112 Go)
dans un boitier USB prévu pour disques de 2"1/2 (marque Vanguard, 25
euros) que j'ai branché sur un port USB du portable.

Ensuite, j'ai installé "True Image" (à l'époque la version 9,
maintenant j'ai la V10) de chez Acronis, diffusé par Micro Application
(auparavant, ce logicel s'appelait "Cloneur Expert", dont j'ai toujours
dit le plus grand bien d'ailleurs). Il m'a coûté 50 euros dans un
hypermarché proche de chez moi.
http://www.microapp.com/logiciel_acronis_true_image_10_7945.html
(pour info, le prix actuel de la version 10 est tombé à 35 euros)

Mon intention était de conserver la proportion d'espace disque pour
chaque partition. Je voulais aussi conserver les mêmes lettres (pour
des raisons "historiques", chez moi toutes les partions applis
s'appellent "I:", toutes les partitions documents s'appellent "M:", ...)

Et bien je n'ai rien eu à faire d'autre que de cliquer successivement sur :
"Cloner un disque"
"Automatique"
"Suivant"
"Démarrer"
(authentique, je n'ai RIEN eu à définir sur les types, noms, lettres,
tailles, ... des partitons)

Mon PC a alors redémarré, les copies de partition se sont faites (dans
la phase où Windows est en mode VGA, avant démarrage du shell) bien
gentiment (pour 80 Go, cela a pris environ 3 heures), puis le PC s'est
arrêté.
J'ai alors permuté PHYSIQUEMENT les 2 disques (c'est la phase la plus
pénible ! :-) )
J'ai rebooté le PC une 1ère fois, True Image a alors fait un mini
traitement dans la phase VGA (je suppose au niveau MBR).

Puis reboot final , sans broncher, XP s'est ouvert du 1er coup, tous les
services ont démarré (Apache, MySQL, ...) accès réseau, WIFI , ...,
VMWare (mes serveurs NT4 et W2K3), .... toutes mes partitions (agrandies
de 50%) ont bien conservé leurs lettres ...
Et XP ne m'a pas demandé de réactivation (ce qui est normal en fait, vu
que seul le DD a été modifié).

As-tu procédé de la même façon ?


Son problème vient du fait qu'il a 2 OS (on remarque qu'il n'y a aucun
problème pour W2K qui équivaut à ta configuration) le problème vient
de la lettre qui est réattribuée à la parttion XP qui n'est plus située
au même endroit et donc avec un système originel en E: ,aprés le clonage
celui-ci doit surement se voir réattribuer la lettre D: si elle est
disponible et donc problème.

Une solution (avec celle que j'ai déja proposé) consisterai à attribuer
avant le clonage la lettre D: à un périphérique comme un lecteur CD/DVD
pour faire en sorte que la 1ère lettre libre disponible soit la lettre
E: correspondant à la lettre du système originel.



Bonjour tout le monde,
ça y est, c'est passé :-)
En fait, toutes les solutions ont été essayées, avec 1 ou 2 disques
branchés, en tentant de bloquer certaines lettres, etc....
Rien n'y faisait, à la limite, le PC démarrait bien, si je laissait les
2 DD, sous la partition clonée (sur la copie) que j'avais bien mise en
E:
(multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Windows XP" /fastdetect)

Mais après démarrage de la partie VGA (comme dit Jean-Claude), il devait
changer car XP se lançait avec l'original, qui devait théoriquement se
trouver en P ou Q, mais qui se retrouvait en E: et la copie en Q:
(vérifié avec le gestionnaire de disque, dans le panneau de
configuration)
La seule chose que je n'ai pas essayée, c'est de faire la copie totale
du disque dur, comme l'a fait Jean-Claude. Parce que, comme je l'avais
annoncé, un rootkit m'avait "modifié" mon W2k original, et j'ai préféré
le réinstaller sur un DD neuf. Et comme j'étais un peu pressé (retour de
vacances de Noël chez les enfants, beaucoup de courrier en attente, et
les voeux à envoyer, bref, je voulais aller vite *à ma façon*.
Je dois dire aussi que j'avais, dans un premier temps, fait 3 partitions
principales, et une étendue avec 5 disques logiques. Alors que l'ancien
DD avait été partitionné en 1 principale, et une étendue, contenant 7
disques logiques.
J'ai donc aussi tenté de modifier cela (après sauvegarde de tous les
fichiers; ça prend des heures, quand même) en supprimant les partitions
principales (sauf la 1ere qui fonctionnait correctement sous WX2k).
Pb là aussi, alors que W2k me laissait supprimer les disques logiques,
il me refusait la suppression des 2e et 3e partitions principales. J'ai
du faire intervenir Partition Magique pour cela.
Ensuite sous XP (l'ancien qui fonctionnait), j'ai refais les partitions,
comme avant: conservé la 1e, j'ai rajouté 1 partition étendue, puis 6
lecteurs logiques (j'ai diminué d'un lecteur pour avoir un gros lecteur
de stockage).
J'ai recopié XP, sous une partition étendue+disque logique, comme avant.
Toujours refus de se lancer, sauf si le 2e DD était branché. Ce qui
correspond à un "saut" vers l'ancien DD après démarrage.
Et puis, dans un ultime essai, j'ai tenté ce que me disais Michel_D, et
j'ai modifié la BDR, pour inverser les lettres de DD (j'avais constaté
avec W2k que les *identités* des disques/partitions étaient les mêmes
que sous XP, ce qui m'a conforté pour cet essai).
J'ai ensuite copié l'ancien XP vers le nouveau DD/partition E: avec le
Ghost sous DOS.
Bingo! ça fonctionne.
Bravo et merci à Michel_D pour sa solution.

Maintenant, une question: pourquoi les logiciels de clonage ne s'occupe
pas de cette question, ni ne préviennent de ce genre de manip à faire
pour faire fonctionner le disque cloné (la copie, l'original fonctionant
toujours)? Si la copie est "refondue" sur l'ancienne partition abimée,
par exemple, ça doit fonctionner. Mais une copie sur un autre DD, niet
de chez niet. Dans ces conditions, le clonage ne sert plus à rien, à
moins de bricoler après.

Juste une question à JCB: tu dis avoir permuté les DD après l'arrêt de
Windows: j'espère que tu as éteint le PC? avant cette manip? Car si je
comprends pour le DD en USB, je ne comprendrai pas pour celui sur la
nappe.
Car moi je l'ai fait, mais cela ne changeait rien du tout. Mais mes 2 DD
étaient sur la nappe.
Quant au "cloneur expert", je n'ai que la version 8. Peut-être là le Pb?

Encore merci à tous pour vos conseils, et surtout Michel_D qui m'a
trouvé la solution.
Amicalement, Michel
--
http://martin.michel47.free.fr/



Michel_D
Le #1028280
Le Sat, 12 Jan 2008 13:46:52 +0100, Michel_D a écrit dans


[...]

Bingo! ça fonctionne.
Bravo et merci à Michel_D pour sa solution.

Maintenant, une question: pourquoi les logiciels de clonage ne s'occupe
pas de cette question, ni ne préviennent de ce genre de manip à faire
pour faire fonctionner le disque cloné (la copie, l'original fonctionant
toujours)? Si la copie est "refondue" sur l'ancienne partition abimée,
par exemple, ça doit fonctionner. Mais une copie sur un autre DD, niet
de chez niet. Dans ces conditions, le clonage ne sert plus à rien, à
moins de bricoler après.



En fait ce sont des logiciels de restauration à la base et il s'avère
que dans certaine situation, un clonage (cas de JCB) est équivalent
à une restauration, voila pourquoi cela marche "nasodigitalement".

PS:Par contre cette problèmatique n'est du qu'à la mémorisation des
lettres attribuées aux volumes/partitions sous NT.


Juste une question à JCB: tu dis avoir permuté les DD après l'arrêt de
Windows: j'espère que tu as éteint le PC? avant cette manip? Car si je
comprends pour le DD en USB, je ne comprendrai pas pour celui sur la
nappe.
Car moi je l'ai fait, mais cela ne changeait rien du tout. Mais mes 2 DD
étaient sur la nappe.
Quant au "cloneur expert", je n'ai que la version 8. Peut-être là le Pb?

Encore merci à tous pour vos conseils, et surtout Michel_D qui m'a
trouvé la solution.
Amicalement, Michel


Michel_D
Le #1025747
Le Sat, 12 Jan 2008 13:46:52 +0100, Michel_D a écrit dans


[...]

Bingo! ça fonctionne.
Bravo et merci à Michel_D pour sa solution.

Maintenant, une question: pourquoi les logiciels de clonage ne s'occupe
pas de cette question, ni ne préviennent de ce genre de manip à faire
pour faire fonctionner le disque cloné (la copie, l'original fonctionant
toujours)? Si la copie est "refondue" sur l'ancienne partition abimée,
par exemple, ça doit fonctionner. Mais une copie sur un autre DD, niet
de chez niet. Dans ces conditions, le clonage ne sert plus à rien, à
moins de bricoler après.



En fait ce sont des logiciels de restauration à la base et il s'avère
que dans certaine situation, un clonage (cas de JCB) est équivalent
à une restauration, voila pourquoi cela marche "nasodigitalement".

PS:Par contre cette problèmatique n'est du qu'à la mémorisation des
lettres attribuées aux volumes/partitions sous NT.



Je reformule mon PS (qui pourrait paraitre trop exclusif):
La mémorisation des lettres sous NT a rajouté une condition supplémentaire
à prendre en compte pour réussir les opérations de clonage.


Juste une question à JCB: tu dis avoir permuté les DD après l'arrêt de
Windows: j'espère que tu as éteint le PC? avant cette manip? Car si je
comprends pour le DD en USB, je ne comprendrai pas pour celui sur la
nappe.
Car moi je l'ai fait, mais cela ne changeait rien du tout. Mais mes 2 DD
étaient sur la nappe.
Quant au "cloneur expert", je n'ai que la version 8. Peut-être là le Pb?

Encore merci à tous pour vos conseils, et surtout Michel_D qui m'a
trouvé la solution.
Amicalement, Michel




Publicité
Poster une réponse
Anonyme