clone d'un système: problème avec systemd au boot

Le
Gaëtan PERRIER
Bonjour,

Je viens de changer le disque dur de mon portable en clonant (avec fsarchiv=
er
savedir/restdir) son disque vers le nouveau puis en réinstallant grub ave=
c un
chroot. Mais au boot suivant, bien que la machine démarre, j'ai plein d'e=
rreurs
systemd du genre:

Failed to mount Configuration File System

Failed to mount FUSE Control File System

Failed to start File System Check on Root Device

etc.

Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?

A+

Gaëtan
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Simon Cavey
Le #26391836
Si le nouveau disque dur a été formaté, il doit y avoir un problè me d'UUID.

Solution booter sur un système live. exécuter la commande

sudo blkid

identifier les UUID des partitions.
monter le disque dur fraichement restauré
mettre à jour les fichier de config avec les nouveau UUID:

/boot/grub/grub.cfg
et surtout
/etc/fstab

Et ça devrait pouvoir fonctionner à nouveau correctement.


Le 08/03/2016 01:06, Gaëtan PERRIER a écrit :
Bonjour,

Je viens de changer le disque dur de mon portable en clonant (avec fsar chiver
savedir/restdir) son disque vers le nouveau puis en réinstallant grub avec un
chroot. Mais au boot suivant, bien que la machine démarre, j'ai plein d'erreurs
systemd du genre:

Failed to mount Configuration File System

Failed to mount FUSE Control File System

Failed to start File System Check on Root Device

etc.

Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?

A+

Gaëtan

pmenier
Le #26391837
Le 08/03/2016 01:06, Gaëtan PERRIER a écrit :
Bonjour,

Je viens de changer le disque dur de mon portable en clonant (avec fsarchiver
savedir/restdir) son disque vers le nouveau puis en réinstallant grub avec un
chroot. Mais au boot suivant, bien que la machine démarre, j'ai plein d'erreurs
systemd du genre:

Failed to mount Configuration File System

Failed to mount FUSE Control File System

Failed to start File System Check on Root Device

etc.

Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?

A+

Gaëtan




Salut

J'ai déjà fait ce genre de manip avec clonezilla sans rencontrer de
problemes. Si tu as toujours l'ancien disque sous la main ça pourrait
valoir le coup d'essayer ...
De plus pas besoin de bouiner pour réinstaller GRUB avec cet outil.

Patrick
Gaëtan PERRIER
Le #26391940
Oui j'avais déjà modifié les UUID à divers endroits
(/etc/default/grub, /etc/fstab, /etc/initramfs-tools) mais sans succès.

A+

Gaëtan

Le Tue, 8 Mar 2016 07:45:53 +0100
Simon Cavey
Si le nouveau disque dur a été formaté, il doit y avoir un problè me d'UUID.

Solution booter sur un système live. exécuter la commande

sudo blkid

identifier les UUID des partitions.
monter le disque dur fraichement restauré
mettre à jour les fichier de config avec les nouveau UUID:

/boot/grub/grub.cfg
et surtout
/etc/fstab

Et ça devrait pouvoir fonctionner à nouveau correctement.


Le 08/03/2016 01:06, Gaëtan PERRIER a écrit :
> Bonjour,
>
> Je viens de changer le disque dur de mon portable en clonant (avec
> fsarchiver savedir/restdir) son disque vers le nouveau puis en
> réinstallant grub avec un chroot. Mais au boot suivant, bien que la
> machine démarre, j'ai plein d'erreurs systemd du genre:
>
> Failed to mount Configuration File System
>
> Failed to mount FUSE Control File System
>
> Failed to start File System Check on Root Device
>
> etc.
>
> Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?
>
> A+
>
> Gaëtan
>

Gaëtan PERRIER
Le #26391939
Le Tue, 08 Mar 2016 07:44:09 +0100
pmenier
Le 08/03/2016 01:06, Gaëtan PERRIER a écrit :
> Bonjour,
>
> Je viens de changer le disque dur de mon portable en clonant (avec
> fsarchiver savedir/restdir) son disque vers le nouveau puis en
> réinstallant grub avec un chroot. Mais au boot suivant, bien que la
> machine démarre, j'ai plein d'erreurs systemd du genre:
>
> Failed to mount Configuration File System
>
> Failed to mount FUSE Control File System
>
> Failed to start File System Check on Root Device
>
> etc.
>
> Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?
>
> A+
>
> Gaëtan
>
>
Salut

J'ai déjà fait ce genre de manip avec clonezilla sans rencontrer de
problemes. Si tu as toujours l'ancien disque sous la main ça pourrait
valoir le coup d'essayer ...
De plus pas besoin de bouiner pour réinstaller GRUB avec cet outil.

Patrick




Je garde éventuellement cette solution pour plus tard mais jusqu'à main tenant
j'ai toujours transféré mes systèmes par copie + chroot pour grub san s aucun
soucis. C'est la première fois que ça me fait ça ...

A+

Gaëtan
Gaëtan PERRIER
Le #26391954
Le Tue, 8 Mar 2016 01:06:41 +0100
Gaëtan PERRIER
Bonjour,

Je viens de changer le disque dur de mon portable en clonant (avec fsarch iver
savedir/restdir) son disque vers le nouveau puis en réinstallant grub a vec un
chroot. Mais au boot suivant, bien que la machine démarre, j'ai plein
d'erreurs systemd du genre:

Failed to mount Configuration File System

Failed to mount FUSE Control File System

Failed to start File System Check on Root Device

etc.

Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?



Ce qui est bizarre c'est qu'une fois démarré si je fais un systemctl -- failed
tout est ok ...

Gaëtan
Gaëtan PERRIER
Le #26391970
Bon en fait le problème est plus grave, car je constate des perfs sur le
nouvel SSD totalement anormales (<100Mo/s).
Donc y a vraiment un truc qui merde... :(

Gaëtan
Gaëtan PERRIER
Le #26391972
Seul le fichier /etc/blkid.tab n'est pas à jour mais je ne sais pas à q uoi il
sert ?

Le Tue, 8 Mar 2016 21:02:18 +0100
Gaëtan PERRIER
Oui j'avais déjà modifié les UUID à divers endroits
(/etc/default/grub, /etc/fstab, /etc/initramfs-tools) mais sans succès.

A+

Gaëtan

Le Tue, 8 Mar 2016 07:45:53 +0100
Simon Cavey
> Si le nouveau disque dur a été formaté, il doit y avoir un probl ème d'UUID.
>
> Solution booter sur un système live. exécuter la commande
>
> sudo blkid
>
> identifier les UUID des partitions.
> monter le disque dur fraichement restauré
> mettre à jour les fichier de config avec les nouveau UUID:
>
> /boot/grub/grub.cfg
> et surtout
> /etc/fstab
>
> Et ça devrait pouvoir fonctionner à nouveau correctement.
>
>
> Le 08/03/2016 01:06, Gaëtan PERRIER a écrit :
> > Bonjour,
> >
> > Je viens de changer le disque dur de mon portable en clonant (avec
> > fsarchiver savedir/restdir) son disque vers le nouveau puis en
> > réinstallant grub avec un chroot. Mais au boot suivant, bien que la
> > machine démarre, j'ai plein d'erreurs systemd du genre:
> >
> > Failed to mount Configuration File System
> >
> > Failed to mount FUSE Control File System
> >
> > Failed to start File System Check on Root Device
> >
> > etc.
> >
> > Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?
> >
> > A+
> >
> > Gaëtan
> >
>
Gaëtan PERRIER
Le #26391974
Le Tue, 8 Mar 2016 01:06:41 +0100
Gaëtan PERRIER
Bonjour,

Je viens de changer le disque dur de mon portable en clonant (avec fsarch iver
savedir/restdir) son disque vers le nouveau puis en réinstallant grub a vec un
chroot. Mais au boot suivant, bien que la machine démarre, j'ai plein
d'erreurs systemd du genre:

Failed to mount Configuration File System

Failed to mount FUSE Control File System

Failed to start File System Check on Root Device

etc.

Vu que j'entrave que dalle à systemd je ne sais pas trop quoi faire ?

A+

Gaëtan



Alors finalement j'ai regardé plus attentivement les log sur l'ancien SSD et
le problème existait déjà. C'est apparu avec la mise à jour de syst emd 228-6
vers 229-2.
Par contre ça n'explique pas mon problème de perf sur le nouveau SSD ...

Gaëtan
Gaëtan PERRIER
Le #26392103
Le Wed, 9 Mar 2016 02:03:51 +0100
Gaëtan PERRIER
Alors finalement j'ai regardé plus attentivement les log sur l'ancien S SD et
le problème existait déjà. C'est apparu avec la mise à jour de sy stemd 228-6
vers 229-2.



Je viens de tester en downgradant vers 228-6 et le problème disparaît p ar
contre j'ai un petit freeze au début du boot.

Gaëtan
Gaëtan PERRIER
Le #26392110
Le Wed, 9 Mar 2016 02:03:51 +0100
Gaëtan PERRIER
Par contre ça n'explique pas mon problème de perf sur le nouveau SSD ...




Finalement les perf sont redevenues normales après un certain temps ...

A+

Gaëtan
Publicité
Poster une réponse
Anonyme