Clonezilla : clonage d'une image vers un disque sur des architectures différen tes

Le
Francois Lafont
Bonjour à tous,

J'ai un PC Dell Optiplex 740 dans lequel se trouve une partition XP-PRO
(sda1) et une partition Linux (sda2). Au démarrage, Grub permet de
choisir l'OS que l'on souhaite charger. Voilà, ça c'est la source. J'ai
fait avec Clonezilla une image de la partition sda1 (XP-PRO) uniquement.
C'est celle-là qui m'intéresse dans ce problème.

#--
Source:

sda = <--><-->
sda1: XP-PRO sda2: Linux
(J'ai une image de sda1 via Clonezilla.)
#--



Quant à la machine source, en fait, c'est une machine virtuelle
Virtualbox. Je voudrais, toujours avec Clonezilla, avoir ceci :

#--
Cible: la machin virtuelle Virtualbox

sda = <-->
sda1: XP-PRO

où sda1 est le clone du sda1 de la machine source.
#--

Est-ce possible ? Si oui, comment faire ?

J'ai déjà fait plusieurs tentatives ratées. J'ai tenté un « restaure
image vers partition » en mode expert mais les options ne sont pas
toujours très claires pour moi. Une fois, je me suis retrouvé avec un
Grub sur la machine cible qui plantait (alors que je ne veux pas de Grub
dans la machine cible vu qu'elle n'a qu'une seule partition). J'avais
tenté de remettre un MBR "par défaut" avec mon CD de Windows XP mais
dans ce cas le démarrage plantait aussi (aucun message d'erreur, juste
un écran noir et pas de lancement de Windows).

Je sais bien que le sda1 source est un XP calibré pour l'architecture de
mon Dell, alors est-ce que mon clonage n'est tout simplement pas
possible car, même en supposant que je fais bien les choses lors de mon
clonage, c'est un XP-PRO Dell-adapté que j'aurai et pas
Virtualbox-adapté de sorte que le démarrage ne peut pas marcher ?

Merci d'avance pour votre aide.


--
François Lafont
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
YBM
Le #23497971
Francois Lafont a écrit :
[...] Une fois, je me suis retrouvé avec un
Grub sur la machine cible qui plantait (alors que je ne veux pas de Grub
dans la machine cible vu qu'elle n'a qu'une seule partition)



Une seule partition ou pas, tu ne pourras pas démarrer un noyau Linux
si GRUB n'intervient pas. Pour le reste je n'ai pas creusé, car c'est
déjà la base à prendre en compte.
Philippe Weill
Le #23498161
Le 25/06/2011 02:59, Francois Lafont a écrit :
Bonjour à tous,

J'ai un PC Dell Optiplex 740 dans lequel se trouve une partition XP-PRO
(sda1) et une partition Linux (sda2). Au démarrage, Grub permet de
choisir l'OS que l'on souhaite charger. Voilà, ça c'est la source. J'ai
fait avec Clonezilla une image de la partition sda1 (XP-PRO) uniquement.
C'est celle-là qui m'intéresse dans ce problème.

#--------------------------------------------------
Source:

sda =<-----------------><----------------->
sda1: XP-PRO sda2: Linux
(J'ai une image de sda1 via Clonezilla.)
#--------------------------------------------------



Quant à la machine source, en fait, c'est une machine virtuelle
Virtualbox. Je voudrais, toujours avec Clonezilla, avoir ceci :

#--------------------------------------------------
Cible: la machin virtuelle Virtualbox

sda =<----------------->
sda1: XP-PRO

où sda1 est le clone du sda1 de la machine source.
#--------------------------------------------------

Est-ce possible ? Si oui, comment faire ?

J'ai déjà fait plusieurs tentatives ratées. J'ai tenté un « restaure
image vers partition » en mode expert mais les options ne sont pas
toujours très claires pour moi. Une fois, je me suis retrouvé avec un
Grub sur la machine cible qui plantait (alors que je ne veux pas de Grub
dans la machine cible vu qu'elle n'a qu'une seule partition). J'avais
tenté de remettre un MBR "par défaut" avec mon CD de Windows XP mais
dans ce cas le démarrage plantait aussi (aucun message d'erreur, juste
un écran noir et pas de lancement de Windows).

Je sais bien que le sda1 source est un XP calibré pour l'architecture de
mon Dell, alors est-ce que mon clonage n'est tout simplement pas
possible car, même en supposant que je fais bien les choses lors de mon
clonage, c'est un XP-PRO Dell-adapté que j'aurai et pas
Virtualbox-adapté de sorte que le démarrage ne peut pas marcher ?

Merci d'avance pour votre aide.





Ta méthode doit pouvoir marcher
Je ne connais pas virtualbox mais qu'a tu utilisé comme type de périphérique disque
sur ta VM si c'est du scsi par défaut cela peux être la source du problème
On a déja rencontré ce genre de problème avec du VMWARE
Emmanuel Florac
Le #23498581
Le Sat, 25 Jun 2011 02:59:20 +0200, Francois Lafont a écrit:

Je sais bien que le sda1 source est un XP calibré pour l'architecture de
mon Dell, alors est-ce que mon clonage n'est tout simplement pas
possible car, même en supposant que je fais bien les choses lors de mon
clonage, c'est un XP-PRO Dell-adapté que j'aurai et pas
Virtualbox-adapté de sorte que le démarrage ne peut pas marcher ?



Normalement pour migrer "physical to virtual" il faut utiliser des outils
spéciaux. Je n'ai pas trop exploré la question, mais il y a des outils
qu'on peut télécharger chez vmware et d'autres. Cherche "p2v" ou
"physical to virtual" dans ton moteur préféré. Tu peux ajouter le mot
clef "virtualbox".
--
La loi, dans un grand souci d'égalité, interdit aux riches comme aux
pauvres de coucher sous les ponts, de mendier dans les rues et de
voler du pain.
Anatole France.
Francois Lafont
Le #23498681
Le 25/06/2011 05:29, YBM a écrit :

Une seule partition ou pas, tu ne pourras pas démarrer un noyau Linux
si GRUB n'intervient pas.



Mais dans la machine (virtuelle) cible, point de Linux (cf mon premier
message) donc je n'ai pas besoin de Grub.


--
François Lafont
Francois Lafont
Le #23498671
Le 25/06/2011 08:53, Philippe Weill a écrit :

Ta méthode doit pouvoir marcher
Je ne connais pas virtualbox mais qu'a tu utilisé comme type de
périphérique disque
sur ta VM si c'est du scsi par défaut cela peux être la source du problème



Sur ma machine Virtuelle, j'ai laissé les paramètres par défaut au
niveau du disque et apparemment c'est une disque dur IDE. De toute
façon, sur Virtualbox (version 4.0.8 r71778), j'ai l'impression que je
n'ai pas d'autre choix possible.


--
François Lafont
Erwan David
Le #23498661
Francois Lafont
Le 25/06/2011 08:53, Philippe Weill a écrit :

Ta méthode doit pouvoir marcher
Je ne connais pas virtualbox mais qu'a tu utilisé comme type de
périphérique disque
sur ta VM si c'est du scsi par défaut cela peux être la source du problème



Sur ma machine Virtuelle, j'ai laissé les paramètres par défaut au
niveau du disque et apparemment c'est une disque dur IDE. De toute
façon, sur Virtualbox (version 4.0.8 r71778), j'ai l'impression que je
n'ai pas d'autre choix possible.



Mais non sur virtualbox on peut avoir du Sata

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Francois Lafont
Le #23498891
Le 25/06/2011 11:52, Emmanuel Florac a écrit :

Normalement pour migrer "physical to virtual" il faut utiliser des outils
spéciaux. Je n'ai pas trop exploré la question, mais il y a des outils
qu'on peut télécharger chez vmware et d'autres. Cherche "p2v" ou
"physical to virtual" dans ton moteur préféré. Tu peux ajouter le mot
clef "virtualbox".



Ok, merci pour l'information. Je vois qu'il y a en effet pas de chose
sur la question. Je vais voir ça...


--
François Lafont
Publicité
Poster une réponse
Anonyme