codage

Le
Olivier
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je voudrais
savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe comment :
HDIROMP
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple) que la
A devienne H, le B devienne D, .
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est possible
avec uniquement des fonctions EXCEL sans utiliser de macro ou de nouvelles
fonctions personnalisées.

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
charabeuh
Le #4902501
Bonjour,

En A1, vous saisissez la formule Êr(32) ==> caractère espace

En A2 jusqu'à AA1, les 26 lettres de l'alphabet dans l'ordre alphabétique

En B1, vous saisissez la formule Êr(32) ==> caractère espace

En B2 jusqu'à AA2 , les 26 lettres de l'alphabet codé

en A3 votre phrase à coder
============================================================================ En A4 la formule =SI(LIGNE(A4)-3<=NBCAR($A$3); STXT($A$3;LIGNE(A4)-3;1);"")

Vous étirez cette formule jusqu'à la cellule A30 (on suppose que la phrase a
30

caractères max)

En B4 la formule = SI(A4="";"";RECHERCHEH(A4;$A$1:$AA$2;2;FAUX))

Vous étirez cette formule jusqu'à la cellule B30

En C30 la formule ³0

En C5 la formule ²9 & C30

Vous étirez cette formule jusqu'à la cellule C4

Le résultat du codage est dans la cellule C4
_______________

"Olivier" news:46915ac0$0$21150$
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je
voudrais savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe comment
: HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple) que
la A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est possible
avec uniquement des fonctions EXCEL sans utiliser de macro ou de nouvelles
fonctions personnalisées.

Merci.




charabeuh
Le #4902491
lire En C29 la formule ²9 & C30
au lieu de En C5 la formule ²9 & C30
_________________________________

"charabeuh" news:%
Bonjour,

En A1, vous saisissez la formule Êr(32) ==> caractère espace

En A2 jusqu'à AA1, les 26 lettres de l'alphabet dans l'ordre alphabétique

En B1, vous saisissez la formule Êr(32) ==> caractère espace

En B2 jusqu'à AA2 , les 26 lettres de l'alphabet codé

en A3 votre phrase à coder
============================================================================ > En A4 la formule =SI(LIGNE(A4)-3<=NBCAR($A$3);
STXT($A$3;LIGNE(A4)-3;1);"")

Vous étirez cette formule jusqu'à la cellule A30 (on suppose que la phrase
a 30

caractères max)

En B4 la formule = SI(A4="";"";RECHERCHEH(A4;$A$1:$AA$2;2;FAUX))

Vous étirez cette formule jusqu'à la cellule B30

En C30 la formule ³0

En C5 la formule ²9 & C30

Vous étirez cette formule jusqu'à la cellule C4

Le résultat du codage est dans la cellule C4
_______________

"Olivier" news:46915ac0$0$21150$
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je
voudrais savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe comment
: HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple) que
la A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est
possible avec uniquement des fonctions EXCEL sans utiliser de macro ou de
nouvelles fonctions personnalisées.

Merci.







Eddy Maue
Le #4902481
un simple différenciel fera l'affaire

dans ta liste b il y a 26 characteres et comme l'alphabet est composé de 26
chrs escluant les accents et les majuscules et minuscule

moi je ferais comme suivant
MaListeCode("jkaxusqplbiygcovxdfmehnrtw")

MaPhrase = "BRAVO CA MARCHE"
PhraseCodé = ""
For i = 1 to Len(MaPhrase)
PhraseCode = PhraseCode
+Substr(MaListeCode,Asc(Substr(Lower(MaPhrase),1,1)),1)
endfor




Olivier a formulé la demande :
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je voudrais
savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe comment :
HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple) que la
A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est possible
avec uniquement des fonctions EXCEL sans utiliser de macro ou de nouvelles
fonctions personnalisées.

Merci.


garnote
Le #4902441
Salut Olivier,

Pour le plaisir :
Une piste verticale à adapter.

Serge


"Olivier"
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je voudrais savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe comment : HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple) que la A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est possible avec uniquement des fonctions EXCEL sans utiliser de
macro ou de nouvelles fonctions personnalisées.

Merci.




jps
Le #4902431
et lire aussi :
en A2 jusqu'à AA2
c'était mes 0,05 euro (ça fait combien en CAD?) du lundi matin
jps

"charabeuh" news: %
lire En C29 la formule ²9 & C30
au lieu de En C5 la formule ²9 & C30
_________________________________

"charabeuh" news:%
Bonjour,

En A1, vous saisissez la formule Êr(32) ==> caractère espace

En A2 jusqu'à AA1, les 26 lettres de l'alphabet dans l'ordre alphabétique

En B1, vous saisissez la formule Êr(32) ==> caractère espace

En B2 jusqu'à AA2 , les 26 lettres de l'alphabet codé

en A3 votre phrase à coder
============================================================================ >> En A4 la formule =SI(LIGNE(A4)-3<=NBCAR($A$3);
STXT($A$3;LIGNE(A4)-3;1);"")

Vous étirez cette formule jusqu'à la cellule A30 (on suppose que la
phrase a 30

caractères max)

En B4 la formule = SI(A4="";"";RECHERCHEH(A4;$A$1:$AA$2;2;FAUX))

Vous étirez cette formule jusqu'à la cellule B30

En C30 la formule ³0

En C5 la formule ²9 & C30

Vous étirez cette formule jusqu'à la cellule C4

Le résultat du codage est dans la cellule C4
_______________

"Olivier" news:46915ac0$0$21150$
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je
voudrais savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe
comment : HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple)
que la A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est
possible avec uniquement des fonctions EXCEL sans utiliser de macro ou
de nouvelles fonctions personnalisées.

Merci.










LSteph
Le #4902421
;o)

Bonjour Eddy,

C'est bien d'accord,
mais... -(pourquoi on cherche?)-
...c'est que le Monsieur il a dit sans VBA!

Cordialement.

lSteph

un simple différenciel fera l'affaire

dans ta liste b il y a 26 characteres et comme l'alphabet est composé de
26 chrs escluant les accents et les majuscules et minuscule

moi je ferais comme suivant
MaListeCode("jkaxusqplbiygcovxdfmehnrtw")

MaPhrase = "BRAVO CA MARCHE"
PhraseCodé = ""
For i = 1 to Len(MaPhrase)
PhraseCode = PhraseCode
+Substr(MaListeCode,Asc(Substr(Lower(MaPhrase),1,1)),1)
endfor




Olivier a formulé la demande :
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je
voudrais savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe
comment : HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple)
que la A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est
possible avec uniquement des fonctions EXCEL sans utiliser de macro ou
de nouvelles fonctions personnalisées.

Merci.






LSteph
Le #4902411
Bonjour JP,

Déjà debout!?

;o)

lSteph

(Anda! Voy a trabahar por los jubilados!)


et lire aussi :
en A2 jusqu'à AA2
c'était mes 0,05 euro (ça fait combien en CAD?) du lundi matin
jps

"charabeuh" news: %
lire En C29 la formule ²9 & C30
au lieu de En C5 la formule ²9 & C30
_________________________________

"charabeuh" news:%
Bonjour,

En A1, vous saisissez la formule Êr(32) ==> caractère espace

En A2 jusqu'à AA1, les 26 lettres de l'alphabet dans l'ordre alphabétique

En B1, vous saisissez la formule Êr(32) ==> caractère espace

En B2 jusqu'à AA2 , les 26 lettres de l'alphabet codé

en A3 votre phrase à coder
============================================================================ >>> En A4 la formule =SI(LIGNE(A4)-3<=NBCAR($A$3);
STXT($A$3;LIGNE(A4)-3;1);"")

Vous étirez cette formule jusqu'à la cellule A30 (on suppose que la
phrase a 30

caractères max)

En B4 la formule = SI(A4="";"";RECHERCHEH(A4;$A$1:$AA$2;2;FAUX))

Vous étirez cette formule jusqu'à la cellule B30

En C30 la formule ³0

En C5 la formule ²9 & C30

Vous étirez cette formule jusqu'à la cellule C4

Le résultat du codage est dans la cellule C4
_______________

"Olivier" news:46915ac0$0$21150$
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je
voudrais savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe
comment : HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple)
que la A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est
possible avec uniquement des fonctions EXCEL sans utiliser de macro ou
de nouvelles fonctions personnalisées.

Merci.












AV
Le #4902401
En A1:AA1 les lettres de l'alphabet (A > Z) avec en AA1 un espace
En A2:AA2 les correspondances
En A3 ta phrase
En A4 et recopie >> AA4 : matricielle à valider par ctrl+maj+entrée
=INDEX($A$2:$AA$2;INDEX(EQUIV(STXT($A$3;LIGNE(INDIRECT("1:"&NBCAR($A$3)));1);$A$1:$AA$1;0);COLONNE()))
Pour évolution et gestion erreur voir exemple
L'exemple est là :
http://cjoint.com/?hjiYTHUyTk

AV
jps
Le #4902381
vi, vi
y se dice "trabajar"
hasta luego, hombre de la mancha (mais je n'ai pas voulu dire "mendiant")
jps

"LSteph"
Bonjour JP,

Déjà debout!?

;o)

lSteph

(Anda! Voy a trabahar por los jubilados!)


et lire aussi :
en A2 jusqu'à AA2
c'était mes 0,05 euro (ça fait combien en CAD?) du lundi matin
jps

"charabeuh" news: %
lire En C29 la formule ²9 & C30
au lieu de En C5 la formule ²9 & C30
_________________________________

"charabeuh" news:%
Bonjour,

En A1, vous saisissez la formule Êr(32) ==> caractère espace

En A2 jusqu'à AA1, les 26 lettres de l'alphabet dans l'ordre
alphabétique

En B1, vous saisissez la formule Êr(32) ==> caractère espace

En B2 jusqu'à AA2 , les 26 lettres de l'alphabet codé

en A3 votre phrase à coder
============================================================================ >>>> En A4 la formule =SI(LIGNE(A4)-3<=NBCAR($A$3);
STXT($A$3;LIGNE(A4)-3;1);"")

Vous étirez cette formule jusqu'à la cellule A30 (on suppose que la
phrase a 30

caractères max)

En B4 la formule = SI(A4="";"";RECHERCHEH(A4;$A$1:$AA$2;2;FAUX))

Vous étirez cette formule jusqu'à la cellule B30

En C30 la formule ³0

En C5 la formule ²9 & C30

Vous étirez cette formule jusqu'à la cellule C4

Le résultat du codage est dans la cellule C4
_______________

"Olivier" news:46915ac0$0$21150$
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je
voudrais savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe
comment : HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple)
que la A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est
possible avec uniquement des fonctions EXCEL sans utiliser de macro ou
de nouvelles fonctions personnalisées.

Merci.













JB
Le #4902371
Bonjour,

En A1: abcdef..
En A2: jkaxus..
En A3: bravo ca marche

-Sélectionner n cellules horizontales:
=STXT(A2;CHERCHE(STXT(A3;COLONNE(INDIRECT("1:"&NBCAR(A3)));1);A1);1)
Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?hjjKxVWfHR

JB

On 8 juil, 23:44, "Olivier"
Bonsoir, je me suis lancé un défi mais je n'y arrive pas. Alors je vo udrais
savoir si quelqu'un pouvait m'aider.
Voilà :
En ligne 1, on a les 26 lettres de l'alphabet : ABCDEFG...
En ligne 2, on a les 26 lettres de l'alphabet mélangées n'importe com ment :
HDIROMP...
En A3, un mot, une phase comme "BRAVO CA MARCHE"
En A4, la même phrase mais codée de telle sorte (qu'avec mon exemple) que la
A devienne H, le B devienne D, ....
Je sais faire en utilisant le VBA. Je voudrais savoir si cela est possible
avec uniquement des fonctions EXCEL sans utiliser de macro ou de nouvelles
fonctions personnalisées.

Merci.


Publicité
Poster une réponse
Anonyme