codes de champs

Le
HB
Bonjour,

Une amie utilise depuis longtemps le modèle Amath97

Bon d'accord c'est dérivé de wordbasic
(objet wordbasic dans VBA !!!)
mais cela lui rend de fiers services

Elle l'a installé avec son "nouveau" Office 2013
et tout ou presque fonctionne.
Seul l'outil vecteur plante

Elle m'a demandé de l'aide et j'ai trouvé, je crois, l'origine du problème :
c'est un pb de code l'un dans l'autre

exemple :
les 3 codes suivants fonctionnent

{ Symbol 115 f Symbol s 8 }
et
{ Symbol 121 f Symbol s 8 }

{eq f(r;X)}

mais le suivant affiche "erreur !" :

{eq f({ Symbol 115 f Symbol s 8 };{ Symbol 121 f Symbol s 8 })}

il me semblait qu'on pouvait ainsi mettre les codes de champs les uns
dans les autres


Comme le code (projet VBA) n'est pas protégé, je peux lui bricoler un
correctif dans la macro associée mais je ne sais pas quoi faire

Merci d'avance pour vos lumières

HB
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JièL
Le #26426592
Le 17/02/2017 à 22:54, HB a écrit :
Bonjour,

Hello,
mais le suivant affiche "erreur !" :
{eq f({ Symbol 115 f Symbol s 8 };{ Symbol 121 f Symbol s 8 })}

Chez moi, hors VBA, il fonctionne, mais je ne vois pas quoi en faire via VBA
il me semblait qu'on pouvait ainsi mettre les codes de champs les uns
dans les autres ...

Oui
Comme le code (projet VBA) n'est pas protégé, je peux lui bricoler un
correctif dans la macro associée mais je ne sais pas quoi faire ...

Je pourrais voir ce doc pour comprendre ?
--
JièL 5 bol
HB
Le #26426620
RE,
j'ai omis un détail ...
Ce code marche très bien jusqu'à 0ffice 2003
(je n'ai pas testé avec 2007 et 2010)
Mais avec office pro 2013 il coince.
Exemple dans le doc suivant :
http://www.cjoint.com/c/GBslqEfUalC
Le fait que ce soit une macro VBA
qui génère ce code est secondaire ...
Si je trouve un code "équivalent"
qui passe avec 2013 ( et + ?) ,
je "patcherai" le modèle amath97 ...
HB
Le 17/02/2017 à 23:25, JièL a écrit :
Le 17/02/2017 à 22:54, HB a écrit :
Bonjour,

Hello,
mais le suivant affiche "erreur !" :
{eq f({ Symbol 115 f Symbol s 8 };{ Symbol 121 f Symbol s 8 })}

Chez moi, hors VBA, il fonctionne, mais je ne vois pas quoi en faire via
VBA
il me semblait qu'on pouvait ainsi mettre les codes de champs les uns
dans les autres ...

Oui
Comme le code (projet VBA) n'est pas protégé, je peux lui bricoler un
correctif dans la macro associée mais je ne sais pas quoi faire ...

Je pourrais voir ce doc pour comprendre ?
Geo
Le #26426667
Bonsoir
Voilà ce que donne votre document avec word 2010.
Qu'est-ce qui est bon et qu'est-ce qui ne l'est pas ?
JièL
Le #26426675
Le 18/02/2017 à 19:48, Geo a écrit :
Voilà ce que donne votre document avec word 2010.

Geo, je pense que tu as oublié le lien ou la pj ;-)
JièL
Le #26426679
Le 18/02/2017 à 12:22, HB a écrit :
Mais avec office pro 2013 il coince.
Exemple dans le doc suivant :
http://www.cjoint.com/c/GBslqEfUalC

Le pb c'est que le bon et pas bon je ne vois pas vraiment ce que ça doit
donner avec 2013 ou plutot ce que ça donnait avec l'ancienne version
(laquelle d'ailleurs ?)
{eq f({ Symbol 115 f Symbol s 8 };{ Symbol 121 f Symbol s 8 })}



Dans le doc sur cjoint il n'y a pas ça et chez moi ça ça fonctionne, ou
du moins ça ne me donne pas une erreur et ça affiche des trucs bizarres
que je ne sais pas lire.
--
JièL bon/pasbon
HB
Le #26426683
Le 18/02/2017 à 23:17, JièL a écrit :
Le 18/02/2017 à 12:22, HB a écrit :
Mais avec office pro 2013 il coince.
Exemple dans le doc suivant :
http://www.cjoint.com/c/GBslqEfUalC

Le pb c'est que le bon et pas bon je ne vois pas vraiment ce que ça doit
donner avec 2013 ou plutot ce que ça donnait avec l'ancienne version
(laquelle d'ailleurs ?)


dans le "pas bon"
- avec 2003 (et sans doute 2000 et 97)
ça donne "vecteur BD"
(BD avec une flèche au dessus)
Il suffit de "basculer les codes de champs" pour le deviner
- avec 2013 ça donne "erreur !"
le premier "bon"
c'est la flèche seule (en fait trois caractères)
( correct même avec 2013)
le second "bon"
BD avec trois "petit rond" (°°°) au dessus
(à la place de la flèche)
( correct aussi avec 2013)

Avec le docx http://www.cjoint.com/c/GBslqEfUalC
voilà ce que je vois (2013) :
http://www.cjoint.com/c/GBtbzy6f1FC

{eq f({ Symbol 115 f Symbol s 8 };{ Symbol 121 f Symbol s 8 })}




Dans le doc sur cjoint il n'y a pas ça et chez moi ça ça fonctionne, ou
du moins ça ne me donne pas une erreur et ça affiche des trucs bizarres
que je ne sais pas lire.

oui c'était une autre formule
(fraction rho sur Psi)
mais le pb est de même nature :
les codes de champs Symbol dans un Champs EQ
semblent provoquer une erreur avec 2013
Geo
Le #26426684
Geo, je pense que tu as oublié le lien ou la pj ;-)

Aie :
http://www.cjoint.com/c/GBssUX66NMz
Geo
Le #26426751
Bonsoir
C'est bon avec 2016.
JièL
Le #26426783
Le 19/02/2017 à 21:34, Geo a écrit :
C'est bon avec 2016.

Chez moi c'est bon avec 2016 (ouf on à la même chose ;-D), bon avec 2010
mais pas bon avec 2013... C'est le 3 qui fait que ça ne fonctionne pas
tu crois ? ;-))))))
HB : j'ai la même chose que l'image de Geo sur 2016 et 2010 mais la même
chose que toi sur 2013... de là à comprendre qqchose, y'a une marge.
--
JièL malcomprenant
Geo
Le #26426830
Bonjour
de là à comprendre qqchose, y'a une marge.

Si, c'est clair, 2013 mérite bien sa réputation.
Publicité
Poster une réponse
Anonyme