N°de colonne = valeur d'une cellule

Le
news microsoft
Bonjour,
pouvez vous m'aider sur ce probleme?
voici une formule :
NB.SI($N12:$N18;N12)
Je voudrais remplacer le 18 par la valeur de la cellule W12
exemple :
NB.SI($N12:$N(valeur de w12);N12)
j'ai essayer concatener
NB.SI($N12:concatener("$N";W12);N12)
mais ca ne marche pas
merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #21020551
Bonjour,

As-tu essayé ceci :
=NB.SI(INDIRECT("$N12:$N"&INDIRECT("W12")&"");N12)


"news microsoft" discussion :
Bonjour,
pouvez vous m'aider sur ce probleme?
voici une formule :
NB.SI($N12:$N18;N12)
Je voudrais remplacer le 18 par la valeur de la cellule W12
exemple :
NB.SI($N12:$N(valeur de w12);N12)
j'ai essayer concatener
NB.SI($N12:concatener("$N";W12);N12)
mais ca ne marche pas
merci de votre aide
Hervé
Le #21020541
Bonjour,

=NB.SI($N12:INDIRECT(W12);N12)
W12 contenant par exemple la référence N25. La plage prise en compte sera
alors N12:N25

Hervé.

"news microsoft" news:
Bonjour,
pouvez vous m'aider sur ce probleme?
voici une formule :
NB.SI($N12:$N18;N12)
Je voudrais remplacer le 18 par la valeur de la cellule W12
exemple :
NB.SI($N12:$N(valeur de w12);N12)
j'ai essayer concatener
NB.SI($N12:concatener("$N";W12);N12)
mais ca ne marche pas
merci de votre aide



news microsoft
Le #21020531
Merci beaucoup

"Hervé"
Bonjour,

=NB.SI($N12:INDIRECT(W12);N12)
W12 contenant par exemple la référence N25. La plage prise en compte sera
alors N12:N25

Hervé.

"news microsoft" news:
Bonjour,
pouvez vous m'aider sur ce probleme?
voici une formule :
NB.SI($N12:$N18;N12)
Je voudrais remplacer le 18 par la valeur de la cellule W12
exemple :
NB.SI($N12:$N(valeur de w12);N12)
j'ai essayer concatener
NB.SI($N12:concatener("$N";W12);N12)
mais ca ne marche pas
merci de votre aide







FdeCourt
Le #21020741
Salut,

Une autre possiblité :

=NB.SI(DECALER($N13;;;$W$12-11;);N13)

Cordialement,

F.
news microsoft
Le #21021091
Pour mon information, juste une question?
A quoi sert les 3 ";" dans les formules decaler
merci

"FdeCourt"
Salut,

Une autre possiblité :

=NB.SI(DECALER($N13;;;$W$12-11;);N13)

Cordialement,

F.
FdeCourt
Le #21021181
Salut,

Parce que tu peux décaler 4 choses :
- La ligne
- La colonne
- Le nombre de ligne
- Le nombre de colonne.

Comme dans le cas ci-dessus il ne faut ni décaler la ligne, ni décaler
la colonne, les arguments sont vides, d'ou les ;;;
DECALER(cellule;ligne;colonne;nbligne;nbcolonne)
Si ligne = rien et colonne = rien, et qu'en l'occurence nbcolonne =
rien
alors il y a bien DECALER(cellule;;;nbligne;)

Cordialement,

F.
Modeste
Le #21021491
Bonsour® FdeCourt avec ferveur ;o))) vous nous disiez :

Salut,

Parce que tu peux décaler 4 choses :
- La ligne
- La colonne
- Le nombre de ligne
- Le nombre de colonne.

Comme dans le cas ci-dessus il ne faut ni décaler la ligne, ni décaler
la colonne, les arguments sont vides, d'ou les ;;;
DECALER(cellule;ligne;colonne;nbligne;nbcolonne)
Si ligne = rien et colonne = rien, et qu'en l'occurence nbcolonne =
rien
alors il y a bien DECALER(cellule;;;nbligne;)



tssss....tssss...
Syntaxe
DECALER(réf;lignes;colonnes;hauteur;largeur)
il ne s'agit pas de "rien" !!!!!
largeur= Colonnes(réf)

Si les arguments hauteur ou largeur sont omis, les valeurs par défaut des arguments hauteur et largeur sont celles de l'argument réf.

toujours se méfier des arguments par défaut !!!
de façon explicite :
DECALER(cellule;0;0;nbligne;1) ÞCALER(cellule;;;nbligne;)
et au cas ou Cellule ferait référence à une selection de plusieures cellules contigües
il conviendra alors explicitement de préciser la dimension du résultat attendu (hauteur et largeur)
michdenis
Le #21021481
| =NB.SI(INDIRECT("$N12:$N"&INDIRECT("W12")&"");N12)

Je ne sais pas ce qui s'est passé... ;-)

mais ceci est suffisant :
=NB.SI(INDIRECT("$N12:$N"&W12);N12)
news microsoft
Le #21022521
Merci beaucoup pour vos explications
"Modeste" %23X$
Bonsour® FdeCourt avec ferveur ;o))) vous nous disiez :

Salut,

Parce que tu peux décaler 4 choses :
- La ligne
- La colonne
- Le nombre de ligne
- Le nombre de colonne.

Comme dans le cas ci-dessus il ne faut ni décaler la ligne, ni décaler
la colonne, les arguments sont vides, d'ou les ;;;
DECALER(cellule;ligne;colonne;nbligne;nbcolonne)
Si ligne = rien et colonne = rien, et qu'en l'occurence nbcolonne > rien
alors il y a bien DECALER(cellule;;;nbligne;)



tssss....tssss...
Syntaxe
DECALER(réf;lignes;colonnes;hauteur;largeur)
il ne s'agit pas de "rien" !!!!!
largeur= Colonnes(réf)

Si les arguments hauteur ou largeur sont omis, les valeurs par défaut des
arguments hauteur et largeur sont celles de l'argument réf.

toujours se méfier des arguments par défaut !!!
de façon explicite :
DECALER(cellule;0;0;nbligne;1) ÞCALER(cellule;;;nbligne;)
et au cas ou Cellule ferait référence à une selection de plusieures cellules
contigües
il conviendra alors explicitement de préciser la dimension du résultat
attendu (hauteur et largeur)
FdeCourt
Le #21022681
Bon je reconnais que les termes utilisés ne sont pas completement
juste, mais je les trouve plus clair !

Par contre, cette affirmation est fausse :
DECALER(cellule;0;0;nbligne;1) ÞCALER(cellule;;;nbligne;)

Puisque si on suppose que nbligne = 5
et que cellule = A1:G1

alors le premier cas correspondra A1:A5, et le deuxième cas
correspondra à A1:G5

Cordialement,

F.
Publicité
Poster une réponse
Anonyme