combien de repetition

Le
pellet15
Bonjour à tous

J'ai une formule
=NB.SI(L3:L2000;"2xD")

cela fonctionne seulement si il y a "2xD" est seule dans la cellule (exp==
3)

mais je voudrait compter le nombre de répétition
comme l'exemple suivant je voudrait que la réponse soit 6 !!!

2xD+10xV+1entr
2xD+10xV+2entr
1xD+10xV+1entr
2xD+10xV+1entr
2xD
2xD
2xD

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
GL
Le #26337087
Le 02/02/2015 23:39, pellet15 a écrit :
Bonjour à tous

J'ai une formule
=NB.SI(L3:L2000;"2xD")

cela fonctionne seulement si il y a "2xD" est seule dans la cellule (exp=3)

mais je voudrait compter le nombre de répétition
comme l'exemple suivant je voudrait que la réponse soit 6 !!!



A ce moment là il faut utiliser CHERCHE :

{=NB(CHERCHE("2xD"; A1:A7))}

par exemple. Validation matricielle (CTRL+SHIFT+ENTER) dans une cellule.


2xD+10xV+1entr
2xD+10xV+2entr
1xD+10xV+1entr
2xD+10xV+1entr
2xD
2xD
2xD

Merci

GL
Le #26337086
Le 03/02/2015 00:09, GL a écrit :
Le 02/02/2015 23:39, pellet15 a écrit :
Bonjour à tous

J'ai une formule
=NB.SI(L3:L2000;"2xD")

cela fonctionne seulement si il y a "2xD" est seule dans la cellule
(exp=3)

mais je voudrait compter le nombre de répétition
comme l'exemple suivant je voudrait que la réponse soit 6 !!!



A ce moment là il faut utiliser CHERCHE :

{=NB(CHERCHE("2xD"; A1:A7))}

par exemple. Validation matricielle (CTRL+SHIFT+ENTER) dans une cellule.



Ceci étant vous pouvez aussi utiliser les caractères génériques, qui
fonctionnent avec NB.SI (sans formule matricielle du coup) :

=NB.SI(L3:L2000; "*2xD*")

Et comme m'a appris MichD, si vous cherchez une étoile * il faut alors
"l'échapper" avec ~* (~ est le caractère d'échappement pour Micro$oft,
un standard, un standard micro$oft, une ineptie quoi... mais bon ça
marche !)



2xD+10xV+1entr
2xD+10xV+2entr
1xD+10xV+1entr
2xD+10xV+1entr
2xD
2xD
2xD

Merci




isabelle
Le #26337091
bonjour,

=SOMMEPROD((GAUCHE(A1:A10;3)="2xD")*1)

isabelle

Le 2015-02-02 17:39, pellet15 a écrit :
Bonjour à tous

J'ai une formule
=NB.SI(L3:L2000;"2xD")

cela fonctionne seulement si il y a "2xD" est seule dans la cellule (exp=3)

mais je voudrait compter le nombre de répétition
comme l'exemple suivant je voudrait que la réponse soit 6 !!!

2xD+10xV+1entr
2xD+10xV+2entr
1xD+10xV+1entr
2xD+10xV+1entr
2xD
2xD
2xD

Merci

isabelle
Le #26337092
au cas ou le texte recherché ne serait pas au début de la chaine

=SOMMEPROD((SIERREUR(TROUVE("2xD";A1:A10);0)<>0)*1)
matriciel à valider avec ctrl+shift+enter

isabelle

Le 2015-02-02 17:39, pellet15 a écrit :
Bonjour à tous

J'ai une formule
=NB.SI(L3:L2000;"2xD")

cela fonctionne seulement si il y a "2xD" est seule dans la cellule (exp=3)

mais je voudrait compter le nombre de répétition
comme l'exemple suivant je voudrait que la réponse soit 6 !!!

2xD+10xV+1entr
2xD+10xV+2entr
1xD+10xV+1entr
2xD+10xV+1entr
2xD
2xD
2xD

Merci

GL
Le #26337136
Le 03/02/2015 01:52, isabelle a écrit :
au cas ou le texte recherché ne serait pas au début de la chaine

=SOMMEPROD((SIERREUR(TROUVE("2xD";A1:A10);0)<>0)*1)
matriciel à valider avec ctrl+shift+enter

isabelle



Je trouve que =NB.SI(A1:A10; "*2xD*") est quand même plus direct non ?

D'autre part, on peut utiliser NB(TROUVE(...)) ou NB(CHERCHE(...))
étant donné que NB ne compte que les valeurs numériques (pas les erreurs)

Cdt.



Le 2015-02-02 17:39, pellet15 a écrit :
Bonjour à tous

J'ai une formule
=NB.SI(L3:L2000;"2xD")

cela fonctionne seulement si il y a "2xD" est seule dans la cellule
(exp=3)

mais je voudrait compter le nombre de répétition
comme l'exemple suivant je voudrait que la réponse soit 6 !!!

2xD+10xV+1entr
2xD+10xV+2entr
1xD+10xV+1entr
2xD+10xV+1entr
2xD
2xD
2xD

Merci

Publicité
Poster une réponse
Anonyme