Combinaison de 2 formules

Le
Andre
Bonjour,

Comment énoncer correctement cette
formule:=SOMME.SI(F7:F100;"32";SOUS.TOTAL(9;D7:D100)__CAD: si les cellules de
la colonne F7:F100 contiennent "32" il faut calculer le total de la colonne
D7:D100 sous filtre de la colonne A
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sundow
Le #22148951
On 21 mai, 10:16, Andre
Bonjour,

Comment énoncer correctement cette
formule:=SOMME.SI(F7:F100;"32";SOUS.TOTAL(9;D7:D100)__CAD: si les cellu les de
la colonne F7:F100 contiennent "32" il faut calculer le total de la colon ne
D7:D100 sous filtre de la colonne A



Bonjour,

=SI(NB.SI($F$7:$F$100;32)>0;SOUS.TOTAL(9;$D$7:$D$100);"la palge
F7:F100 ne contient pas la valeur 32")

Cordialement,

S.
michdenis
Le #22149221
Bonjour,

La ligne F7 représente la première ligne de DONNÉES (pas étiquette)
de ta colonne, sinon, tu devras modifier pour F8

Validation matricielle : Ctrl + Maj + Enter
=SOMME(N(SI(SOUS.TOTAL(3;DECALER(F7;LIGNE(F7:F100)-LIGNE(F7);));F7:F1002)))



"Andre" :
Bonjour,

Comment énoncer correctement cette
formule:=SOMME.SI(F7:F100;"32";SOUS.TOTAL(9;D7:D100)__CAD: si les cellules de
la colonne F7:F100 contiennent "32" il faut calculer le total de la colonne
D7:D100 sous filtre de la colonne A
Essart
Le #22149251
Bonjour,

une variante peut-être avec la fonction SOMMEPROD :
=SOMMEPROD((F7:F1002)*(D7:D100))

Bonne journée

Essart
Andre
Le #22149581
Bonjour Sundow,

Ta formule fonctionne, à condition que je n'aie que la valeur 32 dans la
colonne F (filtre) si j'ai d'autres valeurs en plus que 32, elle me totalise
ces valeurs avec la 32.
Je voudrait qu'il ne totalise que la valeur 32.
Formule que j'adapterai pour les autres valeurs à totaliser dans d'autres
cellules.


"Sundow" a écrit :

On 21 mai, 10:16, Andre > Bonjour,
>
> Comment énoncer correctement cette
> formule:=SOMME.SI(F7:F100;"32";SOUS.TOTAL(9;D7:D100)__CAD: si les cellules de
> la colonne F7:F100 contiennent "32" il faut calculer le total de la colonne
> D7:D100 sous filtre de la colonne A

Bonjour,

=SI(NB.SI($F$7:$F$100;32)>0;SOUS.TOTAL(9;$D$7:$D$100);"la palge
F7:F100 ne contient pas la valeur 32")

Cordialement,

S.
.

Andre
Le #22149761
Bonjour Essart,

Ta formule fonctionne parfaitement en triant les sommes des différentes
valeurs en F mais pas si je trie sur la colonne A (date); la totalisation de
la valeur en F ne tient pas compte de la restriction de A.

"Essart" a écrit :

Bonjour,

une variante peut-être avec la fonction SOMMEPROD :
=SOMMEPROD((F7:F1002)*(D7:D100))

Bonne journée

Essart


.

Caetera
Le #22150051
"Andre"
Comment énoncer correctement cette
formule:=SOMME.SI(F7:F100;"32";SOUS.TOTAL(9;D7:D100)__CAD: si les cellules de
la colonne F7:F100 contiennent "32" il faut calculer le total de la colonne
D7:D100 sous filtre de la colonne A



**************

Si ce sont des valeurs numériques en F7:F100, pas de guillemets :

=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("d"&LIGNE(D7:D100)))*(F7:F1002)))

Etc
Misange
Le #22150111
Bonjour

Il suffit dans ce cas d'ajouter un facteur à sommeprod
=SOMMEPROD((A7:A100>DATE(2010;3;1))* ...
pour ne garder que les dates supérieures au 1/3/2010 par exemple

Misange migrateuse
http://www.excelabo.net


Andre a écrit :
Bonjour Essart,

Ta formule fonctionne parfaitement en triant les sommes des différentes
valeurs en F mais pas si je trie sur la colonne A (date); la totalisation de
la valeur en F ne tient pas compte de la restriction de A.

"Essart" a écrit :

Bonjour,

une variante peut-être avec la fonction SOMMEPROD :
=SOMMEPROD((F7:F1002)*(D7:D100))

Bonne journée

Essart


.

Andre
Le #22150221
Merci Caetera cela fonctionne.
@+


"Caetera" a écrit :

"Andre"
> Comment énoncer correctement cette
> formule:=SOMME.SI(F7:F100;"32";SOUS.TOTAL(9;D7:D100)__CAD: si les cellules de
> la colonne F7:F100 contiennent "32" il faut calculer le total de la colonne
> D7:D100 sous filtre de la colonne A

**************

Si ce sont des valeurs numériques en F7:F100, pas de guillemets :

=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("d"&LIGNE(D7:D100)))*(F7:F1002)))

Etc


.

michdenis
Le #22150211
Oups ! Si c'est la somme plutôt que le nombre, la formule devrait se lire comme suit :

Validation matricielle.
=SOMME(N(SI(SOUS.TOTAL(9;DECALER(F8;LIGNE(F8:F100)-LIGNE(F8);))*(F8:F1002);D8:D100)))



"michdenis"

Bonjour,

La ligne F7 représente la première ligne de DONNÉES (pas étiquette)
de ta colonne, sinon, tu devras modifier pour F8

Validation matricielle : Ctrl + Maj + Enter
=SOMME(N(SI(SOUS.TOTAL(3;DECALER(F7;LIGNE(F7:F100)-LIGNE(F7);));F7:F1002)))



"Andre" :
Bonjour,

Comment énoncer correctement cette
formule:=SOMME.SI(F7:F100;"32";SOUS.TOTAL(9;D7:D100)__CAD: si les cellules de
la colonne F7:F100 contiennent "32" il faut calculer le total de la colonne
D7:D100 sous filtre de la colonne A
Publicité
Poster une réponse
Anonyme