Comment amener Excel à faire une adittion selon un certain critère de dates

Le
Guido
Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) et je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Corto
Le #5090901
Bonjour Guido,
Formule à mettre en D1 et à recopier sur toute la colonne
=SI(A1<>A2;SOMMEPROD(($A$1:$A$8<¡)*$B$1:$B$8)-SOMMEPROD(($A$1:$A$8< ¡)*$C$1:$C$8);"")

Corto

Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) e t je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc...

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido



JB
Le #5090881
Bonjour,

En D1:
=SI(A1<>A2;SOMME.SI($A$1:$A$100;A1;$B$1:$B$100)-SOMME.SI($A$1:$A
$100;A1;$C$1:$C$100);"")

JB
http://boisgontierjacques.free.fr

On 5 déc, 15:35, Guido
Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) et j e
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc...

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido


Guido
Le #5088361
Bonjour Corto,

Merci pour ta formule, elle me va nickel.

Il me faut juste l'adapter au premier résultat inscrit à la main en D1
(comportant un résultat)
Je colle la formule en D2

Merci pour ta formule

Guido


On 5 déc, 15:50, Corto
Bonjour Guido,
Formule à mettre en D1 et à recopier sur toute la colonne
=SI(A1<>A2;SOMMEPROD(($A$1:$A$8<¡)*$B$1:$B$8)-SOMMEPROD(($A$1:$A$8< ¡)*$C$1:$C$8);"")

Corto


Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) et je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc...

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido




Guido
Le #5088341
Bonjour Jacques,

merci pour ta formule, je dois juste dire qu'elle ne correspond pas
vraiment à ma demande, car une fois effectué un résultat, le calcul
repart de zéro.
Corto a émis une formule au poil.

Merci bien.

Guido

On 5 déc, 16:03, JB
Bonjour,

En D1:
=SI(A1<>A2;SOMME.SI($A$1:$A$100;A1;$B$1:$B$100)-SOMME.SI($A$1:$A
$100;A1;$C$1:$C$100);"")

JBhttp://boisgontierjacques.free.fr

On 5 déc, 15:35, Guido
Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) et je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc...

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido




Guido
Le #5088211
Ca va pas fort, et je n'arrive pas à trouver une solution pour mes
tableaux.

En G5, je mets cette formule que je désire corriger et y intégrant G4
comportant un total (soit positif ou négatif).

=SI(C5<>C6;SOMMEPROD(($C$4:$C$127<Å)*$E$4:$E$127)-SOMMEPROD(($C$4:$C
$127<Å)*$F$4:$F$127);"")
Mais j'arrive pas à intégrer simplement la cellule G4.


Tout le reste du tableau est comme ça selon ta formule :
=SI(C5<>C6;SOMMEPROD(($C$4:$C$127<Å)*$E$4:$E$127)-SOMMEPROD(($C$4:$C
$127<Å)*$F$4:$F$127);"")



On 5 déc, 15:50, Corto
Bonjour Guido,
Formule à mettre en D1 et à recopier sur toute la colonne
=SI(A1<>A2;SOMMEPROD(($A$1:$A$8<¡)*$B$1:$B$8)-SOMMEPROD(($A$1:$A$8< ¡)*$C$1:$C$8);"")

Corto


Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) et je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc...

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido




Modeste
Le #5088181
Bonsour® Guido avec ferveur ;o))) vous nous disiez :

je monte un tableau comptable à 3 colonnes (débit crédit total) et je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
A B C D
date credit debit totall

12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00


il faut une ligne d'entete
en D2 tu ecris = D1+B2-C2

tu selectionnnes Format > mise en forme conditionnelle
la formule est : = A3£
format police : blanc ( ou bien même couleur que le fond)

tu utilise ensuite la poignée de recopie pour tirer formule et MEFC vers le bas

Attention !!!!
la colonne 1 doit etre triée dates ascendantes

http://cjoint.com/?mfwLO0de4W


--
--
@+
;o)))

nicolas S2
Le #5088051
Bonjour a toi,

Dans un cas semblable, je procède comme ceci :



La première date en A2, donc la première formule en D3



Cellule D3 : =SI(A3¤;"";SOMME($B$2:B3)-SOMME($C$2:C3))

D4 : =SI(A4¥;"";SOMME($B$2:B4)-SOMME($C$2:C4))



Et ainsi de suite





"Guido"
Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) et je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc...

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido
nicolas S2
Le #5088031
"nicolas S2" news: 4757abbe$0$17222$
Bonjour a toi,

Dans un cas semblable, je procède comme ceci :



La première date en A2, donc la première formule en D3



Cellule D3 : =SI(A3¤;"";SOMME($B$2:B3)-SOMME($C$2:C3))

D4 :
=SI(A4¥;"";SOMME($B$2:B4)-SOMME($C$2:C4))



Et ainsi de suite


et même si tu le souhaite dans la col E le total jours par jours

dans E3 et a recopier :
=SI(A3¤;"";SOMME($B$2:B3)-SOMME($C$2:C3)-SOMME($E$2:E2))






"Guido"
Bonjour,

je monte un tableau comptable à 3 colonnes (débit crédit total) et je
désire qu'Excel ne me calcul le total que lorsque c'est la dernière
écriture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:

A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00

etc...

Merci à qui pourrait me fournir une aide sur ce genre de formule.

A bientôt

Guido



Corto
Le #5087931
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
<title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
Bonjour Guido,<br>
Qu'appelles tu "int&eacute;grer" G4 ?<br>
Comme &ccedil;a ?<br>
=SI($C5&lt;&gt;$C6;SOMMEPROD(($C$5:$C$54&lt;=$C5)*$E$5:$E$54)-SOMMEPROD(($C$5:$C$54&lt;=$C5)*$F$5:$F$54)+<b>$G$4</b>;"")<br>
<br>
Corto<br>
<br>
Guido a &eacute;crit&nbsp;:
<blockquote
cite="mid:"
type="cite">
<pre wrap="">Ca va pas fort, et je n'arrive pas &agrave; trouver une solution pour mes
tableaux.

En G5, je mets cette formule que je d&eacute;sire corriger et y int&eacute;grant G4
comportant un total (soit positif ou n&eacute;gatif).

=SI(C5&lt;&gt;C6;SOMMEPROD(($C$4:$C$127&lt;Å)*$E$4:$E$127)-SOMMEPROD(($C$4:$C
$127&lt;Å)*$F$4:$F$127);"")
Mais j'arrive pas &agrave; int&eacute;grer simplement la cellule G4.


Tout le reste du tableau est comme &ccedil;a selon ta formule :
=SI(C5&lt;&gt;C6;SOMMEPROD(($C$4:$C$127&lt;Å)*$E$4:$E$127)-SOMMEPROD(($C$4:$C
$127&lt;Å)*$F$4:$F$127);"")



On 5 d&eacute;c, 15:50, Corto </pre>
<blockquote type="cite">
<pre wrap="">Bonjour Guido,
Formule &agrave; mettre en D1 et &agrave; recopier sur toute la colonne
=SI(A1&lt;&gt;A2;SOMMEPROD(($A$1:$A$8&lt;¡)*$B$1:$B$8)-SOMMEPROD(($A$1:$A$8&lt;¡)*$C$1:$C$8);"")

Corto


</pre>
<blockquote type="cite">
<pre wrap="">Bonjour,
</pre>
</blockquote>
<blockquote type="cite">
<pre wrap="">je monte un tableau comptable &agrave; 3 colonnes (d&eacute;bit cr&eacute;dit total) et je
d&eacute;sire qu'Excel ne me calcul le total que lorsque c'est la derni&egrave;re
&eacute;criture dans un groupe de date.
(je ne sais si c'est explicite, mais je mets un exemple:
</pre>
</blockquote>
<blockquote type="cite">
<pre wrap="">A B C D
12.11.07 / 30.00 / /
12.11.07 / 42.00 / /
12.11.07 / 125.00 / /
12.11.07 / 17.00 / / 214.00
13.11.07 / / 25.00 /
13.11.07 / / 12.00 /
13.11.07 / 35.00 / /
13.11.07 / 27.00 / / 239.00
</pre>
</blockquote>
<blockquote type="cite">
<pre wrap="">etc...
</pre>
</blockquote>
<blockquote type="cite">
<pre wrap="">Merci &agrave; qui pourrait me fournir une aide sur ce genre de formule.
</pre>
</blockquote>
<blockquote type="cite">
<pre wrap="">A bient&ocirc;t
</pre>
</blockquote>
<blockquote type="cite">
<pre wrap="">Guido
</pre>
</blockquote>
</blockquote>
<pre wrap=""><!---->
</pre>
</blockquote>
</body>
</html>
Guido
Le #5085641
Merci à vous tous,

Pour ce qui est des MFC, j'avais eu cette idée, mais je m'étais dit
que j'allais plutôt intégrer une formule.

Je profite tout particulièrement pour remercier Corto et sa formule,
qui me va au poil avec le G4

A bientôt pour la suite de mes questions.

Guido


On 6 déc, 10:23, Corto
Bonjour Guido,
Qu'appelles tu "intégrer" G4 ?
Comme ça ?
=SI($C5<>$C6;SOMMEPROD(($C$5:$C$54<=$C5)*$E$5:$E$54)-SOMMEPROD(($C$5:$ C$54<=$C5)*$F$5:$F$54)+$G$4;"")
Corto
Guido a écrit :Ca va pas fort, et je n'arrive pas à trouver une soluti on pour mes tableaux. En G5, je mets cette formule que je désire corriger et y intégrant G4 comportant un total (soit positif ou négatif). =SI(C 5

Publicité
Poster une réponse
Anonyme