comment compter dans une cellule les mêmes mots

Le
T.Ruf
Bonjour,
Comment compter dans une plage de cellules les mêmes mots (ou memes chaines
de caracteres) ? Exemple: Dans la colonne "chantiers", comment totaliser le
nombre de fois où est saisie le mot "Outil1er" (il peut être saisie plusieurs
fois dans différentes cellules de cette colonne). J'utilise déjà la fonction
BDNBVAL? mais elle ne sait pas reconnaître plus d'une fois le même mot (ou
chaine de caracteres) dans la même cellule.
Merci.
Thierry
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #5128241
Bonjour,

un début de piste avec le mot recherché en B1 :
=(NBCAR(A2)-NBCAR(SUBSTITUE(A2;$B$1;"")))/NBCAR($B$1)

Camille


Bonjour,
Comment compter dans une plage de cellules les mêmes mots (ou memes chaines
de caracteres) ? Exemple: Dans la colonne "chantiers", comment totaliser le
nombre de fois où est saisie le mot "Outil1er" (il peut être saisie plusieurs
fois dans différentes cellules de cette colonne). J'utilise déjà la fonction
BDNBVAL? mais elle ne sait pas reconnaître plus d'une fois le même mot (ou
chaine de caracteres) dans la même cellule....
Merci....
Thierry


JB
Le #5128231
Bonjour,

=NB.SI(A:A;"outils1er")

ou

=NB.SI(A:A;E1) si E1 contient outils1er

JB
http://boisgontierjacques.free.fr


On 15 jan, 12:43, T.Ruf
Bonjour,
Comment compter dans une plage de cellules les mêmes mots (ou memes chai nes
de caracteres) ? Exemple: Dans la colonne "chantiers", comment totaliser l e
nombre de fois où est saisie le mot "Outil1er" (il peut être saisie pl usieurs
fois dans différentes cellules de cette colonne). J'utilise déjà la fonction
BDNBVAL? mais elle ne sait pas reconnaître plus d'une fois le même mot (ou
chaine de caracteres) dans la même cellule....
Merci....
Thierry


T.Ruf
Le #5293881
Merci....

C'est presque ce qu'il me faut..... mais je souhaite appliquer cette formule
non pas à une seule cellule (A2) mais à un ensemble de cellules ou mieux à
une colonne (A:A)....
Merci beaucoup.....
Thierry


Bonjour,

un début de piste avec le mot recherché en B1 :
=(NBCAR(A2)-NBCAR(SUBSTITUE(A2;$B$1;"")))/NBCAR($B$1)

Camille


Bonjour,
Comment compter dans une plage de cellules les mêmes mots (ou memes chaines
de caracteres) ? Exemple: Dans la colonne "chantiers", comment totaliser le
nombre de fois où est saisie le mot "Outil1er" (il peut être saisie plusieurs
fois dans différentes cellules de cette colonne). J'utilise déjà la fonction
BDNBVAL? mais elle ne sait pas reconnaître plus d'une fois le même mot (ou
chaine de caracteres) dans la même cellule....
Merci....
Thierry




T.Ruf
Le #5293851
Merci....
C'est presque ce que je recherche.... mais si une cellule de la colonne
(A:A) contient 2 x "outils1er", la formule ne fonctionne pas.... la cellule
en question n'est pas prise en compte.....
Merci beaucoup.....
Thierry


Bonjour,

=NB.SI(A:A;"outils1er")

ou

=NB.SI(A:A;E1) si E1 contient outils1er

JB
http://boisgontierjacques.free.fr


On 15 jan, 12:43, T.Ruf
Bonjour,
Comment compter dans une plage de cellules les mêmes mots (ou memes chaines
de caracteres) ? Exemple: Dans la colonne "chantiers", comment totaliser le
nombre de fois où est saisie le mot "Outil1er" (il peut être saisie plusieurs
fois dans différentes cellules de cette colonne). J'utilise déjà la fonction
BDNBVAL? mais elle ne sait pas reconnaître plus d'une fois le même mot (ou
chaine de caracteres) dans la même cellule....
Merci....
Thierry






JB
Le #5293821
Formule d'Ellimac en matriciel

=SOMMEPROD((NBCAR(champ)-NBCAR(SUBSTITUE(champ;B1;"")))/NBCAR(B1))

JB


On 15 jan, 16:35, T.Ruf
Merci....
C'est presque ce que je recherche.... mais si une cellule de la colonne
(A:A) contient 2 x "outils1er", la formule ne fonctionne pas.... la cellul e
en question n'est pas prise en compte.....
Merci beaucoup.....
Thierry




Bonjour,

=NB.SI(A:A;"outils1er")

ou

=NB.SI(A:A;E1) si E1 contient  outils1er

JB
http://boisgontierjacques.free.fr

On 15 jan, 12:43, T.Ruf
Bonjour,
Comment compter dans une plage de cellules les mêmes mots (ou memes chaines
de caracteres) ? Exemple: Dans la colonne "chantiers", comment totalis er le
nombre de fois où est saisie le mot "Outil1er" (il peut être saisi e plusieurs
fois dans différentes cellules de cette colonne). J'utilise déjà la fonction
BDNBVAL? mais elle ne sait pas reconnaître plus d'une fois le même mot (ou
chaine de caracteres) dans la même cellule....
Merci....
Thierry- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




T.Ruf
Le #5134701
Super..... tout à fait ce que je souhaitais.....
Merci beaucoup.......
Thierry



Formule d'Ellimac en matriciel

=SOMMEPROD((NBCAR(champ)-NBCAR(SUBSTITUE(champ;B1;"")))/NBCAR(B1))

JB


On 15 jan, 16:35, T.Ruf
Merci....
C'est presque ce que je recherche.... mais si une cellule de la colonne
(A:A) contient 2 x "outils1er", la formule ne fonctionne pas.... la cellule
en question n'est pas prise en compte.....
Merci beaucoup.....
Thierry




Bonjour,

=NB.SI(A:A;"outils1er")

ou

=NB.SI(A:A;E1) si E1 contient outils1er

JB
http://boisgontierjacques.free.fr

On 15 jan, 12:43, T.Ruf
Bonjour,
Comment compter dans une plage de cellules les mêmes mots (ou memes chaines
de caracteres) ? Exemple: Dans la colonne "chantiers", comment totaliser le
nombre de fois où est saisie le mot "Outil1er" (il peut être saisie plusieurs
fois dans différentes cellules de cette colonne). J'utilise déjà la fonction
BDNBVAL? mais elle ne sait pas reconnaître plus d'une fois le même mot (ou
chaine de caracteres) dans la même cellule....
Merci....
Thierry- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -








Publicité
Poster une réponse
Anonyme